Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

do you have the download mod 5.3 I believe? I'm beginning to think that maybe an addon modified some files and that's why it's not working for me?

I do not have a download mod.

Alan


Production:
osCommerce V. 2.3.4BS
VPS Box

Share this post


Link to post
Share on other sites

Hi

I am using

 

PHP 5.2.6

Curl libcurl/7.18.2 OpenSSL/0.9.8b zlib/1.2.3

Register Globals On

oscommerce - 2.2RC2

osCommerce_PayPal_IPN_v2.3.4

(But when you open that folder the subfolder says osCommerce_PayPal_IPN_v2.3.3???)

 

Everything works fine except the product quantity does not change

 

I set the ipn.php to email me the array info

But some things look a bit strange in there

For instance

[address_status] => confirmed Not sure what the address status refers to

[item_name] => Test Suite Test Suite is the STORE NAME set in the admin NOT the item name set in the catalog

[item_number] => This comes back blank -is this supposed to be the model number set in the catalog

 

Does anyone know of any possible solutions to getting the quantity to update?

Thanks

Share this post


Link to post
Share on other sites

Well correction to the last post

 

I do NOT get the emails either

Only the payment notification from paypal.

 

Are there any other trouble shooting pages to look at other than whats in the docs?

Share this post


Link to post
Share on other sites

OK

This is what I figured out so far in testing

 

If you set up the module using

Aggregate

It will NOT update the product count

and will NOT send the emails

But

If you use per item it will work with problems

If you have more than 1 item in the cart and you check out

This is the error you get at paypal

 

Some required information is missing or incomplete. Please correct your entries and try again.

If you go back to the site

And checkout again

Then it works

It mails the emails and updates the cart

 

Any ideas??

Share this post


Link to post
Share on other sites

Everything is working fine now. I was running tests with my personal account into my business account which are linked. After trying some friends accounts, everything works perfectly.

Edited by Snoboreders

Share this post


Link to post
Share on other sites

Whoops, nope....guess I got too eager. I am still receiving this error when I click the "Complete Your Order Confirmation" button.

 

Not Found

 

The requested URL /us/cgi-bin/checkout_process.php was not found on this server.

 

In my paypal account I went to Profile --> Website Payment Preferences and have this as the auto return destination: http://www.artifexshirts.com/thank_you.php

 

However, when you click on "Complete Your Order Confirmation" that is not auto-return. How can I edit where that button leads to? I can't seem to find it.

 

Thanks,

Chris

Share this post


Link to post
Share on other sites
Whoops, nope....guess I got too eager. I am still receiving this error when I click the "Complete Your Order Confirmation" button.

 

 

 

In my paypal account I went to Profile --> Website Payment Preferences and have this as the auto return destination: http://www.artifexshirts.com/thank_you.php

 

However, when you click on "Complete Your Order Confirmation" that is not auto-return. How can I edit where that button leads to? I can't seem to find it.

 

Thanks,

Chris

 

/catalog/includes/modules/payment/paypal_ipn.php

 

Line 523

 

$parameters['return'] = tep_href_link(FILENAME_CHECKOUT_PROCESS, '', 'SSL');

 

change this to:

$parameters['return'] = "https://www.artifexshirts.com/thank_you.php";

 

Should do the trick.

Share this post


Link to post
Share on other sites

Hiya Guys,

 

Hope this is in the right thread...

 

I have just installed Paypal IPN 2.3.3, and my osCommerce version is osCommerce 2.2 rc2a

 

The only other contribution I've installed is Ultimate SEO URLs v2.2.2 (which worked ok).

 

I installed the Paypal IPN contribution and now when clicking any link to an item in my catalog I get a 404 error - page not found. Other links work OK (privacy policy, terms & conditions, reviews), just seems to be the product pages.

 

Any ideas you may have as to how to fix this would be much appreciated.

 

My site is only in it's early stages and I'm a php coding dummy so please be gentle with me!

 

Kind Regards, Keith.


In life, try everything three times...

First, just to see if you like it.

A Second, to see if you were mistaken the first,

And a third, to see if you tire of it quickly...

Share this post


Link to post
Share on other sites

If your hosting allows it outside the root folder would be better. If it is not allowed put it in some folder deep inside your OSCommerce install and set the permissions to not readable from the web.

 

Heya TCwho,

 

first. on the contribution it is called cc_show you can get it here

 

second.

on the certificates..I read thru that user guide and yes it did talk about the paypal certs, and places to go to get certs, but not specifics on how to get them. I have since found out that I can get them thru my host using Cpanel (there is an option to manage public keys). So now all I need if for my host to fix a small problem with cpanel and away I go!

 

RW

 

I do have one question though for anyone. Where do you upload the certs/keys too? Root folder or just anywhere? Inside the website or outside?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi Guys,

 

I hope someone is kind enough to shed a little light on why after successfully processing some test orders through the live and sandbox systems that customers orders are not being recorded in the admin.

 

Please forgive me I know this will have been discussed a million times over but all things seem ok to me.

 

The order is passed to paypal, the payment is taken by paypal and the customer is successfully returned to the checkout_success page. I also notice on the who's online page that paypal is finding the return url of

 

$parameters['notify_url'] = tep_href_link('ext/modules/payment/paypal_ipn/ipn.php', '', 'SSL', false, false);

 

So now my question is ...... is it the ipn.php that is not logging the order or the checkout_process.php????

 

Any advice from others that have been in this situation would be gratefully received and more importantly put to the test.

 

I look forward to your replies.

 

Thanks

 

Aran

Share this post


Link to post
Share on other sites

Guys,

I want to find out if that contribution is still supported, cause it is looks like not...

Somebody wrote that this thread isn't supported anymore...

Can anybody answer what contribution actually works with PayPal IPN?

Thanks for advice.


Computers777dotcom

Share this post


Link to post
Share on other sites

Hello all,

 

I've installed PayPal IPN v2.3.4 I went to test it and I got the following message 'Paypal does not allow your country of residence to ship to the country you wish to' how can I correct this?

 

Thank you

Share this post


Link to post
Share on other sites

FUNCTIONALITY UPDATE:

 

Hi folks, I’ve noticed several people asking if this module has the capacity to work at all. This is a general comment of my current standing and operational condition of IPN 2.3 with is currently working without issue (although I have had many issues with it)

 

I am hosted on Godaddy which has caused a lot of problems with order updating, stock level adjustment and lack of customer emails. I could always see the PayPal IPN hitting my ipn.php file right after an order was placed but it would only complete the update some of the time.

 

I moved to godaddy and installed this update about the same time several months back. I battled the heck out of it and read nearly every single post on the internet related to Godaddy, Curl and PayPal IPN yet still only got about 20% success rate of the IPN return function working. Check out worked ok and I got all my order details recorded in my database but I had to manually reduce stock levels and send emails to my customers.

 

I did have to make an edit to one of the files to over ride the address verification because it was causing nearly 100% rejections. I don’t have the exact file on hand right now but you can find it in this thread if you search.

 

I have been using this IPN and manually updating stock and emailing customers for most orders until about 2 weeks ago, I did not make any changes to my files yet I began receiving 100% success with the IPN working. I have no idea if Godaddy, Paypal or both made changes or if it will continue to work but at this time all my orders are processing correctly.

 

My posting here doesn’t offer any technical advise, it just lets you know that this module is capable of functioning (with Godaddy, none the less). I also have a heavily modified site with 15-20 or more other add-ins.

 

Cheers,

Markcm

Share this post


Link to post
Share on other sites
Hiya Guys,

 

Hope this is in the right thread...

 

I have just installed Paypal IPN 2.3.3, and my osCommerce version is osCommerce 2.2 rc2a

 

The only other contribution I've installed is Ultimate SEO URLs v2.2.2 (which worked ok).

 

I installed the Paypal IPN contribution and now when clicking any link to an item in my catalog I get a 404 error - page not found. Other links work OK (privacy policy, terms & conditions, reviews), just seems to be the product pages.

 

Any ideas you may have as to how to fix this would be much appreciated.

 

My site is only in it's early stages and I'm a php coding dummy so please be gentle with me!

 

Kind Regards, Keith.

 

Keith,

 

My guess is that you missed a step in the installation. I would recommend that you un-install this module from your admin panel, revert to your back up filesdeleting this module completely and then start over carefully following the instructions. I typically print out the instructions, highlight the begining of each step and then check them off as I complete them to ensure I don't miss any and sometimes I still end up messing something up and have to revert to my back up files.

 

-Markcm

Share this post


Link to post
Share on other sites

Hi everyone :),

 

I am using 2 contribs at the moment, OSC PayPal IPN and Super Download Store. I seem to have a problem with getting IPN emails and the order status updating on its own (I have to update it manually, blah). I have read Terra's fixes and here is information I received from my host when I emailed them about it (I am hosted with resellerzoom.com with a shared SSL, dedicated IP). I also just learned that my site is hosted on one of their Linux shared servers and not a windows server (if this makes any difference). Also, I have another OSC shop on my reseller account, which I do not get IPN emails for either.

 

1. register_globals is indeed off server-wide, however you can easily re-enable it using a local php.ini

We a have a default register_globals geared php.ini downloadable here - http://hostingzoom.com/phpini.txt

 

* Rename phpini.txt to "php.ini", then simply upload this php.ini to any directory which requires reqister_globals enabled.

 

2. Both ports 80 (HTTP) and 443 (HTTPS) are enabled for outgoing access. You are welcome to use either port.

 

3. The server you're on is Not a proxy server.

 

So, where do I go from here to get my IPN working?

Edited by Kmberly

Share this post


Link to post
Share on other sites
Hi everyone :),

 

I am using 2 contribs at the moment, OSC PayPal IPN and Super Download Store. I seem to have a problem with getting IPN emails and the order status updating on its own (I have to update it manually, blah). I have read Terra's fixes and here is information I received from my host when I emailed them about it (I am hosted with resellerzoom.com with a shared SSL, dedicated IP). I also just learned that my site is hosted on one of their Linux shared servers and not a windows server (if this makes any difference). Also, I have another OSC shop on my reseller account, which I do not get IPN emails for either.

 

 

 

So, where do I go from here to get my IPN working?

 

For starters you need to put the renamed file "php.ini" in your root. Some folks have reported putting this fill deeper in the paypal_ipn folder, you will find a post not to far back in this thread where someone commented on putting it there.

Share this post


Link to post
Share on other sites
For starters you need to put the renamed file "php.ini" in your root. Some folks have reported putting this fill deeper in the paypal_ipn folder, you will find a post not to far back in this thread where someone commented on putting it there.

 

Alright, did that. The only php.ini file I had was in the ext/payment/paypal_ipn folder. Anything else I need to do?

Share this post


Link to post
Share on other sites
Alright, did that. The only php.ini file I had was in the ext/payment/paypal_ipn folder. Anything else I need to do?

 

I think some people successfully have it in the ext/payment/paypal_ipn folder while others have it in the root.

 

You will need payment zone configured such as USA, Canada, International... then fill in all your settings in the PayPal IPN from Admin-->Modules-->Payment and then try it out. I set up a cheap test item in my shop and test live, this requires two real paypal accounts or one account and your credit card but you can even refund the transaction once done if you want. If you haven't set up a paypal sandbox account for testing yet it can be helpful for extended testing but I honestly found it to be kind of non-intuitive; there are threads around here on paypal sandbox setups as well. For starters, you need two test profiles in your sandbox account; one for the simulated buyer and one for the simulated seller.

 

Another thing, and sorry but I don't have the exact file and location handy but it is posted somewhere back in this thread; the version I am using was hard coded to force PayPal to check the address against the address entered in your store, if the customer changed a single character you would get an error related to address at checkout, I just commented that line out and haven't had any problems since. If you run in to that address problem and can't find the fix back in this thread send me a PM and I'll dig it up.

Edited by mmph

Share this post


Link to post
Share on other sites
I think some people successfully have it in the ext/payment/paypal_ipn folder while others have it in the root.

 

You will need payment zone configured such as USA, Canada, International... then fill in all your settings in the PayPal IPN from Admin-->Modules-->Payment and then try it out. I set up a cheap test item in my shop and test live, this requires two real paypal accounts or one account and your credit card but you can even refund the transaction once done if you want. If you haven't set up a paypal sandbox account for testing yet it can be helpful for extended testing but I honestly found it to be kind of non-intuitive; there are threads around here on paypal sandbox setups as well. For starters, you need two test profiles in your sandbox account; one for the simulated buyer and one for the simulated seller.

 

Another thing, and sorry but I don't have the exact file and location handy but it is posted somewhere back in this thread; the version I am using was hard coded to force PayPal to check the address against the address entered in your store, if the customer changed a single character you would get an error related to address at checkout, I just commented that line out and haven't had any problems since. If you run in to that address problem and can't find the fix back in this thread send me a PM and I'll dig it up.

 

I am using Sandbox to test. The only problem I have with the module is I don't receive IPN emails. I do receive an email every time an order is made, but it goes to my root address with this (titled 'PHP error_log message'):

cmd=_ext-enter

redirect_cmd=_xclick

item_name=Business Name

amount=45.00

handling=0.00

business=kimgri_1217540805_biz@gmail.com

no_shipping=1

night_phone_b=8016139191

first_name=Bob

last_name=Bob

address1=123 Fake St.

address2=

city=Junkster

zip=84119

state=UT

country=US

email=bobbob@gmail.com

charset=utf-8

currency_code=USD

invoice=100009

custom=3

no_note=1

notify_url=https://www.website.com/catalog/ext/modules/payment/paypal_ipn/ipn.php?language=english

cbt=Complete your Order Confirmation

return=https://www.website.com/catalog/checkout_process.php?osCsid=090dcad92c8796729777903fdeb45ab2

cancel_return=https://www.website.com/catalog/FILENAME_PAYPAL_CANCEL?osCsid=090dcad92c8796729777903fdeb45ab2

bn=osCommerce PayPal IPN v2.3.3

lc=US

Edited by Kmberly

Share this post


Link to post
Share on other sites
I am using Sandbox to test. The only problem I have with the module is I don't receive IPN emails. I do receive an email every time an order is made, but it goes to my root address with this (titled 'PHP error_log message'):

Do you have your IPN folder permissions set correctly as described in the setup instructions and can you see the post-back from paypal hitting your ipn.php file in your who's online page?

Share this post


Link to post
Share on other sites
Do you have your IPN folder permissions set correctly as described in the setup instructions and can you see the post-back from paypal hitting your ipn.php file in your who's online page?

 

I have set the ext/ directory to 644 like the instructions have said. When I re-read through the instructions, those were the only permissions I could find to change.

 

I don't know what you mean by "can you see the post-back from paypal hitting your ipn.php file in your who's online page". Under who's online in the admin, I see:

00:02:10 0 Guest 98.202.183.29 16:07:20 16:07:20 /catalog/ext/modules/payment/paypal_ipn/ipn.php

 

00:23:10 3 Bob Bob 98.202.183.29 15:46:20 16:03:34 /catalog/shopping_cart.php?osCsid=090dcad92c8796729777903fdeb45ab2

 

Edit: I also just got this email:

PayPal IPN Invalid Process

$_POST:

 

 

$_GET:

Edited by Kmberly

Share this post


Link to post
Share on other sites
I have set the ext/ directory to 644 like the instructions have said. When I re-read through the instructions, those were the only permissions I could find to change.

 

I don't know what you mean by "can you see the post-back from paypal hitting your ipn.php file in your who's online page". Under who's online in the admin, I see:

00:02:10 0 Guest 98.202.183.29 16:07:20 16:07:20 /catalog/ext/modules/payment/paypal_ipn/ipn.php

 

00:23:10 3 Bob Bob 98.202.183.29 15:46:20 16:03:34 /catalog/shopping_cart.php?osCsid=090dcad92c8796729777903fdeb45ab2

 

Edit: I also just got this email:

PayPal IPN Invalid Process

$_POST:

 

 

$_GET:

Ok, the first line in your who's online report of "Guest..." is PayPal attempting to post back information to your ipn file; so at least you know it's getting that far.

 

I believe it's the ipn.php file its self that is supposed to be 644, all of it's parent directories up to the ext folder should be 755; that's how I have mine set and it is working correctly.

 

 

The email should have data in it pertaining to th order if the ipn were working correctly.

Share this post


Link to post
Share on other sites
Ok, the first line in your who's online report of "Guest..." is PayPal attempting to post back information to your ipn file; so at least you know it's getting that far.

 

I believe it's the ipn.php file its self that is supposed to be 644, all of it's parent directories up to the ext folder should be 755; that's how I have mine set and it is working correctly.

 

 

The email should have data in it pertaining to th order if the ipn were working correctly.

 

Okay, I have all the same permissions as you now. I only get the PHP error_log messages now. Don't know when I receive the PHP Invalid Process emails, it seems to be random. Hm.

Share this post


Link to post
Share on other sites

All of a sudden lately I have been getting a lot of customers with special characters in their addresses. A lot of them are the darn "o" with two dots above it. OSC takes it fine but when the customer tries to pay via paypal it gives them an error and tells them to contact the site admin. I end up going into their address and changing the letter in there and they resend it and all is well but it's a PIA. Any idea how to resolve this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×