Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

I realize this forum says it's for OSC v2.x. I have a customer that I inherited that is running OSC v1.280 (according to includes/application_top.php). The payap_ipn.php shows version 1.1.2.11.

 

My client started having a problem a couple of weeks ago where paypal no longer showed the shipping amounts being passed through. They show up in OSC, but when you confirm order and it goes to paypal, only the item totals are there, shipping amount isn't showing up at all.

 

Is there a recommended fix for this given the version of OSC and paypal_ipn that is in use?

 

Did this suddenly start occurring due to a change at Paypal?

 

Thanks in advance for any information/assistance that can be provided.

 

- John

 

Hello, I had the same problem, also with the version 2.3.2 of Paypal IPN. The sandbox worked fine, but going live the shipping costs were gone. So I went searching here on the forums and found 2 solutions that could work. Only when I did both it worked.

1. Login to paypal

> click Profile tab

> click Postage Calculations (in Seller Preferences.

> tick box Click here to allow transaction-based postage values to override the profile postage settings listed above (if profile settings are enabled).

> click Save

 

2. - Locate the following file in your OSC installation

 

[installation Directory]\catalog\includes\modules\payment\paypal_ipn.php

 

- Make a backup copy of the file

- Open it up with a text editor

- Search for the following string: "no_shipping"

- You should find the following line:

 

$parameters['no_shipping'] = '1';

 

- Change the "1" in "2" to read

 

$parameters['no_shipping'] = '2';

 

 

I found it here: http://forums.oscommerce.com/index.php?showtopic=278816 all the credits go to Hairyharry and Helper.

 

I hope it works for you too! Good Luck! :)

Share this post


Link to post
Share on other sites
It's defined in the language level file, not in database. Look into catalog/includes/languages/xxxxx/modules/payment/paypal_ipn.php, you'll easily find where to modify the text.

Super Download Shop, PayPal Express Checkout IPN, Selling Downloads, Visual Validation (preventing robotic flood), phpBB2 Integration

 

Yes, I'm willing to help, but please ask in the right place. Think twice before trying to PM me, it might be ignored.

Share this post


Link to post
Share on other sites
Please don't confuse others posting modifications to the code without knowing what you're doing. The no_shipping parameter has been set to 2 in v2.3.2, and the line with no_shipping set to 1 is for selling intangible items.

 

The no_shipping parameter described in PayPal document:

Prompt customer for shipping address.

Default or 0: customer is prompted to include a shipping address.

1: customer is not asked for a shipping address.

2: customer must provide a shipping address.

There for according to your suggestion, when there is no shipping, customers will be asked for a shipping address at PayPal, which doesn't make any sense.

 

It's been stated in the v2.3.2 install guide that you must leave your shipping calculations blank in your PayPal profile, so can the shipping costs sent by this module take place at PayPal payment page.


Super Download Shop, PayPal Express Checkout IPN, Selling Downloads, Visual Validation (preventing robotic flood), phpBB2 Integration

 

Yes, I'm willing to help, but please ask in the right place. Think twice before trying to PM me, it might be ignored.

Share this post


Link to post
Share on other sites

thanks, I managed to change it to "Credit/Debit Card (Securely via PayPal)" and this is successfully displayed on the checkout page.

 

However, when I go to view an invoice in the admin section under Payment: it says "Credit/Debit Card (Securely via"

 

Why do you think it has left the last bit off? I tried to print the invoice and it still said the same thing. Do you know why this could be? :(

 

And also, when I just highlight an order in the admin side to get the choice of options (edit, delete, invoice... etc) it says "Payment Method: Credit/Debit Card (Securely via" on the right hand side too

 

Ben

 

It's defined in the language level file, not in database. Look into catalog/includes/languages/xxxxx/modules/payment/paypal_ipn.php, you'll easily find where to modify the text.
Edited by Benjjj6

Share this post


Link to post
Share on other sites
The payment_method field in database table orders is set to varchar(32) by default installation, which can only hold up to 32 characters. You can change it via phpMyAdmin to varchar(64) or even longer if you need, but please don't ask me how to do it step-by-step regarding phpMyAdmin.

Super Download Shop, PayPal Express Checkout IPN, Selling Downloads, Visual Validation (preventing robotic flood), phpBB2 Integration

 

Yes, I'm willing to help, but please ask in the right place. Think twice before trying to PM me, it might be ignored.

Share this post


Link to post
Share on other sites

Thanks Alex, I managed to change it and it solved the problem

 

thanks again :)

 

 

Do you know how to remove the tags from this line, which customers see under comments as their order status changes:

 

PayPal IPN Verified [Pending (Unverified; <span class=currency_symbol></span>262.54<span class=currency_symbol>EUR</span>); multi_currency]
Edited by Benjjj6

Share this post


Link to post
Share on other sites
The currency symbol is defined by you (or other contrbutions), set in admin under Localization -> Currencies page, not by this module.

Super Download Shop, PayPal Express Checkout IPN, Selling Downloads, Visual Validation (preventing robotic flood), phpBB2 Integration

 

Yes, I'm willing to help, but please ask in the right place. Think twice before trying to PM me, it might be ignored.

Share this post


Link to post
Share on other sites
There for according to your suggestion, when there is no shipping, customers will be asked for a shipping address at PayPal, which doesn't make any sense.

 

It's been stated in the v2.3.2 install guide that you must leave your shipping calculations blank in your PayPal profile, so can the shipping costs sent by this module take place at PayPal payment page.

 

Hello Alex, I've checked it and you are totally right about this. It was not my intention to confuse people with this "solution"...

Share this post


Link to post
Share on other sites

I apologize if this has been covered, but I can't find it in here.

 

I have installed the PayPal IPN module to hopefully correct various issues I was having with PayPal. It couldn't be easier to install. Anyway, when I check out in osCommerce now, I have both the PayPal and the PayPal Credit/Debit Card (IPN) options. If I only want them using the IPN, do I just uninstall the PayPal module?

 

Thanks a lot.

Share this post


Link to post
Share on other sites
thanks Gaz, appreciate the response. and I do understand the issue - I am sure there is a way though and that eventually one of the other contribution will have an answer - they are both really good contri's

 

 

all i really want to be able to do is offer my mailing list subscribers (who are not necessarily registered with my shop) an incentive to come an buy by means of a discount coupon, i just couldnt find another contribution to do the job as properly as CCGV(trad) does.

 

I have fixed my problem for now in that I installed Discount Coupon Codes by KGT and that is doing the job I need it to do. It no issues with the price going to paypal incorrectly. All that works fine.

 

The contribution is here if anyone else would like it

http://www.oscommerce.com/community/contributions,4269

Share this post


Link to post
Share on other sites

Thanks for any advice.

 

Using a clean install of v2.2 RC1

 

Had troubles with currency selection in IPN and so upgraded to the 2.3.2 version (currency works fine here)

 

All goes well intil entering the PP page when credit card detail and information is all pre populated.

 

BUT

 

The item pricing does not come across.

 

I have tried a number of combinations ot single and aggregate settings as well as true / false for tax

 

I have checked PP for postage and set all to 0 (zero), also tried clearing the settings but they default back to 0.00.

 

It also appears to want to default back to Australian $ (my currency) even when I clear the settings.

 

thanks


Geoff

 

Telegraph Point 2441

Australia

Share this post


Link to post
Share on other sites
What currency codes do you have in your Admin->Localization->Currencies page?

Super Download Shop, PayPal Express Checkout IPN, Selling Downloads, Visual Validation (preventing robotic flood), phpBB2 Integration

 

Yes, I'm willing to help, but please ask in the right place. Think twice before trying to PM me, it might be ignored.

Share this post


Link to post
Share on other sites

I have just the one for Australia

 

It has a code of Aus, if I set it for AUD this somehow sets all the prices on my items to zero (0)

 

if I change it back to Aus the prices are restored

 

thanks

Edited by geoffwin

Geoff

 

Telegraph Point 2441

Australia

Share this post


Link to post
Share on other sites

Following from your question I played around with the currencies and added USD and CAD to the mix, set AUD as the default and did an "update currencies" - which worked for the first time.

 

Perhaps it was because I had only one currency listed?

 

Anyway it now populates the the price and product name.

 

Also I have a discount coupon mod and if I apply the coupon it dispalys the correct price up to checkout confirmation, but on confirmation the discount is ignored and the full value is sent to PP

 

Am I able to set it so the coupon price is sent to PP?

 

thanks Geoff

Edited by geoffwin

Geoff

 

Telegraph Point 2441

Australia

Share this post


Link to post
Share on other sites

I made all the necessary changes in my PayPal IPN version 1.1.2.11 that were recommended here in this thread and once again I'm still not getting the shipping money from my PayPal transactions. I've had this issue behave badly 2 different ways:

 

#1. some transactions will show the shipping price within the final invoice, but PayPal doesn't collect the shipping money at all.

 

#2. past couple of days I've had an order process through and the shipping doesn't even show up at all on the invoice. I've had my customers tell me that they didn't see any choices for shipping (we use USPS), and were able to just click to the next screen and complete the order without seeing or paying for any shipping whatsoever.

 

------------------------------------------------------------------------

Here's a copy of the thread I used to try and fix my problem:

------------------------------------------------------------------------

Following these steps you should be able to change the value of no_shipping without updating the module:

 

- Locate the following file in your OSC installation

 

[installation Directory]\catalog\includes\modules\payment\paypal_ipn.php

 

- Make a backup copy of the file

- Open it up with a text editor

- Search for the following string: "no_shipping"

- You should find the following line:

 

$parameters['no_shipping'] = '1';

 

- Change the "1" in "2" to read

 

$parameters['no_shipping'] = '2';

 

This appears to have worked for me.

I have had several orders today which went through no problems some with different billing addresses to shipping.

 

let me know if it works for you and I will update paypal

-----------------------------------------------------------------------------------

 

Does anybody have any idea why it still doesn't work?

 

Should I upgrade my PayPal IPN to the latest version, will that fix it?

 

or is this a problem with the USPS shipping module?

 

any help would be greatly appreciated!!!

 

My Website: http://www.drfreeclouds.com

 

thanks... Ron D

Share this post


Link to post
Share on other sites

I am looking for suggestions on how to proceed.

 

Latest version of OSC and Paypal_ipn. Php version is 4.7.7.

 

-cURL is working. Used php.net/curl tool and it was able to fetch google page and store in a file.

-Also accessed the ipn.php directly and it took to blank page. It also sends an "invalid process" email to debug address because no POST data was made to ipn.php.

-ipn.sandbox.paypal.com is able to access this file, evident from the log where a header 200 was seen.

 

Paypal payments go through in sandbox.

 

It seems to be ipn.php is working, paypal is working but something else between ipn.php and other programs that update order may not be.

 

Is there something that needs to be done at mySQL level?

 

problem #1: Order Status is not getting updated.

 

problem #2: (perhaps due to problem #1) Emails are not sent to buyer/seller from the shop. Paypal emails

are going to buyer/seller.

 

Truly appreciate any tips and guidance. Thank you!

Share this post


Link to post
Share on other sites

Hey,

 

Im using the same contribution as you although the discount coupon is only applied to the PayPal amount when I use the Aggregate option, If I choose the 'Per Item' option in the PayPal IPN module settings then the discount is not applied.

 

Do you have this same problem, or does the coupon work no matter which option you choose?

 

Also, it seems the shipping amount is not sent to PayPal when using the 'Per Item' method, does this happen to anyone else?

 

Thanks,

 

Ben

 

I have fixed my problem for now in that I installed Discount Coupon Codes by KGT and that is doing the job I need it to do. It no issues with the price going to paypal incorrectly. All that works fine.

 

The contribution is here if anyone else would like it

http://www.oscommerce.com/community/contributions,4269

Edited by Benjjj6

Share this post


Link to post
Share on other sites

Hey everyone, since using this contrib I have a problem with order emails, but only the order emails that come through when the payment gateway of paypal is used, as you can see in the example the price says its $10, when infact it is only $1, as you can see in the subtotal and total feilds, the correct amounts are displayed in the paypal payment side, and the correct amount is charged to thier account, but the email shows the incorrect prices on the items, every single item comes to $10 regardless of price or quantity, I assume its collecting the data from the incorrect field and is displaying the 10% gst field.

 

 

1 x OCZ COPPER BGA RAMSINK (8 PIECES) (BGACRS8-RTL) = $10

------------------------------------------------------

Sub-Total: $1

Store Pickup (No shipping charge added. Pickup during regular business hours.): $0

GST: $0

Total: $1

 

 

Any help would be greatly appreciatied.

 

Cheers

 

Azz

Share this post


Link to post
Share on other sites

Gday from Oz-tralia!

 

 

I have one issue that I'm sure is simple but I just can't figure it. I don't know if it is a Paypal IPN or CCGV(trad) problem... I am assuming paypal as the CCGV(trad) works fine with other payment methods...

 

The discount code seems to work except when a customer selects Paypal (I have the latest Paypal IPN 2.3.2) where it ignores the discount & charges the customer full price. (the correct price including deduction is displayed in Osc but then on Paypal the amount is wrong)

 

I have noted that in the install of CCGV(trad) there is some notes on IPN / CCGV manual edits to the /includes/modules/payment/paypal_ipn.php file.

I have started to do this - but stopped as it seems to be written (maybe) for an older IPN?

 

The reason I thought this is because the 2nd piece that is meant to be edited doesn't exist in the file from the IPN install. The piece of code I refer to is:

 

CODE

find this code:

//------insert customer choosen option eof ----

$total_weight += ($order->products[$i]['qty'] * $order->products[$i]['weight']);

$total_tax += tep_calculate_tax($total_products_price, $products_tax) * $order->products[$i]['qty'];

$total_cost += $total_products_price;

 

$products_ordered .= $order->products[$i]['qty'] . ' x ' . $order->products[$i]['name'] . ' (' . $order->products[$i]['model'] . ') = ' . $currencies->display_price($order->products[$i]['final_price'], $order->products[$i]['tax'], $order->products[$i]['qty']) . $products_ordered_attributes . "\n";

}

 

and below add this:

$order_total_modules->apply_credit();// CCGV

 

 

 

 

Can anyone help getting the order total to work?

Share this post


Link to post
Share on other sites

Is there a problem with paypal, my IPN and email notifications of payment received have stopped. I have emailed paypal, no answer yet, just wondering if anyone else has experienced this over the past few days.

Share this post


Link to post
Share on other sites

I'm running version 2.2 RC1.

 

forgive me because i know this is a dumb question...but alas I'm left w/out answers after my own search.

 

Will this work in version 2.2 RC1? Has anyone tried it? Thanks,

 

Michael

Share this post


Link to post
Share on other sites
I'm running version 2.2 RC1.

 

forgive me because i know this is a dumb question...but alas I'm left w/out answers after my own search.

 

Will this work in version 2.2 RC1? Has anyone tried it? Thanks,

 

Michael

 

 

Gday Michael - I am using RC1 - seems to work on it's own but won't work with CCGV (unless someone can mod it??) You have to use paypal_IPN 1.4 with CCGV(trad)

I have got both working on RC1, now just have to try to get Featured products working & some SEO contrib (which is best?)

Share this post


Link to post
Share on other sites

Many Thanksss, Alex, I just fixed the shipping address, now it works now.

 

Another question:

 

I am trying to set an image on the paypal check out instead of my paypal email address, but I don't have SSL enable to my web site(it should be https://..)

 

Paypal recommend the image is stored on a secure server, if the image is not stored on a secure server, the customers web browser will display a message that the payment page contains insecure items.

 

 

Do you know where has a free web site(a secure server) can upload an image to the server, so I can link the URL to the paypal for the image.

 

or any another solution based on I don't have a secure server???

 

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×