Jump to content
Mark Evans

Official PayPal IPN Support Thread

Recommended Posts

The message do not appear, but i dont know if this is a symptom cure, or if a real cure, i have to try with the downloadable content, and check if this is working...

 

Anyone have tryed before ?

Who cares? - I get paid correctly and no annoying emails. Thats all I wanted!

Share this post


Link to post
Share on other sites

Has anyone made any progress on getting CCGC(trad) to work with Paypal IPN ver 2.2 yet?

 

It's well known on this forum these two are not compatible out of the box.

 

Like others, I have had success with Paypal IPN ver 1.4 with downloads and CCGV(trad).

 

Anyone have any luck with this?

 

Thanks,

Brian

Share this post


Link to post
Share on other sites

Hmm im having a problem even though it says how to "fix" it in the this_invoice_has_already_been_paid_error.txt file.

 

I've installed v2.2 with no problems, set it to run on test and created a sandbox account. I was getting the 'Invoice Has Already Been Paid' error message so i then used the text files fix.

 

But i still get the error (it does say in the txt file to disable it via paypal if error still occurs) but i would prefer not to disable duplicate invoice checking.

 

I looked at some of the older threads and i can get the payments to work if i replace

 

$parameters['invoice'] = substr($cart_PayPal_IPN_ID, strpos($cart_PayPal_IPN_ID, '-')+1);

in paypal_ipn.php

 

with

$parameters['invoice'] = $cart_PayPal_IPN_ID;

 

But then the IPN isnt successful (the order is made, payment sent but the order status is stuck on Preparing[iPN] and emails nor stock level is sent.

 

Im not using any other Contribs.

 

Any advice?

Share this post


Link to post
Share on other sites

I apologize if this has already been posted. I did a search and didn't find the answer. I uploaded all the files for this contrib. It is showing up under payment modules in admin. However, when I go to edit the settings and hit Update, my changes aren't saved. It still shows Enable PayPal IPN module is set to false. Any idea why my changes aren't updating?

 

Thanks

Share this post


Link to post
Share on other sites

Hi,

 

I've tried searching the forum but so far no luck in finding an answer to these two problems:

 

I'm running version 2.2 of the IPN module.

 

1. New users orders are not at all appearing in the admin section, i.e. they don't go into Preparing IPN status.Also, they have no extra delivery field appearing when they order (usually there is a billing and delivery address field that

can be edited).

 

2. if an existing customer orders billing and delivery address appear and

can be edited...and the order appears in the admin. However, if the person

orders again than the previous order gets deleted or overwritten (means: in

the admin only the new order is visible...even when you click on the

customers name and check all orders).

 

Does anyone know of this problem and a solution?

Share this post


Link to post
Share on other sites

I've found that the errors that were occuring on mine in Test mode, did not occur when set to Live.

Share this post


Link to post
Share on other sites
I've found that the errors that were occuring on mine in Test mode, did not occur when set to Live.

 

Do you mean the paypal test server? we're on the live server, so alas the problem is something else.

Anyone else have any ideas?

Share this post


Link to post
Share on other sites

Your paypal profile setting should have.

 

IPN set to true(radio button).

 

 

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites
Your paypal profile setting should have.

 

IPN set to true(radio button).

Satish

 

Thanks for that Satish, but the documentation states in bold and red:

 

You do NOT need to enable the IPN in your PayPal account as all the required information is sent by the module.

 

So surely that can't be the problem.

 

As I said, it's only failing to register orders for new customers, returning customers orders are being registered.

Share this post


Link to post
Share on other sites
Do you mean the paypal test server? we're on the live server, so alas the problem is something else.

Anyone else have any ideas?

AH no that was a general suggestion to people encountering different problems.

 

Sounds like the error your having may be to do with other contributions that you have installed?

Share this post


Link to post
Share on other sites
Sounds like the error your having may be to do with other contributions that you have installed?

 

I was beginning to come to that conclusion....

 

I have an SEO URL module installed, I'll have a look at the rewrite rules and watch the server logs whilst testing to see what paypal tries to do on the call back.

Share this post


Link to post
Share on other sites
I apologize if this has already been posted. I did a search and didn't find the answer. I uploaded all the files for this contrib. It is showing up under payment modules in admin. However, when I go to edit the settings and hit Update, my changes aren't saved. It still shows Enable PayPal IPN module is set to false. Any idea why my changes aren't updating?

 

Thanks

 

I have been having this same problem. Did you manage to solve it? Or does anyone else have a solution?

 

Thanks

Share this post


Link to post
Share on other sites

Chaps - this is not a module problem, but a bug in osCommerce which exists since 2006. For the fix please see: http://forums.oscommerce.com/index.php?sho...mp;#entry932499

 

The bug sits in both compatibility.php files (admin & root).

 

You can also download the candidate release notes:

http://www.oscommerce.com/ext/osc22rc1_upgrade.html.zip

 

The compatibility fix is listed under "[bUGFIX] Compatibility Array Index" on the page.

 

all the best - Terra

 

Keywords: payment module updates not saved, update, updated,


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

Hello all, finally need to post after many months of reading the forums - thanks to all concerned.

 

Contribution 'Page heading title' (which displays the category name instead of 'products') worked well until PayPal IPN 2.2 was installed. Is there a known solution to this? Thanks in advance.

Share this post


Link to post
Share on other sites

Great contribution and has been working great on most installs...but got an odity on one site.

Bascially after paying at paypal and returning to the site it seems the customers_id session variable is no longer valid as the initial check in checkout_process is failing and forcing them to log back in....this is also of cource keeping the code clearing the cart from being executed....any help would be great...customer is complaining pretty badly...lol...don't they all

Share this post


Link to post
Share on other sites
Great contribution and has been working great on most installs...but got an odity on one site ... Bascially after paying at paypal and returning to the site it seems the customers_id session variable is no longer valid ...

This sound like a lost session problem which is not specific to the payment module but indicates a server / site error. For best results with sessions, cookies should be forced - but this can only be done if the site has a full SSL. Like you say - if the install worked before, then it's a site/server error, not a problem with the module. If you look at how the flow goes (are secure pages on the same server etc.) you may find your answer. all the best - Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
Chaps - this is not a module problem, but a bug in osCommerce which exists since 2006. For the fix please see: http://forums.oscommerce.com/index.php?sho...mp;#entry932499

 

The bug sits in both compatibility.php files (admin & root).

 

You can also download the candidate release notes:

http://www.oscommerce.com/ext/osc22rc1_upgrade.html.zip

 

The compatibility fix is listed under "[bUGFIX] Compatibility Array Index" on the page.

 

all the best - Terra

 

Keywords: payment module updates not saved, update, updated,

 

Thanks Terra, that fixed it!

Share this post


Link to post
Share on other sites

I recently discovered that my client had changed her Primary email in Paypal, so of course, her orders started getting stuck in Preparing [Paypal IPN] status. I've fixed the email addresses now so that they match, but is there anyway to resend the orders that are stuck in that status without the customer having to resubmit their order? My client didn't get any payment in her Paypal account, so that's the part that I'm not sure how to resubmit to get her paid. The packing list shows fine in osCommerce even though the order didn't go through - a wonderful confirmation that this contribution works great! Thanks in advance.

Share this post


Link to post
Share on other sites
I recently discovered that my client had changed her Primary email in Paypal, so of course, her orders started getting stuck in Preparing [Paypal IPN] status.

If the email address (which is also the PayPal account name) is wrong, then customers cannot pay. They would have a seen a message saying that this account does not exist. You would therefore have to contact the customers, apologise to them and tell them, that if they still want to order they need to resubmit (and pay) their orders. But in reality I believe those sales are lost.

PS: the problem isn't just that they got "stuck" in the preparing stage - the problem is that customers were unable to pay and therefore abandoned the checkout. As far as the customers are concerned, the site appeared broken and they abandoned the order.

All the best - Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

Stupid Question,

 

I have d/led and installed osC RC1 and have been working to get it set-up properly, and I am now working on setting up my payment options.

 

Does osC RC1 have the latest version of Paypal IPN or should I download the latest version and install it?

 

Also what is the Instant Payment Notification URL?


Powered By osC 2.2RC2a STS 4.5.8 - HTC 2.6.3 - FP 1.5.9 - BCH 1.0.0

Share this post


Link to post
Share on other sites

Hi, hope someone can help. I'm using an old IPN version 1.1. It's been working fine for 2 years so I've never had any reason to upgrade. From the 30th June I've noticed that when a customer clicks the 'Return to Merchant' button at paypal it now returns to the customer login screen rather than the checkout_success.php page. It never used to do this as it's always returned to the checkout success page. This in turn means that the customers cart isn't emptied and the order emails aren't sent. The IPN is still updating the order in admin to show that PayPal IPN Verified [ie. Completed (Verified; £1.99)

 

I haven't changed anything and was wondering if anyone else has experienced this? Maybe Paypal UK/Euro has changed something. The only thing I've noticed during test that might be different is that I receive a warning from Paypal when I click the 'Return to Merchant' button stating that I'm leaving a 'Secure site for a non secure site' would I like to continue. Clicking continue takes you back to the standard osCommerce customer logon screen. My site is very simple and deals in low value, low volume items. I have always relied on paypal to secure the payment process as I've never really felt the need to secure the whole process (be that right or wrong).

 

From reading the installation notes with IPN v1.1 (and the latest IPN version 2.2) it states that the order information (IPN) works with unsecured connections. And it has until now!!

 

Currently at Paypal I don't have the 'Auto Return' nor the IPN turned on as this has always been sent by the module and hasn't been a previous requirement (as per the modules install guide).

 

Be very grateful if someone could maybe cast an eye over my problem. Maybe I need to install v2.2. At least customer carts would be emptied. Would v2.2 cure my problem??

 

Hope you can help. Cheers MM.

Share this post


Link to post
Share on other sites

I'm struggling with the configuration of this module. I cannot figure out what my public certificate (I have the paypal public certificate on my desktop) nor can I figure out what my private key is. Actually....I think I know what that is. But the private certificate is confusing. Where would I find that?

 

Thank you.

Share this post


Link to post
Share on other sites
Hi, hope someone can help. I'm using an old IPN version 1.1. It's been working fine for 2 years so I've never had any reason to upgrade. From the 30th June I've noticed that when a customer clicks the 'Return to Merchant' button at paypal it now returns to the customer login screen rather than the checkout_success.php page. It never used to do this as it's always returned to the checkout success page. This in turn means that the customers cart isn't emptied and the order emails aren't sent. The IPN is still updating the order in admin to show that PayPal IPN Verified [ie. Completed (Verified; £1.99)

 

I haven't changed anything and was wondering if anyone else has experienced this? Maybe Paypal UK/Euro has changed something.

 

 

Hi, I just tried Auto Return which didn't make any difference. Could this be a session ID problem? If so why would it work for 2 years and then start to return to the wrong page?? My site has never had any SSL protection so I don't think I can force cookies or sessions within osC. I also checked my host cpanel to see if there's anything I can change, but cant find anything that will help. Really appreciate some pointers as I'm not too sure what to do next. Either my host has changed something on the host server or paypal are no longer processing the IPN correctly to return sites without SSL protection. Hope someone can help.

Cheers MM.

Share this post


Link to post
Share on other sites

Godaddy site says to use http://proxy.shr.secureserver.net:3128 for the CURLOPT_PROXY.

 

See http://help.godaddy.com/article.php?article_id=288

 

This is the code that I modified from an earlier version of ipn.php

 

function authenticate($domain) {

$paypal_response = '';

$curl_flag = function_exists('curl_exec');

if($curl_flag) {

$ch = @curl_init();

@curl_setopt($ch, CURLOPT_URL, "https://$domain/cgi-bin/webscr");

@curl_setopt($ch, CURLOPT_POST, true);

@curl_setopt($ch, CURLOPT_POSTFIELDSIZE, 0);

@curl_setopt($ch, CURLOPT_POSTFIELDS, $this->_response_string);

@curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);

@curl_setopt($ch, CURLOPT_TIMEOUT, 120);

@curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, false);

//BEGIN GODADDY FIX

//@curl_setopt($ch, CURLOPT_HTTPPROXYTUNNEL, TRUE);

@curl_setopt($ch, CURLOPT_PROXYTYPE, CURLPROXY_HTTP);

@curl_setopt($ch, CURLOPT_PROXY, "http://proxy.shr.secureserver.net:3128");

//END GODADDY FIX

$paypal_response = @curl_exec($ch);

@curl_close($ch);

if($paypal_response == '') $curl_flag = false;

}

Share this post


Link to post
Share on other sites
Hi, hope someone can help. I'm using an old IPN version 1.1. It's been working fine for 2 years so I've never had any reason to upgrade. From the 30th June I've noticed that when a customer clicks the 'Return to Merchant' button at paypal it now returns to the customer login screen rather than the checkout_success.php page. It never used to do this as it's always returned to the checkout success page. This in turn means that the customers cart isn't emptied and the order emails aren't sent. The IPN is still updating the order in admin to show that PayPal IPN Verified [ie. Completed (Verified; £1.99)

 

I haven't changed anything and was wondering if anyone else has experienced this? Maybe Paypal UK/Euro has changed something. The only thing I've noticed during test that might be different is that I receive a warning from Paypal when I click the 'Return to Merchant' button stating that I'm leaving a 'Secure site for a non secure site' would I like to continue. Clicking continue takes you back to the standard osCommerce customer logon screen. My site is very simple and deals in low value, low volume items. I have always relied on paypal to secure the payment process as I've never really felt the need to secure the whole process (be that right or wrong).

 

From reading the installation notes with IPN v1.1 (and the latest IPN version 2.2) it states that the order information (IPN) works with unsecured connections. And it has until now!!

 

Currently at Paypal I don't have the 'Auto Return' nor the IPN turned on as this has always been sent by the module and hasn't been a previous requirement (as per the modules install guide).

 

Be very grateful if someone could maybe cast an eye over my problem. Maybe I need to install v2.2. At least customer carts would be emptied. Would v2.2 cure my problem??

 

Hope you can help. Cheers MM.

I m also facing the same problem, from more than 10 days :'(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×