Jump to content
chooch

Information Pages Unlimited v1.0

Recommended Posts

I think you missed some point in the installation instructions...

 

 

I done this, step by step, twice over. I looked through this thread, saw a few others who were having the same problems, tried their solution, but I STILL DON'T have a insert button....

 

 

I'm just going to trash this because it doesn't automatically add the links to the information box in the left column, which is ultimately what I need.....

Share this post


Link to post
Share on other sites
I done this, step by step, twice over. I looked through this thread, saw a few others who were having the same problems, tried their solution, but I STILL DON'T have a insert button....

I'm just going to trash this because it doesn't automatically add the links to the information box in the left column, which is ultimately what I need.....

 

it adds automatically the links... Your installation is sure broken.


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites
it adds automatically the links... Your installation is sure broken.

 

 

 

I'm not sure how it can be broken if others in this thread are having the same problems? Surely it's not coincidence. I will try it all over again... for the third time...

 

There are a few in this thread that have a few solutions, of which i've tried all, and no work.....some of them are hard to understand though...

 

I'll try again and let you know if it works the the third time.

Share this post


Link to post
Share on other sites
I'm not sure how it can be broken if others in this thread are having the same problems? Surely it's not coincidence. I will try it all over again... for the third time...

 

There are a few in this thread that have a few solutions, of which i've tried all, and no work.....some of them are hard to understand though...

 

I'll try again and let you know if it works the the third time.

 

I installed the last version in 2 different stores in past weeks. With OSC MS2. They are both working.


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites
I installed the last version in 2 different stores in past weeks. With OSC MS2. They are both working.

 

 

Welp, no problems I will try again. But... I have installed at least 15 contributions over the last week with zero problems what so ever, plus I am a web designer and deal with this sort of thing all the time (in the last 11 years I would say I have gained a little bit of experience)...(in other words.. i'm not a typical first time goer who does not know php code or what they are doing)

 

If it doesn't work the third time, I will know it is not me..because I simply can not be that stupid.

 

Thanks!

Edited by sprstudios

Share this post


Link to post
Share on other sites
Welp, no problems I will try again. But... I have installed at least 15 contributions over the last week with zero problems what so ever, plus I am a web designer and deal with this sort of thing all the time (in the last 11 years I would say I have gained a little bit of experience)...(in other words.. i'm not a typical first time goer who does not know php code or what they are doing)

 

If it doesn't work the third time, I will know it is not me..because I simply can not be that stupid.

 

Thanks!

 

Which version are you using? And Which OSC Version?


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites
Which version are you using? And Which OSC Version?

 

 

Got it from here:

 

http://www.oscommerce.com/community/contri...ation+unlimited

 

 

 

This Version:

Information Pages Unlimited 2.04.2 11 Jan 2008

 

 

with

 

oscommerce-2.2rc2

 

 

I did everything step by step, and everything looks/views fine except for no insert button and it doesnt' add the links my information box in the left column.

 

I went step by step, ran the sql's.. one part though,

 

"3) If you want to be able to change the WELCOME TEXT on your mainpage then also

run the 'information_group.sql' file located in the /sql folder and follow step 8.A"

 

... There was no information_group.sql in my /sql folder....only a

 

information.sql and information_additional.sql

 

but I RAN BOTH of them.

 

======================================

everything was fine, but at

 

index.php,

 

"locate the following lines (approximately line 303):

<td class="main"><?php echo tep_customer_greeting(); ?></td>"

 

===================

 

I do not have this line in my index.php at line 303 or anywhere in the file. So, I inserted

<!-- Add-on - Information Pages Unlimited -->

<td class="main"><?php echo tep_information_customer_greeting(); ?></td>

 

AT LINE 303 since I didn't have a line to replace. This may have messed it up, I don't know, but the customer greeting displayed fine... I just cant' edit it!!

 

everything else was step by step.

Edited by sprstudios

Share this post


Link to post
Share on other sites
Got it from here:

 

http://www.oscommerce.com/community/contri...ation+unlimited

This Version:

Information Pages Unlimited 2.04.2 11 Jan 2008

with

 

oscommerce-2.2rc2

I did everything step by step, and everything looks/views fine except for no insert button and it doesnt' add the links my information box in the left column.

 

I went step by step, ran the sql's.. one part though,

 

"3) If you want to be able to change the WELCOME TEXT on your mainpage then also

run the 'information_group.sql' file located in the /sql folder and follow step 8.A"

 

... There was no information_group.sql in my /sql folder....only a

 

information.sql and information_additional.sql

 

but I RAN BOTH of them.

 

======================================

everything was fine, but at

 

index.php,

 

"locate the following lines (approximately line 303):

<td class="main"><?php echo tep_customer_greeting(); ?></td>"

 

===================

 

I do not have this line in my index.php at line 303 or anywhere in the file. So, I inserted

<!-- Add-on - Information Pages Unlimited -->

<td class="main"><?php echo tep_information_customer_greeting(); ?></td>

 

AT LINE 303 since I didn't have a line to replace. This may have messed it up, I don't know, but the customer greeting displayed fine... I just cant' edit it!!

 

everything else was step by step.

 

Probably has been removed from previous versions of the contribution. Step 3 and 8 are optional. And you need to upload the information.php box too. (Point 5)


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites
Probably has been removed from previous versions of the contribution. Step 3 and 8 are optional. And you need to upload the information.php box too. (Point 5)

 

 

 

I did upload information.php making sure // Return a customer greeting was correct.

 

I ultimately removed the <!-- Add-on - Information Pages Unlimited -->

<td class="main"><?php echo tep_information_customer_greeting(); ?></td> anyways because I am not using a greet customer / login guest.etc.etc.

Edited by sprstudios

Share this post


Link to post
Share on other sites

Great contribution

One Question

 

On my parent information page how can i show the links to the child pages in the main page body as well as in the info box?

 

thanks

 

jody

Share this post


Link to post
Share on other sites

Exactly like categories do in the main index page

 

so it would be

 

Main Article page heading

 

Child 1 Child 2 Child 3 (all the same 1 level below main)

 

I cant get another level child to show at all.... only top level and 2nd level show in the box

 

they are all in the db and i can link directly to them if i put the correct id in the url

 

Also if there are more than 1 child then when clicking the child in the infobox in the column they disappear and the parent appears

 

ideas - pulling me hair out here

 

thanks

 

 

 

 

Great contribution

One Question

 

On my parent information page how can i show the links to the child pages in the main page body as well as in the info box?

 

thanks

 

jody

Share this post


Link to post
Share on other sites
Great contribution

One Question

 

On my parent information page how can i show the links to the child pages in the main page body as well as in the info box?

 

thanks

 

jody

 

Hi i have the same problem!!

 

jedinight

Share this post


Link to post
Share on other sites
Hi i have the same problem!!

 

jedinight

 

did you upload and overwrite the new infobox file information.php?


I love oscommerce and OS software! I'm not a programmer, I'm only a learning boy and a translator :) I love full contribution packages!

Share this post


Link to post
Share on other sites

I there,

 

Has anywone come with the little tiny problem that when you write content using the Unlimited Pages Contribution, in the admin panel, using Tinymice Editor, the following problem occurs:

 

I write, I save, it displays ok in the catalog. But, when I go back to edit the content in order to make some changes, it comes up blank in the Tinymice for each language, and I see myself having to go back to the catalog, copy the content, and paste it back again in the Tinymice.

 

Could someone help? I have been searching but no luck so far....

 

zanx!

Share this post


Link to post
Share on other sites
I done this, step by step, twice over. I looked through this thread, saw a few others who were having the same problems, tried their solution, but I STILL DON'T have a insert button....

I'm just going to trash this because it doesn't automatically add the links to the information box in the left column, which is ultimately what I need.....

 

Hello sprstudios,

 

I had the same problems with the insert buttons a while back.

I found out that it isnt the .php code yet an issue with the SQL database.

 

For some reason when i inserted the code into the database it set the objects to auto lock.

You need to go into the information_group table and delete everything in the "locked' field.

 

Check if that helps!

Share this post


Link to post
Share on other sites
I there,

 

Has anywone come with the little tiny problem that when you write content using the Unlimited Pages Contribution, in the admin panel, using Tinymice Editor, the following problem occurs:

 

I write, I save, it displays ok in the catalog. But, when I go back to edit the content in order to make some changes, it comes up blank in the Tinymice for each language, and I see myself having to go back to the catalog, copy the content, and paste it back again in the Tinymice.

 

Could someone help? I have been searching but no luck so far....

 

zanx!

 

Hello Zanx,

 

I have the same issue as you - with editing an entry. In trying to fix it / find a solution I have reinstalled the module, remove tinymice, insert a fresh SQL query from the installation file, use an old information_manager.php / information_form.php from another catalog that works... done everything I could think of without editing the base code.

 

I am puzzled to why it doesnt work!

 

I have another site working with Information Pages. The only difference between the new site and the other one is OS Commerce.

The new site that is having trouble with OS Commerce is running 2.2rc1.

While the old site that works is using 2.2ms2-060817.

 

Anyone else having the same problem or know of a solution?

 

Cheers!

Share this post


Link to post
Share on other sites

Hi echolalia,

 

so that version of OS2 M2M does the job? If I install this version, pages unlimited will work okay? Because I thought I could find some solution, so it displays the "information_description" of the "INFORMATION TABLE", inside the textfield of the description, just as it does with the "information_title".

 

I mean, why does "information_title" gets inserted in the input_field, and the "information_description" doesn't get inserted in its textfield? very weird... I've tried to see where is the problem.. but can't solve this problem...

 

anyone help? Have you found another solution Echolalia?

 

regards,

amanda

Share this post


Link to post
Share on other sites

Hi,

can anyone help me?

 

I'd like the articles in "Information Pages Unlimited" are listed in categories or sections. Nested into four levels, e.g. Main categories and sub categories like Company - staff - departments - individual employees.

 

Could anyone integrate that? Or is it already done? In any event, not in that version that I saw on. But it's long ago.

 

Regards

Jochen

Share this post


Link to post
Share on other sites
I am working on some stuff at the moment but will try a different angle on this, maybe the Header Tags Controller can be modified to account for this contribution. I can't start testing things until the middle of next week but will let you know if I have success.
Hi All!

Does anybody know if it's possible to solve this HTC thing?

//Micke

Share this post


Link to post
Share on other sites
I did upload information.php making sure // Return a customer greeting was correct.

 

I ultimately removed the <!-- Add-on - Information Pages Unlimited -->

<td class="main"><?php echo tep_information_customer_greeting(); ?></td> anyways because I am not using a greet customer / login guest.etc.etc.

Hi, may be a bit late for you but I had the same issue.

 

I edited /admin/information_form.php and commented out a couple of lines to do a quick and dirty fix.

 

// Decide when to show the buttons (Determine or 'locked' is active)

// if( (empty($info_group['locked'])) || ($information_action == 'Edit')) {

echo tep_image_submit('button_insert.gif', IMAGE_INSERT);

// }

 

 

HTH

 

S


Dont forget to Search. Your problem has already been fixed before.<br>

Please visit Manchester-Fireworks.com.

Share this post


Link to post
Share on other sites
Hi echolalia,

 

so that version of OS2 M2M does the job? If I install this version, pages unlimited will work okay? Because I thought I could find some solution, so it displays the "information_description" of the "INFORMATION TABLE", inside the textfield of the description, just as it does with the "information_title".

 

I mean, why does "information_title" gets inserted in the input_field, and the "information_description" doesn't get inserted in its textfield? very weird... I've tried to see where is the problem.. but can't solve this problem...

 

anyone help? Have you found another solution Echolalia?

 

regards,

amanda

 

Hello Amanda,

 

I haven't had any luck. Been away for the a while so yet to see if there is another solution. I was hoping that someone on the forums would have some idea what's going on as I'm still learning OS Commerce / PHP.

 

Anyone had any luck?

 

Cheers!

Echo

Share this post


Link to post
Share on other sites

Hi Everyone,

 

I am using IPU 2.0, and I have encountered a problem with the right column width.

 

The website that I am working on has custom column widths: left 195 pixels, and right 145 pixels.

 

However, all information pages created using IPU appear to have both left and right colums set at 195. How do I change the right colum to 145?

 

 

Cheers,

GB

Share this post


Link to post
Share on other sites

Hello,

 

After installing the above mentioned contribution, I create a page from admin and everything works correctly, I go to the index, give him to the new link that I have just created and there does not go out the text that I have introduced, only there goes out the word "Array".

 

The has same thing happened to someone?

 

I have tried with the last version, 2.04.2 and it does exactly the same thing, there goes out the word "Array" instead of the text that I introduce. For if it uses as something, I have also installed the contribuciones Seo and SiteMap.

 

Please, to seeing if someone can help me

 

They can see the mistake in: http://www.animalots.org/quienes-somos-i-1.html

 

 

Thank you.

Share this post


Link to post
Share on other sites
Hello Amanda,

 

I haven't had any luck. Been away for the a while so yet to see if there is another solution. I was hoping that someone on the forums would have some idea what's going on as I'm still learning OS Commerce / PHP.

 

Anyone had any luck?

 

Cheers!

Echo

 

Hello -

 

think I found the solution (works for me, anyway):

 

locate the file: catalog/admin/information_form.php

 

in this file, find

 

<td class="main" valign="top"><?php echo tep_draw_textarea_field('information_description[' . $languages[$i]['id'] . ']', '', '100', '20',

 

(somewhere about line 94)

 

after '100', '20', add: 'mceEditor',

 

(beware not to accidentially delete any of the following code)

 

Save back to server - It should work now. If you want, you can also change the size of the editor field by changing the 100 (width) and the 20 (height).

 

Good luck!

 

Boghandler

Share this post


Link to post
Share on other sites

welcome page

 

Hey,

I have installed osc 2.2.rc2a with iupv2042 and use fckeditor. Have done everything according to readme.txt. Have got the new button/update button by removing via phpmyadmin the text in the tabel information_group field locked.

 

But now it will not show on the osc site. Is there anything I have to do. please help me

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×