Latest News: (loading..)
chooch

Information Pages Unlimited v1.0

373 posts in this topic

when I add the sql in information.sql using phpmyadmin I get:

Error
SQL query: 

CREATE TABLE `information` (

`information_id` tinyint( 3 ) unsigned NOT NULL AUTO_INCREMENT ,
`information_group_id` int( 11 ) unsigned NOT NULL default '0',
`information_title` varchar( 255 ) NOT NULL default '',
`information_description` text NOT NULL ,
`parent_id` int( 11 ) default NULL ,
`sort_order` tinyint( 3 ) unsigned NOT NULL default '0',
`visible` enum( '1', '0' ) NOT NULL default '1',
`language_id` int( 11 ) NOT NULL default '0',
PRIMARY KEY ( `information_id` , `language_id` ) 
) ENGINE = MYISAM DEFAULT CHARSET = latin1;

MySQL said:  

#1064 - You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=latin1' at line 11

 

Line 11 is: `sort_order` tinyint( 3 ) unsigned NOT NULL default '0',

 

I have MySQL 4.0.27-standard.

Trying to instal version 2.03 (IPU) but have tried the sql from some earlier versions (down to v2) but no luck there either.

latest osc - as of a few weeks ago.

I know not much about mysql, but have run sql from other mods & other stores no probs.

 

Can anyone shed some light on what the problem might be?

My guess is it needs a different version of mysql perhaps - cant find anyone else with this problem.

 

Ive not installed this contribution before - had used Information Pages Enhanced v1.3 in previous stores. I downloaded this one by mistake ... but thought I'd give it a try.

 

Thanks

ant

 

I got the same error... anyone has ideas?

Share this post


Link to post
Share on other sites
Is it possible to use Google's new website optimizer tool for conducting multivariate tests on these html virtual pages created with the information pages unlimited contribution?

 

According to google, you can't use it with sections of a page that are database driven; however, I'm not sure what that means.

I've just looked at your link and the userguide demo here: http://services.google.com/training/websit...imizeruserguide

 

Basically you'll need to put javascript calls surrounding the pieces you want to test.

practically speaking you could test with different sections of content that is stored separately, like a name, short description, long description etc.

The product info pages are pretty modular so that is a possible candidate for this, information pages I think are more a bigger block of text which make them less suitable for this tool.

note, you can only have 1 target url for the test, so you can't dynamically pass any parameters, the variations are stored on the google site and content is replaced dynamically in the users browser through the javascript code.

If you are really smart about it, you could probably keep some of that control and tweaking in your sites css file if you figure out that eg headline in red always convert better, without then having to go to the google website optimization tool to set this for all the pages you are multivariate testing ...

Share this post


Link to post
Share on other sites

Hello folks!

 

Just installed this contrib (v. 2.03) and everthing worked fine except for the Welcome Message feature.

 

First I found out the code seemed to lock the feature, what I solved by uncommenting ne line on information_manager.php, but after I insert entries, they don't come up on the main page as expected. Yes, I did the modifications pointed out on the readme but still no clue. I took a look at the source of the rendered html and I can see the comment "<!-- Add-on - Information Pages Unlimited -->", but the expected content is just blank.

 

Any clues??????

 

Thank you all!

Share this post


Link to post
Share on other sites
when I add the sql in information.sql using phpmyadmin I get:

CREATE TABLE `information` ( 
 `information_id` tinyint(3) unsigned NOT NULL auto_increment, 
 `information_group_id` int(11) unsigned NOT NULL default '0', 
 `information_title` varchar(255) NOT NULL default '', 
 `information_description` text NOT NULL, 
 `parent_id` int(11) default NULL, 
 `sort_order` tinyint(3) unsigned NOT NULL default '0', 
 `visible` enum('1','0') NOT NULL default '1', 
 `language_id` int(11) NOT NULL default '0', 
 PRIMARY KEY  (`information_id`,`language_id`) 
) TYPE=MyISAM AUTO_INCREMENT=1 ;

 

it worked for me... I had same error before :)

Share this post


Link to post
Share on other sites
First I found out the code seemed to lock the feature, what I solved by uncommenting ne line on information_manager.php, but after I insert entries, they don't come up on the main page as expected. Yes, I did the modifications pointed out on the readme but still no clue. I took a look at the source of the rendered html and I can see the comment "<!-- Add-on - Information Pages Unlimited -->", but the expected content is just blank.

 

Sorry folks, found the answer in a previous post. Weird the search within the topic didn't found the exact keyword I was originally looking for.

 

Thank you all!!!!

Share this post


Link to post
Share on other sites
I suspect your main language is not English anymore, and so not set to ID=1.

 

To illustrate, have a look in your install package (sql\information_additional.sql) and you will find the following:

INSERT INTO `information` (`information_id`, `information_group_id`, `visible`, `sort_order`, `information_title`, `information_description`, `language_id`, `parent_id`) VALUES (1, 2, '1', 1, 'HEADING_TITLE', 'What\'s New Here?', 1, 0);

 

The before last 1 in this code is your language ID. This should be set to your main language. So, find out what your main language ID is, and change all those (before last) 1's to your language ID. Then upload the SQL file again.

 

If it works, let the forum know it worked, or not.

 

 

Hello

 

I am using Portuguese , so my language ID is 4.......I am not sure where u mean to change and put 4.

 

Pls. let me know.

 

dca

Share this post


Link to post
Share on other sites

Hi,

 

I followed step 1 to 8, but I could not see the Information Boxes on the homepage itself. May I know how to get that up on the catalog? It's showing in the Admin panel. Sorry if this sounds too newbie..i am not a coding person. Any help or advice will be appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites

Hi,

 

I'm looking for a way to use spaw editor with this contrib...

 

any clues?

Share this post


Link to post
Share on other sites
I suspect your main language is not English anymore, and so not set to ID=1.

 

To illustrate, have a look in your install package (sql\information_additional.sql) and you will find the following:

INSERT INTO `information` (`information_id`, `information_group_id`, `visible`, `sort_order`, `information_title`, `information_description`, `language_id`, `parent_id`) VALUES (1, 2, '1', 1, 'HEADING_TITLE', 'What\'s New Here?', 1, 0);

 

The before last 1 in this code is your language ID. This should be set to your main language. So, find out what your main language ID is, and change all those (before last) 1's to your language ID. Then upload the SQL file again.

 

If it works, let the forum know it worked, or not.

 

Hi can someone explain this a little bit better?

My english is ok but my sql skills not.

What exactly do i have to change for an dutch default language and where?

Share this post


Link to post
Share on other sites

I haven't this topic covered yet, so I'll ask.

 

I have this working on a number of sites with HTMLarea. When the user creates a link to another page in the site they loose the session id. That makes anything in the cart go away. It has become a big issue with a couple of clients.

 

Does anyone have any ideas?

 

Thanks

 

Nick

Share this post


Link to post
Share on other sites

Hi

I have installed this contrib but im having a problem adding pages. When i add it and click on it in the catalog it states Page not found, The requested information page was not found on this server. I know someone else had this problem but i couldnt find an answer to it. Any help would be great.

Thanks

Dion

Share this post


Link to post
Share on other sites

Dion, I'll assume that after you created the page in the back end that you can edit it with out problem, verifying that there is something there to bring up. You need to check to see if the way your url is coming up matches what the code is looking for. ie. information.php?info_id=16 the code is looking for info_id= something. If the text is different it won't work. I hope this helps some.

Share this post


Link to post
Share on other sites
Hi, sorry for my bad english, I have a problem with a this contribuition ( Pages Unimited 2.03) , I follow all the steps and in te catalog appears the mesage

 

Parse error: parse error in d:\archivos de programa\oscommerce\oscommerce-2.2ms2-060817\catalog\index.php on line 33

 

Tht is the edit for index.php in line 33

/ Add-on - Information Pages Unlimited
 require_once(DIR_WS_FUNCTIONS . 'information.php');
 tep_information_customer_greeting_define(); // Should be called before the Default Language is defined

 require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_DEFAULT);
?>
<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
<html <?php echo HTML_PARAMS; ?>>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=<?php echo CHARSET; ?>">
<title><?php echo TITLE; ?></title>

and this around the line 303

 

          <!-- Add-on - Information Pages Unlimited -->
           <td class="main"><?php echo tep_information_customer_greeting(); ?></td>	
         </tr>
         <tr>
           <td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>
         </tr>
         <td class="main"><?php echo TEXT_MAIN; ?><br>
             <?php include(DIR_WS_MODULES . FILENAME_NEWS); ?>
             </td>

         <tr>

 

I don't know who's the problem, my experience in php is very limited and I need help please, What can I do?

 

Thanks for all.

 

 

 

Hi I have the same problem of this person! In my index.php comes up a notice saying that it doesn't find the file. PROBLEM ON LINE 34.

 

I copied the file information.php in the directory catalog/includes/boxes/information.php as the tutorial explains, but the index.php is looking in the following directory:

 

catalog/includes/functions/information.php

 

How do I fix this so it looks into the right directory???.. for sure it's a stupid thing.. but I don't know what to do??....

 

zanx in advance!

Share this post


Link to post
Share on other sites

ABout the previous post.. don't take notice! solved... sorry.. I forgot to upload the file in that directory.. dough!

Share this post


Link to post
Share on other sites
Dion, I'll assume that after you created the page in the back end that you can edit it with out problem, verifying that there is something there to bring up. You need to check to see if the way your url is coming up matches what the code is looking for. ie. information.php?info_id=16 the code is looking for info_id= something. If the text is different it won't work. I hope this helps some.

 

 

Hi I have the same problem as Dion.. when I click the file that I've created from the index.php page, it says:

 

"The requested URL /catalog/information.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. "

 

In the url is trying to find the file here: "http://www.xxx.com/catalog/information.php?info_id=6"

 

But obviously the information.php is not in the catalog folder.. and the id of the article is in fact number 6... so it's correct the path "information.php?info_id=6", but the folder... it'not, right??

 

Please advise how to solve this problem: why does it look in the catalog folder? What to do so it finds the new file I've created?.

Share this post


Link to post
Share on other sites

Hi there.. is someone around? hope someone can help me soon.. now the problem is that it doesn't show anything at all.. when I click on an article it comes up a blank page.. --'

 

I copied the information.php that comes with the installation of the main root of catalog and published it in catalog/

 

So.. why does it come in a blank page?

Share this post


Link to post
Share on other sites

can anyone kindly advise how can i list down the information tree including the parent and child at one go so that customers can view the information box without clicking in one by one. thanks

Share this post


Link to post
Share on other sites

I have installed this on a fresh build. When I select Info Manager from the admin menu my screen fills with the data below. I can edit the sql with phpmyadmin and the welcome text displays correctly. I also do not have any information menus. I originally installed tinymce as per instructions and when that produced these results I installed tinymce anywhere.

 

Any ideas where I should look next.

 

thanks

 

butch

 

 

0) { while (list($key, $val)=each($data)) {$no++; } } $title = ADD_QUEUE_INFORMATION . " #$no"; echo tep_draw_form('',FILENAME_INFORMATION_MANAGER, 'information_action=AddSure'); echo tep_draw_hidden_field('gID', $gID); include('information_form.php'); break; case "AddSure": $language_id = $languages[0]['id']; // First insert the 1st known language $sql_data_array = array( 'language_id' => $language_id, 'information_group_id' => tep_db_prepare_input($gID) ); if(isset($_POST['visible'])) $sql_data_array['visible'] = tep_db_prepare_input($_POST['visible']); if(isset($_POST['sort_order'])) $sql_data_array['sort_order'] = tep_db_prepare_input($_POST['sort_order']); if(isset($_POST['parent_id'])) $sql_data_array['parent_id'] = tep_db_prepare_input($_POST['parent_id']); if(isset($_POST['information_title'])) $sql_data_array['information_title'] = tep_db_prepare_input($_POST['information_title'][$language_id]); if(isset($_POST['information_description'])) $sql_data_array['information_description'] = tep_db_prepare_input($_POST['information_description'][$language_id]); tep_db_perform(TABLE_INFORMATION, $sql_data_array); $information_id = tep_db_insert_id(); for ($i=1, $n=sizeof($languages); $i<$n; $i++) { $language_id = $languages[$i]['id']; $sql_data_array = array( 'information_id' => $information_id, 'language_id' => $languages[$i]['id'], 'information_group_id' => tep_db_prepare_input($gID) ); if(isset($_POST['visible'])) $sql_data_array['visible'] = tep_db_prepare_input($_POST['visible']); if(isset($_POST['sort_order'])) $sql_data_array['sort_order'] = tep_db_prepare_input($_POST['sort_order']); if(isset($_POST['parent_id'])) $sql_data_array['parent_id'] = tep_db_prepare_input($_POST['parent_id']); if(isset($_POST['information_title'])) $sql_data_array['information_title'] = tep_db_prepare_input($_POST['information_title'][$language_id]); if(isset($_POST['information_description'])) $sql_data_array['information_description'] = tep_db_prepare_input($_POST['information_description'][$language_id]); if(count($sql_data_array) > 1) { tep_db_perform(TABLE_INFORMATION, $sql_data_array); } } $data = tep_get_information_list(); $title = tep_image(DIR_WS_ICONS . 'confirm_red.gif', CONFIRM_INFORMATION) .SUCCED_INFORMATION . ADD_QUEUE_INFORMATION . " $sort_order "; include('information_list.php'); unset($data); break; case "Edit": if ($information_id = $_REQUEST['information_id']) { $edit = tep_get_information_entry($information_id); $data = tep_get_information_list(); $button = array("Update"); $title = EDIT_ID_INFORMATION . " $information_id"; echo tep_draw_form('',FILENAME_INFORMATION_MANAGER, 'information_action=Update'); echo tep_draw_hidden_field('information_id', $information_id); echo tep_draw_hidden_field('gID', $gID); include('information_form.php'); } else {$error="80";} break; case "Update": if ((int)$_POST['information_id']) { for ($i=0, $n=sizeof($languages); $i<$n; $i++) { $language_id = $languages[$i]['id']; $sql_data_array = array(); if(isset($_POST['visible'])) $sql_data_array['visible'] = tep_db_prepare_input($_POST['visible']); if(isset($_POST['sort_order'])) $sql_data_array['sort_order'] = tep_db_prepare_input($_POST['sort_order']); if(isset($_POST['parent_id'])) $sql_data_array['parent_id'] = tep_db_prepare_input($_POST['parent_id']); if(isset($_POST['information_title'])) $sql_data_array['information_title'] = tep_db_prepare_input($_POST['information_title'][$language_id]); if(isset($_POST['information_description'])) $sql_data_array['information_description'] = tep_db_prepare_input($_POST['information_description'][$language_id]); if(count($sql_data_array) > 0) { $sql_data_array['information_group_id'] = tep_db_prepare_input($gID); tep_db_perform(TABLE_INFORMATION, $sql_data_array, 'update', "information_id = '" . (int)$_POST['information_id'] . "' and language_id = '" . (int)$language_id . "'"); } } $data = tep_get_information_list(); $title = "$confirm " . UPDATE_ID_INFORMATION . " $information_id " . SUCCED_INFORMATION . ""; include('information_list.php'); } else {$error="80";} break; case 'Visible': if ($visible == '1') { $vivod=DEACTIVATION_ID_INFORMATION; tep_db_query("update " . TABLE_INFORMATION . " set visible = '0' where information_id = '" . (int)$information_id . "'"); } else { $vivod=ACTIVATION_ID_INFORMATION; tep_db_query("update " . TABLE_INFORMATION . " set visible = '1' where information_id = '" . (int)$information_id . "'"); } $data=tep_get_information_list(); $title="$confirm $vivod $information_id " . SUCCED_INFORMATION . ""; include('information_list.php'); break; case "Delete": if ($information_id = $_GET['information_id']) { $delete = tep_get_information_entry($information_id); $data = tep_get_information_list(); $title = DELETE_CONFIRMATION_ID_INFORMATION . " $information_id"; echo ''; echo ''; echo ''; echo '"; } else {$error="80";} break; case "DelSure": if ($information_id = $_GET['information_id']) { tep_db_query("delete from " . TABLE_INFORMATION . " where information_id = '" . (int)$information_id . "'"); $data = tep_get_information_list(); $title = "$confirm " . DELETED_ID_INFORMATION . " $information_id " . SUCCED_INFORMATION . ""; include('information_list.php'); } else {$error="80";} break; default: $data = tep_get_information_list(); $title = MANAGER_INFORMATION . " / " . $info_group['information_group_title'] . ""; include('information_list.php'); flush(); tep_update_information_languages(); } // END SWITCH if ($error) { $content=error_message($error); echo $content; $data = tep_get_information_list(); $no = 1; if (sizeof($data) > 0) { while (list($key, $val)=each($data)) {$no++; } } $title = ADD_QUEUE_INFORMATION . " $no"; echo tep_draw_form('',FILENAME_INFORMATION_MANAGER, 'information_action=AddSure'); echo tep_draw_hidden_field('gID', $gID); include('information_form.php'); } ?>

' . $title . '

' . ENTRY_TITLE . '

' . $delete['information_title'] . '

'; echo tep_draw_form('',FILENAME_INFORMATION_MANAGER, "information_action=DelSure&information_id=" . $delete['information_id']); echo tep_draw_hidden_field('information_id', $information_id); echo tep_draw_hidden_field('gID', $gID); echo tep_image_submit('button_delete.gif', IMAGE_DELETE); echo ' ' . tep_image_button('button_cancel.gif', IMAGE_CANCEL) . ''; echo "

Share this post


Link to post
Share on other sites

I am still struggling with this. What additional info can I provide?

 

Thanks for any response

Share this post


Link to post
Share on other sites

I have started with a brand new install of oscommerce-2.2ms2-060817.

then I removed all default icons

installed PhpMyAdmin

applied both sql files

copied all files from the ipuv203 catalog folders

added admin/tinymce

 

catalog website diplays correctly

admin website displays a screen full on code as in the above posts when I select Information manager or any of it's options.

 

thank you

 

Butch

Share this post


Link to post
Share on other sites
I have started with a brand new install of oscommerce-2.2ms2-060817.

then I removed all default icons

installed PhpMyAdmin

applied both sql files

copied all files from the ipuv203 catalog folders

added admin/tinymce

 

catalog website diplays correctly

admin website displays a screen full on code as in the above posts when I select Information manager or any of it's options.

 

thank you

 

Butch

 

 

never mind I found the problem

Share this post


Link to post
Share on other sites
I've just looked at your link and the userguide demo here: http://services.google.com/training/websit...imizeruserguide

 

Basically you'll need to put javascript calls surrounding the pieces you want to test.

practically speaking you could test with different sections of content that is stored separately, like a name, short description, long description etc.

The product info pages are pretty modular so that is a possible candidate for this, information pages I think are more a bigger block of text which make them less suitable for this tool.

note, you can only have 1 target url for the test, so you can't dynamically pass any parameters, the variations are stored on the google site and content is replaced dynamically in the users browser through the javascript code.

If you are really smart about it, you could probably keep some of that control and tweaking in your sites css file if you figure out that eg headline in red always convert better, without then having to go to the google website optimization tool to set this for all the pages you are multivariate testing ...

 

Hi Carine,

 

Thanks for helping me out. Though in all honesty, it took me a couple days of reading it until I felt like I had gained any understanding. Probably took you two seconds to write.

 

So the product pages seem a good candidate for the website optimizer, huh? I don't think I will be using them any time soon. What about if I just created individual PHP pages though? - for each landing page?.

Would that work?

 

If you are really smart about it, you could probably keep some of that control and tweaking in your sites css file if you figure out that eg headline in red always convert better, without then having to go to the google website optimization tool to set this for all the pages you are multivariate testing ...

 

Never would have thought about this. While I am curious to see which font has the highest conversion rate and how much my yellow form fields raise conversion rates over white form fields: this is probably more trouble than its worth to me. I feel pretty confident about most of the components of the CSS.

 

Google optimizer is just too cool of a toy to not have its full benefits. The two main functions I want are to tweak the headlines and the landing page pictures. And there are some writing techniques I would like to experiment with also, in regards to the site copy.

 

 

Thanks again,

 

Victor

 

PS: I like your avatar. You know, Maurice, the guy who plays the voice of Brain, is a friend of mine.

Edited by victor363

Share this post


Link to post
Share on other sites

I am very new to this and am having the same problem as butch. The catalog code works as it has created a contact button and and information box on the main page but the admin stuff comes across as just code

Share this post


Link to post
Share on other sites
I am very new to this and am having the same problem as butch. The catalog code works as it has created a contact button and and information box on the main page but the admin stuff comes across as just code

 

The problem was that there is a still a <? that should be <?php.

Share this post


Link to post
Share on other sites

Hi there, first of all I think this is a great contribution.

But i'm still having the problem of not being able to add or edit Welcome Messages. I tried to change the languageID with the SQL file but it doesn't work.

Anyone has another solution?

I'm using the latest osc2.2 rc1 and the latest version of ipu.

 

Groeten, Dennis

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now