Jump to content
chooch

Information Pages Unlimited v1.0

Recommended Posts

Okay this has been the most difficult mod so far, because of all the extras I needed to install to get it to work.

 

now I have the editors up and running after a few minor issues, I created a test info page submitted it and got the following error message.

 

Warning: Cannot modify header information - headers already sent by (output started at /home/simplydr/public_html/shop4/admin/information_manager.php:131) in /home/simplydr/public_html/shop4/admin/includes/functions/general.php on line 22

 

Can anyone enlighten me on how to ressolve this error.

 

Thanks

 

Johnny

I replaced the admin/information_manager.php file from 2047 and it appears to be working with no problems.

Share this post


Link to post
Share on other sites

Hello,

 

I am having the same problem as Andy. After installing this contri (2.05) I go into my admin and choose the option

"Info manager" and then get the following error.

 

1146 - Table 'ledmesse_osc1.information_groep' doesn't exist

 

select information_group_title, locked from information_groep where information_group_id = '1'

 

[TEP STOP]

 

 

Is there anyone who knows the solution?

Share this post


Link to post
Share on other sites

Not to sound unappreciative of the free mod, but this mod seems rather half-way written to me?

Am I correct that this does not work at all unless you do have FCK Editor installed?

 

I receive no errors on the web site, but when attempting to create a new Information page in the admin, I have no text boxes available to type into and no submit button or anyway to save the content. The interface seems incomplete, and I am not sure what other step might have been skipped. I would rather not need to install another mod as well if I can avoid it.

Share this post


Link to post
Share on other sites
Not to sound unappreciative of the free mod, but this mod seems rather half-way written to me?

Am I correct that this does not work at all unless you do have FCK Editor installed?

 

I receive no errors on the web site, but when attempting to create a new Information page in the admin, I have no text boxes available to type into and no submit button or anyway to save the content. The interface seems incomplete, and I am not sure what other step might have been skipped. I would rather not need to install another mod as well if I can avoid it.

 

Ok I finished installing the latest FCK editor as well as the config patch from oscommerce add-ons. I can now successfully add a new info page. Unfortunately none of the existing info pages are included in the info manager. Bummer.

Share this post


Link to post
Share on other sites

This module is exactly what I'm looking for. I was able to successfully install it, however, the pages don't use the layout I have setup for my site, so they end up looking funny. You can look at my site to see what I'm referring to. www.zoanthids.com, the link is at the bottom left, "zoanthid lighting". Is there anyway to make the pages use the normal size and background as the other pages on my site?

 

Also, not nearly as important, but is there a way to replace the text for the infobox "info pages" with an image? You can see on my site that each box in the side navigations have image headings. Also, is there a way to make the contribution create pages with a name that you specify upon creating them? Like "zoanthid-lighting.php" instead of "infopages.php?info_id=1", that may be a long shot but I'd thought I'd ask.

 

Thanks for your help, the first problem is really the one I'm worried about.

 

Holly

Share this post


Link to post
Share on other sites

Okay I have installed this module and got it working.

 

However the problem I have at the moment is that whilst my information pages show up on the site correctly. I cant go back into admin and edit them as the data is not there.

 

I am guessing I need to put in the information form somthing to call the data from the database using V2.47

 

Please can some one guide me through this or suggest a mod that allows editing of a previous page/ welcome text.

 

Thanks

 

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Okay I have narrowed it down a little.

 

the reason why the description is not showing after one has submitted and gone to edit it is to do with the fck editor

 

as when you switch this off you are left with a text area and the text that was submitted.

 

this is turned on and off in the information manager. and I did manage to switch it back on and off by changing true to false and vice versa using both admins configuration and editing the text in the file manager file to true and false.

 

Noticed that in admin configuartion the fck editor is not in english and wondering if this may lead to the solution.

 

Any help gratefully recieved.


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Found the problem.

 

its all to do with the following(note I was using ipuv 2047)

 

B) Use the file information_form.php provided for FCK editor or apply this change to the stock information_form.php

 

FIND:

 

<td class="main" valign="top"><?php echo tep_draw_textarea_field('information_description[' . $languages[$i]['id'] . ']', '', '100', '20', (($languages[$i]['id'] == $languages_id) ? stripslashes($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description'))); ?></td>

 

REPLACE WITH:

 

<td class="main" width="100%"><?php
		if (DESCRIPTION_EDITOR == 'ja' ) {
		 tep_draw_fckeditor('information_description[' . $languages[$i]['id'] . ']', (($languages[$i]['id'] == $languages_id) ? stripslashes($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description')), '100%', FCK_EDITOR_HEIGHT);
		} else {
			echo tep_draw_textarea_field('information_description[' . $languages[$i]['id'] . ']', '', '100', '20', (($languages[$i]['id'] == $languages_id) ? stripslashes($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description')));
		}

	 ?>
	 </td>

 

But for it to work so I could view it properly I changed the 100% to 800, which is full screen, the ja to true.

 

And in admin configuration changed the height to 300, although you can set it to what you like.

 

Thanks

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Very frustrated right now, and not sure what is going on. A couple months ago, the editing was working fine for me in Info Manager, although there was an annoying "arrow to click" to be able to expand the editor screen and see it. The owner of the site has still not been able to get it to work, and now I can't either. I don't host this site so no idea if it is related to a hosting issue. Please provide guidance if you can!

 

Symptoms:

 

When going to Info Manager and clicking to edit a page, there are the first few fields, the page is active, and the top part of the FCK editor without the bottom half. If you click the arrow at the left bottom corner, the rest of the white text area shows up - but all it has inside it is "800"! The live pages on the site DO have all the appropriate text and links in them. So I cannot figure out why this is not working in the admin. I am afraid to edit anything for fear of totally screwing up her site right now.

 

Should I install the latest update/patch? Will that even remotely address this issue?

Could this be a database update prob on the host end?

Anyone else seen this issue?

Share this post


Link to post
Share on other sites
Very frustrated right now, and not sure what is going on. A couple months ago, the editing was working fine for me in Info Manager, although there was an annoying "arrow to click" to be able to expand the editor screen and see it. The owner of the site has still not been able to get it to work, and now I can't either. I don't host this site so no idea if it is related to a hosting issue. Please provide guidance if you can!

 

Symptoms:

 

When going to Info Manager and clicking to edit a page, there are the first few fields, the page is active, and the top part of the FCK editor without the bottom half. If you click the arrow at the left bottom corner, the rest of the white text area shows up - but all it has inside it is "800"! The live pages on the site DO have all the appropriate text and links in them. So I cannot figure out why this is not working in the admin. I am afraid to edit anything for fear of totally screwing up her site right now.

 

Should I install the latest update/patch? Will that even remotely address this issue?

Could this be a database update prob on the host end?

Anyone else seen this issue?

 

Most definately not enough to go on .. I will have a stab at gut instinct which is that the server now has short_tags off and the script is using <? instead of the correct <?php therefore printing to screen code that should have been parsed by php.

 

Long shot with the lack of detail.

Share this post


Link to post
Share on other sites
Very frustrated right now, and not sure what is going on. A couple months ago, the editing was working fine for me in Info Manager, although there was an annoying "arrow to click" to be able to expand the editor screen and see it. The owner of the site has still not been able to get it to work, and now I can't either. I don't host this site so no idea if it is related to a hosting issue. Please provide guidance if you can!

 

Symptoms:

 

When going to Info Manager and clicking to edit a page, there are the first few fields, the page is active, and the top part of the FCK editor without the bottom half. If you click the arrow at the left bottom corner, the rest of the white text area shows up - but all it has inside it is "800"! The live pages on the site DO have all the appropriate text and links in them. So I cannot figure out why this is not working in the admin. I am afraid to edit anything for fear of totally screwing up her site right now.

 

Should I install the latest update/patch? Will that even remotely address this issue?

Could this be a database update prob on the host end?

Anyone else seen this issue?

 

I had the same problem and fixed it by hard coding the height and width. In the catalog/admin directory edit the file 'information_form.php' around line 94 and replace the <td class="main" width="100%"> </td> tags as follows:

 

<td class="main" width="100%"><?php

if (DESCRIPTION_EDITOR == 'true' ) {

tep_draw_fckeditor('information_description[' . $languages[$i]['id'] . ']', (($languages[$i]['id'] == $languages_id) ? stripslashes

($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description')), '800', 300);

} else {

echo tep_draw_textarea_field('information_description[' . $languages[$i]['id'] . ']', '', '100', '20', (($languages[$i]['id'] == $languages_id) ? stripslashes($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description')));

}

?>

</td>

 

Hope that helps!

Sb

Edited by shbosc

Share this post


Link to post
Share on other sites

Hi,

 

I installed "information pages unlimited" .

 

I would like to hide sub pages on Information text Box on main page.. that only parents pages will be shown !

 

Any advise please, where and what to Commet in the code..

 

Thanks a lot for your help..

 

Best Regards,

Nathali


Best Regards,

Nathali

Share this post


Link to post
Share on other sites
Hi,

 

I installed "information pages unlimited" .

 

I would like to hide sub pages on Information text Box on main page.. that only parents pages will be shown !

 

Any advise please, where and what to Commet in the code..

 

Thanks a lot for your help..

 

Best Regards,

Nathali

 

Any help please !!

 

Thanks..


Best Regards,

Nathali

Share this post


Link to post
Share on other sites
Found the problem.

 

its all to do with the following(note I was using ipuv 2047)

 

B) Use the file information_form.php provided for FCK editor or apply this change to the stock information_form.php

 

FIND:

 

<td class="main" valign="top"><?php echo tep_draw_textarea_field('information_description[' . $languages[$i]['id'] . ']', '', '100', '20', (($languages[$i]['id'] == $languages_id) ? stripslashes($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description'))); ?></td>

 

REPLACE WITH:

 

<td class="main" width="100%"><?php
		if (DESCRIPTION_EDITOR == 'ja' ) {
		 tep_draw_fckeditor('information_description[' . $languages[$i]['id'] . ']', (($languages[$i]['id'] == $languages_id) ? stripslashes($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description')), '100%', FCK_EDITOR_HEIGHT);
		} else {
			echo tep_draw_textarea_field('information_description[' . $languages[$i]['id'] . ']', '', '100', '20', (($languages[$i]['id'] == $languages_id) ? stripslashes($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description')));
		}

	 ?>
	 </td>

 

But for it to work so I could view it properly I changed the 100% to 800, which is full screen, the ja to true.

 

And in admin configuration changed the height to 300, although you can set it to what you like.

 

Thanks

Johnny

 

 

Okay so most of my site is using tiny mce now, so rather than have fck for one and mce for another mioght as well have tiny mce for all.

 

Great we say, except for some reason the

 

<?php // START tinyMCE
 $mce_str='information_description[' . tep_db_prepare_input($gID) . ']';

?>
<script language="javascript" type="text/javascript" src="includes/javascript/tiny_mce/tiny_mce.js"></script>
<?php 
 require('includes/javascript/tiny_mce/general.php');
// END tinyMCE 
?>

 

only appears to apply to gID=1 (information pages), whereas gID=2 the welcome messages dont work with tiny mce code.

this was confirmed by changing the group 2's to group 1's and vice versa, and group 1 didnt work and group 2 did work.

 

in the grand scheme the fck editor worked on both groups 1 and 2, but this is done in the information_form and not information_manager files.

 

Can anyone tell me how to get the tiny mce working for both groups 1 and 2?

 

Thanks

 

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Thank you, Steve, That fix did the trick.

 

(For reference to others - this was an IPUV/FCK Editor issue and not related to any php functions on the server. However, this did not start occurring until the site owner's web host made some migrations to new servers, reissued new IPs, and probably restored some files from back up. My guess is they may have restored some old files because at one point the editor was working just fine and I was not having this type of issue - I probably had already customized this file on some previous occasion and then it was overwritten.)

 

Problem resolved for now!

 

I had the same problem and fixed it by hard coding the height and width. In the catalog/admin directory edit the file 'information_form.php' around line 94 and replace the <td class="main" width="100%"> </td> tags as follows:

 

<td class="main" width="100%"><?php

if (DESCRIPTION_EDITOR == 'true' ) {

tep_draw_fckeditor('information_description[' . $languages[$i]['id'] . ']', (($languages[$i]['id'] == $languages_id) ? stripslashes

($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description')), '800', 300);

} else {

echo tep_draw_textarea_field('information_description[' . $languages[$i]['id'] . ']', '', '100', '20', (($languages[$i]['id'] == $languages_id) ? stripslashes($edit[information_description]) : tep_get_information_entry($information_id, $languages[$i]['id'], 'information_description')));

}

?>

</td>

 

Hope that helps!

Sb

Share this post


Link to post
Share on other sites
only appears to apply to gID=1 (information pages), whereas gID=2 the welcome messages dont work with tiny mce code.

this was confirmed by changing the group 2's to group 1's and vice versa, and group 1 didnt work and group 2 did work.

 

in the grand scheme the fck editor worked on both groups 1 and 2, but this is done in the information_form and not information_manager files.

 

Can anyone tell me how to get the tiny mce working for both groups 1 and 2?

 

Thanks

 

Johnny

 

 

Can anyone help ressolve the welcome message issue so that tiny mce works with it please.

 

Thanks

 

Johnny


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

HI , this is just a good contributions, it worrk god and nice to me, and no any error.

 

But does any one how to change the display format,

 

i mean like, the default display is like.

 

COMPANY

WHT’S NEW

FAQ

WARRENTY

NEWS LETTER

T&C

SERVICE

 

 

But i want it to display like this

 

COMPANY WHTS NEW FAQ WARRENTY NEWS LETTER T&C SERVICE

 

does anyone know it, coz i try few time times and still can change it...

 

can anyone help ...thx.....

Share this post


Link to post
Share on other sites

Hi,

 

I've added the code to my index.php file to amend the home page text as the install file suggests but how do i get the home page to appear in the list of Information pages so i can then change it?

 

Thanks for any help.

 

Thanks

Ashley

Share this post


Link to post
Share on other sites

Currently receving this error when updating or creating a new page. ( However this only happens if the page has a hyperlink within)

 

403 Forbidden

 

Forbidden

You cannot access this website at this time, please go to http://www.*********.info

 

the **** is the domain..

 

This has only happened when a check and repair has been done on the database?

 

Simon

Share this post


Link to post
Share on other sites

I got this error while making the "Dumping data for table `information_group`" in SQL Changes:

 

INSERT INTO `configuration_group` ( `configuration_group_id` , `configuration_group_title` , `configuration_group_description` , `sort_order` , `visible` )
VALUES (
'16', 'HTML-Editor', 'HTML-Editor Optionen', 16, 1
);

#1062 - Duplicate entry '16' for key 1 

 

So like it says in instructions, I changed number 16 (all 4 of them) to next free number that was 17. Was that correct?

Then I got this error:

 

INSERT INTO `information_group` ( `information_group_id` , `information_group_title` , `information_group_description` , `sort_order` , `visible` , `locked` )
VALUES ( 1, 'Information pages', 'Information pages', 1, 1, '' ) ;

#1062 - Duplicate entry '1' for key 1 

 

What is wrong in there there?

Share this post


Link to post
Share on other sites

^ Ok I only changed 16 to 17 in the first set of rules, so then it all go through. Hopefully correct way.

 

INSERT INTO `configuration_group` (`configuration_group_id`, `configuration_group_title`, `configuration_group_description`, `sort_order`, `visible`) VALUES
('17', 'HTML-Editor', 'HTML-Editor Optionen', 17, 1);

 

All is otherwise good, but I have the same problem than others with welcome message, can not see the edit button or messages to edit.

Think it has to do with language that I'm using, finnish, fi. Because when I install IPU into fresh default OSC then it works just great.

 

I use IPUv2.06 and OSC2.2rc2a.

I checked that my fi is ID=4, so where that needs to be edited to get the welcome_message to work?

Help?

Share this post


Link to post
Share on other sites

Hi,

 

I appear to have some kind of limit issue as when I post the information I loose about half of it any ideas to ehy this might be the case?


Getting better with mods but no programmer am I.

Share this post


Link to post
Share on other sites

Does anybody know how to implement PHP information into the page description to call on some functions of the website?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×