Jump to content
Sign in to follow this  
Blacknightcomputers

PPPay.com payment module not adding Postage charges

Recommended Posts

Hi i am useing the pppay.com payment module to accept payments on my web site but when it takes you to the ppay.com website to pay its only giving you the total figure to pay with out the postage costs???? could some one please help .....

 

 

Regards

Phillip cooper

Share this post


Link to post
Share on other sites
Hi i am useing the pppay.com payment module to accept payments on my web site but when it takes you to the ppay.com website to pay its only giving you the total figure to pay with out the postage costs???? could some one please help .....

Regards

Phillip cooper

 

 

I'm having the same problem. Did you find a solution?

 

Ron

Share this post


Link to post
Share on other sites
I'm having the same problem. Did you find a solution?

 

Ron

 

 

Hi

 

no i have not found a solution yet i am looking through the oscommerce site and hope to find a solution... plus if any one else is reading this and has found a solution please share it with us all here PLEASE.... if you find a solution post it here and i will do the same if i find a solution..

 

Regards

Phil

Share this post


Link to post
Share on other sites

Hi

 

Ive just taken my first payments from pppay.com and have just had to turn the module off as it is not including the shipping to the total order value. I use zones shipping as I ship worlwide.

 

Can any body help with this little niggle? WE need to have it so it adds the shipping to the order total when going to pppay.com.

 

Also it needs to return back to the store so that the order is taken out of the usrs shopping cart and into their order history section.

 

Cheers

Duds

Share this post


Link to post
Share on other sites

HI All

 

K think it's cracked, well works for me now.

 

catalog/includes/modules/payment/pppay.php needs modifying:

 

BACK UP FIRST I WILL NOT BE HELD RESPONSIBLE IF YOU MUCK IT UP

 

Line 93 needs changing from:

 

 tep_draw_hidden_field('Amount_1', number_format(($order->info['total'] - $order->info['shipping_cost']) * $currencies->get_value($my_currency), $currencies->get_decimal_places($my_currency))) .

 

to:

 

tep_draw_hidden_field('Amount_1', number_format($order->info['total'] * $currencies->get_value($my_currency), $currencies->get_decimal_places($my_currency))) .

 

Basiccaly what was happening was that the module was sending the order total and the shipping price, but not adding the two together at the the other end, pppay.com may have changed the word 'shipping' their end at some stage. Anyway what this does now is adds the order total and shipping together and then sends it off to ppay.com.

 

Thanks to my brother for being such a code head, i'd be lost without him :)

 

K next problem is getting the p[acking slip to populate and the module to return the buyer back to the website so that it removes the items from their cart. unless it does this already? I've been unable to test this bit.

 

Cheers

 

Duds

Share this post


Link to post
Share on other sites

Hi

 

Is this working for anyone else - I amended the code as above but get the same results. No postage added and no order form.

 

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×