Jump to content
Sign in to follow this  
azer

Ship In Cart

Recommended Posts

I think this is a great contrib, but i miss the payment fees in this, like cod fee! Is there someone who got this contrib to work with payment fees?

Share this post


Link to post
Share on other sites

I also think this is a great contribution but I have one question:

 

I had everything working great when I was just using the table rate shipping method. But I recently installed the MultiGeoZone MultiTable Shipping (http://www.oscommerce.com/community/contributions,2571) contribution, and now the shipping options are not showing in my cart for logged-in US customers (I only have the multigeozone active).

 

My cart shows the shipping estimates just fine if you are not logged in, but once logged in as a US customer it shows nothing (just sub-total and total). If you are logged in as UK it shows the UK option.

 

Checkout works fine under all circumstances and all options are there (including logged-in US), it's just the shipping estimate in the cart that isn't working for logged-in US customers.

 

my test site is www.isplendor.com

 

Any help would be greatly appeciated.

 

Thanks!

 

-- Josh

Share this post


Link to post
Share on other sites

Anyone know how to set the default zone to the store zone?

 

I have been playing with it for awhile, but just cant get it to work.

 

I have MultiGeoZone MultiTable Shipping installed...so if no zone is there it reverts to "Rest of the world" table and shows a very high shipping.

 

Thanks.

Share this post


Link to post
Share on other sites

I just got the latest version installed and it works great if a customer is logged in. Is there a way to make it work for customers that are not logged in?

Share this post


Link to post
Share on other sites
I just got the latest version installed and it works great if a customer is logged in. Is there a way to make it work for customers that are not logged in?

 

Yes there are several ways to make this work for customers not logged in...

 

Find this code near line 30:

if (($cart->count_contents() > 0) && (tep_session_is_registered('customer_id'))) {

 

To show the estimated shipping cost to users NOT LOGGED IN ONLY, replace with:

if (($cart->count_contents() > 0) && (!tep_session_is_registered('customer_id'))) {

 

To show the estimated shipping cost to BOTH LOGGED IN AND NOT LOGGED IN customers, replace with:

if ($cart->count_contents() > 0)  {

Share this post


Link to post
Share on other sites

I was having the same issue with this contribution where the it did not show up when a user wasn't logged in. I did the above fix, replacing:

 

if (($cart->count_contents() > 0) && (tep_session_is_registered('customer_id'))) {

 

with:

 

if ($cart->count_contents() > 0) {

 

The box shows up now but there are no shipping options (ups, usps.. etc..) and there is no space to fill in your zip. It works just fine when you are logged in and all the options show up.

Share this post


Link to post
Share on other sites

Hi,

I just installed Ship In Cart v2.20 by azer in my local test shop and I must confess I thought it was going to put the shipping cost in the shopping cart infobox, not on the shopping cart page. Did I do something wrong?

If not, is this possible?

 

Also, when I switch language from French to English the shipping information dissapears.

 

Finally, what is the way it is intended to be used ? I have this problem:

Having this information on the shopping cart page as my shop is currently set up is redundant

When the customer continues to the next page, they are asked to specify the shipping method again !

Is this page supposed to be skipped now by an admin setting?

 

Then is ship in cart a contribution whose goal is to combine the two pages, shopping_cart and check-out shipping into a single page?

I didn't realize that's what it was.

 

Thanks in advance,

India


*** Je suis plus souvent sur le forum français ***

ms2fr, Header Tags 2.5.5b, Order logging before payment, Better PayPal Description perso, Free shipping per product, Must agree to terms, Country State Selector, World Zones, Visible countries, Store Pick Up, several shipping modules, Personal Invoice Number, 'On the Fly' Auto Thumbnailer using GD Library, More_Pics_6 for 2.2 ms2, Ultimate SEO URLs 2-2.1d/e,Virement Bancaire, Estimated Shipping 1.5, xml_guide, SP+,Step By Step 1.8, Order Editor 2.6.3, Google Analytics, Dynamic Sitemap 2.0, OSC-Expeditor, Recover Cart Sales, Links Manager 1.15

local : linux 2.6 Fedora Core 3, server : APACHE 2.0.54, MySQL 4.1.18, php : 4.4.0 (on strike refuse to update)

remote : IcoOpenBSD 4.x, server : IcodiaSecureHttpd, MySQL 4.1.24, php : 4.4.9

 

You never get a second chance to make a first impression.

Share this post


Link to post
Share on other sites
Also, when I switch language from French to English the shipping information dissapears.

Sorry my fault (forgot languages/english/modules/shipping_estimator.php).


*** Je suis plus souvent sur le forum français ***

ms2fr, Header Tags 2.5.5b, Order logging before payment, Better PayPal Description perso, Free shipping per product, Must agree to terms, Country State Selector, World Zones, Visible countries, Store Pick Up, several shipping modules, Personal Invoice Number, 'On the Fly' Auto Thumbnailer using GD Library, More_Pics_6 for 2.2 ms2, Ultimate SEO URLs 2-2.1d/e,Virement Bancaire, Estimated Shipping 1.5, xml_guide, SP+,Step By Step 1.8, Order Editor 2.6.3, Google Analytics, Dynamic Sitemap 2.0, OSC-Expeditor, Recover Cart Sales, Links Manager 1.15

local : linux 2.6 Fedora Core 3, server : APACHE 2.0.54, MySQL 4.1.18, php : 4.4.0 (on strike refuse to update)

remote : IcoOpenBSD 4.x, server : IcodiaSecureHttpd, MySQL 4.1.24, php : 4.4.9

 

You never get a second chance to make a first impression.

Share this post


Link to post
Share on other sites
I was having the same issue with this contribution where the it did not show up when a user wasn't logged in. I did the above fix, replacing:

 

if (($cart->count_contents() > 0) && (tep_session_is_registered('customer_id'))) {

 

with:

 

if ($cart->count_contents() > 0) {

 

The box shows up now but there are no shipping options (ups, usps.. etc..) and there is no space to fill in your zip. It works just fine when you are logged in and all the options show up.

 

I did the same fix also and I'm having the same issue with no shipping options. I've got the state and zip fields (as they are set to "true" in the admin) but no shipping options show up unless signed in. Any help would be appreciated.

Share this post


Link to post
Share on other sites
I did the same fix also and I'm having the same issue with no shipping options. I've got the state and zip fields (as they are set to "true" in the admin) but no shipping options show up unless signed in. Any help would be appreciated.

 

What worked for me (for customers that are not signed in) was to enable the 'country' field, too, alongside the state and zip fields. However, I didn't really want that field, since I don't ship internationally yet. So, I set it manually by adding:

 

define('STORE_COUNTRY','223');

 

to catalog/includes/languages/english/modules/shipping_estimator.php

and then disabled the country option again in the admin. Probably a crude workaround, but it seems to work so far.

 

Note: I am using Steve Fatula's Fedex_Direct_2.04-CVS as my shipping module.

Share this post


Link to post
Share on other sites
What worked for me (for customers that are not signed in) was to enable the 'country' field, too, alongside the state and zip fields. However, I didn't really want that field, since I don't ship internationally yet. So, I set it manually by adding:

 

define('STORE_COUNTRY','223');

 

to catalog/includes/languages/english/modules/shipping_estimator.php

and then disabled the country option again in the admin. Probably a crude workaround, but it seems to work so far.

 

Note: I am using Steve Fatula's Fedex_Direct_2.04-CVS as my shipping module.

 

Oops, had to stick with just enabling the country field, otherwise the shipping costs don't update correctly.

Share this post


Link to post
Share on other sites

Hi. I was hoping to get some help on the shipincart contribution (which is a wonderful contribution)

 

I have 2 questions/problems:

 

1. For non-logged in customers I cannot see UPS options in the cart. USPS options show just fine, and UPS shows just fine when logged in, but not w/o logging in.

 

2. For International customers I can't see any shipping options in the cart once they are logged in. It is fine before logging in (they can choose their country from the shipincart and see their option), but once they login it disappears from the cart).

 

Is there anything inparticular I should be looking for to correct this?

 

My site is http://www.blueluxe.com

 

Thank you very much for any assistance.

 

Regards,

 

-- Josh

Share this post


Link to post
Share on other sites

This is a great contribution. Thank you!

 

I don't see where to add the images for the carrier. Would someone point me in the right direction? Thank you in advance.

 

Also, the little checkmark is not showing up either. I changed the file name and put it in the icon folder.

 

Thanks

Rob

Share this post


Link to post
Share on other sites

I am looking to install this contribution, but I already have some entries in my SQL configuration table with configuration_id's of 225,226 and 227.

 

Does anyone know a work around for this?Could I use a configuration_id that has not been used?

 

Any help much appreciated. Thanks in advance

Share this post


Link to post
Share on other sites
I am looking at this contrib and would like to know how how I check my SQL tables.... any help in this old thread...? :)

 

If you still need help, I just figured this out myself...

 

Log into your PHPAdmin (mine is in control panel > PHP database > PHPmyAdmin)

 

then you open the database you are wanting to look at.

 

On mine on the left hand side is a list I clicked on "configuration_group" and it showed me a list of all the query's mine went to 15. After installing, I checked again and mine went from 15 then showed the shopping cart as 19, so I guess it worked!

Share this post


Link to post
Share on other sites
I was having the same issue with this contribution where the it did not show up when a user wasn't logged in. I did the above fix, replacing:

 

if (($cart->count_contents() > 0) && (tep_session_is_registered('customer_id'))) {

 

with:

 

if ($cart->count_contents() > 0) {

 

The box shows up now but there are no shipping options (ups, usps.. etc..) and there is no space to fill in your zip. It works just fine when you are logged in and all the options show up.

 

The same here. I don't even see the country and zip code input field even I enable them in Admin. Any helps? :rolleyes:

Edited by kkndkknd

Share this post


Link to post
Share on other sites

HI

 

Just installed the Ship In Cart and we are getting the following error

 

Fatal error: Cannot redeclare class in

httpclient in /includes/classes/http_client.php on line 37

 

 

Uhave searched everywhere an con not find an answer. can anyone point us in the correct direction

 

 

Thanks

 

joe


----------------------------

Long Island, New York

Share this post


Link to post
Share on other sites

I just installed the contribution and the idea is perfect.

 

I do have a big issue.

 

Once I hit the shopping cart all the font goes haywire and the page looks horrible due to the change. any help???

 

This actually happens with more than just this contribution.

Share this post


Link to post
Share on other sites
I just installed the contribution and the idea is perfect.

 

I do have a big issue.

 

Once I hit the shopping cart all the font goes haywire and the page looks horrible due to the change. any help???

 

This actually happens with more than just this contribution.

 

 

Nevermind....$%!*$ dreamweaver.....

Share this post


Link to post
Share on other sites
This is a great contribution. Thank you!

 

I don't see where to add the images for the carrier. Would someone point me in the right direction? Thank you in advance.

 

Also, the little checkmark is not showing up either. I changed the file name and put it in the icon folder.

 

Thanks

Rob

 

I know this is old, but did anybody ever answer this question?


Steve

I appreciate all the help that everyone on this site has given me!

Share this post


Link to post
Share on other sites

I installed this contrib and my problem is the update cart button does not allow me to remove items from cart. I guess because the new update button with the package is present, any ideas?


Knowledge is useless, unless transferred.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×