Jump to content

Archived

This topic is now archived and is closed to further replies.

sebman21

Problem in administration

Recommended Posts

When I opend my OScommerce administration window, I found this message:

 

Fatal error: Call to undefined function: tep_output_string() in /*****/store_admin/includes/functions/html_output.php on line 156

 

and the rest of the site isnt working. To see what it looks like, you can visit my site at nationwideparty.com and click on an item on the side.

 

Do you have any suggestions on why this is happening? Thanks

Share this post


Link to post
Share on other sites

Your server has just gone down - that may be the source of your problems.

 

Vger

Share this post


Link to post
Share on other sites

I'm currently seeing:

 

Fatal error: Cannot pass parameter 3 by reference in /home/httpd/vhosts/nationwideparty.com/httpdocs/store/includes/modules/product_listing.php on line 13

 

What's on line 13?

Share this post


Link to post
Share on other sites
I'm currently seeing:

 

Fatal error: Cannot pass parameter 3 by reference in /home/httpd/vhosts/nationwideparty.com/httpdocs/store/includes/modules/product_listing.php on line 13

 

What's on line 13?

 

$listing_split = new splitPageResults($listing_sql, MAX_DISPLAY_SEARCH_RESULTS, 'p.products_id');

is on line 13

Share this post


Link to post
Share on other sites
$listing_split = new splitPageResults($listing_sql, MAX_DISPLAY_SEARCH_RESULTS, 'p.products_id');

is on line 13

 

I sort of fixed this problem. Before, the items didnt show up, but now at least something comes up. However, when I click on an item, nothing comes up.

 

With my original problem in the administration site on line 156 (153-169 below) of html_output.php is:

(line 156 has *** around it)

 

////
// Output a form
 function tep_draw_form($name, $action, $parameters = '', $method = 'post', $params = '') {
 *********$form = '<form name="' . tep_output_string($name) . '" action="';***********
if (tep_not_null($parameters)) {
  $form .= tep_href_link($action, $parameters);
} else {
  $form .= tep_href_link($action);
}
$form .= '" method="' . tep_output_string($method) . '"';
if (tep_not_null($params)) {
  $form .= ' ' . $params;
}
$form .= '>';

return $form;
 }

 

I tried to install Ultimate SEO, but I did not touch this file. Any Suggestions? Thanks

Share this post


Link to post
Share on other sites

×