Jump to content
Sign in to follow this  
jawproducts

Shipping not showing on checkout_confirmation page?

Recommended Posts

I am lost, I haven't been able to find this answer anywhere! On our site www.jawproducts.com , I have the USPS module installed and it is calculating fine based on weight, but when you go to the checkout_confirmation page, it only shows each product with the price, then a subtotal, then handling, then order total, but there is NO line with the SHIPPING total . I know its adding it in, but there is nothing showing shipping in the breakdown. I can't find how to fix this!!

Jen

Share this post


Link to post
Share on other sites

Hi Jen. The one thing that comes to mind is to check your configuration table and make sure "Display Shipping" is true. (Or you can check the Order Total Module in Admin and do the same there.)

 

Hope it helps.

 

- Kim

Share this post


Link to post
Share on other sites

Thanks Kim

I did all of that already, and "display shipping" does say true, and the order total module is correct

I guess ill never figure this out!

thanks so much

Share this post


Link to post
Share on other sites
I am lost, I haven't been able to find this answer anywhere! On our site www.jawproducts.com , I have the USPS module installed and it is calculating fine based on weight, but when you go to the checkout_confirmation page, it only shows each product with the price, then a subtotal, then handling, then order total, but there is NO line with the SHIPPING total . I know its adding it in, but there is nothing showing shipping in the breakdown. I can't find how to fix this!!

Jen

 

Hi,

 

Yes, I have the same problem. It skips passed the Shipping Module straight to the Payment Module. (!)

Share this post


Link to post
Share on other sites

I am also having the same problem.

 

No matter what changes I make, Shipping is not being added to the total cost. I have so far this week lost out on ?50 by the shop not charging shipping.

 

Anyone got any ideas?

Share this post


Link to post
Share on other sites

Hey guys I had the same problem and it was so annoying. Whenever I took a test run in my store with my info, the shipping would work. And each time I thought I fixed a customer would email me and say that they werent being charged.

 

So finally, just now, I entered in my brother in laws info from chicago (im in ny). I went through and I wasnt charged. I went into my admin/modules/shipping, clicked on USPS and disabled the Shipping Zone (switched from United States to None). Now that it is on none, I am able to choose shipping charges, etc.

 

Hope this helps you guys and my fingers are crossed that It will continue to work.

 

Leslie

Share this post


Link to post
Share on other sites
I am lost, I haven't been able to find this answer anywhere! On our site www.jawproducts.com , I have the USPS module installed and it is calculating fine based on weight, but when you go to the checkout_confirmation page, it only shows each product with the price, then a subtotal, then handling, then order total, but there is NO line with the SHIPPING total . I know its adding it in, but there is nothing showing shipping in the breakdown. I can't find how to fix this!!

Jen

Hi Jen,

 

Can you check that the items in your catalog have their weight added. I know it sounds silly, But!

Share this post


Link to post
Share on other sites
Hi Jen,

 

Can you check that the items in your catalog have their weight added. I know it sounds silly, But!

 

Thanks for the help but i tried all of the above and still , the shipping will not show up at all!!

Share this post


Link to post
Share on other sites

See if you can see this; see how it does not show the shipping? it is still adding it in, but it will not show up on the page. jaw.jpg

Share this post


Link to post
Share on other sites

It has been awhile and I STILL havent been able to solve this problem, ive looked EVERYWHERE, checked every file and i just don't know the problem, can someone please help me? The checkout_confirmation page just has no shipping method section at all, it just doesnt show up as you can see above, even though it shows up before the confirmation page.

Share this post


Link to post
Share on other sites

Hi Leslie,

 

I had the same problem.

 

Your suggestion to change United States to none worked now my Payment options won't show up, any suggestions?

Share this post


Link to post
Share on other sites

STILL HAVING this problem, over a year now and STILL no shipping shows up, did anyone figure this out?

Share this post


Link to post
Share on other sites
STILL HAVING this problem, over a year now and STILL no shipping shows up, did anyone figure this out?
Can you post the code for your shipping.php page (root level)? Something is going on, but without seeing the code, it's guess work.

 

PS: I created a test account (test test) please delete. Also - have you looked at your site in Firefox? The buttons at the top don't look good at all in Firefox.

 

Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites

I will poste the shipping page ;

also i didnt realize the tabs were bad in firefox (I dont know why they are white like that, i used a contribution to install tabs and cant figure out why its doing that). Here is my shipping.php

<?php

/*

$Id: shipping.php,v 1.22 2003/06/05 23:26:23 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

require('includes/application_top.php');

 

require(DIR_WS_LANGUAGES . $language . '/' . FILENAME_SHIPPING);

 

$breadcrumb->add(NAVBAR_TITLE, tep_href_link(FILENAME_SHIPPING));

?>

<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">

<html <?php echo HTML_PARAMS; ?>>

<head>

<?php

// BOF: WebMakers.com Changed: Header Tag Controller v2.5.2

// Replaced by header_tags.php

if ( file_exists(DIR_WS_INCLUDES . 'header_tags.php') ) {

require(DIR_WS_INCLUDES . 'header_tags.php');

} else {

?>

<title><?php echo TITLE; ?></title>

<?php

}

// EOF: WebMakers.com Changed: Header Tag Controller v2.5.2

?>

<base href="<?php echo (($request_type == 'SSL') ? HTTPS_SERVER : HTTP_SERVER) . DIR_WS_CATALOG; ?>">

<link rel="stylesheet" type="text/css" href="stylesheet.css">

</head>

<body marginwidth="0" marginheight="0" topmargin="0" bottommargin="0" leftmargin="0" rightmargin="0">

<!-- header //-->

<?php require(DIR_WS_INCLUDES . 'header.php'); ?>

<!-- header_eof //-->

 

<!-- body //-->

<table border="0" width="100%" cellspacing="3" cellpadding="3">

<tr>

<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">

<!-- left_navigation //-->

<?php require(DIR_WS_INCLUDES . 'column_left.php'); ?>

<!-- left_navigation_eof //-->

</table></td>

<!-- body_text //-->

<td width="100%" valign="top"><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="0">

<tr>

<td class="pageHeading"><?php echo HEADING_TITLE; ?></td>

<td class="pageHeading" align="right"><?php echo tep_image(DIR_WS_IMAGES . 'table_background_specials.gif', HEADING_TITLE, HEADING_IMAGE_WIDTH, HEADING_IMAGE_HEIGHT); ?></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td class="main"><?php echo TEXT_INFORMATION; ?></td>

</tr>

</table></td>

</tr>

<tr>

<td><?php echo tep_draw_separator('pixel_trans.gif', '100%', '10'); ?></td>

</tr>

<tr>

<td><table border="0" width="100%" cellspacing="1" cellpadding="2" class="infoBox">

<tr class="infoBoxContents">

<td><table border="0" width="100%" cellspacing="0" cellpadding="2">

<tr>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

<td align="right"><?php echo '<a href="' . tep_href_link(FILENAME_DEFAULT) . '">' . tep_image_button('button_continue.gif', IMAGE_BUTTON_CONTINUE) . '</a>'; ?></td>

<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>

</tr>

</table></td>

</tr>

</table></td>

</tr>

</table></td>

<!-- body_text_eof //-->

<td width="<?php echo BOX_WIDTH; ?>" valign="top"><table border="0" width="<?php echo BOX_WIDTH; ?>" cellspacing="0" cellpadding="2">

<!-- right_navigation //-->

<?php require(DIR_WS_INCLUDES . 'column_right.php'); ?>

<!-- right_navigation_eof //-->

</table></td>

</tr>

</table>

<!-- body_eof //-->

 

<!-- footer //-->

<?php require(DIR_WS_INCLUDES . 'footer.php'); ?>

<!-- footer_eof //-->

<br>

</body>

</html>

<?php require(DIR_WS_INCLUDES . 'application_bottom.php'); ?>

 

thank you SO MUCH, I was looking at checkout_shipping.php - I am a little new to this so maybe I am being a complete idiot?? Lol

 

thank you!!

Share this post


Link to post
Share on other sites

i am confused, I thought shipping.php was just shipping terms?? I didn't think that had anything to do with checkout shipping

Share this post


Link to post
Share on other sites
i am confused, I thought shipping.php was just shipping terms?? I didn't think that had anything to do with checkout shipping

When some asks you to post the source code, they mean that you use your browser to go go to the page in question. In your case, it is the shipping age in the checkout process.

 

Once there, in internet explorer, click on view, then source. This opens a nice text window with the source code in it. Press control and a to select all, then copy and post into a new post.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
i am confused, I thought shipping.php was just shipping terms?? I didn't think that had anything to do with checkout shipping

I'm sorry - late night mistake - I meant checkout_shipping.php. You are absolutely right. Stupid me. Can you post checkout_shipping.php and I take a look? Terra

 

PS: the previous post from Dittones refers to your settings for virtual products - under Configuration -> Download. If you do not sell virtual products (downloads, gift vouchers etc.) then Enable Download should be set to FALSE. Basically, virtual products are not charged shipping. However - in standard osCom customers still come to the checkout_shipping.php page, so I don't think you problem is related to that.

Edited by Terra

My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
When some asks you to post the source code, they mean that you use your browser to go go to the page in question. In your case, it is the shipping age in the checkout process.

 

Once there, in internet explorer, click on view, then source. This opens a nice text window with the source code in it. Press control and a to select all, then copy and post into a new post.

NOOOOOOOOO- don't do that! I don't need the HMTL output, I need the PHP code! just like jawproducts posted earlier - only I messed up with the page name. the HTML output which is generated when you view a page in the browser is useless for code checking.

 

Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
When some asks you to post the source code, they mean that you use your browser to go go to the page in question. In your case, it is the shipping age in the checkout process.

 

Once there, in internet explorer, click on view, then source. This opens a nice text window with the source code in it. Press control and a to select all, then copy and post into a new post.

Will try again.

 

When someone asks you to post the source code, they mean that you use your browser to go to the page in question. In your case, it is the shipping page in the checkout process.

 

Once there, in internet explorer, click on view, then source. This opens a nice text window with the source code in it. Press control and a (CTL A) to select all, then copy and post into a new post.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Will try again.

 

When someone asks you to post the source code, they mean that you use your browser to go to the page in question. In your case, it is the shipping page in the checkout process.

 

Once there, in internet explorer, click on view, then source. This opens a nice text window with the source code in it. Press control and a (CTL A) to select all, then copy and post into a new post.

Still the wrong answer - the HTML output is of no use for code checking. I did mean the PHP code as posted by jawproducts but got the page name wrong. Terra


My code for combining PayPal IPN with ** QTPro 4.25 ** osC Affiliate ** CCGV(trad)

and how to solve the invoice already paid error

General info: Allow customer to delete order comment ** FTP Programs & Text Editors ** Amending order email **

Share this post


Link to post
Share on other sites
Still the wrong answer - the HTML output is of no use for code checking. I did mean the PHP code as posted by jawproducts but got the page name wrong. Terra

Good luck.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×