Jump to content
Sign in to follow this  
mustdoit

Star_Products 1.5 Help

Recommended Posts

Hi all,

 

I installed star_product 1.5 following the directions exactly and backing up as I went along. I then went to admin to select a star product then went to the site to see what it looked like and this is what happened Home Page I know this is probably something simple but I wouldn't even know where to start. Could someone take a looksee and tell me what I need to do to correct this? Also, is there a way to remove the featured items below but keep the featured item for (month) tab part and have it above the star product? Is this toooooooo hard or a simple task? Please help!

 

Thanks,

 

Terry

Share this post


Link to post
Share on other sites

Hi Terry,

 

Took a look at your site but couldn't see star product anywhere. Is this your problem or have you turned it off since posting the request for help? If you could show us what's going wrong, or maybe explain in a bit more detail it would make it easier for us all to help.

 

Moving around featured item and star product is relatively simple. You "just" ;) need to edit index.php in your osCommerce catalogue folder which calls the different modules so that the spot that calls them is right for your layout.

 

For example insert

<?php include(DIR_WS_MODULES . FILENAME_STAR_PRODUCT); ?>

where you want star product and insert

<?php include(DIR_WS_MODULES . FILENAME_NEW_PRODUCTS); ?>

where you want to have the "Featured Products for [MONTH]"

 

cheers

 

silentz


"Grrrr! It's time this installation tasted Boomstick..."

Share this post


Link to post
Share on other sites

Can I add to this thread?

 

When I switch the star product on via admin, I get the following error:

 

1054 - Unknown column 'p.products_id' in 'on clause'

 

select substring(pd.products_description, 1, 598) as products_description, p.products_id, p.products_image, p.manufacturers_id, p.products_price, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, IF(s.status, s.specials_new_products_price, p.products_price) as final_price, p.products_tax_class_id, sp.product_id from products p, products_description pd, star_product sp left join specials s on p.products_id = s.products_id where p.products_id = pd.products_id and p.products_status = '1' and pd.products_description != '' and p.products_id=sp.product_id and pd.language_id = '1'

 

[TEP STOP]

Any suggestions please?

 

Thank you

Share this post


Link to post
Share on other sites

Hi Terry!

 

I wanted to help out too but I couldnt see what's wrong with your site.

 

Custom, that error means you have not properly uploaded the sql file in your root. Try running it and refresh.

 

Likewise, I like this contrib but after I install, the price dsnt show in the star product box. After tinkering, all the prices on the cart went blank! I am in the process of reuploading my back up site as returning the files to the original configuration did not help the price issue. I check all posts regarding price, setting defaults, etc. but none helped. I figured the damage was with another file outside of those I configured for this mod.

 

In addition, the sql file has an error, having no index file.

 

I hope someone resolves this as this is a wonderful mod to have indeed.

 

Thanks!

 

Also see this thread: http://forums.oscommerce.com/index.php?sho...101979&st=0

Edited by hardcore_shad

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×