Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

Thanks for the help dynamo! The checkout_process.php fix worked for the cc order part. Still can't get the EC checkout but I'll have to wait until Monday to talk with paypal about why I am getting the 10417 error.

 

Only thing I'm running besides this payment module is the newest version of STS.

 

-GT

Share this post


Link to post
Share on other sites
Still battling with the payment module. EC fails and CC fails 90% of the time. I think it might have something to do with the OrderTotal being passed. Could someone take a quick look at the log file and let me know if it looks okay.

 

In function: before_process() - Direct Payment

Did first contact attempt return error? Yes

---------------------------------------------------------------------

-------------------------------DP_DUMP-------------------------------

------------This is the information that was sent to PayPal----------

---------------------------------------------------------------------

[?xml version="1.0" encoding="utf-8"?]

[soap:Envelope xmlns:soap=http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema]

[soap:Header]

[RequesterCredentials xmlns=urn:ebay:api:PayPalAPI]

[Credentials xmlns=urn:ebay:apis:eBLBaseComponents]

[username]fae-test_api1.fireartsemporium.com[/username]

[Password]XXXXXXXXXXXXXXXXX[/Password]

[subject][/subject]

[/Credentials]

[/RequesterCredentials]

[/soap:Header]

[soap:Body]

[DoDirectPaymentReq xmlns=urn:ebay:api:PayPalAPI]

[DoDirectPaymentRequest]

[Version xmlns=urn:ebay:apis:eBLBaseComponents]2.0[/Version]

[DoDirectPaymentRequestDetails xmlns=urn:ebay:apis:eBLBaseComponents]

[PaymentAction]Sale[/PaymentAction]

[PaymentDetails]

[OrderTotal currencyID=USD]0.00[/OrderTotal]

[OrderDescription]Order placed on April 7, 2007, 5:16 pm by Bob (ID: 7)[/OrderDescription]

[itemTotal currencyID=USD]0[/itemTotal]

[shippingTotal currencyID=USD]0[/shippingTotal]

[HandlingTotal currencyID=USD][/HandlingTotal]

[TaxTotal currencyID=USD]0[/TaxTotal]

[Custom]Phone: xxx-xxx-xxxx -- Email: x@x.com[/Custom]

[invoiceID][/invoiceID]

[NotifyURL][/NotifyURL]

[buttonSource][/buttonSource]

[shipToAddress]

[Name]Bob Smith[/Name]

[street1]42 Heart St[/street1]

[street2][/street2]

[CityName]San Francisco[/CityName]

[stateOrProvince]CA[/stateOrProvince]

[PostalCode]94110[/PostalCode]

[Country]US[/Country]

[/shipToAddress]

[PaymentDetailsItem][Name]Snakes[/Name][Amount currencyID=USD]125.00[/Amount][Number]33{9}47{3}46 ()[/Number][Quantity]1[/Quantity][/PaymentDetailsItem][PaymentDetailsItem][Name]Order Total Discrepancy[/Name][Amount currencyID=USD]-125.00[/Amount][Number]NA[/Number][Quantity]1[/Quantity][/PaymentDetailsItem]

[/PaymentDetails]

[CreditCard]

[CardOwner]

[Payer]bob@bob.com[/Payer]

[PayerName]

[FirstName]Bob[/FirstName]

[LastName]Smith[/LastName]

[/PayerName]

[Address]

[street1]42 Heart St[/street1]

[street2][/street2]

[CityName]San Francisco[/CityName]

[stateOrProvince]CA[/stateOrProvince]

[PostalCode]94110[/PostalCode]

[Country]US[/Country]

[/Address]

[/CardOwner]

[CreditCardType]Visa[/CreditCardType]

[CreditCardNumber]4784254807458440[/CreditCardNumber]

[startMonth][/startMonth]

[startYear][/startYear]

[issueNumber][/issueNumber]

[ExpMonth]01[/ExpMonth]

[ExpYear]2010[/ExpYear]

[CVV2]123[/CVV2]

[/CreditCard]

[iPAddress]xx.xx.xx.xxx[/iPAddress]

[MerchantSessionId]pld91753o9dl8p3bnch6kb9dv3[/MerchantSessionId]

[/DoDirectPaymentRequestDetails]

[/DoDirectPaymentRequest]

[/DoDirectPaymentReq]

[/soap:Body]

[/soap:Envelope]---------------------------------------------------------------------

-------------------------------FINAL_REQ-----------------------------

-------------------This is the response from PayPal------------------

---------------------------------------------------------------------

Array

(

[security] =>

[RequesterCredentials] => Array

(

[0] => Array

(

[Credentials] => Array

(

[0] => Array

(

[username] =>

[Password] =>

[subject] =>

)

 

)

 

)

 

)

 

[DoDirectPaymentResponse] => Array

(

[0] => Array

(

[Timestamp] => 2007-04-08T00:08:26Z

[Ack] => Failure

[CorrelationID] => 9ea4241fd3b2d

[Errors] => Array

(

[0] => Array

(

[shortMessage] => Invalid Data

[LongMessage] => This transaction cannot be processed. The amount to be charged is zero.

[ErrorCode] => 10525

[severityCode] => Error

)

 

)

 

[Version] => 2.000000

[build] => 1.0006

)

 

)

 

)

---------------------------------------------------------------------

---------------------------------TS_REQ------------------------------

--------Results of the transaction search if it was executed---------

---------------------------------------------------------------------

Share this post


Link to post
Share on other sites

Sorry about that last post... duh.

 

The zero error looks painfully familiar.

 

I've been running wpp for a while without a hitch and decided to give the beast ccgv (trad) a try since you included it in your fine contrib (grrr). I'm running wpp 9.1

 

I get the error msg: Invalid Data (10525)

This transaction cannot be processed. The amount to be charged is zero.

 

Anything insight is greatly appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites

Somewhere in modifying the wpp module, I've screwed up the admin settings. When I click on Payment in the Modules section of the Admin page, two things are wrong:

 

1) There is nothing for wpp listed.

2) The configuration boxes on the right have disappeared for all payment options, no matter which one I select.

 

I've been checking and rechecking code. Any ideas what I did wrong?

 

I should add: at the same time this happened, the checkout_payment.php page suddenly turns up blank.

Share this post


Link to post
Share on other sites

Hi Brian,

 

I have managed to solve the internal error I was having but now when I click on the express checkout button I get this pretty display:

 

array(3) { ["Security"]=> string(0) "" ["RequesterCredentials"]=> array(1) { [0]=> array(1) { ["Credentials"]=> array(1) { [0]=> array(3) { ["Username"]=> string(0) "" ["Password"]=> string(0) "" ["Subject"]=> string(0) "" } } } } ["SetExpressCheckoutResponse"]=> array(1) { [0]=> array(6) { ["Timestamp"]=> string(20) "2007-04-12T11:11:06Z" ["Ack"]=> string(7) "Failure" ["CorrelationID"]=> string(13) "fd556df5cd4c0" ["Errors"]=> array(1) { [0]=> array(4) { ["ShortMessage"]=> string(47) "Shipping Address Invalid City State Postal Code" ["LongMessage"]=> string(68) "A match of the Shipping Address City, State, and Postal Code failed." ["ErrorCode"]=> string(5) "10736" ["SeverityCode"]=> string(5) "Error" } } ["Version"]=> string(8) "2.000000" ["Build"]=> string(6) "1.0006" } } }

Warning: Cannot modify header information - headers already sent by (output started at /home/******/public_html/includes/modules/payment/paypal_wpp.php:565) in /home/******/public_html/includes/functions/general.php on line 33

 

Any help or advice would be appreciated.

 

Thanks

 

Mark


Lifes a bitch, then you marry one, then you die!

Share this post


Link to post
Share on other sites

Hi Brian,

 

I have managed to solve the internal error I was having but now when I click on the express checkout button I get this pretty display:

 

array(3) { ["Security"]=> string(0) "" ["RequesterCredentials"]=> array(1) { [0]=> array(1) { ["Credentials"]=> array(1) { [0]=> array(3) { ["Username"]=> string(0) "" ["Password"]=> string(0) "" ["Subject"]=> string(0) "" } } } } ["SetExpressCheckoutResponse"]=> array(1) { [0]=> array(6) { ["Timestamp"]=> string(20) "2007-04-12T11:11:06Z" ["Ack"]=> string(7) "Failure" ["CorrelationID"]=> string(13) "fd556df5cd4c0" ["Errors"]=> array(1) { [0]=> array(4) { ["ShortMessage"]=> string(47) "Shipping Address Invalid City State Postal Code" ["LongMessage"]=> string(68) "A match of the Shipping Address City, State, and Postal Code failed." ["ErrorCode"]=> string(5) "10736" ["SeverityCode"]=> string(5) "Error" } } ["Version"]=> string(8) "2.000000" ["Build"]=> string(6) "1.0006" } } }

Warning: Cannot modify header information - headers already sent by (output started at /home/******/public_html/includes/modules/payment/paypal_wpp.php:565) in /home/******/public_html/includes/functions/general.php on line 33

 

Any help or advice would be appreciated.

 

Thanks

 

Mark


Lifes a bitch, then you marry one, then you die!

Share this post


Link to post
Share on other sites

Hi Brian,

 

I have managed to solve the internal error I was having but now when I click on the express checkout button I get this pretty display:

 

array(3) { ["Security"]=> string(0) "" ["RequesterCredentials"]=> array(1) { [0]=> array(1) { ["Credentials"]=> array(1) { [0]=> array(3) { ["Username"]=> string(0) "" ["Password"]=> string(0) "" ["Subject"]=> string(0) "" } } } } ["SetExpressCheckoutResponse"]=> array(1) { [0]=> array(6) { ["Timestamp"]=> string(20) "2007-04-12T11:11:06Z" ["Ack"]=> string(7) "Failure" ["CorrelationID"]=> string(13) "fd556df5cd4c0" ["Errors"]=> array(1) { [0]=> array(4) { ["ShortMessage"]=> string(47) "Shipping Address Invalid City State Postal Code" ["LongMessage"]=> string(68) "A match of the Shipping Address City, State, and Postal Code failed." ["ErrorCode"]=> string(5) "10736" ["SeverityCode"]=> string(5) "Error" } } ["Version"]=> string(8) "2.000000" ["Build"]=> string(6) "1.0006" } } }

Warning: Cannot modify header information - headers already sent by (output started at /home/******/public_html/includes/modules/payment/paypal_wpp.php:565) in /home/******/public_html/includes/functions/general.php on line 33

 

Any help or advice would be appreciated.

 

Thanks

 

Mark


Lifes a bitch, then you marry one, then you die!

Share this post


Link to post
Share on other sites

First, upload an unmodified version of the module as I know it works as-is.

 

Second, the error "Shipping Address Invalid City State Postal Code" sounds like the customer account you're using doesn't have a correct address setup. Make sure the customer account's billing address is the same as the card's billing address, then try again.

 

@pogogirl: Did you include the checkout_process.php fix? If so, your store is messed up somewhere else.

Edited by dynamoeffects

Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Ok so I have this installed..all appears ok...sales are slow but happening...just launched a charity single...getting loads who are trying to purchase but are having problems at the credit card stage..why is it accepting for some and not others...putting off customers returning...here is a latest error

 

error states 'I have missed address, country out of the billing address but I have filled in every section'

 

I run a music site offering digital downloads...but this is causing a problem..I am sure it's something simple and easy to rectify..but cannot find the solution..help would be really appreciated.

 

Russell

www.imusiclabel.com

info@imusiclabel.com

Share this post


Link to post
Share on other sites

I am running the UK version.

On the page where customer selects the payment method, they are faced with 3 options;

 

1, Card payment and the card payment fields to fill in.

2, Bank Payment / Online Banking

3, Cheque, Check , Money Order

 

Some customers who wish to pay by card are filling in the card payment fields but accidentally have the Bank Payment or cheque payment options selected, so when they click to complete the order they think they have paid by card when they haven't.

This surprisingly happening most days.

 

I think it may be less confusing if the card payment fields are not present where they select the payment method but on a following page if this payment option is selected.

 

I don’t know if anyone has any thoughts on this and how easy it would be to do?

Share this post


Link to post
Share on other sites

This isn't a WPP related question, per se. There is a contribution that makes the payment selection a little more intuitive, but I haven't seen anything like what you're talking about. What you're talking about would be a change in the checkout_payment.php script, where adding a little javascript that hides and shows the selected payment module.

 

Actually, this would be rather simple to implement. If I have time this week, I'll see about releasing it as a contribution.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
This isn't a WPP related question, per se. There is a contribution that makes the payment selection a little more intuitive, but I haven't seen anything like what you're talking about. What you're talking about would be a change in the checkout_payment.php script, where adding a little javascript that hides and shows the selected payment module.

 

Actually, this would be rather simple to implement. If I have time this week, I'll see about releasing it as a contribution.

 

That's fantastic news.

 

Thanks Frank

Share this post


Link to post
Share on other sites

Hi Brian,

 

Sorry to bug you again with this problem... if any luck I would really apreciate it :blush:

I just hope I will not run into problems with Paypal for not behaving by their policy (which is a bit weird in my eyes, especially displaying the Paypal on the Payment page after it was already exposed on the login page).

You may have a look at my site: http://www.verifresh.com/onlinestore

 

Many thanks again ;)

Theodore

 

Thanks brahms, I see what you're doing and I'll look into it. For now, I suggest disabling the EC button on the payment page. There's an option in the module's settings.

Share this post


Link to post
Share on other sites

The Express Checkout button isn't required to be on the checkout_payment page, so there's no issue about the policy. I really haven't had much time to look at it still. It takes a fair amount of effort to load up my dev store, get into it, all the code open, sandbox open, and start testing. Just not something I've had much time to work on.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

hi can anyone help me i have installed paypal website payment pro (uk) - pwa on my osc site and it was working fine until i enabled ssl and now i have lost the ability to checkout without an account and when i try to checkout with an account when i click on continue to confirm shipping details i get the following error:

 

 

Fatal error: Call to undefined function: tep_paypal_wpp_enabled() in /hsphere/local/home/hotnhorn/littlewigglesclothing.com/catalog/includes/modules/payment/paypal_wpp_uk.php on line 36

 

I am new to all this so any help would be much appreciated

sarah

Share this post


Link to post
Share on other sites

Include the changes found in the /includes/functions/general.php file.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Dear Brian,

 

I can understand that... so if for teh meantime you think I should not worry that Paypal is gonna shout... I am quiet :-)

Many thanks for your time anyway... you did a great job.

 

best regards,

Theodore

 

The Express Checkout button isn't required to be on the checkout_payment page, so there's no issue about the policy. I really haven't had much time to look at it still. It takes a fair amount of effort to load up my dev store, get into it, all the code open, sandbox open, and start testing. Just not something I've had much time to work on.

Share this post


Link to post
Share on other sites

I really can't help you on that one. You're using the PayPal-maintained fork of this module, so you'll need to contact their support regarding that. This thread is to discuss support of this module:

 

http://www.oscommerce.com/community/contributions,3647

 

The only reason I was able to answer your earlier question is that their official version is based off of this module.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

hi i was having no luck with the offical version so i am now using v0.9 for us/uk, have almost got everything working but get (error no. ) displayed when ever i go to check out. have ran wpp_diagnostics.php and get the following results:

 

 

Basic Tests

 

Using at least PHP 4.3.0? Yes

 

Does your store have an SSL certificate installed and working? Yes

 

Is cURL installed? Yes

 

Does cURL work? (Simple HTTP test) Yes

 

API Certificate installed? Yes

 

API Certificate directory protected? Yes

 

API Username in place? Yes

 

API Password in place? Yes

 

Database update in place? Yes

 

XML Document "doDirectPayment.xml" exists? Yes

 

XML Document "doExpressCheckout.xml" exists? Yes

 

XML Document "getExpressCheckoutDetails.xml" exists? Yes

 

XML Document "setExpressCheckout.xml" exists? Yes

 

XML Document "transactionSearch.xml" exists? Yes

 

Advanced Diagnostics

 

Able to connect to PayPal through cURL? No

Error received: 35: SSL: error:00000001:lib(0):func(0):reason(1)

 

Received a valid response? Yes

 

Did PayPal respond without errors? (If not, errors are below) Yes

 

 

 

Can any body tell me what this error code refers to, have searched forums with no luck

Share this post


Link to post
Share on other sites

Yes. You have to have a PayPal account plus be signed up for their pro service to even test this. If you're not paying $20 a month to paypal right now, you are not signed up for their pro service. If you don't even have a PayPal account, you won't be able to even use PayPal IPN.

 

1) Get a PayPal Account

2) Sign up for their pro service

3) Test this module


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×