Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

@Bushmaster: Add an extra "/" after "catalog" wherever you see it in you configure.php file.

 

 

Ok I think I have it fixed. There were already slashs after all the catalog entries. In your code

//Make sure the XML file exists

if (file_exists(DIR_FS_CATALOG . DIR_WS_INCLUDES . 'wpp_xml/' . $type . '.xml')) {

//Suck in XML framework

$xml_file = DIR_FS_CATALOG . DIR_WS_INCLUDES . 'wpp_xml/' . $type . '.xml';

 

I changed it to this

//Make sure the XML file exists

if (file_exists(DIR_FS_CATALOG .'/'. DIR_WS_INCLUDES . 'wpp_xml/' . $type . '.xml')) {

//Suck in XML framework

$xml_file = DIR_FS_CATALOG .'/'. DIR_WS_INCLUDES . 'wpp_xml/' . $type . '.xml';

 

Thanks for all your time. Now all I need to do is fix some of the colors and finish the product.

Share this post


Link to post
Share on other sites

The configure.php file expects slashes after the CATALOG defines. Changing my code instead of altering your configure.php file is going to lead to more problems down the road.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
I've checked this and they do support it, they claim the cURL will work on default as well, I tried everything I know, any ideas?

 

I was actually able to replicate this error. There is a problem in 0.9 because I close the curl handle, then try to reference it again if there was a problem. It came up because I was trying to use a Sandbox certificate on a live account. Ensure that you're using the correct certificate -- sandbox certificates can't be used in live mode and vice versa.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
@gmltw: That problem is caused by the rules in your htaccess file. Switch your .htaccess file with the original one, and then try again.

 

@Bushmaster: Add an extra "/" after "catalog" wherever you see it in you configure.php file.

 

dynamoeffects, thank you for responding!

 

I loaded the original .htaccess file but I am still receiving the same error.

 

If you wish to have a look at the site gourmetsoiree.com you can see what is happening. I have a test account set up for a fake customer. There are items in the cart already, if you sign in and click on checkout, you will see the error page. The UN or email is testingstore@gourmetsoiree.com and the PW is testing.

 

Please keep in mind that I am still in the beginning stages. I want to make sure that everything functions before I spend time on design. So it doesn't look very nice right now.

 

 

 

Thanks,

 

Gary

Share this post


Link to post
Share on other sites
The configure.php file expects slashes after the CATALOG defines. Changing my code instead of altering your configure.php file is going to lead to more problems down the road.

 

catalog/includes/configure.php

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

define('DIR_WS_HTTP_CATALOG', '/catalog/');

define('DIR_WS_HTTPS_CATALOG', '/catalog/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

So what part of it had them there and changing your code is what made it work did I not explain in the first post. There can't be 2 // after catalog the whole site shuts down. So if this is out of the normal I can't help that or tell you why. I seen that same code set up in another file and that is why I tried it. If there is files you want to see to find out why it is that way let me know I will get them to you.

Edited by Bushmaster

Share this post


Link to post
Share on other sites
catalog/includes/configure.php

So what part of it had them there and changing your code is what made it work did I not explain in the first post. There can't be 2 // after catalog the whole site shuts down. So if this is out of the normal I can't help that or tell you why. I seen that same code set up in another file and that is why I tried it. If there is files you want to see to find out why it is that way let me know I will get them to you.

 

 

I would imagine that the way DIR_FS_CATALOG is defined would be the problem, but I do not write the code just put where it needs to be.

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));
Edited by Bushmaster

Share this post


Link to post
Share on other sites

I was able to successfully set up and test the WPP using the sandbox, but when I tried to switch to the live environment, it would not go through.

 

I requested a new api signature in the live section of PayPal and updated oscommerce in the admin section with the new user/password/signature.

 

Has anyone else experienced this? I was in debug mode, but it did give me an error dump. It just gave me a page could not be displayed error when I went to confirm.

 

Thanks

Share this post


Link to post
Share on other sites

@Bushmaster: There needs to be a slash at the end of DIR_FS_CATALOG.

 

@jboutot: Sandbox and live certificates can't be interchanged.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
@Bushmaster: There needs to be a slash at the end of DIR_FS_CATALOG.

 

So you are saying that this define should look difrent then all the rest of them and have it in the first part of the statement.

define('DIR_FS_CATALOG/', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']));

Share this post


Link to post
Share on other sites
@Bushmaster: There needs to be a slash at the end of DIR_FS_CATALOG.

 

I just downloaded the package from here. Now I see where it needs to go. I have a feeling I am in for a lot of searching from this happening. I do not recall ever having to change this line for any thing. I will have to ad a sub domain and do the install from the host again and see it they did it by default.

define('DIR_FS_CATALOG', dirname($HTTP_SERVER_VARS['SCRIPT_FILENAME']) . '/');

Share this post


Link to post
Share on other sites

That's because it's a recent addition. When I started this module, that define was manually entered, and like all of the other fields, it requires a forward slash at the end. I've had to change it on several stores as well.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
That's because it's a recent addition. When I started this module, that define was manually entered, and like all of the other fields, it requires a forward slash at the end. I've had to change it on several stores as well.

 

 

Ok I guess I will find out what other places have been changed to work with it not being there when I add it. :'(

Share this post


Link to post
Share on other sites

I can not simply copy the PayPal WPP over what is in my checkout_shipping.php file. My checkout_shipping.php file had to be modified for Multi Vendor Shipping (MVS). My store will be useless to me without MVS so I have to make the two work together. I have both php files below, Is there anyone that can help me with this merge. Has anyone done this yet.

 

Thanks,

 

Gary

Share this post


Link to post
Share on other sites
I can not simply copy the PayPal WPP over what is in my checkout_shipping.php file. My checkout_shipping.php file had to be modified for Multi Vendor Shipping (MVS). My store will be useless to me without MVS so I have to make the two work together. I have both php files below, Is there anyone that can help me with this merge. Has anyone done this yet.

 

Thanks,

 

Gary

 

Gary I sent you a PM.

Share this post


Link to post
Share on other sites

hey guys,

 

how does this module deal with the order record in the mysql database if a credit card transaction is declined while using direct payment feature?

 

Thanks for ther help!

 

Best,

V

Share this post


Link to post
Share on other sites

Payment modules don't add the order to database, they only process the payment. If a card is declined, the checkout process is stopped before the order is written to the database in checkout_process.php, and the user is sent back to checkout_payment.php


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Your credit card was declined. Please try another card or contact your bank for more info.

 

Invalid Configuration (10501)

This transaction cannot be processed due to an invalid merchant configuration

 

I was able to install the WPP version 0.9 .. and it was able to pass the diagnostic test. But i get the error above.

 

Is that a Paypal issue? I researched for this error and this has something to do with a Website Payments Pro account not approved yet. I thought if Paypal have provided a API Certificate , everything is ready to go? I really dont have access to this paypal account, i only rely on what paypal info my client sends me.

Share this post


Link to post
Share on other sites

No, your client has to sign up for Website Payments Pro, which costs $20 a month. If they're not paying $20/month to PayPal, they're not signed up for Website Payments Pro.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

So if Paypal doesn't support Canadian transactions what is my alternative.

 

 

I contacted Paypal and their 'Technical Team' sent me this message.

 

 

 

Thank you for contacting PayPal.

 

Here is the coding to change the currency from USD to CAD:

 

<input type="hidden" name="currency_code" value="CAD">

 

If you have any further questions, please feel free to contact us again.

 

Sincerely,

Eileen

PayPal Community Support

PayPal, an eBay Company

 

 

 

 

So it sounds like Paypal will support Canadian funds its some part in the coding that needs to be changed.

 

 

Any ideas?

 

 

Thanks in advance

Share this post


Link to post
Share on other sites

From Paypal Developer message board.

 

 

You might be interested to know, though, that PayPal has recently added support for multiple currencies in Direct Payment and Virtual Terminal. You can now process payments in any of the following 6 currencies:

 

US Dollars (USD)

Australian Dollars (AUD)

Canadian Dollars (CAD)

Euros (EUR)

Pounds Sterling (GBP)

Yen (JPY)

Share this post


Link to post
Share on other sites

Yes, 0.9 has multiple currency support, but if you're not a US or UK merchant, it will not work for you. Canada's probably the next on the list of countries to be supported, but that's just a guess.

Edited by dynamoeffects

Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

First, thanks so much to Brian Burton for this fantastic contribution. I had a few questions regarding version 0.9.

 

I'm using version 0.7.3, and it's working great as far as I can tell. Do I really need to install 0.9? What would I gain if I do and most importantly, how difficult is it to move from 0.7.3 to 0.9?

 

Thanks again for this great contribution (the real reason I chose osCommerce in the first place).

Share this post


Link to post
Share on other sites

The big changes are:

* No more pear modules.

* Itemized order when you view the payment in your paypal account

* CCGV support

* UK support

* Lots of bug fixes

 

If it's working great for you, there's no reason to switch unless you want the additional features. 0.9 also handles PayPal's responses better. For instance, if it sends back the command to retry the transaction, it'll retry the transaction instead of showing the customer an error.

 

To upgrade, you'd just need to recompare all of the files and upload the new files, while deleting the pear modules. 0.7.3 was developed so long ago that I really don't remember what has changed since then. I know that it was a pretty stable release and that other still use it.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

I tried to install 0.9 version. and it shows the following error. Please help!

 

 

Warning: Invalid argument supplied for foreach() in \os\catalog\includes\modules\payment\paypal_wpp.php on line 991

 

Warning: Invalid argument supplied for foreach() in \os\catalog\includes\modules\payment\paypal_wpp.php on line 899

 

Warning: Cannot modify header information - headers already sent by (output started at \os\catalog\includes\modules\payment\paypal_wpp.php:991) in \os\catalog\includes\functions\general.php on line 29

Share this post


Link to post
Share on other sites

Go into Admin -> Modules -> Order Totals. Are any of the order total modules installed?


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×