Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

Did you complete your PayPal Pro application process (i.e. Accept the billing agreement)?


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Did you complete your PayPal Pro application process (i.e. Accept the billing agreement)?

 

Yes I did. I have the EC working, it itemizes everything, and it really feels like I'm close... but not quite there.

 

Any ideas?

Share this post


Link to post
Share on other sites
Yes I did. I have the EC working, it itemizes everything, and it really feels like I'm close... but not quite there.

 

Any ideas?

 

Is it likely that the fact I'm in the UK (though working on a US site) might have an impact? Will my UK credit card get declined for a purchase (even though it's in dollars)?

 

I'm reaching, maybe, but I would love to sit back and have it all ticking over perfectly.

Share this post


Link to post
Share on other sites

As long as it's a Visa, MasterCard, American Express, or Discover, it should work. 15XXX errors usually have something to do with the customer data that's sent. Since you're in the UK, the "State" field in the billing address needs to be written perfectly. You can try contacting PayPal and asking why these transactions are being declined. The exact error you're receiving has this note: "The transaction was declined by the issuing bank, not PayPal. The merchant should attempt another card"


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
As long as it's a Visa, MasterCard, American Express, or Discover, it should work. 15XXX errors usually have something to do with the customer data that's sent. Since you're in the UK, the "State" field in the billing address needs to be written perfectly. You can try contacting PayPal and asking why these transactions are being declined. The exact error you're receiving has this note: "The transaction was declined by the issuing bank, not PayPal. The merchant should attempt another card"

 

Ok so I really am inching closer. Thanks Brian, I'll try another card.

Share this post


Link to post
Share on other sites
Ok so I really am inching closer. Thanks Brian, I'll try another card.

 

And it worked perfectly - processed and everything! Thanks for the last-minute encouragement, and for the contribution.

Share this post


Link to post
Share on other sites

Not sure. Someone uploaded a fix for SEO URLs, but not sure for which version of that contribution.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Hello,

 

I'm using v0.8.3.2 and have a weird problem with the direct payment option...

 

The checkout process goes through fine & the order gets accepted. However, the transaction does not show up in my paypal account, and my card doesn't get charged.

 

I'm using the "live" option along with my live pem key, live username and live password. The wpp_diagnostics.php script shows everything all good.

 

I'm not getting any error messages at all.

 

Any ideas?

Thanks,

 

-Sean

Edited by SeanLee

Share this post


Link to post
Share on other sites

Set "Declined Cards" to "No".


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Hi, Ive just installed the UK version of this.

 

When I click express checkout I get this. logins etc are correct. Anyone have this? or any ideas how to resolve.

 

"An error occured when we tried to contact PayPal's servers.

 

User authentication failed"

 

Dump

 

In function: ec_step1()

Value List: CURRENCY=GBP&LOCALECODE=US&ADDROVERRIDE=1&SHIPTOSTREET=address1
&SHIPTOSTREET2=&SHIPTOCITY=City&SHIPTOZIP=PostCode
&SHIPTOSTATE=&SHIPTOCOUNTRY=GB&ACTION=S&AMT=32.98&RETURNURL=http://www.ur.co.uk/directory/ec_process.php&CANCELURL[75]=http://www.
url.co.uk/directory/shopping_cart.php?ec_cancel=1&TENDER=P&TRXTY
PE=S&PARTNER=PayPalUK&VENDOR=<<merchant>>&USER=&PWD=<<Password>>

Response:
Array
(
[RESULT] => 1
[RESPMSG] => User authentication failed
)

Edited by Pilly

Share this post


Link to post
Share on other sites

Sounds like you don't have the correct username/password entered.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Otherwise, I have no idea. That's a version of this contribution modified by PayPal, so it'd probably be a better idea to ask them.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Dear Brian,

 

I hope you can help.

 

We have been using your contribution for a month or so without a glitch - processed hundreds of direct payment transaction and are very happy with the result.

 

A couple of days ago with absolutely no change whatsoever in our settings a new error has started to appear in the form of an Error Dump. The error is not always present we still process cards successfully but now get the error at least 3 times a day or so.

 

It relates to to the Transactionsearch portion of the transaction - for some reason it seems like there is a problem and because of that the customer is then informed that there is a problem and the transaction fails.

 

We emailed Paypal and gave them the correlation IDs of the transactions and they confirmed that each time it was to do with a TransactionSearch request. They suggested that maybe our PEAR modules are not installed properly ?

 

I checked the TransactionSearch.XML file and it is as you wrote it - bug free not a syntax error in sight.

 

Anyway Here is a copy of the dump you might have a better idea of what is going on here:

(dump is below... but before the dump another quick question if I may.. is it normal that the error dumps generated by your contrib are always very badly formatted with obvious chuncks missing ? look for yourself below at the raw dump)

 

Thanks again for your help and FANTASTIC contrib.

 

------------------------------------------

 

 

In function: before_process() - Direct Payment

Did first contact attempt return error? Nope

---------------------------------------------------------------------

-------------------------------DP_DUMP-------------------------------

------------This is the information that was sent to PayPal----------

---------------------------------------------------------------------

---------------------------------------------------------------------

-------------------------------FINAL_REQ-----------------------------

-------------------This is the response from PayPal------------------

---------------------------------------------------------------------

Array

(

[security] =>

[RequesterCredentials] => Array

(

[0] => Array

(

[Credentials] => Array

(

[0] => Array

(

[username] => contactXXXXXXXXXXXX.com

[Password] => XXXXXXXXXXXX

[subject] =>

)

 

)

 

)

 

)

 

[faultcode] => SOAP-ENV:Client

[faultstring] => XML syntax error

)

 

 

---------------------------------------------------------------------

---------------------------------TS_REQ------------------------------

--------Results of the transaction search if it was executed---------

---------------------------------------------------------------------

Array

(

[security] =>

[RequesterCredentials] => Array

(

[0] => Array

(

[Credentials] => Array

(

[0] => Array

(

[username] =>

[Password] =>

[subject] =>

)

 

)

 

)

 

)

 

[TransactionSearchResponse] => Array

(

[0] => Array

(

[Timestamp] => 2007-02-09T15:10:18Z

[Ack] => Success

[CorrelationID] => 23b5542f3d854

[Version] => 2.000000

[build] => 1.0006

)

 

)

 

)

Share this post


Link to post
Share on other sites

Another one of my clients has been having a simliar problem today and yesterday. Paypal has either flubbed another software update or they're having server load issues.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Another one of my clients has been having a simliar problem today and yesterday. Paypal has either flubbed another software update or they're having server load issues.

 

 

Brian,

 

Do you think disabling the TransactionSearch function will have seriously adverse problems ? We must have lost at least 20 transaction in the last week because of this.

 

Can you please tell me why it would need to be used otherwise ? If it is to prevent double charges then we can do without it I suppose all we'll have to do is reimburse customers - we even have a button on the confirmation page that can only be pressed once anyway...

Share this post


Link to post
Share on other sites

The transaction search is only activated if the module didn't receive a response from PayPal. Unless PayPal has altered their API within the last few days, this isn't something that I can fix.

 

Let me preface that by saying that the transaction search doesn't charge/cancel orders. It simply asks PayPal if a matching transaction occurred.

Edited by dynamoeffects

Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Actually, looking a little closer at that error message, looks like they may have changed their API this week. I'll look into it.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Actually, looking a little closer at that error message, looks like they may have changed their API this week. I'll look into it.

 

Do you think this could be a reason I was getting the 10525 Invalid data error when testing the Beta Version of this module the last couple days?

Share this post


Link to post
Share on other sites

No, that was a bug in the beta.

 

My client said, "I have PayPal working on it for me also. It's not happening with everyone. only a small percentage." So if you're having problems that sprung up in the last day or so, talk to PayPal.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
The transaction search is only activated if the module didn't receive a response from PayPal. Unless PayPal has altered their API within the last few days, this isn't something that I can fix.

 

Let me preface that by saying that the transaction search doesn't charge/cancel orders. It simply asks PayPal if a matching transaction occurred.

 

 

Brian,

 

It certainly has an adverse effect though as in 3 or 4 occasions when this happened we were lucky enough to receive a call from the actual customer trying to go through the transaction saying that their Card was not accepted or something to that effect...

 

So we processed the card manually for them...

 

I just wish I can reproduce the error myself to see exactly what sort of message these customers seem to get so that I alter the message accordingly.

 

Everytime I try a live transaction, it goes through Ok... and so are at least around 50 other customers every day but those 4 or 5 who are lucky/unlucky enough to get this must be doing something specific to cause this problem - I understand from your post that it could be because of a timeout...... is there a timeout variable in your code one can alter and reduce to very little to see if I can reproduce the error myself ?

 

Thanks

Share this post


Link to post
Share on other sites

If it's only 10%, sounds more like the customer isn't entering their correct address or entering it incorrectly.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
If it's only 10%, sounds more like the customer isn't entering their correct address or entering it incorrectly.

 

It's not really as I checked their details and all is well.. we only allow purchases with accounts and the address is most certainly not the culprit this time

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×