Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

Hi everybody,

 

I've just installed this contribution and I'm getting this error message:

 

Fatal error: Cannot redeclare tep_show_category() (previously declared in /home/allurear/public_html/includes/header.php:178) in /home/allurear/public_html/includes/boxes/categories.php on line 13

 

I was looking in this forum and I didn't figure out what to do. If someone

can please help me it would be great.

 

Thanks

Share this post


Link to post
Share on other sites
according to ny state: publication 718...

 

"Reporting codes, rather than ZIP codes, should be

used for identifying customer location. (Postal zones

usually do not coincide with political boundaries, and

the use of ZIP codes for tax collection results in a high

degree of inaccurate tax reporting.)"

 

modify for new york counties and use any one of these contributions

some mods for tax by county

(i used the ohio one- removing all ohio data and plugging in the 80 or so NY counties)

 

I knew about using zip codes for taxes, but it was all I saw & so it seemed the best current solution. Thanks for the heads-up. I now have the Ohio version converted & working properly for NYS.

 

HOWEVER... the problem with (not) taxing shipping still exists. AND I was incorrect in that tax on shipping is never charged with this module via either PP Express or Direct Payment. How are you charging tax on shipping? Or are you?

see page 22

http://www.tax.state.ny.us/pdf/publication.../pub750_804.pdf

 

dynamoeffects: do you have any guidance on this? checkout_confirmation.php near the end of a purchase shows the tax applied correctly (tax is applied to the sum of sub-total + shipping), but the data sent to PP bypasses this and the shipping isn't included in the tax calc. This both undercharges the customer and also causes OSC order totals to not match actual customer charges.

Share this post


Link to post
Share on other sites
2.) I recently noticed a problem on the checkout_payment.php page (I think it's always been like this I just never noticed). After choosing paypal express button, logging into paypal and then hitting 'Review Payment' it brings me back to my site and the shipping page. When i then go to the payment page it only shows the words 'Products Ordered (Edit)' and 'Add Comments About Your Order' and then the comment field and continue button. It does not show the cart contents or the coupon field (I have ccgv installed so i'd like to use this page rather than skipping it via the setting in admin).

 

Any thoughts on what I can look for on the checkout_payment.php page that is not populating the cart and not showing the coupon field?

 

Thanks!

Hello again. I was hoping someone had some thoughts about the problem above.

 

I'm assuming something is off with and if statement so it's not showing the gift voucher section on checkout_payment, but I can't find where that would be. And I can't figure out at all why nothing shows in the cart. The page works just fine for non-paypal express people.

 

Thank you again.

 

Regards,

 

-- Josh

Share this post


Link to post
Share on other sites

I have 0.7 version installed. Presently, the module is not forwarding the order number or the phone number. I have read through this forum, but haven't found mention of this anywhere.

 

The issue has really to do with using paypal to print shipping labels, especially with their new multi order shipping feature. So I need the order number to appear on the shipping labels, which I guess would happen since the multi order shipping feature shows a column for order number.

 

So which version of this module forwards the order number over to payal?

Share this post


Link to post
Share on other sites

Hello,

 

I am currently using the Paypal direct payments contribution. everything works great, the only thing is that the credit card numbers are not coming over to my mysql database, i am getting hte first 4 numbers, xxxx, xxxx and the last 4. how do i get all 16 numbers? -- that is the only way i can call the credit card companies and verify questionable information.

 

Thank you,

Share this post


Link to post
Share on other sites

Every time I try to process a payment, I get an error after the checkout confirmation page. If I'm doing a Direct Payment transaction (typing in a card number), I get this error:

 

Your credit card was declined. Please try another card or contact your bank for more info.

 

No response from PayPal

No response was received from PayPal. Please contact the store owner for assistance.

 

And if I'm doing an Express Checkout transaction, I go to the PayPal site and get returned back to my site. The message "You're currently checking out with PayPal Express Checkout!" shows up, then I click on the Continue button and get sent to the confirmation page. When I click on the Confirm Order button, I get this error:

 

Your credit card was declined. Please try another card or contact your bank for more info.

 

No response from the payment processor

No response was received from the payment processor. Please contact the store owner for assistance.

 

I've run the Diagnostics script, and it says everything is perfect -- even the Advanced Diagnostics section is all YES, YES, YES. I've double-checked all of the code, re-installed the pertinent PHP files, and still I get these errors every time. My certificate is in the correct place, I verified the API username and password, and everything seems right.

 

I get a debug e-mail, and it says:

 

In function: before_process() - Direct Payment Did first contact attempt return error? Nope

---------------------------------------------------------------------

-------------------------------DP_DUMP-------------------------------

------------This is the information that was sent to PayPal----------

---------------------------------------------------------------------

---------------------------------------------------------------------

-------------------------------FINAL_REQ-----------------------------

-------------------This is the response from PayPal------------------

---------------------------------------------------------------------

Array

(

[security] =>

[RequesterCredentials] => Array

(

[0] => Array

(

[Credentials] => Array

(

[0] => Array

(

[username] => xxxxxxxxxxxxxxxxx

[Password] => xxxxxxxxxxxxxxxxx

[subject] =>

)

 

)

 

)

 

)

 

[faultcode] => SOAP-ENV:Client

[faultstring] => Data type '' mismatch in element 'PaymentAction'

)

 

 

---------------------------------------------------------------------

---------------------------------TS_REQ------------------------------

--------Results of the transaction search if it was executed---------

---------------------------------------------------------------------

Array

(

[security] =>

[RequesterCredentials] => Array

(

[0] => Array

(

[Credentials] => Array

(

[0] => Array

(

[username] =>

[Password] =>

[subject] =>

)

 

)

 

)

 

)

 

[TransactionSearchResponse] => Array

(

[0] => Array

(

[Timestamp] => 2006-12-21T06:46:29Z

[Ack] => Success

[CorrelationID] => 931e39d497542

[Version] => 2.000000

[build] => 1.0006

)

 

)

 

)

 

Any ideas?

 

 

 

 

Any ideas?

Edited by wheeloftime

Share this post


Link to post
Share on other sites

Regarding my previous post...

 

The problem was that the MODULE_PAYMENT_PAYPAL_DP_PAYMENT_ACTION field did not exist in the Configuration database table. I believe that I must have had an older version of this module installed, then copied all of the new PHP files over. I un-installed the module via the Admin page, then re-installed it and it worked perfectly.

 

One tiny thing... I noticed that in the e-mails I receive once an order is placed, it always shows the payment method as "PayPal Direct Payment", even if I use the Express Checkout transaction method. No big deal, but I'm wondering if it's supposed to be that way?

 

Rob

Share this post


Link to post
Share on other sites
Hello again. I was hoping someone had some thoughts about the problem above.

 

I'm assuming something is off with and if statement so it's not showing the gift voucher section on checkout_payment, but I can't find where that would be. And I can't figure out at all why nothing shows in the cart. The page works just fine for non-paypal express people.

Make sure that valid coupons exist, otherwise the box hides itself. If the cart's emptying itself, that's a session issue.

 

I have 0.7 version installed. Presently, the module is not forwarding the order number or the phone number. I have read through this forum, but haven't found mention of this anywhere.

 

The issue has really to do with using paypal to print shipping labels, especially with their new multi order shipping feature. So I need the order number to appear on the shipping labels, which I guess would happen since the multi order shipping feature shows a column for order number.

 

So which version of this module forwards the order number over to payal?

Only 0.8+ versions add the phone number to the payment information. No version sends the order number as that's not generated until after the payment module has run.

 

Hello,

 

I am currently using the Paypal direct payments contribution. everything works great, the only thing is that the credit card numbers are not coming over to my mysql database, i am getting hte first 4 numbers, xxxx, xxxx and the last 4. how do i get all 16 numbers? -- that is the only way i can call the credit card companies and verify questionable information.

 

Change this line:

$order->info['cc_number'] = substr($cc_number, 0, 4) . str_repeat('X', (strlen($cc_number) - 8)) . substr($cc_number, -4);

 

To this:

$order->info['cc_number'] = $cc_number;


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Make sure that valid coupons exist, otherwise the box hides itself. If the cart's emptying itself, that's a session issue.

Hi. I have several active coupons, all of which work perfectly (for non paypal express people). But as soon as I try ppl xpress the field is gone from the payments page.

 

For the cart, it's not actually emptying because if you then go to the next page (checkout_confirmation) everything in the cart looks just fine. The payments page looks like it's showing the words "Products Ordered (Edit)", but just not the actual cart contents field.

 

Thanks again for your help!

 

-- Josh

Share this post


Link to post
Share on other sites

In that case, the code that hides the payment options is wrapped around the coupon box. You'll need to edit the code and find where it's wrapped around.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
In that case, the code that hides the payment options is wrapped around the coupon box. You'll need to edit the code and find where it's wrapped around.

Hello again! After looking at it over and over I finally found the error with the coupon box. I had moved it's location on the page and when I put it back I must have missed some of the code and it interfered with the module for paypal users.

 

So it's now back on the payment screen even for customers using express c/o.

 

Any thoughts on how to investigate the cart issue?

 

Thanks again!

 

-- Josh

Share this post


Link to post
Share on other sites
This is the support thread for the PayPal Direct Payments & Express Checkout module. Please post any bugs or errors you see while using it so that they can be fixed.

 

The contribution can be found here:

http://www.oscommerce.com/community/contributions,3647

 

I am building a website for my client, and they are concerned about putting their paypal username and password in the admin panel. Are there any security concerns? Why arn't they encrypted?

 

Is the api username and password the same as the regular username and password.

 

Please confirm

Share this post


Link to post
Share on other sites
I am building a website for my client, and they are concerned about putting their paypal username and password in the admin panel. Are there any security concerns? Why arn't they encrypted?

 

Is the api username and password the same as the regular username and password.

 

Please confirm

 

 

Whats is cURL and how do i install it?

Share this post


Link to post
Share on other sites
I am building a website for my client, and they are concerned about putting their paypal username and password in the admin panel. Are there any security concerns? Why arn't they encrypted?

 

Is the api username and password the same as the regular username and password.

 

Please confirm

 

No. The API username and password are used only to access the APIs. The username is based on your PayPal username, but the password is unique.

 

 

Whats is cURL and how do i install it?

 

cURL is a Unix application that allows other applications to access internet protocols by sending a URI (uniform resource identifier) and processing the results, without requiring the calling application to re-implement all the underlying code.

 

Most hosting services will have this installed already. I'm fairly certain that it is a standard part of most Linux distributions, so if you're running your own Linux host, check the man pages. If you are hosting your site on Windows, there should be a Windows equivalent.

 

--Glen

Share this post


Link to post
Share on other sites

On the subject of SOLO/SWITCH/MAESTRO cards..

 

This is the Paypal integration guide PDF that lists all the params needed to implement among other things SWITCH/SOLO cards in WPP. Mainly the addition of : CARDISSUE (issue number for solo/switch) and CARDSTART (start date) and possibly ACCTTYPE (card type)

 

I hope this is useful to the developers so we can have these (important) cards added to this module and make it complete

 

To view the PDF please go to :

 

https://www.paypal.com/en_GB/pdf/PP_Website...rationGuide.pdf

 

Unfortunately no matter how good this module is , for us poor chaps in the UK not having support for these cards makes it incomplete as buyers expect to have these cards accepted and would complain if they are not.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I am fairly news to OSC and just installed the Payments Pro system.

 

Everything works except the "express checkout" button allows you to login to your account, then throws an

 

(10428)

Handling total is invalid.

 

Is there an easy fix for this. Ive spent my afternoon reading through this topic and its fixed 99.99% of my issues. Your contributors and users are excellent.

 

The Store is located at http://SOLOshirts.com/store

 

Please help ASAP, we want to set this store live today! thanks sooooo much for any help.

 

Matt

SBNhosting.com

Share this post


Link to post
Share on other sites

The actual message it gives is:

 

Transaction refused because of an invalid argument. See additional error messages for details. (10428)

Handling total is invalid.

 

I just re-tested the standard paypal pament (not express) and it works like a CHARM! Incredible contribution!! I even gave it some false info to test its use of the CCV and shipping info.. its PERFECT!

 

Please let me know where to look to fix the above issue

Thanks sooooooo much!

Share this post


Link to post
Share on other sites

I'm confused.

 

When I go to PayPal to download the API certificate, do I choose the "API Signature" option or the "API SSL Client Side Certificate" option? Which one is required for this module, and what is the difference?

Share this post


Link to post
Share on other sites

You want the Downloadable "API SSL Client Side Certificate".

 

You will choose to download it, and then you want to upload it to your /catalog/includes/modules/payment/wpp_cert/ folder.

 

Make sure you add the API username and password to your OSC Admin area in the modules/pay area.

 

It works 100% perfect for me except the above posted issue.

Share this post


Link to post
Share on other sites
You want the Downloadable "API SSL Client Side Certificate".

 

You will choose to download it, and then you want to upload it to your /catalog/includes/modules/payment/wpp_cert/ folder.

 

Make sure you add the API username and password to your OSC Admin area in the modules/pay area.

 

It works 100% perfect for me except the above posted issue.

Thanks. That's the one I downloaded, luckily. I just wanted to make sure that was the right one before attempting to install this module. I'm sure I'll run into enough problems given my incredibly novice PHP and API knowledge, so the last thing I needed was worrying if I downloaded the proper certificate. :blush:

Edited by nibl69

Share this post


Link to post
Share on other sites

OK guys, I'm giving this a shot - uploaded all the new files (v0.8.2), modified all the files that were already present, and I can't even get to step 1 - for some reason the module won't show up under Admin.

The only part of the instructions I haven't followed is uploading the cert - because frankly I don't want to pay for one unless I'm pretty sure I can get the thing to work (I'm assuming I should still be able to see the module, but get an error about the cert - right?)

And right now there's no option under the cart or checkout options for PayPal Express or for credit cards - only the old PayPal (non-pro) option - I'm assuming because I have to turn the new one on.

Can anybody give me an idea why the admin section wouldn't even be seeing the module?

(Another oddity - if I just plain delete the old paypal.php from /includes/modules/payment the admin panel still sees it? What am I missing??)

Thanks!

Share this post


Link to post
Share on other sites

Ive got a portion of the dump created by paypal_wpp.php

 

This is where I believe the "handling error" is coming from:

 

<OrderTotal currencyID="USD">74.85</OrderTotal>

<OrderDescription>Order placed on December 28, 2006, 10:32 am by Matthew Morey (ID: 4)</OrderDescription>

<ItemTotal currencyID="USD">74.85</ItemTotal>

<ShippingTotal currencyID="USD">0</ShippingTotal>

<HandlingTotal currencyID="USD">PAYPAL_HANDLING_TOTAL</HandlingTotal>

<TaxTotal currencyID="USD">0</TaxTotal>

 

Do you see on the next to last line that the "PAYPAL_HANDLING_TOTAL" isnt a real value? How do I fix?

Share this post


Link to post
Share on other sites
Ive got a portion of the dump created by paypal_wpp.php

 

This is where I believe the "handling error" is coming from:

 

<OrderTotal currencyID="USD">74.85</OrderTotal>

<OrderDescription>Order placed on December 28, 2006, 10:32 am by Matthew Morey (ID: 4)</OrderDescription>

<ItemTotal currencyID="USD">74.85</ItemTotal>

<ShippingTotal currencyID="USD">0</ShippingTotal>

<HandlingTotal currencyID="USD">PAYPAL_HANDLING_TOTAL</HandlingTotal>

<TaxTotal currencyID="USD">0</TaxTotal>

 

Do you see on the next to last line that the "PAYPAL_HANDLING_TOTAL" isnt a real value? How do I fix?

 

 

I made a quick temp solution, not sure what it will break, but its allowing the express transaction to go through.

 

In the doExpressCheckout.xml file, where it has "PAYPAL_HANDLING_TOTAL" I changed this to "0" and its working. What exactly will this change do to me in the long run?

Share this post


Link to post
Share on other sites

@netcommerce: To address your security concerns, even though Glen already answered you well, your client shouldn't worry. The most that someone would be able to do with the API username/password would be to add money to your client's paypal account or view past transactions. More than anything, if an attacker has access to your client's admin and/or database, you have far more pressing issues to worry about.

 

@Shadoglare: Sounds like you have more than one installation of osCommerce, and you're modifying the wrong one.

 

@SBNhosting.com: That change won't affect anything as long as you don't have handling fees.

Edited by dynamoeffects

Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
@Shadoglare: Sounds like you have more than one installation of osCommerce, and you're modifying the wrong one.

 

Yup - it struck me while I was at work today - I'm using a test install of the store in a separate directory, and I forgot to update the file paths in the admin config file :blush:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×