Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

In that case, you must contact PayPal and ask them why they are declining those specific transactions. 10417 is notorious and seemingly random.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Several weeks ago I successfully implemented your 0.7.3 version of this module and it worked perfectly. I am going to return to that and install it to see if that makes any difference. If it works, I will re-install your latest version to eliminate any installation mistakes on my behalf. If you're interested, I will post my results some time in the next day or two.

Share this post


Link to post
Share on other sites

Thanks for the great contribution.

 

I've managed to succefully install the Paypal Pro module. However, I would like to take it one step further and integrate the look of the second "acceptance mark" option. Something close to what paypal has on their website...

 

https://www.paypal.com/IntegrationCenter/ic...elines-pro.html

 

I'm hoping that someone (Dynamo?) can point me in the right direction, or provide sample code that I could use to display the payment options as outlined by paypal for the acceptance mark option?

 

Cheers!

Share this post


Link to post
Share on other sites
Several weeks ago I successfully implemented your 0.7.3 version of this module and it worked perfectly. I am going to return to that and install it to see if that makes any difference. If it works, I will re-install your latest version to eliminate any installation mistakes on my behalf. If you're interested, I will post my results some time in the next day or two.

 

If you find a solution, I'd love to know. Back when I received the 10417 error, it was because I was using 4111111111111111 as a test number in the sandbox.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
sal2006: You have another file in your includes/modules/payment directory that uses the class name "paypal_wpp." Do you have pbreit's installed as well?

 

Thanks for replying..

 

I don't have pbreit's installed.. currently I have a problem with saving the information in my admin/payment module I enter the paypal information and click on update and nothing saves!!!!

 

please help

Share this post


Link to post
Share on other sites
If you find a solution, I'd love to know. Back when I received the 10417 error, it was because I was using 4111111111111111 as a test number in the sandbox.

 

Well as it turns out, when I implemented the two table change statements during the install process, they didn't take. For whatever reason I have no idea. But, once I ran them again and checked my database to make sure they stuck, everything worked fine. Interesting though the error that was returned. I was just about to contact Paypal about it and see what was up but I ALWAYS go back through my installation first because I more often than not find mistakes. And seeing how I was able to successfully implement one of your older modules, I knew it had to be something stupid. Hope this helps others who run into the same 'problem'...or inadvertently make the same mistake.

Share this post


Link to post
Share on other sites

I wanted to make the transactions not go through with paypal until I gave it the final ok. Mostly because we may not have the inventory in stock that a customer just ordered. I made 3 small changes to make this possible.

 

In /catalog/includes/modules/payment/paypal_wpp.php

 

around line 299 find line:

$data['PAYPAL_PAYMENT_ACTION'] = 'Sale';

 

replace with:

$data['PAYPAL_PAYMENT_ACTION'] = MODULE_PAYMENT_PAYPAL_DP_PAYMENT_ACTION;

 

 

around line 1308 after line:

tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, use_function, date_added) values ('Set Order Status', 'MODULE_PAYMENT_PAYPAL_DP_ORDER_STATUS_ID', '0', 'Set the status of orders made with this payment module to this value', '6', '14', 'tep_cfg_pull_down_order_statuses(', 'tep_get_order_status_name', now())");

 

insert line:

tep_db_query("insert into " . TABLE_CONFIGURATION . " (configuration_title, configuration_key, configuration_value, configuration_description, configuration_group_id, sort_order, set_function, date_added) values ('Payment Action', 'MODULE_PAYMENT_PAYPAL_DP_PAYMENT_ACTION', 'Authorization', 'Sale or Authorization (Capture later)?', '6', '15', 'tep_cfg_select_option(array(\'Sale\', \'Authorization\'), ', now())");

 

 

around line 1315 at end of function:

function keys()

 

append at end of array:

, 'MODULE_PAYMENT_PAYPAL_DP_PAYMENT_ACTION'

 

 

Some other paypal contribution I installed a while ago had this configuration variable, so this is not my original idea or contribution.

Share this post


Link to post
Share on other sites
On both direct payment and express checkout?

 

I installed the version put up on Octover 11 2006 - 0.8.1 and I also received an Error after checking out through Express Checkout when I was redirected back to checkout_shipping.php page:

 

An error occured when we tried to process your credit card.

Transaction refused because of an invalid argument. See additional error messages for details. (10428)

Handling total is invalid.

 

 

Direct payments worked just fine for me.

BTW, this is a great contribution!

Share this post


Link to post
Share on other sites

Whoops, there is definitely a bug there. The before_process() function is almost a complete rewritten from 0.7.3 and I was sure it would introduce a few bugs.

 

A new version of the module has been uploaded. If you have 0.8.1 installed, just uninstall the current module in the admin, upload the new one (/catalog/includes/modules/payment/paypal_wpp.php), install it, and reconfigure. No other files have been changed.

 

I've also implemented the Sale/Authorization change you mentioned above and fixed a tiny bug in the email that's sent to the store owner after a failed transaction where it would say the total was $0.00.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Whoops, there is definitely a bug there. The before_process() function is almost a complete rewritten from 0.7.3 and I was sure it would introduce a few bugs.

 

A new version of the module has been uploaded. If you have 0.8.1 installed, just uninstall the current module in the admin, upload the new one (/catalog/includes/modules/payment/paypal_wpp.php), install it, and reconfigure. No other files have been changed.

 

I've also implemented the Sale/Authorization change you mentioned above and fixed a tiny bug in the email that's sent to the store owner after a failed transaction where it would say the total was $0.00.

 

Upgraded to 0.8.2

ran a transaction through Express Checkout

was redirected to checkout_shipping.php w/ this error:

 

An error occured when we tried to process your credit card.

 

Transaction refused because of an invalid argument. See additional error messages for details. (10423)

This transaction cannot be completed with PaymentAction of Authorization.

 

 

The PayPal API gives this explanation for error 10423:

 

This error occurs if at Integration Point 1, you set PaymentAction to Sale with SetExpressCheckoutRequest but at Integration Point 3, you set PaymentAction to Authorization with DoExpress Checkout Payment. PayPal does not allow this switch from Sale to Authorization in a single checkout session. PayPal does allow the reverse, however. You can set PaymentAction to Authorization with SetExpress Checkout at Integration Point 1 and switch PaymentAction to Sale with DoExpress Checkout Payment at Integration Point 3.

 

Hmmm... I have Authorization set as the Payment Action for the Configuration Options and I didn't see in the code where the Payment Action was hardcoded to "Sale" in any place. Where in the code does Integration Point 1 take place?

Share this post


Link to post
Share on other sites

Did you uninstall the module before reinstalling it?


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Did you uninstall the module before reinstalling it?

 

Yes.

- Downloaded 0.8.2 .zip file

- In Administration -> Payment Modules: I uninstalled "PayPal Direct Payment" module

- Replace file /catalog/includes/modules/payment/paypal_wpp.php

with new /catalog/includes/modules/payment/paypal_wpp.php in zip file

- In Administration -> Payment Modules: I installed "PayPal Direct Payment" module

- Put back same settings in module as I had before

Share this post


Link to post
Share on other sites

Im trying to setup Express Checkout here but my site seem to be problematic in some way. I tried different directory, different files(brand new one) and skinned one i get the same frozen thingy. As i click "CheckOutWithPaypal" aKa express checkout, it prompted a download for ec_process.php and thats it. Page stays where it is. Can anyone find a way to solve this? Im willing to offer wages! Please help.

 

http://www.mcg12.com/

Share this post


Link to post
Share on other sites

Hi all,

 

I Think there is a bug in version 0.8.2. The express check out show up and works fine. The direct payment box with credit card with icons and all just disappear. I just got a box with a message that I have no other payment method. I will work on it some more tomorrow and will post the results.

Share this post


Link to post
Share on other sites

@steveosc: Overwrite all of your XML files with the latest ones as well. It's really a mystery why it's behaving like that as I can't get the same behavior.

 

@WickedBoy: Apache isn't setup correctly. Contact your webhost about the problem.

 

@tonyhuvo: Compare your checkout_payment.php file with the one that comes in the zip file.

 

I'll do a complete reinstall of the module when I have time to ensure that I didn't miss something, but because it's working fine on my test site, I'm thinking that these problems have to do with the installation.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Does anyone know how to set OSC to send an "aggregate" total to Paypal?

 

I am trying to use the "Easy Discount" & "Easy Coupon" contributions and the discount/coupon shows in the total at checkout but Paypal charges the full amount.

 

Any ideas on how to get the discounted total to carry over to WPP?

 

If this was to work out, it would be a simple way to give discount codes and even implement the use of gift certificate codes. :thumbsup:

 

TIA!

~Mark

Share this post


Link to post
Share on other sites
@steveosc: Overwrite all of your XML files with the latest ones as well. It's really a mystery why it's behaving like that as I can't get the same behavior.

 

dynamoeffects -

Still haven't gotten "Payment Action: Authorization" to work after overwriting all the xml files in wpp_xml directory.

 

I Tested 4 different scenarios; hope this helps us or someone else with the same problem.

I used my PayPal Sandbox account for receiving payment and each time used Express Checkout w/ a separate verified paypal sandbox account to make the payment:

 

1. Payment Module Settings ->

- Payment Action: Authorization

- Express checkout: Confirmed Address: Yes

After clicking "Confirm Order" returned error 10423

 

2. Payment Module Settings ->

- Payment Action: Sale

- Express checkout: Confirmed Address: Yes

After clicking "Confirm Order" returned error 10417

 

3. Payment Module Settings ->

- Payment Action: Sale

- Express checkout: Confirmed Address: No

After clicking "Confirm Order" I was able to checkout successfully

 

4. Payment Module Settings ->

- Payment Action: Authorization

- Express checkout: Confirmed Address: No

After clicking "Confirm Order" returned error 10423

 

 

Express Checkout and Authorization...? If I figure it out, I'll post it.

Share this post


Link to post
Share on other sites

Steve, open up /catalog/includes/modules/payment/paypal_wpp.php and after these lines:

 

		foreach ($data as $k => $v) {
	  $xml_contents = str_replace($k, $v, $xml_contents);
	}

 

add this line:

if ($type == 'doExpressCheckout') die($xml_contents);

 

It'll dump the formatted XML doc to the screen. Tell me what's between the <PaymentAction></PaymentAction> fields.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

How do!

 

I have a small local hosting company that i have been happy with, however, I think they are lacking the cURL. What excatly do I need to tell them?

This is the error im getting

cURL, which is required by the PayPal Website Payments Pro module, is not present. Please contact your webhost and request that it be installed.

 

Other than that, I followed the directions and all appears to be working ..so far :thumbsup:

Edited by graysonhobby

Share this post


Link to post
Share on other sites
How do!

 

I have a small local hosting company that i have been happy with, however, I think they are lacking the cURL. What excatly do I need to tell them?

 

That you need cURL. They'll know what to do.

 

 

Im sorry but what should i tell my host? Thanks.

 

Exactly what you told me.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Steve, open up /catalog/includes/modules/payment/paypal_wpp.php and after these lines:

 

		foreach ($data as $k => $v) {
	  $xml_contents = str_replace($k, $v, $xml_contents);
	}

 

add this line:

if ($type == 'doExpressCheckout') die($xml_contents);

 

It'll dump the formatted XML doc to the screen. Tell me what's between the <PaymentAction></PaymentAction> fields.

 

It didn't output the xml tags; just the values. Here's what I had, I replaced some values with [] to describe the data. I'm guessing <PaymentAction> is the 4th value - Authorization.

 

[my API Username] [my API Password] 2.0 Authorization EC-[an alphanumeric string] W59[an alphanumeric string] 2.00 Order placed on October 16, 2006, 2:39 pm by [customer first last] (ID: 12) 1 1 0 Phone: -- Email: [customer email address] [customer first last] [customer street address] [customer city state zip] US [product name]{1}16{3}14 ([product model])1

Share this post


Link to post
Share on other sites

If you right click and select "View Source", it'll show you the formatted data.

 

Ah, I think I found the problem. Try doing this:

1. Open /includes/wpp_xml/setExpressCheckout.xml

2. After this line:

<cpp-payflow-color>PAYPAL_CPP_PAYFLOW_COLOR</cpp-payflow-color>

 

add this:

<PaymentAction>PAYPAL_PAYMENT_ACTION</PaymentAction>

 

And tell me what happens.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

I am sorry for the crosspost on this, but I thought the expertise of you all over here, might be able to shed some light, or send me in the right direction.

------------

 

I am having some problems after Installing Extra Info Pages. I have OS Comm 2.2 with WPP payments 0.73, and now extra pages 4.5.

 

After installing the Extra pages, I have that working. But in doing so, my WPP payment module is not working correctly. I keeping getting paypal dump errors emailed to me (since I have debug mode on for emails to me on errors.)

 

This has only occured since I installed the extra pages program. Also, I used to be able to leave a cart with items in it, then go back to my site as a visitor and still have those items in the cart. Now, the cart is empty each time. I am wondering if the two are related?

 

I have learned alot about PHP & SQL, more than I ever wanted to, but it has been fun. Now this has become a real problem because I cannot get my orders. I can't just revert to a backup of a few days ago, because I have other mods installed since then.

 

Any thoughts, or ideas would be helpful. I have gone through the process of installing extra pages, seeing where my problem might be, but I just can't seem to put my finger on it.

 

I am also aware of some changes Paypal has made, but I think this was happening as of the 29th of Sept, before the paypal changes.

 

Thanks!

Paul

 

PS, the site is Pauls Unique Woodworks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×