Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

Hi..

 

I can't get the setopt() error to work..

 

I uploaded pear and set up the path correctly.

my path was:

/home/yh0p2/public_html/pear/

 

Fatal error: Call to undefined function: setopt() in /home/yh0p2/public_html/includes/modules/payment/paypal_wpp.php on line 324 ???

Share this post


Link to post
Share on other sites
Can anyone please help me with this issue? Any suggestions as to what could be causing this would be great. It has turned into a real problem.

 

Thanks for all your time.

 

I have this problem on one of my servers as well. Uninstalled it because I didn't have the time to figure it out. In my case, we were getting triple billed. Not zesty.

 

-jared

Share this post


Link to post
Share on other sites

Are CURL proxy required? any possibilities that it might be causing setopt() error?

 

Also, what is PEAR? is it like a software to installed on the server, or just bunch of files that just needs to be uploaded?

Share this post


Link to post
Share on other sites

A setOpt() error means that your version of PHP doesn't have cURL installed. Contact your hosts about the issue.

 

For those of you with customers getting double billed, I'm not sure what's going on. Try changing this line:

 

$final_req = $caller->DoDirectPayment($ddp_details);

 

to this:

 

$final_req = $caller->DoDirectPayment($ddp_details);
tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, 'PayPal Transaction', $cc_first_name . ' ' . $cc_last_name . "\n\nOccured on:" . date("U"), STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

 

Then try a test transaction. If you get two emails with the dates nearly exact, the module's running twice for some reason. If you get only one, the problem's with the server or PayPal.

Edited by dynamoeffects

Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Also, what is PEAR? is it like a software to installed on the server, or just bunch of files that just needs to be uploaded?

 

They just need to be uploaded to your server. Read the README.html file that's contained in the contribution. It answers all of the basic questions.

 

 

Also, to those of you who have customers getting double billed, post a list of what other contributions you have installed.

Edited by dynamoeffects

Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
They just need to be uploaded to your server. Read the README.html file that's contained in the contribution. It answers all of the basic questions.

Also, to those of you who have customers getting double billed, post a list of what other contributions you have installed.

 

 

Hi dynamo -

 

I only have

STS and Additional shipping installed (http://www.oscommerce.com/community/contributions,1852/page,4)

 

Its weird because when testing in paypals sandbox it works, but live transactions get double billed.

 

Any help to resolve this would be great.

 

Thanks for your time.

Share this post


Link to post
Share on other sites
Any help to resolve this would be great.

 

Look two posts above yours.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
A setOpt() error means that your version of PHP doesn't have cURL installed. Contact your hosts about the issue.

 

For those of you with customers getting double billed, I'm not sure what's going on. Try changing this line:

 

$final_req = $caller->DoDirectPayment($ddp_details);

 

to this:

 

$final_req = $caller->DoDirectPayment($ddp_details);
tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, 'PayPal Transaction', $cc_first_name . ' ' . $cc_last_name . "\n\nOccured on:" . date("U"), STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS);

 

Then try a test transaction. If you get two emails with the dates nearly exact, the module's running twice for some reason. If you get only one, the problem's with the server or PayPal.

 

Hi Dynamo - I tried changing the code above I received two emails.

 

1 Confirming my order

2 This email looks like a paypal passback variable "test account Occured on:1143624131"

 

The test Payment was sent to my sandbox account fine. Seems to only be on live transactions.

 

Any suggestions?

Share this post


Link to post
Share on other sites

Hey Newbie here.

 

Here is my problem:This is with Paypal sandbox settings with paypal_wpp_0.7.3.

 

When clicking on "Check Out with Paypal" button, every thing goes fine until I'm back to my shop site to confirm the order this message comes up:

 

Error Your credit card was declined. Please try another card or contact your bank for more info.

 

No response from the payment processor

No response was received from the payment processor. Please contact the store owner for assistance.

 

It is very strange since it is for Paypal transaction and not a credit card one. Why this error comes up is a mystery. On the other hand the credit card payment seems to work fine with the sandbox settings.

 

Any help would be appreciated.

Regards,

TK

Share this post


Link to post
Share on other sites

Second question which may or may not do with my above first question.

 

When choosing a product, the very first "Check out with Palpay" button seems to be directed to a different link compared to the "Check out with Paypay" buttons that appear later in the check out process. (my first question is regards to the buttons in the later check out process)

When clicking the very first Check out with Paypal button, the following error message appears.

 

(2060) Unable to locate cURL binary (MODULE_PAYMENT_PAYPAL_EC_CURL_PATH).

 

How can I solve this problem?

Any help is much appreciated.

Regards,

TK

Share this post


Link to post
Share on other sites

Hi Dynamo,

 

My orders are messed up. They are in the database, but they aren't listed in Administration Area > Orders (0 of 0 orders). They aren't even displayed in my previous orders under my account. It says 0 of 0 orders, and the pagination goes like: -4, -3, -2, -1, 0.

 

Any ideas about this?

Share this post


Link to post
Share on other sites
I appreciate the response. I have already contacted GoDaddy and made the recommended changes. I was able to test the pear functionality sucessfully. Still no luck. Any ideas?
Mike,

 

I worked through the same problem a while back. Here is a link to my post on the solution for using this contrib with godaddy:

 

GoDaddy proxy settings with WPP contrib

 

HTH

Sean


-----------------

Sean Johnson

Share this post


Link to post
Share on other sites
A setOpt() error means that your version of PHP doesn't have cURL installed. Contact your hosts about the issue.

 

I created a file called curltest.php:

<?php
if (function_exists('curl_exec')) {
$curl_message = '<br>cURL has been <b>DETECTED</b> in your system';
} else {
$curl_message = '<br>cURL has <b>NOT</b> been <b>DETECTED</b> in your system';
}

echo $curl_message;
?>

When I ran it, it detected cURL. This would indicate that all path and proxy settings are correct, right?

Is there something else I could try?

Share this post


Link to post
Share on other sites
I have this problem on one of my servers as well. Uninstalled it because I didn't have the time to figure it out. In my case, we were getting triple billed. Not zesty.

 

-jared

 

 

I just found out my customers are also getting billed twice, this is a serious issue as customers don't know they are being double charged.

 

Can anyone suggest what might cause this, or what to check?

 

Regards,

J Adams

Share this post


Link to post
Share on other sites

I guess I should ask before I assume anything - does this module incorporate any IPN features? I mean, does it update the order status automatically for chargebacks etc?

 

Also, is this double billing problem happening to everybody or is it isolated to people who have certain mods running along side it?

Edited by ATeschner

Share this post


Link to post
Share on other sites
Also, is this double billing problem happening to everybody or is it isolated to people who have certain mods running along side it?

I have installed this module on two stores of mine as well as three other store for my clients. I have never experienced this double billing issue. I used the 7.1 version of this module and did not have the time to update to 7.3. But the 7.1 is working just fine for me.

Good luck.


Regards,

Share this post


Link to post
Share on other sites

Is it true, only 60% of the orders goes through?

 

Also, my host claims that he doesnt have a proxy set up for curl, and I still get the setopt() error.

Share this post


Link to post
Share on other sites

paypal_wpp.php
line 324:
if (trim(MODULE_PAYMENT_PAYPAL_DP_PROXY) != '') {
$caller->setOpt('curl', CURLOPT_PROXYTYPE, CURLPROXY_HTTP);
$caller->setOpt('curl', CURLOPT_PROXY,
MODULE_PAYMENT_PAYPAL_DP_PROXY);
}

 

Can we remove this part? if our host doesnt use proxy for curl

Share this post


Link to post
Share on other sites
paypal_wpp.php
line 324:
if (trim(MODULE_PAYMENT_PAYPAL_DP_PROXY) != '') {
$caller->setOpt('curl', CURLOPT_PROXYTYPE, CURLPROXY_HTTP);
$caller->setOpt('curl', CURLOPT_PROXY,
MODULE_PAYMENT_PAYPAL_DP_PROXY);
}

 

Can we remove this part? if our host doesnt use proxy for curl

 

If you don't enter a value for the proxy in the module's configuration page, it doesn't get executed, so it shouldn't matter.

Share this post


Link to post
Share on other sites
Dear forum,

I have spent days searching for answers for my seemengly simple problem but could not find any.

I have installed and configured 0.71 according to the instructions.

I currently have a credit card, paypal and money order payement modules installed.

In my understanding once direct payment is enabled, on checkout_payment I should see yet another form of payment similar to my credit card. Problem #1 - I see no extra payment options, but my pre-existing ones. Problem #2 - if I choose express checkout instead - so after successfully going through PayPal sandbox I get back to the site where I am directed to checkout_payment page with error in red displayed "Please select a payment method for your order". Debug is enabled and no emails have been received.

What do I do wrong?

 

Thanks again

 

I continued to troubleshoot it further. I am one step before starting to debug the actual code.

I still cannot make it to work. What I tried is as following:

1. did not merge the files, but rather copied them as is from 0.71 package to my catalog dir - no luck

2. merged the files - no luck

3. suspecting problems with my site config , I installed standard oscommerse soft from their website and then applied the 0.71 with no merge - no luck

 

There must be something basic that I miss.

What module is responsible to include direct payment on the checkout_payment page?

 

here are the steps that I perform in nutshell again:

1. copy 0.7 to my catalog dir

2. update sql using .sql file

3. copy pear to catalog dir

4. copy certificate from my paypal sandbox

5. install the direct payment module providing my sandbox certificate username and password, enable debug

 

 

Curl must be working, cause clicking on express checkout brings me to paypal and then succsessfully brings me back.

 

Please let me know what do I miss

Share this post


Link to post
Share on other sites
Second question which may or may not do with my above first question.

 

When choosing a product, the very first "Check out with Palpay" button seems to be directed to a different link compared to the "Check out with Paypay" buttons that appear later in the check out process. (my first question is regards to the buttons in the later check out process)

When clicking the very first Check out with Paypal button, the following error message appears.

 

(2060) Unable to locate cURL binary (MODULE_PAYMENT_PAYPAL_EC_CURL_PATH).

 

How can I solve this problem?

Any help is much appreciated.

Regards,

TK

 

You're using pbreit's payment module. Do a search for his support thread.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Hi Dynamo - I tried changing the code above I received two emails.

 

1 Confirming my order

2 This email looks like a paypal passback variable "test account Occured on:1143624131"

 

The test Payment was sent to my sandbox account fine. Seems to only be on live transactions.

 

Any suggestions?

 

 

What happens when you do a live transaction? One or two emails?


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Hey Newbie here.

 

Here is my problem:This is with Paypal sandbox settings with paypal_wpp_0.7.3.

 

When clicking on "Check Out with Paypal" button, every thing goes fine until I'm back to my shop site to confirm the order this message comes up:

 

Error Your credit card was declined. Please try another card or contact your bank for more info.

 

No response from the payment processor

No response was received from the payment processor. Please contact the store owner for assistance.

 

It is very strange since it is for Paypal transaction and not a credit card one. Why this error comes up is a mystery. On the other hand the credit card payment seems to work fine with the sandbox settings.

 

Any help would be appreciated.

Regards,

TK

 

Did you switch your certificate to the live version?


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Hi Dynamo,

 

My orders are messed up. They are in the database, but they aren't listed in Administration Area > Orders (0 of 0 orders). They aren't even displayed in my previous orders under my account. It says 0 of 0 orders, and the pagination goes like: -4, -3, -2, -1, 0.

 

Any ideas about this?

 

My contribution doesn't touch the orders page or the orders table in the DB, so I don't know why this would be occuring. Make sure your orders table actually has orders in it. If there are none, something else erased them.

 

 

I created a file called curltest.php:

<?php
if (function_exists('curl_exec')) {
$curl_message = '<br>cURL has been <b>DETECTED</b> in your system';
} else {
$curl_message = '<br>cURL has <b>NOT</b> been <b>DETECTED</b> in your system';
}

echo $curl_message;
?>

When I ran it, it detected cURL. This would indicate that all path and proxy settings are correct, right?

Is there something else I could try?

 

Then your host has disabled access to the curl_setopt() function. Ask them if that's the issue.

 

I just found out my customers are also getting billed twice, this is a serious issue as customers don't know they are being double charged.

 

Can anyone suggest what might cause this, or what to check?

 

Regards,

J Adams

 

Add the code that I posted on page 43 and tell me how many emails you receive when doing a live transaction.

 

 

I guess I should ask before I assume anything - does this module incorporate any IPN features? I mean, does it update the order status automatically for chargebacks etc?

 

Also, is this double billing problem happening to everybody or is it isolated to people who have certain mods running along side it?

 

No, there are no IPN features. The only way my module would be billing a customer twice is if it ran, in its entirety, twice. I'm thinking this is a conflict with another contribution, but I'm waiting to hear responses about the code I pasted on page 43 (when used with a live transaction).

 

 

Is it true, only 60% of the orders goes through?

 

Also, my host claims that he doesnt have a proxy set up for curl, and I still get the setopt() error.

 

I think the amount is much higher now thanks to internationalization additions by SteveDallas, but it's still significantly lower than a traditional merchant account.

 

 

I continued to troubleshoot it further. I am one step before starting to debug the actual code.

I still cannot make it to work. What I tried is as following:

1. did not merge the files, but rather copied them as is from 0.71 package to my catalog dir - no luck

2. merged the files - no luck

3. suspecting problems with my site config , I installed standard oscommerse soft from their website and then applied the 0.71 with no merge - no luck

 

There must be something basic that I miss.

What module is responsible to include direct payment on the checkout_payment page?

 

here are the steps that I perform in nutshell again:

1. copy 0.7 to my catalog dir

2. update sql using .sql file

3. copy pear to catalog dir

4. copy certificate from my paypal sandbox

5. install the direct payment module providing my sandbox certificate username and password, enable debug

Curl must be working, cause clicking on express checkout brings me to paypal and then succsessfully brings me back.

 

Please let me know what do I miss

 

Use the checkout_payment page from 0.7 and see if that makes a difference.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Yes, there are orders in the table. Just won't show up, even in the admin side.

 

L!mit, you said you had the same problem - I still can't locate your post?

 

Invision Board doesn't has the option to search a specific persons post either.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×