Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

Regarding this contribution, at What stage does OSCommerce first learn of a completed transaction i.e. when does the order status change from 1 to 2 (or whatever) on the database?

 

Thanks in Advance

Share this post


Link to post
Share on other sites

OK, I've almost got this working, but am getting a "10002 Authentication/Authorization Failed (10002) Username/Password is incorrect" error. I have quadruple checked my API info, what else could it be?

Share this post


Link to post
Share on other sites

OK, I've almost got this working, but am getting a "10002 Authentication/Authorization Failed (10002) Username/Password is incorrect" error. I have quadruple checked my API info, what else could it be?

 

If you have entered sandbox credentials for testing, make sure that the Sandbox button is checked, otherwise check Live. You need one set of credentials for each server, and they are not interchangeable.

 

--Glen

Share this post


Link to post
Share on other sites

If you have entered sandbox credentials for testing, make sure that the Sandbox button is checked, otherwise check Live. You need one set of credentials for each server, and they are not interchangeable.

 

--Glen

 

I've got the PayPal API credentials only, figured I would skip the sandbox altogether, so I never had those in there. I only need the one module installed/enabled right, there aren't any companion modules I'm missing here?

 

On another note, now that I have the buttons showing up on the orders for PayPal, it is trying to send me to the wrong path for the page to add a charge, where are those paths set so that I can fix it?

Share this post


Link to post
Share on other sites

I've got the PayPal API credentials only, figured I would skip the sandbox altogether, so I never had those in there. I only need the one module installed/enabled right, there aren't any companion modules I'm missing here?

 

On another note, now that I have the buttons showing up on the orders for PayPal, it is trying to send me to the wrong path for the page to add a charge, where are those paths set so that I can fix it?

 

There are no companion modules, so if you followed the instructions, everything should be working correctly. This module requires an API certificate, not an API signature; make sure that you have downloaded the right set of credentials.

 

On the buttons, where is it trying to send you, and where are the button pages stored? The usual place to find the button pages is catalog/admin/includes/paypal_wpp/*.

 

--Glen

Share this post


Link to post
Share on other sites

There are no companion modules, so if you followed the instructions, everything should be working correctly. This module requires an API certificate, not an API signature; make sure that you have downloaded the right set of credentials.

 

On the buttons, where is it trying to send you, and where are the button pages stored? The usual place to find the button pages is catalog/admin/includes/paypal_wpp/*.

 

--Glen

 

I definitely have the certificate, you can't download the signature right? I used the auto-generated absolute path to the cert, maybe that isn't correct for my setup?

 

As for the buttons, nevermind, I just tried it again and it works now... It WAS leaving out the /includes/paypal_wpp/.

Share this post


Link to post
Share on other sites

I definitely have the certificate, you can't download the signature right? I used the auto-generated absolute path to the cert, maybe that isn't correct for my setup?

 

As for the buttons, nevermind, I just tried it again and it works now... It WAS leaving out the /includes/paypal_wpp/.

 

You are correct that you cannot download a signature. It's a copy and paste operation. You would receive a "certificate not found" error if you used the wrong path, so that isn't the problem. Have you filled out the WPP application and has PayPal approved it?

 

I don't know why the buttons weren't working, but I changed the path to them in 1.0.7. Did you have 1.0.6 or prior installed before?

 

--Glen

Share this post


Link to post
Share on other sites

You are correct that you cannot download a signature. It's a copy and paste operation. You would receive a "certificate not found" error if you used the wrong path, so that isn't the problem. Have you filled out the WPP application and has PayPal approved it?

 

I don't know why the buttons weren't working, but I changed the path to them in 1.0.7. Did you have 1.0.6 or prior installed before?

 

--Glen

 

I upgraded from a very old version, I'm ashamed to say which (0.9.2 I believe...). I had this working fine back then with WPP, so I know the account on PayPal's side of things is good.

Share this post


Link to post
Share on other sites

I upgraded from a very old version, I'm ashamed to say which (0.9.2 I believe...). I had this working fine back then with WPP, so I know the account on PayPal's side of things is good.

 

0.9.2 was a solid version, so I wouldn't be ashamed to say it. I took a long time to upgrade to v1.x myself, because the earlier version was working well for me.

 

One thing that tripped me up once was that my copy/paste operation put an extra space at the end, and a trailing space in the password field will cause this problem.

 

--Glen

Share this post


Link to post
Share on other sites

0.9.2 was a solid version, so I wouldn't be ashamed to say it. I took a long time to upgrade to v1.x myself, because the earlier version was working well for me.

 

One thing that tripped me up once was that my copy/paste operation put an extra space at the end, and a trailing space in the password field will cause this problem.

 

--Glen

 

0.9.2 was great, I only decided to upgrade because it seemed like a lot of features had been added. AND as luck would have it, it looks like i got it working! I re-re-re-requested my API credential after clearing everything out and starting over on anything associated with the credential that I could find. I just tried to click the Express Checkout, and voila!, I went to the PayPal login screen! Thanks for your help!

Share this post


Link to post
Share on other sites

Hi all

 

I am also using this contribution and it works very well.

 

We were recently contacted by Paypal saying that starting Jan 1st they were implementing 3D Secure (for UK; not sure about other countries) and we would need to update our payment modules.

Otherwise credit card payments will stop working.

 

Do you know if the module will be updated for 3d secure and, if so, where can we find that?

 

I wanted to start preparing with time to avoid unpleasant surprises...

 

Thank you and regards

Pedro.

Share this post


Link to post
Share on other sites

Hi all

 

I am also using this contribution and it works very well.

 

We were recently contacted by Paypal saying that starting Jan 1st they were implementing 3D Secure (for UK; not sure about other countries) and we would need to update our payment modules.

Otherwise credit card payments will stop working.

 

Do you know if the module will be updated for 3d secure and, if so, where can we find that?

 

I wanted to start preparing with time to avoid unpleasant surprises...

 

Thank you and regards

Pedro.

Pedro,

I'm working on implementing 3D Secure. I have been a bit busy with my own shop lately and haven't quite finished it, but will get back to it in a few days.

 

--Glen

Share this post


Link to post
Share on other sites

I'm trying to install this contribution but I'm running into a problem.

 

I followed all the steps in the documentation, but when I leave in the code below I can't login as an existing customer. It just keeps refreshing the login page.

 

 //---PayPal WPP Modification START ---//
 include(DIR_WS_INCLUDES . 'paypal_wpp/paypal_wpp_include.php');
 //---PayPal WPP Modification END ---//

 

When I comment out this line, I can login and get to the checkout page, but I get a bunch of errors along the way like this one:

 

Fatal error: Call to undefined function: tep_paypal_wpp_ep_button()

 

If anyone can help, I'd really appreciate it. I'm so close to being done with this site.

Share this post


Link to post
Share on other sites

Ok, so now I'm getting this error when I try to checkout:

 

1146 - Table 'db63544_viphair.TABLE_ORDERS_STATUS_HISTORY_TRANSACTIONS' doesn't exist

 

INSERT INTO TABLE_ORDERS_STATUS_HISTORY_TRANSACTIONS ( `orders_status_history_id`, `transaction_id`, `transaction_type`, `payment_type`, `payment_status`, `transaction_amount`, `module_code`, `transaction_avs`, `transaction_cvv2`, `transaction_msgs` ) VALUES ( 6, '07B09996NW781453F', 'AUTHORIZATION', 'INSTANT', 'PENDING', 10.00, 'paypal_wpp', 'Yes Address and five-digit ZIP', 'Match CVV2', 'authorization' )

 

There was nothing in the installation files about updating the database, I thought the admin side did that automatically when I installed the module.

 

I really need some help, I am getting my a$$ kicked over here!

Share this post


Link to post
Share on other sites

Ok, so now I'm getting this error when I try to checkout:

 

 

 

There was nothing in the installation files about updating the database, I thought the admin side did that automatically when I installed the module.

 

I really need some help, I am getting my a$$ kicked over here!

 

The install process does make the required database table updates, but there was a bug in v1.0.6 that created the table with an incorrect name. Upgrade to v1.0.7 or go back a few pages in this thread to locate the instructions that I posted to rename the table to the correct name.

 

If you are upgrading from an earlier version to v1.0.7, you must remove, then re-install the module in the admin. This will clear the configuration settings and make the required changes to the database.

 

--Glen

Share this post


Link to post
Share on other sites

The install process does make the required database table updates, but there was a bug in v1.0.6 that created the table with an incorrect name. Upgrade to v1.0.7 or go back a few pages in this thread to locate the instructions that I posted to rename the table to the correct name.

 

If you are upgrading from an earlier version to v1.0.7, you must remove, then re-install the module in the admin. This will clear the configuration settings and make the required changes to the database.

 

--Glen

 

 

Thanks Glen. I'll try this when I get back to my comp.

Share this post


Link to post
Share on other sites

I followed all the steps in the documentation, but when I leave in the code below I can't login as an existing customer. It just keeps refreshing the login page.

 

 //---PayPal WPP Modification START ---//
include(DIR_WS_INCLUDES . 'paypal_wpp/paypal_wpp_include.php');
//---PayPal WPP Modification END ---//

 

That points to misconfigured HTTPS settings in your configure.php file. It's trying to send your customer to the secure URL of your website, but since it's misconfigured it enters into an infinite loop. If you want to post the top portion of your configure.php file, we can help you get that set correctly.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

When a customer puts in a comment and puts a wrong credit card info, the commend box is wiped out when the an error is shown, is that normal? Before I installed this and there was an error message on payment page it would show the error but retain all the customer's data inputted but now it doesn't.

Share this post


Link to post
Share on other sites

I don't know how long this has been going on. We released our store last saturday, had a couple of sales then it stopped around Monday. Today, my boss emailed me saying there's an error and that it outputs Invalid Data 10729 saying the shipping address is invalid. I did a dump and it seems like the state isn't being sent for the shipping address

 

In function: before_process() - Direct Payment

Did first contact attempt return error? Yes

---------------------------------------------------------------------

-------------------------------DP_DUMP-------------------------------

------------This is the information that was sent to PayPal----------

---------------------------------------------------------------------

[?xml version="1.0" encoding="utf-8"?]

[soap:Envelope xmlns:soap=http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema]

[soap:Header]

[RequesterCredentials xmlns=urn:ebay:api:PayPalAPI]

[Credentials xmlns=urn:ebay:apis:eBLBaseComponents]

[username]XXXXXXXXXXXXXXXXXXXXXXXXXXX[/username]

[Password]XXXXXXXXXXXXXXXX[/Password]

[subject][/subject]

[/Credentials]

[/RequesterCredentials]

[/soap:Header]

[soap:Body]

[DoDirectPaymentReq xmlns=urn:ebay:api:PayPalAPI]

[DoDirectPaymentRequest]

[Version xmlns=urn:ebay:apis:eBLBaseComponents]2.0[/Version]

[DoDirectPaymentRequestDetails xmlns=urn:ebay:apis:eBLBaseComponents]

[PaymentAction]Sale[/PaymentAction]

[PaymentDetails]

[OrderTotal currencyID=USD]12.60[/OrderTotal]

[OrderDescription]Order placed on October 28, 2009, 1:07 pm by chris lin (ID: 52)[/OrderDescription]

[itemTotal currencyID=USD]0.8[/itemTotal]

[shippingTotal currencyID=USD]11.8[/shippingTotal]

[HandlingTotal currencyID=USD][/HandlingTotal]

[TaxTotal currencyID=USD]0[/TaxTotal]

[Custom]Phone: 2311234567 -- Email: chris@trendyname.org[/Custom]

[invoiceID][/invoiceID]

[NotifyURL][/NotifyURL]

[buttonSource][/buttonSource]

[shipToAddress]

[Name]chris lin[/Name]

[street1]123 first street[/street1]

[street2][/street2]

[CityName]la palma[/CityName]

[stateOrProvince][/stateOrProvince]

[PostalCode]90623[/PostalCode]

[Country]US[/Country]

[/shipToAddress]

[PaymentDetailsItem][Name]Penbo Penguin[/Name][Amount currencyID=USD]79.99[/Amount][Number]-[/Number][Quantity]1[/Quantity][/PaymentDetailsItem][PaymentDetailsItem][Name]Discount Coupon (TEST)[/Name][Amount currencyID=USD]-79.19[/Amount][Number]TEST[/Number][Quantity]1[/Quantity][/PaymentDetailsItem][PaymentDetailsItem][Name]Order Total Discrepancy[/Name][Amount currencyID=USD]0.00[/Amount][Number]-[/Number][Quantity]1[/Quantity][/PaymentDetailsItem]

[/PaymentDetails]

[CreditCard]

[CardOwner]

[Payer]chris@trendyname.org[/Payer]

[PayerName]

[FirstName]chris[/FirstName]

[LastName]lin[/LastName]

[/PayerName]

[Address]

[street1]123 first street[/street1]

[street2][/street2]

[CityName]la palma[/CityName]

[stateOrProvince]CA[/stateOrProvince]

[PostalCode]90623[/PostalCode]

[Country]US[/Country]

[/Address]

[/CardOwner]

[CreditCardType]MasterCard[/CreditCardType]

[CreditCardNumber]XXXXXXXXXXXXXXXX[/CreditCardNumber]

 

[ExpMonth]01[/ExpMonth]

[ExpYear]2012[/ExpYear]

[CVV2]XXX[/CVV2]

[/CreditCard]

[iPAddress]xx.xx.xx.xx[/iPAddress]

[MerchantSessionId]5a56ptq49vp7qenuvibv962jv3[/MerchantSessionId]

[/DoDirectPaymentRequestDetails]

[/DoDirectPaymentRequest]

[/DoDirectPaymentReq]

[/soap:Body]

[/soap:Envelope]---------------------------------------------------------------------

 

 

-------------------------------FINAL_REQ-----------------------------

-------------------This is the response from PayPal------------------

---------------------------------------------------------------------

Array

(

[security] =>

[RequesterCredentials] => Array

(

[0] => Array

(

[Credentials] => Array

(

[0] => Array

(

[username] =>

[Password] =>

[subject] =>

)

 

)

 

)

 

)

 

[DoDirectPaymentResponse] => Array

(

[0] => Array

(

[Timestamp] => 2009-10-28T20:07:51Z

[Ack] => Failure

[CorrelationID] => 7aaff194c3fb6

[Errors] => Array

(

[0] => Array

(

[shortMessage] => Invalid Data

[LongMessage] => There's an error with this transaction. Please enter your state in the shipping address.

[ErrorCode] => 10729

[severityCode] => Error

)

 

)

 

[Version] => 2.0

[build] => 1093451

[Amount] => 12.60

)

 

)

 

)

 

 

---------------------------------------------------------------------

---------------------------------TS_REQ------------------------------

--------Results of the transaction search if it was executed---------

---------------------------------------------------------------------

 

 

It's the same error over and over, StateOrProvince is left blank for shipping address.. I am the only one with access to the files and I don't remember changing anything to the files. Anyone know where I could start to try to troubleshoot this? It's weird, cause the shipping address is perfect on the confirmation page so you'd figured those would get passed on to paypal. It's getting messed up somewhere.

Edited by cLin

Share this post


Link to post
Share on other sites

Ok, I seem to have located the line, in /includes/modules/payment/paypal_wpp.php, there's a line that says

 

$order_info['PAYPAL_SHIPPING_STATE'] = $this->wpp_fix_state_for_paypal($order->delivery['country']['iso_code_2'] ,$order->delivery['state']);

 

If I change that to something like

        $order_info['PAYPAL_SHIPPING_STATE'] ="CA";

 

then the transaction goes thru since I defined the actual state. So it seems like one of those variables aren't being carried into this function, which doesn't make sense since it's shown in the payment_confirmation.php page.

Share this post


Link to post
Share on other sites

Yay, fixed it. I installed the Zone By State Shipping module which changed how the delivery address' state was being defined (it's usually grabs by zone_name, I changed it to zone_code). I just switched some values in paypal_wpp and tested it and it works great.

Share this post


Link to post
Share on other sites

Hi everyone. I've tried searching for this problem but haven’t had any luck finding a solution so far.

 

I’ve just installed the PayPal Website Payments Pro module (the full PayPal module directly from the PayPal site) and have setup my UK Website Payments Pro details. I’ve tried a transaction and it works perfectly.

 

However, if I type an incorrect card number (or even leave it blank) it redirects me to the osCommerce login screen instead of showing any errors.

 

I noticed the session number also changes when this happens.

 

I am using v2.2 RC2a on PHP 5.2.11 and MySQL 5.0.82

 

Any ideas what could be causing this?

 

Thanks so much :-)

Phil

Share this post


Link to post
Share on other sites

I've just discovered turning off SEO URLs fixes the above issue but ideally I'd like to keep the SEO URLs. Anyone else experience this before when combining SEO URLs and PayPal Website Payments Pro Direct?

Edited by philuk

Share this post


Link to post
Share on other sites

I've just discovered turning off SEO URLs fixes the above issue but ideally I'd like to keep the SEO URLs. Anyone else experience this before when combining SEO URLs and PayPal Website Payments Pro Direct?

 

If you are experiencing difficulty with the module obtained from PayPal, please contact PayPal for support. This topic is for support of the module developed by DynamoEffects, which can be found here. I don't know whether they still offer it, but PayPal released a module a couple of years back that was based on a previous version of the DynamoEffects module. The current version is actively maintained and is known to work with SEO URLs.

 

--Glen

Share this post


Link to post
Share on other sites

Yay, fixed it. I installed the Zone By State Shipping module which changed how the delivery address' state was being defined (it's usually grabs by zone_name, I changed it to zone_code). I just switched some values in paypal_wpp and tested it and it works great.

 

The WPP module expects the billing and shipping state fields to be populated with a zone_name, as standard osC defines it. I will look into accepting a zone_code in the state fields as well. This should be fairly simple, and will allow you to install future versions of WPP without modification.

 

--Glen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×