Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

REALLY NEED HELP!!!

 

After I click continue the final time before the checkout confirmation page, I keep getting an error saying:

 

An error occured when we tried to process your credit card.

 

Shipping Address State Empty (10729)

The field Shipping Address State is required

 

The state is definitely in the field and I can't figure out where the problem is. I thought it was because I didn't have SSL at first, so I had it installed but even with SSL, I'm getting the same error.

Which version of this module did you install?

 

--Glen

Share this post


Link to post
Share on other sites
Thanks for the answer SteveDallas.

 

Since it's not possible via direct paymentm we would like to do it via express checkout. The problem is that when the customer is redirected on the paypal website, he is invited either to pay and creating a paypal account at the same time or paying with an already existing account. We had a confirmation that it's possible to remove the forced subscription to paypal on the left to put a simple credit card payment but I can't get what parameters I have to give or if it is a specific webpage I must redirect the customer to so that this forced subscription doesn't appear and just let the customer pay directly.

 

Any ideas ?

 

Thanks !

There appears to be a way to use the Express Checkout API to do what you want to do, but the implementation is outside the scope of this topic, which is supporting the WPP module.

 

What you need is a payment module using the Express Checkout API as a more or less standard osCommerce payment module (no Express Checkout buttons). In the SetExpressCheckout request, you would set the optional parameter "LandingPage" to "Billing". This should do what you want.

 

I am unaware of any existing payment module that operates this way. If you want to discuss this further, contact me via PM.

 

--Glen

Share this post


Link to post
Share on other sites
So am I able to upgrade to this version? I wouldn't mind a few extra features. I also hoping it would solve my Security Head is no Valid error I get when I enter my CC info and press submit. Oddest error since the API credentials are correct (double and triple checked) and aside from that, no other info is asked for Paypal

 

Yes, you are able to upgrade to this version, but you will need different API credentials. This module was written before the API Signature access method was available, and has not yet been updated to support it. (It's on my list of things to do.) You will need to download an API Certificate and upload it to your server as described in the installation instructions.

 

I don't know why you are receiving the Security Header is not Valid error with your current module, but if there is a problem, it would likely appear with this module as well.

 

--Glen

Share this post


Link to post
Share on other sites
REALLY NEED HELP!!!

 

After I click continue the final time before the checkout confirmation page, I keep getting an error saying:

 

An error occured when we tried to process your credit card.

 

Shipping Address State Empty (10729)

The field Shipping Address State is required

 

The state is definitely in the field and I can't figure out where the problem is. I thought it was because I didn't have SSL at first, so I had it installed but even with SSL, I'm getting the same error.

 

 

I'm running RC2. I first installed 1.06 and had this error, so I tried 1.07a with the same results. Everything else seems to work, just can't finish the checkout.

Using private SSL provided by hostgator.

Share this post


Link to post
Share on other sites

Thanks SteveDallas,

 

The parameter landingpage is already set to billing but it still displays the paypal create account page to pay.

I'll leave it like that for the moment.

 

Thanks again for the help and sorry for the off topic questions :)

Share this post


Link to post
Share on other sites
Regarding the random "Order Total Discrepancy" showing up in some paypal invoices as zero. I only charge sales tax in one state and I have noticed that on those particular invoices the "Order Total Discrepancy" always shows up and is always the exact amount the sales tax should be....and the sales tax is blank. The grand total is correct but it seems to be itemizing oddly. This occurs during direct checkout.

 

What version of WPP are you using? I have tested this with v1.0.7a and it works correctly.

 

--Glen

Share this post


Link to post
Share on other sites
Thanks SteveDallas,

 

The parameter landingpage is already set to billing but it still displays the paypal create account page to pay.

I'll leave it like that for the moment.

 

Thanks again for the help and sorry for the off topic questions :)

 

My response was based on my reading of the documentation, and not on an actual test. I seem to recall reading of a method of accomplishing what you are asking for, but can't find it in the current PayPal documentation. They have made a number of changes over the years and may have removed that option.

 

--Glen

Share this post


Link to post
Share on other sites

For the certificate, can someone tell me the structure of it? I followed the instructions but I couldn't find the location in paypal. All I find was the PEM file and a place to get my API signature.

 

Also, how does sandbox mode work? I turned it on, I entered in my real cc info and when I press confirm order, it took me to the shopping_cart.php but with no errors. I checked admin and the order wasn't placed. Is this normal?

Edited by cLin

Share this post


Link to post
Share on other sites

how does sandbox mode work?

 

It needs a sandbox account no real account will work.

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites
REALLY NEED HELP!!!

 

After I click continue the final time before the checkout confirmation page, I keep getting an error saying:

 

An error occured when we tried to process your credit card.

 

Shipping Address State Empty (10729)

The field Shipping Address State is required

 

The state is definitely in the field and I can't figure out where the problem is. I thought it was because I didn't have SSL at first, so I had it installed but even with SSL, I'm getting the same error.

 

 

Go to Configuration/Customer Details and turn state to true ;) that will fix the problem. It is the last entry on that page, I have all else set to false, gender, date of birth, etc.

 

Hope this helps, took me a day or so to figure this out when it happened to me lol For the record it doesn't have anything to do with the module, just one of the tedious little settings OSC has to have just right to work :P

Edited by chancedevin

Share this post


Link to post
Share on other sites
Go to Configuration/Customer Details and turn state to true ;) that will fix the problem. It is the last entry on that page, I have all else set to false, gender, date of birth, etc.

 

Hope this helps, took me a day or so to figure this out when it happened to me lol For the record it doesn't have anything to do with the module, just one of the tedious little settings OSC has to have just right to work :P

 

 

That was one of the first things I checked , I tried both with the state enabled and disabled with the same results. I know paypal is sending the state to the address field because after you get back to the confirmation, the address is correct (with the state), but after I try to confirm the order, I get that error and get sent back to the first delivery information page. Even if I add a manual address to the user account, I still get the same error.

Maybe the name of the state variable being is mismatched somewhere?

Edited by wizard907

Share this post


Link to post
Share on other sites
That was one of the first things I checked , I tried both with the state enabled and disabled with the same results. I know paypal is sending the state to the address field because after you get back to the confirmation, the address is correct (with the state), but after I try to confirm the order, I get that error and get sent back to the first delivery information page. Even if I add a manual address to the user account, I still get the same error.

Maybe the name of the state variable being is mismatched somewhere?

 

 

Enable "Debug Mode" in the module configuration. You should receive an error dump in email (with the sensitive fields blanked out). It will show both the transaction sent to PayPal and the response. Send it to me in a PM or by email to osc at glensgarage dot com. I'll should be able to determine why it reports an error.

 

Does this happen with Express Checkout, Direct Payment (credit card), or both?

 

--Glen

Share this post


Link to post
Share on other sites
how does sandbox mode work?

 

It needs a sandbox account no real account will work.

 

Satish

 

How do I get a sandbox account? I just want to be able to test my cart to make sure everything is working like if I was an actual customer =\

Share this post


Link to post
Share on other sites
How do I get a sandbox account? I just want to be able to test my cart to make sure everything is working like if I was an actual customer =\

 

Register at the PayPal Sandbox. After you are registered, you will need to create two test accounts; one to play the role of the shopowner, and another to play the role of the customer. The shopowner account must apply for WPP and download the API credentials. It looks the same as the regular PayPal site, but approval is instant.

 

--Glen

Share this post


Link to post
Share on other sites
Enable "Debug Mode" in the module configuration. You should receive an error dump in email (with the sensitive fields blanked out). It will show both the transaction sent to PayPal and the response. Send it to me in a PM or by email to osc at glensgarage dot com. I'll should be able to determine why it reports an error.

 

Does this happen with Express Checkout, Direct Payment (credit card), or both?

 

--Glen

 

I just ran the wpp_diagnostics.php and it says that I don't have the database update in place? Can somebody tell me what it's referring to?

Thanks

Share this post


Link to post
Share on other sites
I just ran the wpp_diagnostics.php and it says that I don't have the database update in place? Can somebody tell me what it's referring to?

Thanks

 

Since you first installed v1.0.6, it probably means that one of the database tables was created with the wrong name. That was my fault; sorry about that. There are three ways to fix it:

 

1. Go into the module's settings. (Admin->Modules, then click on PayPal Direct Payment) Save all the settings (copy and paste to a text file). Click 'Remove'. Click 'Install'. Re-enter all of your settings.

 

or

 

2. Open your mySQL administration tool and rename the table.

Steps for phpMyAdmin

a. Select the table named TABLE_ORDERS_STATUS_HISTORY_TRANSACTIONS.

b. Click on the tab "Operations".

c. Type "orders_status_history_transactions" into the box under "Rename table to:" and click "Go".

 

or

 

3. Paste the following command into your mySQL administration tool (phpMyAdmin, for instance):

 

ALTER TABLE `TABLE_ORDERS_STATUS_HISTORY_TRANSACTIONS` RENAME `orders_status_history_transactions`;

 

All three procedures accomplish essentially the same thing, so pick the one that you find easiest to follow.

 

--Glen

Share this post


Link to post
Share on other sites

Thanks Steve, that took care of that.

Now when I run the diagnostic, I get as far as:

 

Did PayPal respond without errors? (If not, errors are below) No

Internal Error (10001)

Internal Error

 

The transactions are going through now, but should I be worried about those errors?

 

Thanks

Share this post


Link to post
Share on other sites
Thanks Steve, that took care of that.

Now when I run the diagnostic, I get as far as:

 

Did PayPal respond without errors? (If not, errors are below) No

Internal Error (10001)

Internal Error

 

The transactions are going through now, but should I be worried about those errors?

 

Thanks

 

For some reason, the transaction that we use to test connectivity with the server now displays a 10001 error when you connect to the sandbox. When you are ready to go live, run the diagnostics again using the live credentials. Everything should display as OK. I plan to revise the test to either use a different transaction when talking to the sandbox, or to accept 10001 errors as "normal operation" when in sandbox mode. The latter will probably be easier, as all we are looking for at this point is whether PayPal responds. On the live server, a 10001 error could indicate a real problem, so we'll report that.

 

--Glen

Edited by SteveDallas

Share this post


Link to post
Share on other sites

Ok, so I got the order to go through with the sandbox mode. I'm guessing to get it working live for real transactions, I would just replace the certificate, api username and password with the live paypal account and to change the mode from sandbox to live?

Share this post


Link to post
Share on other sites
Ok, so I got the order to go through with the sandbox mode. I'm guessing to get it working live for real transactions, I would just replace the certificate, api username and password with the live paypal account and to change the mode from sandbox to live?

 

Exactly.

 

--Glen

Share this post


Link to post
Share on other sites
For some reason, the transaction that we use to test connectivity with the server now displays a 10001 error when you connect to the sandbox. When you are ready to go live, run the diagnostics again using the live credentials. Everything should display as OK. I plan to revise the test to either use a different transaction when talking to the sandbox, or to accept 10001 errors as "normal operation" when in sandbox mode. The latter will probably be easier, as all we are looking for at this point is whether PayPal responds. On the live server, a 10001 error could indicate a real problem, so we'll report that.

 

--Glen

 

I get those errors running on a live server with live credentials, using a Hostgator SSL private cert.

Share this post


Link to post
Share on other sites
I get those errors running on a live server with live credentials, using a Hostgator SSL private cert.

 

That is odd. And transactions are processing normally? If they are, I wouldn't worry about it. If you can't process transactions, contact PayPal tech support; there may be a problem with your account.

 

--Glen

Share this post


Link to post
Share on other sites

I am doing a sorely needed upgrade from 0.9.2 to 1.1, and am getting an error that is telling me that "class payments" cannot be declared twice. I can't seem to find where it used to be declared.... any ideas?

Edited by Gremlyn1

Share this post


Link to post
Share on other sites
I am doing a sorely needed upgrade from 0.9.2 to 1.1, and am getting an error that is telling me that "class payments" cannot be declared twice. I can't seem to find where it used to be declared.... any ideas?

 

The current version of this module is 1.0.7. Are you installing the one that Harald released? That's a different module entirely, and I don't know if there is a support topic.

 

--Glen

Share this post


Link to post
Share on other sites
The current version of this module is 1.0.7. Are you installing the one that Harald released? That's a different module entirely, and I don't know if there is a support topic.

 

--Glen

 

Oops, sorry I meant 1.0.7... I ahve too many software versions to keep track of these days :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×