Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

sorry the url was http then mysite then this

 

ext/modules/payment/paypal/express.php?osC_Action=retrieve&token=EC-12F891466S355980W&PayerID=FZNHLQTBLPXSW

 

While this is not the place to support the hpdl Express Checkout module, I might be able to help a bit. First, are you running RC2(a) of osC? If not, did you follow the entire list of installation instructions in the 'readme' file of the module? In particular, did you make the modifications on this link?

 

--Glen

Share this post


Link to post
Share on other sites
While this is not the place to support the hpdl Express Checkout module, I might be able to help a bit. First, are you running RC2(a) of osC? If not, did you follow the entire list of installation instructions in the 'readme' file of the module? In particular, did you make the modifications on this link?

 

--Glen

 

 

i do apologize for asking in the wrong place but i was hoping that you could enlighten me a little on my problem and the fact that someone else had a similar problem as myself. Yes i am running RC2 but i did upload the files from the add-on in hopes that their was an update or something else that my site was missing, and no i didnt make any of the modifications on that link. I hoped that the address would shed some light on why it was not returning to my site.

Share this post


Link to post
Share on other sites
i do apologize for asking in the wrong place but i was hoping that you could enlighten me a little on my problem and the fact that someone else had a similar problem as myself. Yes i am running RC2 but i did upload the files from the add-on in hopes that their was an update or something else that my site was missing, and no i didnt make any of the modifications on that link. I hoped that the address would shed some light on why it was not returning to my site.

 

Since you are running RC2, you don't need to make the modifications in that link. The return address is correct. It is a page that the module uses to retrieve the customer's shipping address from PayPal. While I don't use that EC module in my shop, I have implemented it for someone in the past. I didn't get to see how it performed because there was a problem in their PayPal account; it wasn't upgraded to a Business account when I was doing the testing.

 

--Glen

Share this post


Link to post
Share on other sites
Since you are running RC2, you don't need to make the modifications in that link. The return address is correct. It is a page that the module uses to retrieve the customer's shipping address from PayPal. While I don't use that EC module in my shop, I have implemented it for someone in the past. I didn't get to see how it performed because there was a problem in their PayPal account; it wasn't upgraded to a Business account when I was doing the testing.

 

--Glen

 

 

thank you for your help, and i do have some good news.

 

i tryed the second add-on you suggested to cory, the PayPal Express Checkout IPN by AlexStudio and everything works and its great. thank you for your time and help

 

will

Share this post


Link to post
Share on other sites

on paypal wpp 1.0.4 when you issue a refund from admin, on my screen it shows WPP_AMOUNT_OPTIONAL next to the refund amount box .. obviously something is missing, but i do not know what.

 

also when you select partial, you are able to insert an amount. when you choose full, it's grayed out. i'm sure that is how it is suppose to work (i'm guessing the new 1.0.4 already records the amount), but i just want to confirm since i came from 1.0.1 and it was different.

Share this post


Link to post
Share on other sites

is there anything that has to be done with this module with the new Paypal Fraud Management Filters?

Share this post


Link to post
Share on other sites

Hi All,

 

I have installed the excellent PayPal WPP Direct Payments & Express Checkout contribution, version 1.0.4 to my store and generally it has gone well. I am running Oscommerce 2.2 rc2a.

 

I have successfully transacted with Direct Payments in the sandbox and everything is fine.

However when I use express checkout everything appears to work OK except that after I confirm the transaction on the PayPal website I am returned to shopping_cart.php.

 

(full link is https://---------------/----/shopping_cart.php?action=express_checkoutb4---871e6d117e---c628a6ef8ec---&token=EC-0MS518---6542037T&PayerID=C5CP---3VPSTA

[dashes substituted for security purposes]

 

The cart is shown as empty but no payment has been taken by PayPal and no order logged is OSc. The user has been logged out and when the user logs back in the cart contents are still there.

 

Although I have a template based store I have followed the manual install instructions to the letter and the only section I had an issue with was the includes/header.php

 

Because it is a template my header.php file looks nothing like the example given. Only the HEADER_TITLE_CART_CONTENTS is part of header.php

 

The other HEADERS are part of includes/footer.php

 

So far I have only modified footer.php by adding

 

$show_user_options = tep_paypal_wpp_show_user_options();

 

and

 

<?php if ($show_user_options) { ?>

 

in place of

 

<? if (tep_session_is_registered('customer_id')) { ?>

 

Do I need to amend the HEADER_TITLE_CART_CONTENTS in header.php?

 

Please can someone explain what this code modification is doing and whether problems here could have a bearing on the Express Checkout issue I have? I presume this code is just displaying the various options depending on whether the user is already logged in or not?

 

If this was the problem area I would have expected Direct Payments to have the same problem?

 

I am right in thinking that the return url does not need to be set on my PayPal account when using Express Checkout?

 

Is there anything else I can check to track down why I have this problem?

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Hmmm, I have a 2.2 store built on the 060817 update. I have this mod installed but keep getting the message

 

Your store has a bug in checkout_process.php that prevents this module from working. Please read the Troubleshooting section of the READ_ME.htm that came with the module for more information.

 

Taking a look I don't see a difference in the code snippet from the README and what's there.

 

Replaced checkout_process with the rc2.2a version. Same message.

 

What am I looking for here? I do have various mods installed - CCGV among them.

 

Thanks for any pointers.

Edited by Iggy

Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites
Hmmm, I have a 2.2 store built on the 060817 update. I have this mod installed but keep getting the message

 

Your store has a bug in checkout_process.php that prevents this module from working. Please read the Troubleshooting section of the READ_ME.htm that came with the module for more information.

 

Taking a look I don't see a difference in the code snippet from the README and what's there.

 

Replaced checkout_process with the rc2.2a version. Same message.

 

What am I looking for here? I do have various mods installed - CCGV among them.

 

Thanks for any pointers.

 

Just for giggles - the results of the diagnostics

 

Warning: Illegal offset type in isset or empty in /www/marquamstore.com/html/includes/classes/payment.php on line 72

Paypal Website Payments Pro Diagnostics

 

for Version 1.0.0+

 

by Brian Burton (dynamoeffects)

Basic Tests

Using at least PHP 4.3.0? Yes

Does your store have an SSL certificate installed and working? Yes

Is cURL installed? Yes

Does cURL work? (Simple HTTPS test) Yes

API Certificate installed? Yes

API Certificate directory protected? Yes

API Username in place? Yes

API Password in place? Yes

Database update in place? Yes

Payment class modifications in place? Yes

Bug in checkout_process.php fixed? [Read More] Yes

XML Document "doDirectPayment.xml" exists? Yes

XML Document "doExpressCheckout.xml" exists? Yes

XML Document "getExpressCheckoutDetails.xml" exists? Yes

XML Document "setExpressCheckout.xml" exists? Yes

XML Document "transactionSearch.xml" exists? Yes

XML Document "doCapture.xml" exists? Yes

XML Document "getTransactionDetails.xml" exists? Yes

XML Document "refundTransaction.xml" exists? Yes

Advanced Diagnostics

Able to connect to PayPal through cURL? Yes

Received a valid response? Yes

Did PayPal respond without errors? (If not, errors are below) Yes

Success!

 

Congratulations! This contribution appears to be correctly installed on your store!

 

Please note that if you're still having problems with your installation, it is most likely because you didn't completely integrate all of the code.


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites
Hi All,

 

I have installed the excellent PayPal WPP Direct Payments & Express Checkout contribution, version 1.0.4 to my store and generally it has gone well. I am running Oscommerce 2.2 rc2a.

 

I have successfully transacted with Direct Payments in the sandbox and everything is fine.

However when I use express checkout everything appears to work OK except that after I confirm the transaction on the PayPal website I am returned to shopping_cart.php.

 

(full link is https://---------------/----/shopping_cart.php?action=express_checkoutb4---871e6d117e---c628a6ef8ec---&token=EC-0MS518---6542037T&PayerID=C5CP---3VPSTA

[dashes substituted for security purposes]

 

The cart is shown as empty but no payment has been taken by PayPal and no order logged is OSc. The user has been logged out and when the user logs back in the cart contents are still there.

Re-check your modifications to shopping_cart.php. Note that the new code goes above the indicated text.

 

Although I have a template based store I have followed the manual install instructions to the letter and the only section I had an issue with was the includes/header.php

 

Because it is a template my header.php file looks nothing like the example given. Only the HEADER_TITLE_CART_CONTENTS is part of header.php

 

The other HEADERS are part of includes/footer.php

 

So far I have only modified footer.php by adding

 

$show_user_options = tep_paypal_wpp_show_user_options();

 

and

 

<?php if ($show_user_options) { ?>

 

in place of

 

<? if (tep_session_is_registered('customer_id')) { ?>

 

Do I need to amend the HEADER_TITLE_CART_CONTENTS in header.php?

 

Please can someone explain what this code modification is doing and whether problems here could have a bearing on the Express Checkout issue I have? I presume this code is just displaying the various options depending on whether the user is already logged in or not?

The header.php modification hides the 'logout' button when you are processing an Express Checkout payment.

 

If this was the problem area I would have expected Direct Payments to have the same problem?

Your Express Checkout problem is probably a faulty edit to shopping_cart.php. The header.php problem is not related.

I am right in thinking that the return url does not need to be set on my PayPal account when using Express Checkout?

This is correct. The module sets the return url as needed, overriding what you have set in your account.

 

--Glen

Share this post


Link to post
Share on other sites
Hmmm, I have a 2.2 store built on the 060817 update. I have this mod installed but keep getting the message

 

Your store has a bug in checkout_process.php that prevents this module from working. Please read the Troubleshooting section of the READ_ME.htm that came with the module for more information.

 

Taking a look I don't see a difference in the code snippet from the README and what's there.

 

Replaced checkout_process with the rc2.2a version. Same message.

 

What am I looking for here? I do have various mods installed - CCGV among them.

 

Thanks for any pointers.

The code that generates the error is checking to see if there are any entries in the global $order_totals array. This array is populated by calling $order_total_modules->$process(). If you call the WPP module's $before_process() method before calling $order_total_modules->$process(), the $order_totals array will be empty and generate the error.

 

Re-check checkout_process.php to be certain that the code is actually being executed and that some other modification has not bypassed it.

 

--Glen

Share this post


Link to post
Share on other sites
The code that generates the error is checking to see if there are any entries in the global $order_totals array. This array is populated by calling $order_total_modules->$process(). If you call the WPP module's $before_process() method before calling $order_total_modules->$process(), the $order_totals array will be empty and generate the error.

 

Re-check checkout_process.php to be certain that the code is actually being executed and that some other modification has not bypassed it.

 

--Glen

 

Thanks Glen. I appreciate the tip. As far as I can tell it's not being bypassed. Maybe you'd read the first few lines of checkout_process and confirm?

 

  include('includes/application_top.php');

// if the customer is not logged on, redirect them to the login page
 if (!tep_session_is_registered('customer_id')) {
$navigation->set_snapshot(array('mode' => 'SSL', 'page' => FILENAME_CHECKOUT_PAYMENT));
tep_redirect(tep_href_link(FILENAME_LOGIN, '', 'SSL'));
 }

 if (!tep_session_is_registered('sendto')) {
tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, '', 'SSL'));
 }

 if ( (tep_not_null(MODULE_PAYMENT_INSTALLED)) && (!tep_session_is_registered('payment')) ) {
tep_redirect(tep_href_link(FILENAME_CHECKOUT_PAYMENT, '', 'SSL'));
}

// avoid hack attempts during the checkout procedure by checking the internal cartID
 if (isset($cart->cartID) && tep_session_is_registered('cartID')) {
if ($cart->cartID != $cartID) {
  tep_redirect(tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'));
}
 }

 include(DIR_WS_LANGUAGES . $language . '/' . FILENAME_CHECKOUT_PROCESS);

// load selected payment module
 require(DIR_WS_CLASSES . 'payment.php');
// #################### Added CCGV ######################
 if ($credit_covers) $payment=''; //ICW added for CREDIT CLASS
// #################### End Added CGV ######################
 $payment_modules = new payment($payment);

// load the selected shipping module
 require(DIR_WS_CLASSES . 'shipping.php');
 $shipping_modules = new shipping($shipping);

 require(DIR_WS_CLASSES . 'order.php');
 $order = new order;

require(DIR_WS_CLASSES . 'order_total.php');
$order_total_modules = new order_total;

$order_totals = $order_total_modules->process();

// load the before_process function from the payment modules
$payment_modules->before_process();

 $sql_data_array = array('customers_id' => $customer_id,
					  'customers_name' => $order->customer['firstname'] . ' ' . $order->customer['lastname'],
					  'customers_company' => $order->customer['company'],
					  'customers_street_address' => $order->customer['street_address'],


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites
Thanks Glen. I appreciate the tip. As far as I can tell it's not being bypassed. Maybe you'd read the first few lines of checkout_process and confirm?

 

It looks okay to me. If that is the version of checkout_process.php that is on your server, it should be working.

 

--Glen

Share this post


Link to post
Share on other sites
It looks okay to me. If that is the version of checkout_process.php that is on your server, it should be working.

 

--Glen

 

Thanks for double checking that. I installed .9 which I've used in the past and it throws

 

This transaction cannot be processed due to an invalid merchant configuration

 

So I'll have to get into PayPal and double check. Then I'll try it out with the new version and see if it continues.

 

Really appreciate it!


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites
Thanks for double checking that. I installed .9 which I've used in the past and it throws

 

This transaction cannot be processed due to an invalid merchant configuration

 

So I'll have to get into PayPal and double check. Then I'll try it out with the new version and see if it continues.

 

Really appreciate it!

 

If this problem occurred on my site, my next step with 1.0.4 would be to add some debugging code to checkout_process to see if the $order_totals array is being created.

 

--Glen

Share this post


Link to post
Share on other sites
Re-check your modifications to shopping_cart.php. Note that the new code goes above the indicated text.

 

 

The header.php modification hides the 'logout' button when you are processing an Express Checkout payment.

 

 

Your Express Checkout problem is probably a faulty edit to shopping_cart.php. The header.php problem is not related.

 

This is correct. The module sets the return url as needed, overriding what you have set in your account.

 

--Glen

Share this post


Link to post
Share on other sites

Thanks for the reply.

I was quite meticulous adding the code and on re-checking I did not find any errors.

I have been looking into this further today and I believe it is a session issue.

 

When Paypal returns to my site (at the shopping cart) it has a different (new) session ID to the one it was passed when the Express Checkout button was clicked.

 

Does this indicate that the session has died?

 

OK so even if the session was correct why is it returning to the shopping cart after PayPal Express - is this correct?

 

Continuing to investigate ...

 

Any further help much appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

can i get a response please:

 

on paypal wpp 1.0.4 when you issue a refund from admin, on my screen it shows WPP_AMOUNT_OPTIONAL next to the refund amount box .. obviously something is missing, but i do not know what.

 

also when you select partial, you are able to insert an amount. when you choose full, it's grayed out. i'm sure that is how it is suppose to work (i'm guessing the new 1.0.4 already records the amount), but i just want to confirm since i came from 1.0.1 and it was different.

Edited by jasyn

Share this post


Link to post
Share on other sites
If this problem occurred on my site, my next step with 1.0.4 would be to add some debugging code to checkout_process to see if the $order_totals array is being created.

 

--Glen

 

Hi Glen,

 

Works fine. Both versions. My client won't let me have direct access to the PayPal account so it was a matter of not responding to the email PP sent on setup it seems. A quick call from the owner and PP got it cleared.

 

Many thanks for your help!


Everything's funny but nothing's a joke...

Share this post


Link to post
Share on other sites

Does anyone know why when I click "Check out with PayPal" button in the checkout page, I am sent to a not found page with a message, "The requested URL /php4 was not found on this server." Can anyone help me with this? I have tried looking into my files but unable to figure out what to change. Please help.

Share this post


Link to post
Share on other sites
can i get a response please:

on paypal wpp 1.0.4 when you issue a refund from admin, on my screen it shows WPP_AMOUNT_OPTIONAL next to the refund amount box .. obviously something is missing, but i do not know what.

 

also when you select partial, you are able to insert an amount. when you choose full, it's grayed out. i'm sure that is how it is suppose to work (i'm guessing the new 1.0.4 already records the amount), but i just want to confirm since i came from 1.0.1 and it was different.

 

Install catalog/admin/includes/paypal_wpp/languages/english/paypal_wpp.php from version 1.0.4 of the module. This value was added in 1.0.2.

 

--Glen

Share this post


Link to post
Share on other sites
Hi Glen,

 

Works fine. Both versions. My client won't let me have direct access to the PayPal account so it was a matter of not responding to the email PP sent on setup it seems. A quick call from the owner and PP got it cleared.

 

Many thanks for your help!

 

Glad to hear that you got it working. I'll add that symptom to my notes.

 

I'm always happy to help out.

 

--Glen

Share this post


Link to post
Share on other sites
Does anyone know why when I click "Check out with PayPal" button in the checkout page, I am sent to a not found page with a message, "The requested URL /php4 was not found on this server." Can anyone help me with this? I have tried looking into my files but unable to figure out what to change. Please help.

 

What do you see for a link when you mouse over the "Check out with PayPal" button? It should look something like:

 

https://www.storename.com/catalog/shopping_...opping_cart.php

 

If your browser doesn't display links when you move your mouse over a button, see if you can right click the button to bring up a contextual menu and use the "Copy link" choice to put it on your clipboard and paste it into any text editor.

 

If it looks correct, make sure you have followed the installation instructions in the READ_ME.htm file, especially step #10.

 

--Glen

Share this post


Link to post
Share on other sites

anyone ever figure out a definitive cause for the "checkout_payment.php?error_message=Please+select+a+payment+method+for+your+order" redirect from paypal when you click the button at paypal to verify your reviewed payment details?

 

 

 

 

sincerely,

Share this post


Link to post
Share on other sites
What do you see for a link when you mouse over the "Check out with PayPal" button? It should look something like:

 

https://www.storename.com/catalog/shopping_...opping_cart.php

 

If your browser doesn't display links when you move your mouse over a button, see if you can right click the button to bring up a contextual menu and use the "Copy link" choice to put it on your clipboard and paste it into any text editor.

 

If it looks correct, make sure you have followed the installation instructions in the READ_ME.htm file, especially step #10.

 

--Glen

 

 

Thanks for replying back Glen.... When I put my mouse on top of the link, the status bar shows

 

https://www.mysite.com/php4?action=express_...opping_cart.php

 

I don't know why it is showing up php4 cuz i searched php4 in the files but couldn't find it to replace it with the correct directory.

 

I'm not sure if it's because I need to install an early version of this mod first because I installed it fresh from v.1.0.4. Do i need to install like version 0.1.1 first then update it the version 1.0.4 or is version 1.0.4 a full package mod already?

Edited by l3reacher

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×