Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

When one checks out with a company name it does not get passed to Paypal, only his/her name is passed.

 

Recently, on rare occasions when an order placed using the wpp (not express) method, does not get posted to the orders table in the database. Has anyone had this issue?

Edited by rvsupply

Share this post


Link to post
Share on other sites
I juz upload to the server, and when I opened the index.php on browser it shows like this:

 

Fatal error: Call to undefined function tep_paypal_wpp_show_user_options() in /var/www/html/includes/header.php on line 68

 

What's wrong here then?

 

 

Reinstall it and follow the instructions. You probably forgot to put the include into application_top.php

 

  //---PayPal WPP Modification START ---//
 include(DIR_WS_INCLUDES . 'paypal_wpp/paypal_wpp_include.php');
 //---PayPal WPP Modification END ---//

Share this post


Link to post
Share on other sites

Hi all

 

Having only been running live a few days a few things have come to light that I would have never known before now.

 

I have WPP installed and I have a Pro PP account. When I view and order and either try to 'capture' or "Add' I have to login through the admin interface again and then I get -

 

The requested URL /ribbonrie/admin/paypal_wpp_charge.php was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

Now my wpp files are not under ribbonrie/admin as above they are in ribbonrie/admin/includes/paypal_wpp

 

Have I done something incorrectly during the set up here?

 

Any advice much appreciated. Other than this it works well from what I have seen so far :D

 

Most grateful


Heather...

 

icon_baby_crawl-1.gifCrawling my way through pages of code with my fingers crossed and one eye on here. Grateful to many at the osCommerce Community. Thank YOU

 

Coding successes: GV & Coupons, UltraPics, FCK Editor, Product Listings Enhancement, Short Descriptions, Define Main Page, Text Box, Attribute Sets Plus, . PayPal WPP. UL Catagories. Dynamenu. Featured Products. Mailist Report 1.2. Easy Meta Tags (Now even I could have screwed that up) Sold Out but Displayed 0.3. Club osc Specials on Front Page. Order Editor. HTML Emails V2

Working on: SEO

 

 

Proud member of the Code Breakers Club

Share this post


Link to post
Share on other sites

paypal pro is available for canadians,

 

canadian paypal pro

 

i was wondering if someone can tell me if this mod will work for a canadian cart?

 

thanks muchly

 

Tanya

Share this post


Link to post
Share on other sites
paypal pro is available for canadians,

 

canadian paypal pro

 

i was wondering if someone can tell me if this mod will work for a canadian cart?

 

thanks muchly

 

Tanya

 

It appears that WPP for Canada uses the same API as the US version, which means that this contribution should work, though you may have to tweak it to use CAD rather than USD as its currency. I haven't looked too closely at that part of the code. I would create a test store and install the module there, and try some transactions in the PayPal Sandbox before attempting a live install.

 

--Glen

Share this post


Link to post
Share on other sites

thank ya kindly my friend :)

 

i shall give it a go and let you know how it all gos for me :)

Share this post


Link to post
Share on other sites
................

 

When you go through checkout and enter the card information, and you click confirm on the final step on checkout_confirmation.php and click confirm order, it brings you back to the checkout_payment.php again asking for the card info again!......

 

I am having the same issues, and running the store without sef urls is not an option. The site has been live for a couple of years now and is well indexed using the sef urls..

 

how does one go about fixing the issue of the confirmation page sending you back to the payment page?

 

thank you kindly for sharing your mod with the community :)

Share this post


Link to post
Share on other sites

Hello

 

i have direct payments working great.

 

the express button doesnt work!!

 

it keeps taking me back to login.php.... reguardless of where i clicked on the express checkout button...

 

i have tried forcing cookies and that didnt work.

 

 

any ideas??

 

tried playing with configuration "reestablish sessions"...

 

takes me back to a blank shopping cart.

 

SSL is working good, direct payments work great.

 

just need express payments to work.

 

please help!!

 

thanks

Share this post


Link to post
Share on other sites

wpp_diagnostics.php reports the following :

 

Did PayPal respond without errors? (If not, errors are below) No

Internal Error (10001)

Internal Error

 

 

almost any attempt to pay via direct paypal pro uk interface fails.

 

this worked perfectly until 2 months ago.

 

please help


*Do not advertise in your signature

Share this post


Link to post
Share on other sites

I manage to isolate a small example of a TransactionSearchRequest that fails.

Any ideas will be appreciated.

the following was used to invoke the SOAP request:

 

curl -d @reqfile.xml https://api.paypal.com/2.0/ --cert-type PEM --cert paypal_live_cert.pem > ansfile.xml

 

Here is the SOAP request (reqfile.xml):

------------------------

<?xml version="1.0" encoding="utf-8"?>
<SOAP-ENV:Envelope
xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance"
xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/1999/XMLSchema"
SOAP-ENV:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">

<SOAP-ENV:Header>
<RequesterCredentials xmlns="urn:ebay:api:PayPalAPI">
<Credentials xmlns="urn:ebay:apis:eBLBaseComponents">
<Username>ebay_api1.robosavvy.com</Username>
<Password>XXXXXXXXXXXXXXXX</Password>
<Subject/>
</Credentials>
</RequesterCredentials>
</SOAP-ENV:Header>
<SOAP-ENV:Body>
<TransactionSearchReq xmlns="urn:ebay:api:PayPalAPI">
<TransactionSearchRequest>
<Version xmlns="urn:ebay:apis:eBLBaseComponents">2.0</Version>
<StartDate>2008-10-15T00:00:00Z</StartDate>
<EndDate>2008-10-16T00:00:00Z</EndDate>
<Payer>sales@robosavvy.com</Payer>
<Amount currencyID="USD">1.00</Amount>
</TransactionSearchRequest>
</TransactionSearchReq>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>

 

 

 

 

 

Here is the response (ansfile.xml):

 

 

 

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance" xmlns:xsd="http://www.w3.org/1999/XMLSchema" xmlns:xs="http://www.w3.org/2001/XMLSchema" xmlns:cc="urn:ebay:apis:CoreComponentTypes" xmlns:wsu="http://schemas.xmlsoap.org/ws/2002/07/utility" xmlns:saml="urn:oasis:names:tc:SAML:1.0:assertion" xmlns:ds="http://www.w3.org/2000/09/xmldsig#" xmlns:wsse="http://schemas.xmlsoap.org/ws/2002/12/secext" xmlns:ebl="urn:ebay:apis:eBLBaseComponents" xmlns:ns="urn:ebay:api:PayPalAPI">
<SOAP-ENV:Header>
<Security xmlns="http://schemas.xmlsoap.org/ws/2002/12/secext" xsi:type="wsse:SecurityType"></Security>
<RequesterCredentials xmlns="urn:ebay:api:PayPalAPI" xsi:type="ebl:CustomSecurityHeaderType">
<Credentials xmlns="urn:ebay:apis:eBLBaseComponents" xsi:type="ebl:UserIdPasswordType">
<Username xsi:type="xs:string"></Username>
<Password xsi:type="xs:string"></Password>
<Subject xsi:type="xs:string"></Subject>
</Credentials>
</RequesterCredentials>
</SOAP-ENV:Header>
<SOAP-ENV:Body id="_0">
<TransactionSearchResponse xmlns="urn:ebay:api:PayPalAPI">
<Timestamp xmlns="urn:ebay:apis:eBLBaseComponents">2008-10-16T13:53:16Z</Timestamp>
<Ack xmlns="urn:ebay:apis:eBLBaseComponents">Failure</Ack>
<CorrelationID xmlns="urn:ebay:apis:eBLBaseComponents">3aed8da6814bc</CorrelationID>
<Errors xmlns="urn:ebay:apis:eBLBaseComponents" xsi:type="ebl:ErrorType">
<ShortMessage xsi:type="xs:string">Internal Error</ShortMessage>
<LongMessage xsi:type="xs:string">Internal Error</LongMessage>
<ErrorCode xsi:type="xs:token">10001</ErrorCode>
<SeverityCode xmlns="urn:ebay:apis:eBLBaseComponents">Error</SeverityCode>
</Errors>
<Version xmlns="urn:ebay:apis:eBLBaseComponents">2.0</Version>
<Build xmlns="urn:ebay:apis:eBLBaseComponents">718216</Build>
</TransactionSearchResponse>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>


*Do not advertise in your signature

Share this post


Link to post
Share on other sites

You need to contact PayPal support about 10001 errors. They're the only ones that can help you.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Hi All,

 

First, let me say THANKS Brian!

 

I've had the 0.9.2 ver installed for a while successfully. I switched hosts and now have the option to run without register globals enabled. By the way, it's PHP 5.2.6 and SQL 5.0.51a on Apache 2.2.9.

 

Here's the problem. CC transactions work great, but when attempting Express Checkout, the customer logs in at PP, hits confirm and then is redirected back to the PP Login page. It appears the return URL or customer session is being nixed??

 

I tried upgrading to the most recent version, but that didn't change anything.

 

The two mods I tried to run without register globals are

1. http://www.oscommerce.com/community/contributions,2097

and

2. http://www.magic-seo-url.com/oscommerce/ti...lobals-off.html

 

Both mods have the same symptom. I found one solution in the associated forums, but it just broke more stuff.

 

I've seen some other references in this forum to running this contrib without register globals. Can anyone say which no globals patch worked for them or offer a solution to the redirect problem above. Thanks in advance!

 

Art

Share this post


Link to post
Share on other sites

Good Evening All,

 

My website suddenly started to loop the checkout process. I have PayPal Payments Pro and did a test purchase just after I had it setup and everything worked just peachy. Now after you input your credit card information at checkout_confirmation.php and click Confirm Order it redirects to the following address:

 

shopping_cart.php?error_message=

 

As you can see there is no error message there...

 

I have changed nothing, and yet this happens. Anyone have an idea or need some code posted?

 

THANK YOU VERY MUCH!

Share this post


Link to post
Share on other sites

Good morning,

 

I am currently having an issue where OSCommerce is not transferring the total weight of the shipment to PayPal in order to print a label, I have to manually enter it into PayPal.

 

Anybody know where that piece of code is within OSCommerce/WPP?

 

THANKS!!

 

Michael

Share this post


Link to post
Share on other sites

Hopefully someone can help with this problem (if it is a problem and not just they way things are).

 

1. I add an Item to my Cart

2. in my cart i select the 'Paypal express checkout' Button

3. i am sent to Paypal Sandbox

4. i login to paypal with my test buyer account

5. i select continue

8 i am returned to the Delivery information screen (shipping.php)

 

If the paypal email address i used is on file (i am a current customer), the shipping address in paypal is NOT returned, i have the correct option set in paypal - Express Checkout: Address Override PayPal

 

If the paypal email adress i used is NOT on file (New customer), the shipping address IS returned from paypal and an acount is created

 

Why is the ovveride setting not working? - or am i misinterprting how this should work.

Why is there No billing address (stays blank in both situations above)

 

other info to aide any diagnostic

I have shared SSL, which is working ok (redirects ok to Shared site for SSl required pages) (except admin which wont direct to ssl pages, even though admin set ok, but im not overly worried about that)

 

one further query, whilst i have your expert attention.

 

if i switch on IPN at Paypal (i know i dont need it as the request to paypal carries the return adress for WPP), will this send a packet to my store anyway for other transactions that may come through Ebay ?, will my website capture nd record ebay payment? - this is probably a dumb question! but thought i would ask.

 

hope i havnt put everyone to sleep....

 

regards

 

Smiler

Share this post


Link to post
Share on other sites
Good morning,

 

I am currently having an issue where OSCommerce is not transferring the total weight of the shipment to PayPal in order to print a label, I have to manually enter it into PayPal.

 

Anybody know where that piece of code is within OSCommerce/WPP?

 

THANKS!!

 

Michael

 

There is no provision to send the weight of the parcel to PayPal in either the Direct Payment or Express Checkout API, so it appears that PayPal can't accept this information other than manually.

 

--Glen

Share this post


Link to post
Share on other sites

Hi,

 

I just installed the PayPal WPP Direct Payment 1.02 and for some reason when I try to access the french version of my website http://www.giftwithabasket.com/index.php?language=fr it just come up with a blank web page. Not only that, of I try to just access http://www.giftwithabasket.com it will also show a blank page until I close the browser. Anyone experience this also and know the solution?

 

Thank You

Share this post


Link to post
Share on other sites
Hi,

 

I just installed the PayPal WPP Direct Payment 1.02 and for some reason when I try to access the french version of my website http://www.giftwithabasket.com/index.php?language=fr it just come up with a blank web page. Not only that, of I try to just access http://www.giftwithabasket.com it will also show a blank page until I close the browser. Anyone experience this also and know the solution?

 

Thank You

 

Hi all,

I found out what was the problem. First of all I found out how to turn on error output for php so I could tell what was going on. This was possible by creating a .htacces in the website root directory and adding these two lines at the end of the file:

 

php_flag display_errors on

php_value error_reporting 7

 

 

Once error messages were on I got the following error messages when trying to access the french version of the web page:

 

Warning: require(includes/paypal_wpp/languages/french/paypal_wpp.php) [function.require]: failed to open stream: No such file or directory in /includes/paypal_wpp/paypal_wpp_include.php on line 17

 

Warning: require(includes/paypal_wpp/languages/french/paypal_wpp.php) [function.require]: failed to open stream: No such file or directory in /includes/paypal_wpp/paypal_wpp_include.php on line 17

 

Fatal error: require() [function.require]: Failed opening required 'includes/paypal_wpp/languages/french/paypal_wpp.php' (include_path='.:.:.:') in /includes/paypal_wpp/paypal_wpp_include.php on line 17

 

 

So pretty much the french web page wasn't working because it couldn't find the file 'includes/paypal_wpp/languages/french/paypal_wpp.php'. I just made a duplicate of the english folder and renamed it to french and voila, problem solved.

Share this post


Link to post
Share on other sites

When a customer tries to pay with PayPal and uses bonus reward points for part of the payment PayPal will not accept the request. See the error response below. PayPal does not accept a negative value.

24 July 2008: "Apparently PayPal changed their server behavior so the negative value is no longer accepted."

 

Is there any fix for this problem?

 

In function: before_process()

Response from PayPal:

 

[security] = N/A

[RequesterCredentials]

[0]

[Credentials]

[0]

[username] = N/A

[Password] = N/A

[subject] = N/A

 

[DoExpressCheckoutPaymentResponse]

[0]

[Timestamp] = 2008-10-13T13:24:07Z

[Ack] = FailureWithWarning

[CorrelationID] = b89618454d14a

[Errors]

[0]

[shortMessage] = Invalid Data

[LongMessage] = Handling total is invalid.

[ErrorCode] = 10428

[severityCode] = Error

 

[1]

[shortMessage] = Transaction refused because of an invalid argument. See additional error messages for details.

[LongMessage] = The totals of the cart item amounts do not match order amounts.

[ErrorCode] = 10413

[severityCode] = Warning

Share this post


Link to post
Share on other sites
When a customer tries to pay with PayPal and uses bonus reward points for part of the payment PayPal will not accept the request. See the error response below. PayPal does not accept a negative value.

24 July 2008: "Apparently PayPal changed their server behavior so the negative value is no longer accepted."

 

Is there any fix for this problem?

 

Not exactly. You can look at the code in paypal_wpp.php that handles CCGV (trad) to see how it's handled there and add similar code to work with Bonus Reward Points.

 

If there were a way to turn off itemization of the contents of the shopping cart, that would work, too. I just checked the docs and this isn't available.

 

--Glen

Share this post


Link to post
Share on other sites

I've got the module installed but I just received and order that shows a "Order Total Discrepancy". The order was made using a coupon discount. The details of the order are posted below. I doubled check everything but did I miss something in the installation? Any help is appreciated.

 

Item Name: XXXX

Quantity: 12

 

Total: $47.40 USD

 

Item Name: Discount Coupon (5% off)

Quantity: 1

 

Total: -$2.37 USD

 

Item Name: Order Total Discrepancy

Item Number: -

 

Quantity: 1

 

Total: $2.37 USD

 

Cart Subtotal: $47.40 USD

Shipping: $19.44 USD

 

Cart Total: $66.84 USD

Share this post


Link to post
Share on other sites

Just posting this to help others out. This bug may be related to my use of SIDKiller contribution as well, which heavily modifies tep_href_link, but not sure.

 

Express Checkout ReturnURL was acting incredibly strange, if you passed a URL with multiple query string variables it would strip the & in the return.

 

Example URL passed:

http://yoursite.com/catalog/shopping_cart....osCsid=whatever

 

after entering the info in PayPal and hitting Continue it would redirect me to...

 

http://yoursite.com/catalog/shopping_cart....heckoutwhatever , with the &osCsid= completely removed.

 

-----------

 

So to make Express Checkout work I modified: /catalog/includes/modules/payment/paypal_wpp.php a bit.

 

Around line 582 or so, I changed this code:

$order_info['PAYPAL_RETURN_URL'] = tep_href_link(basename($_SERVER['SCRIPT_NAME']), 'action=express_checkout', 'SSL');

 

to

 

//$order_info['PAYPAL_RETURN_URL'] = tep_href_link(basename($_SERVER['SCRIPT_NAME']), 'action=express_checkout', 'SSL');

$temp_return_link = tep_href_link(basename($_SERVER['SCRIPT_NAME']), '', 'SSL');

$order_info['PAYPAL_RETURN_URL'] = $temp_return_link . '&action=express_checkout';

 

and it Express Checkout then worked. Hope this helps someone as this was confusing me for like 6 hours.

Share this post


Link to post
Share on other sites
I wonder if the first attempt times out so the customer hits back and try’s again. So the customers first attempt was succesful but he doesn't know it because he is faced with a white screen. I wish there was some screen it would go to after the customer clicks confirm order that would show that the order is being processed. Like an intermediate screen between checkout confirm and checkout success with a graphic that shows it is working and have it set so it doesn't timeout so fast.

 

I get the same type of behavior when I issue a refund. I click refund and wait a few seconds and I get the error that it fails. I get the error dump via email stating the failure also. The only problem is that the refund never fails. It is always successful. The code assumes failure because of a time constraint put on getting back a response.

 

this will fix part of your problem

http://addons.oscommerce.com/info/5654

 

the timing out often issue you will need to figure out, but this will cut down on many duplicate orders.


-Dave

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×