Jump to content
Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

On a separate note, once installed, I cannot get the link in the admin/orders page to open to "Add a Charge". It seems to get caught by Access Control. Do you have any comments on how to correct this where the "forbiden.php" page arrives?

 

Thanks,

Share this post


Link to post
Share on other sites

Hi,

I was after some help. I recently installed the WPP 1.0.2 on my MS2-060817 build without any problems. I recently decided to start using my CCGV(trad) module again, which had remained inactive for some time. I double checked all the files to make sure everythin was in good standing and started running some tests.

 

When i successfully do a coupon transaction, due to Order Total Discrepancy, it adds on the exact amount the coupon takes off. From what i read, this shouldn't happen with CCGV (only every other mod), so i've no clue why it does it.

 

Any help would be fantastic trying to get this to work

 

Cheers,

Mike

 

(Also Gift Voucher bit of CCGV doesn't seem to work at all - doesn't take anything off the total and charges the full amount.)

Edited by tehsphinx

Share this post


Link to post
Share on other sites

Can't seem to find any support thread for the Paypal Direct Payment v1.1 contribution so I'm going to try posting here to see if anyone knows.

 

I installed a module to allow direct credit card payments through Paypal (Paypal Website Payments Pro) and on the Admin Orders screen in Payment Method, it says "Mastercard" whenever a customer pays with a Mastercard, but shows a Visa logo. Same with Amex payments...shows a visa logo. Anyone know where I can adjust this? I looked through my admin/orders.php but cant' seem to figure out what file it calls out to for cc_type (I'm a total PHP noob...but trying to learn).

 

Thanks!

Share this post


Link to post
Share on other sites

I have installed this contrib, awesome! I only have one problem, when I click the Issue Refund or Add Charge, I get rerouted to my login page. AFter I type in my login info I get a 404 error. Any thoughts?

Share this post


Link to post
Share on other sites
Hi,

I was after some help. I recently installed the WPP 1.0.2 on my MS2-060817 build without any problems. I recently decided to start using my CCGV(trad) module again, which had remained inactive for some time. I double checked all the files to make sure everythin was in good standing and started running some tests.

 

When i successfully do a coupon transaction, due to Order Total Discrepancy, it adds on the exact amount the coupon takes off. From what i read, this shouldn't happen with CCGV (only every other mod), so i've no clue why it does it.

 

Any help would be fantastic trying to get this to work

 

Cheers,

Mike

 

(Also Gift Voucher bit of CCGV doesn't seem to work at all - doesn't take anything off the total and charges the full amount.)

Is Itemize/Aggregate option available.

 

If not change version as with coupons YOu need to aggregate the details sent to paypal.

 

I am not aware if there is an option or a module that allows itemize plus coupons to work together.

 

Satish


Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Share this post


Link to post
Share on other sites
I have an update that fixes the refund issues and a few other problems reported. This will also have better support for stores with "Display Price with Tax" set to true. I'll release it today after this problem is resolved.

 

I have been up and down this forum and don't see the fix for the refund issue. Has it been released yet?

 

I would like to say that this is a well written and executed contribution. I installed it last night and only had this issue and the one where this line is not in my shopping_cart.php

 

$initialize_checkout_methods = $payment_modules->checkout_initialization_method(); so I inserted the code here

 

				<td align="right" class="main"><?php echo '<a href="' . tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL') . '">' . tep_image_button('button_checkout.gif', IMAGE_BUTTON_CHECKOUT) . '</a>'; ?></td>
			<td width="10"><?php echo tep_draw_separator('pixel_trans.gif', '10', '1'); ?></td>
		  </tr>
		</table></td>
<?php 
//---PayPal WPP Modification START ---//
tep_paypal_wpp_ep_button(FILENAME_SHOPPING_CART);
 //---PayPal WPP Modification END ---// 
?>

 

And it seems to be formated correctly.

Share this post


Link to post
Share on other sites
I installed the module and made all of the modifications listed in the read me file except the one for the shopping_cart.php file. The code

 

<?php

$initialize_checkout_methods = $payment_modules->checkout_initialization_method();

 

does not exist in my file. I know I need to insert the replacement code but I'm not sure where to do it. Does anyone have any ideas?

 

 

Look here

 

http://forums.oscommerce.com/index.php?s=&...t&p=1300694

Share this post


Link to post
Share on other sites

Hi all,

 

I was getting this error message, and I don't know what it means. Could someone please tell me where I could have the list or possible error messages and what it means ? Or better yet, if anybody knows what is the meaning of the error messages ?

 

Note: This happens after I click on the "Confirm Order" button on the last step.

 

 

Invalid Configuration (10501)

This transaction cannot be processed due to an invalid merchant configuration.

 

Please help...

 

Thanks,

Chris

Share this post


Link to post
Share on other sites
Hi all,

 

I was getting this error message, and I don't know what it means. Could someone please tell me where I could have the list or possible error messages and what it means ? Or better yet, if anybody knows what is the meaning of the error messages ?

 

Note: This happens after I click on the "Confirm Order" button on the last step.

 

 

 

 

Please help...

 

Thanks,

Chris

 

Oops, sorry, I didn't notice there is this small search box under each forum section where I can find specific words within the "topic" scope.

 

Ok, thanks though!

Share this post


Link to post
Share on other sites

First post ever so sincere apologies if this is wrong and also more sincere apologies if this has been answered but after a good search and trying several things we still have a small problem sadly and hope someone can point us in the right direction.

 

After entering card details and clicking continue, rather than being taken to the confirm payment page, the page just refreshes like a reset button on a form and like the customer would've just arrived at the page again to enter card details for the first time.

Everything else seems to work perfectly.

 

Here's the diagnostic report that we're getting up to:

 

Basic Tests

Using at least PHP 4.3.0? Yes

Does your store have an SSL certificate installed and working? Yes

Is cURL installed? Yes

Does cURL work? (Simple HTTPS test) Yes

API Certificate installed? Yes

API Certificate directory protected? Yes

API Username in place? Yes

API Password in place? Yes

Database update in place? Yes

Payment class modifications in place? Yes

Bug in checkout_process.php fixed? [Read More] Yes

XML Document "doDirectPayment.xml" exists? Yes

XML Document "doExpressCheckout.xml" exists? Yes

XML Document "getExpressCheckoutDetails.xml" exists? Yes

XML Document "setExpressCheckout.xml" exists? Yes

XML Document "transactionSearch.xml" exists? Yes

XML Document "doCapture.xml" exists? Yes

XML Document "getTransactionDetails.xml" exists? Yes

XML Document "refundTransaction.xml" exists? Yes

Advanced Diagnostics

Able to connect to PayPal through cURL? Yes

Received a valid response? Yes

Did PayPal respond without errors? (If not, errors are below) No

Internal Error (10001)

Internal Error

Installation Incomplete!

Review and resolve the errors above and run this script again.

 

I've checked and double checked the installation and also checked that registed globals are on.

 

I'm sure it's something really stupid that we've missed but any help would be greatly appreciated.

Share this post


Link to post
Share on other sites

For those who were getting constant "loops" in the payment or shipping pages, I just (finally) found one error: In the Read_Me page, it states to make this change on checkout_shipping.php:

 

 

5. FIND the following line around line 446:

 

<td align="center" width="25%" class="checkoutBarTo"><?php echo CHECKOUT_BAR_PAYMENT; ?></td>

 

and REPLACE that line with these:

<?php 
 //---PayPal WPP Modification START ---//
 if ($show_payment_page || !$ec_enabled) { 
?>
           <td align="center" width="25%" class="checkoutBarTo"><?php echo CHECKOUT_BAR_PAYMENT; ?></td>
<?php	
 }
//---PayPal WPP Modification END ---//
?>

 

Now, I don't know how I missed this the first 49573458 times, but when checking through that many pages it's easy to miss something at the end of one. The problem was that my checkout_shipping did not have that line. Now that the replacement code is tucked in neatly above the "CHECKOUT_BAR_CONFIRMATION" line, I'm going to watch how this works with customers through the day, though I didn't get any errors when testing.

Share this post


Link to post
Share on other sites

I am using version 0.9.1 of PayPal WPP. I switched hosts and now get this error:

 

Your credit card was declined. Please try another card or contact your bank for more info.

Invalid Data (10525)

This transaction cannot be processed. The amount to be charged is zero.

 

When I changed hosts I copied all the files, tranferred the database, updated the config files and then updated the API certificate location. Did I miss something? I need to fix this ASAP.

Share this post


Link to post
Share on other sites
I am using version 0.9.1 of PayPal WPP. I switched hosts and now get this error:

 

Your credit card was declined. Please try another card or contact your bank for more info.

Invalid Data (10525)

This transaction cannot be processed. The amount to be charged is zero.

 

When I changed hosts I copied all the files, tranferred the database, updated the config files and then updated the API certificate location. Did I miss something? I need to fix this ASAP.

 

I checked the debug email and it does show [OrderTotal currencyID=USD]0.00[/OrderTotal] under [PaymentDetails]

Share this post


Link to post
Share on other sites

I think I fixed my problem. I don't really understand why it now works, though. I noticed that it was skipping the shipping selection and wasn't calculating tax. I reviewed the settings for the Order Total Module and the Shipping Module. I did't change any settings, but it now works fine. Scary.

Share this post


Link to post
Share on other sites

Hi

 

Great contrib,

 

I have WPP installed along with Discount Coupons (by KGT) .

 

Is order "discrepancy" supposed to show up when using express checkout along with a discount or is that some sort of security thing?

 

Anyone have this working with KGT's discount coupons? I see its been modified for CCGV, but that's not what I have installed.

 

Also how can I debug the express checkout info being sent to Paypal? I know the code is processed through checkout_process, but cant figure out how I can see whats being sent. Its getting tiresome having to complete a transaction each time I want to test my code.

 

Any help would be great.

Share this post


Link to post
Share on other sites
Hi

 

Great contrib,

 

I have WPP installed along with Discount Coupons (by KGT) .

 

Is order "discrepancy" supposed to show up when using express checkout along with a discount or is that some sort of security thing?

 

Anyone have this working with KGT's discount coupons? I see its been modified for CCGV, but that's not what I have installed.

 

Also how can I debug the express checkout info being sent to Paypal? I know the code is processed through checkout_process, but cant figure out how I can see whats being sent. Its getting tiresome having to complete a transaction each time I want to test my code.

 

Any help would be great.

 

Disregard I figured it out.

 

Possibly to help others -

 

One thing I noticed is Payapl doesn't 't seem to handle negative submitted values. I had to do the calculations separately and then subtract from the total. Not sure how it works with CCGV, I am using discount coupons by KGT all seems to work fine once integrated. I moved the coupon box from checkout payment to checkout shipping, so no need for the "payment page" to be enabled.

 

I just wanted the Express Checkout feature and this was the best contrib, so not sure how direct payment works.

 

Thanks dynamo for the great work..

Share this post


Link to post
Share on other sites

Hi,

 

I posted an issue a while back but didn't get an answer and am still having the issue on my live shop :(

 

It would seem that if you already have an account in OScommerce but don't sign in, rather click the PayPal express checkout. You then login and return back to your site. You select the delivery option and continue. When you try to proceed even though there is a large row at the top saying 'You are checking out with PayPal Express' an error is displayed saying 'No Checkout Method Selected'.

 

When you then select a different Payment method no values display on the screen. The payment address is empty but when you click on the payment address it brings up your details to select.

 

After further testing it would appear that this issue only occurs when you use PayPal express and you have an account on the store but haven't logged in to it. Somehow it reassociates the accounts after the PayPal selection - by email address? and then throws up errors / doesn't register variables.

 

If I try checking out with PayPal express without having an account in OSCommerce it works ok.

 

Does this issue sound familiar? - Anyone else having it or any pointers you can give me? - I really need to get this fixed as think I am losing customers :(

 

Many thanks

 

Mike

Share this post


Link to post
Share on other sites

Hi

 

Can someone please give some advice here.

 

I have the pre-installed Paypal direct that I have enabled but have found that it only sends the amount to paypal and not the address.

 

So I came accross this add-on and was wondering if it sends the billing address to Paypal?

 

Many thanks

 

B


Whats the point of a signature?

Share this post


Link to post
Share on other sites

We have an OS Commerce based website which has started throwing a Credit Card error from Paypal whenever anyone tries to pay, as follows:

 

Your credit card was declined. Please try another card or contact your bank for more info.

 

Field format error: 10513-This transaction cannot be processed. Please enter a last name.

 

I have had a look at the php code (I know basically nothing about OS Commerce) and the last name is held in the field paypalwpp_cc_lastname. If I do an echo

 

<tr><td><?php echo 'Last name = ' . $paypalwpp_cc_lastname?></td></tr>

 

 

at the end of the page then I get confirmation that the last name entered is being written to the variable, and yet I keep getting this error.

 

Can anyone provide any pointers as to what's going wrong?

 

Thanking you in advance.

Share this post


Link to post
Share on other sites
has anyone tried to apply paypal pay later into this contribution?

 

Yeah I will also need Paylater. l Haven't had a chance to look at the code for Paylater.

Edited by L!mit

Share this post


Link to post
Share on other sites

I juz upload to the server, and when I opened the index.php on browser it shows like this:

 

Fatal error: Call to undefined function tep_paypal_wpp_show_user_options() in /var/www/html/includes/header.php on line 68

 

What's wrong here then?

Share this post


Link to post
Share on other sites

Hi,

 

I'm currently using this module and have just started getting a strange error. The error seems to occur after deleting an order from the admin side and then making another order.

 

Basically I can successfully perform a transaction on checkout but the SQL to add an entry to the orders_status_history_transactions table for the key it is trying to enter already exists.

 

I'm not sure how the code calculates the next key it requires and also not sure if this is a bug or something I've done wrong. Any advice would really be appreciated!

 

Thanks

 

Mike

 

P.S Error Below:

 

1062 - Duplicate entry '11' for key 1

 

INSERT INTO orders_status_history_transactions (

 

`orders_status_history_id`, `transaction_id`,

 

`transaction_type`, `payment_type`, `payment_status`,

 

`transaction_amount`, `module_code`,

 

`transaction_avs`, `transaction_cvv2`,

 

`transaction_msgs` ) VALUES ( 11,

 

'2SX03103X3483513H', 'AUTHORIZATION', 'INSTANT',

 

'PENDING', 3.56, 'paypal_wpp', 'UK-specific “X”

 

Address and Postal Code', 'Match CVV2',

 

'authorization' )

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Hi

 

In addition to my last problem I am having problems installing another contribution which I think would be of benefit to lots of shops.

 

I am trying to install 'Points and Rewards v2.1' and I guess it works in a similar concept to CCGV which you have provided support for.

 

The issue I am having is that a customer can redeem collected points against the cost of the item and although on the checkout_confirmation page, it will show an amended total to be paid, PayPal takes the complete amount.

 

I am guessing that some modification would need to be done in paypal_wpp.php and I can see reference to ccgv in wpp_generate_PDI but I'm not an expert on this as to what I should change to allow the transaction amount to become modified.

 

Would really appreciate any pointers, you may have come across this before?

 

Thanks

 

Mike

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×