Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Sign in to follow this  
dynamoeffects

PayPal WPP Direct Payments & Express Checkout Support

Recommended Posts

I'm having a nightmare.

 

I have had to move my store to a new server and now my payments don't work as it says the API is missing. I assume that this could be the user name or password that has somehow got lost in the move?

 

Unfortunately I cannot access my admin side either as my password that previously worked does not.

 

Any advice would be gratefully received.

Share this post


Link to post
Share on other sites

Did you remember to update your configure.php file in the /admin/includes/ directory?


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

@Schadeboy: That's caused by a PayPal programmer introducing a bug into their server software, then pushing it live. Nothing you could've done to prevent it.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

yes updated this but the actual full path has changed. I now have access but this module is not working.

 

If the path to API changes (which mine has) will I need to reinstall the module? I have manually changed the database path in the hope to get it working but its as if the module does not exist.

 

Is there any other files I can manually edit that contans the correct server path as all my admin side is messed up at the moment and payments cannot be processed.

 

Thanks for the speedy reply as usual

Share this post


Link to post
Share on other sites

Oh, also open up the module's settings in your admin and change the path to the certificate. That could also be a problem.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

i just want to confirm that paypal wpp 0.9.2 supports CCGS(trad)? i plan on installing it for the discount coupon code.

Share this post


Link to post
Share on other sites

I have had confirmation that ammex cards are not supported by paypal pro uk - is there any easy way to remove this from the list in the checkout_payment without breaking anything?

 

Thanks

Share this post


Link to post
Share on other sites

@jasyn: Yes, it supports CCGV(trad). Any other discount coupon contribution will cause the orders' item lists at paypal show up with "Order Total Discrepancy" instead of the coupon details.

 

@Olly: Change these lines:

	  $accepted_card_types = array(array('id' => 'Visa', 'text' => 'Visa'),
							   array('id' => 'MasterCard', 'text' => 'MasterCard'),
							   array('id' => 'Discover', 'text' => 'Discover'),
							   array('id' => 'Amex', 'text' => 'American Express'));
  if (MODULE_PAYMENT_PAYPAL_DP_UK_ENABLED == 'Yes') {
	$accepted_card_types[] = array('id' => 'Solo', 'text' => 'Solo');
	$accepted_card_types[] = array('id' => 'Switch', 'text' => 'Switch');
  }

 

to this:

	  $accepted_card_types = array(array('id' => 'Visa', 'text' => 'Visa'),
							   array('id' => 'MasterCard', 'text' => 'MasterCard'),
							   array('id' => 'Discover', 'text' => 'Discover'));

  //Amex is not supported for UK merchants
  if (MODULE_PAYMENT_PAYPAL_DP_UK_ENABLED != 'Yes') {
	$accepted_card_types[] = array('id' => 'Amex', 'text' => 'American Express');
  } else {
	$accepted_card_types[] = array('id' => 'Solo', 'text' => 'Solo');
	$accepted_card_types[] = array('id' => 'Switch', 'text' => 'Switch');
  }

 

I've changed it in the soon-to-be 0.9.3 release like that.

Edited by dynamoeffects

Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites

Ok will do - thanks

 

Also getting errors today which may or may not be related to the server move. Not getting a response to these dumps

 

   [StartDate]2007-11-27T00:00:00-0700[/StartDate]
  [Payer]adxxxxxxxxxxxxxx[/Payer]
  [Amount currencyID="GBP"]61.68[/Amount]
[/TransactionSearchRequest]
 [/TransactionSearchReq]
[/soap:Body]
[/soap:Envelope]---------------------------------------------------------------------
-------------------------------FINAL_REQ-----------------------------
-------------------This is the response from PayPal------------------
---------------------------------------------------------------------
Array
(
[Security] => 
[RequesterCredentials] => Array
	(
		[0] => Array
			(
				[Credentials] => Array
					(
						[0] => Array
							(
								[Username] => sales_api1.jbosolutions.co.uk
								[Password] => D3P4RJQ83EJ5LCEE
								[Subject] => 
							)

					)

			)

	)

[faultcode] => SOAP-ENV:Client
[faultstring] => XML syntax error
)


---------------------------------------------------------------------
---------------------------------TS_REQ------------------------------
--------Results of the transaction search if it was executed---------
---------------------------------------------------------------------
Array
(
[Security] => 
[RequesterCredentials] => Array
	(
		[0] => Array
			(
				[Credentials] => Array
					(
						[0] => Array
							(
								[Username] => 
								[Password] => 
								[Subject] => 
							)

					)

			)

	)

[TransactionSearchResponse] => Array
	(
		[0] => Array
			(
				[Timestamp] => 2007-11-28T16:20:07Z
				[Ack] => Success
				[CorrelationID] => 645418f4bd280
				[Version] => 2.000000
				[Build] => 1.0006
			)

	)

)

 

Is this normal as the custoemr says they just get an error saying no response from paypal

Share this post


Link to post
Share on other sites
@Schadeboy: That's caused by a PayPal programmer introducing a bug into their server software, then pushing it live. Nothing you could've done to prevent it.

 

I had figured it was on PayPal's end. Fortunately it didn't last long.

 

I sure hope the bug was a direct result of PayPal trying to fix their tax charging issue that I've reported to them months ago, where their system is not properly charging sales tax on both the items a customer orders and the shipping charges. So far, the tax they charge, despite having the system set otherwise, is charging only on the items ordered. Arizona tax law requires tax on both items ordered and shipping.

 

Of course, if they've introduced a bug, I guess it doesn't matter what they were working on.


Brian (Schadeboy) Schade

CIO and Webmaster

Twilight Teez, LLC

 

"Camping is nature's way of promoting the hotel industry."

-Dave Barry

Share this post


Link to post
Share on other sites

Brian - I am curious about the upgrade process going from 0.8.2 (I believe that is my version) to the most current release. I tried the upgrade instructions, but found them to be somewhat confusing. When I was done, my system wouldn't work. I didn't have time to troubleshoot, and restored from backup. I'm wondering a couple of things:

 

1 - Is it worth upgrading to the latest version? Will I gain anything from moving to 0.9.2? I'm in the US and only process in US Dollars.

 

2 - Is it better to upgrade or try to do a clean install?

 

Thanks.


Brian (Schadeboy) Schade

CIO and Webmaster

Twilight Teez, LLC

 

"Camping is nature's way of promoting the hotel industry."

-Dave Barry

Share this post


Link to post
Share on other sites

Replying to my own post... I tried another unsuccessful Express Checkout this morning ... again everything runs fine on the server, except PayPal doesn't actually process the payment.... so I went and turned on debugging and did it again, and it worked!! Is this PayPal acting screwy or again am I missing something here?

 

 

Hey... got an issue that just showed up out of the blue and wanted to run it by you (I'm *sure* I've seen this discussed before, but I haven't been able to find it in older threads)...

 

I've got 0.9.2 installed, everything's been working smoothly for months... payments with credit cards runs fine, but now when someone uses Paypal Express Checkout, everything goes through ok except the actual paypal transfer doesn't take place. The last time I was testing on the site (with CCGV) was in mid-September, and everything worked like a champ so I'm stumped what the problem could be (or if it's just Paypal acting up on their side). No errors show up, just no money getting moved.

 

I haven't made any major changes in the checkout code since then (I just looked over the changes I did with a File comparison tool, and they were all cosmetic), just hoping someone can suggest a possible avenue to look at.

 

And a side note, thanks for all the work on this contribution... it's a great bit of work.

 

Brian

Share this post


Link to post
Share on other sites

@Schadeboy: I'd upgrade, if only for the "Retry" workaround where PayPal would just respond with "Retry" and send the customer back to the payment page. With newer versions, it will retry the transaction up to 10 times before giving up. 0.9.2's a stable version.

 

@haighworld: Not sure what turning on debugging would change, but sounds good. Sounds more like Paypal has been a little flaky lately.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
@Schadeboy: I'd upgrade, if only for the "Retry" workaround where PayPal would just respond with "Retry" and send the customer back to the payment page. With newer versions, it will retry the transaction up to 10 times before giving up. 0.9.2's a stable version.

 

The methodology of upgrading, as written in the instructions that come with the 0.9.2 aren't real clear. when I tried, as mentioned before, I ran into problems. I wasn't sure if I needed up upload all of the new files or what. Is upgrading a better path than trying to do a clean install? And is there a more clear set of upgrade instructions than "Follow the changelog"?

 

Frankly following the changelog leaves a lot of questions unanswered.

 

Thanks!

Edited by Schadeboy

Brian (Schadeboy) Schade

CIO and Webmaster

Twilight Teez, LLC

 

"Camping is nature's way of promoting the hotel industry."

-Dave Barry

Share this post


Link to post
Share on other sites

I'm putting through test transactions today and I am getting error 7

 

I just can't work out why I keep getting these errors. I listed one yesterday that I put through virtual terminal no problem but would not go through OSC.

 

Is anyone else having issues with paypal or is it my store?

Share this post


Link to post
Share on other sites

@Schadeboy: You should be able to get away with just updating the module itself and the XML files in /includes/wpp_xml/. The best method would be to compare the included files with your store using software like Beyond Compare and noting the differences.

 

@Olly: If it's an error "7", that sounds like a cURL error since PayPal errors are at least 5 digits long. That cURL error means that it couldn't connect to PayPal, so contact your host and make sure that you have permission to use cURL and ask if you're supposed to be using a proxy.


Please use the forums for support! I am happy to help you here, but I am unable to offer free technical support over instant messenger or e-mail.

Share this post


Link to post
Share on other sites
Interesting, so it looks like that session variable is getting wiped out somewhere. After I'm sure that the fixes I've made to the contribution work in a normal store, I'll install the register globals contrib to see what it's doing that would kill off certain variables.

 

Any further thoughts on this DE? I followed Roaddoctors issues with interest as his symptoms are identical to ours. Cheers! :thumbsup:

Share this post


Link to post
Share on other sites

Hi,

 

I posted here yesterday:

 

http://forums.oscommerce.com/index.php?showtopic=285495

 

I'm looking for help with Paypal Website payment pro.

 

I managed to get the module installed, If you clink the link above you will see how I have it configured. I think I have it right.

When I test everything, I can't add anything to the shopping cart,

 

 

I don't understand the part on the instruction that says I have to run a MySQL program, so paypal can access my database.

I'm not sure if the problems are related.

 

If you want to see what I mean here is my website:

 

www.nielsentradingco.com

 

also how do I merge my buttons & the paypal buttons? I had the "check out with paypal button on the shopping cart, but that seems to have disappeared.

 

I'm a newbie at this , so any help would be greatly appreciated!!

 

Thanks,

Sheri

Share this post


Link to post
Share on other sites

Hey Brian,

 

This has been running bullet proff for about 6 mths now and everything is great. Until today. Every card is getting declined. So I upgraded to the lastest version. Same thing.

 

Is anyone else having this problem. I didnt change any code, buy my ISP company has been tinkering with my email server lately. I wonder if they did some other back end 'update'

 

Any direction will be thankful

 

Thanks

Share this post


Link to post
Share on other sites
Hey Brian,

 

This has been running bullet proff for about 6 mths now and everything is great. Until today. Every card is getting declined. So I upgraded to the lastest version. Same thing.

 

Is anyone else having this problem. I didnt change any code, buy my ISP company has been tinkering with my email server lately. I wonder if they did some other back end 'update'

 

Any direction will be thankful

 

Thanks

 

This is the error I received before upgrading

 

2006 - MySQL server has gone away

update orders_status_history set comments = concat(if(trim(comments) != '', concat(trim(comments), ' '), ''), 'Transaction ID: 5Hxxx83xxxx67240F Payment Type: PayPal Direct Payment Payment Status: Completed AVS Code: Yes Address and five-digit ZIP CVV2 Code: Error') where orders_id = 2095

Share this post


Link to post
Share on other sites
Guest

So I am supposed to run:

 

mysql -u user -p dbname < paypal_wpp.sql

 

In my SQL?

 

I get this in MYPHP admin:

 

#1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql -u use -p db_p_os1 < paypal_wpp.sql' at line 1

 

I also get this in the osc admin:

 

Fatal error: Call to undefined function: tep_paypal_wpp_enabled() in /home/american/public_html/shoppe/includes/modules/payment/paypal_wpp.php on line 37

 

Can anyone me with this?

Share this post


Link to post
Share on other sites
Guest

i answered my own question.

 

Right on line 37 of the one error, the admin directory is mentioned. Make sure you change it to your own name, if you have been smart enough to change it to thwart the hackers.

 

Now it works just fine.

 

Thanks for another great contribution.

 

I feel Zenned. There is a balance in the world and my account.

Share this post


Link to post
Share on other sites

Hi All!

 

90% of my express checkout orders never return the phone number back to me.

 

I have this set as a mandatory option in my Paypal settings... but for some reason, it never gets returned. I have to log into paypal to get the number, and then manually enter it into my Oscommerce store.

 

Any tips / comments / suggestions on how I can debug this?

 

I must have something weird with my store since I don't see anyone else posting about this problem. :(

 

Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×