Jump to content
Sign in to follow this  
toasty

Attribute Sets Plus

Recommended Posts

Hello Chris,

 

I've installed this mod yesterday which seemd to go without a hitch. I'm able to make new lists en new options but i'm still having two problems at the moment.

 

1. In de product -> options-list. This list is empty. No products show up.

 

2. When i click attach for one on lists i've made i get the following error.

Warning: Invalid argument supplied for foreach() in /home/zeebra-zeefdruk.nl/public_html/tinta/webwinkel/admin/global_attribute_update.php on line 287.

 

I'm new to this sort of thing. So please dont get to technical.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Great contribution. It does 99% of what I need in a mod which is close enough for me.

 

I have run across one problem though. It might not even be the contribution.

 

I loaded the latest OSCommerce.

In order to keep from turning on globals I installed register_globals_v1.3a

Updated configuration and all still works well.

 

I installed the attribute set contribution and everything is functional for the most part. I just have one wee problem When I go to make edits to categories or products the following shows up.

 

I understand the headers thing and what the error means, just not where it is getting generated.

 

Warning: Cannot modify header information - headers already sent by (output started at /...../httpdocs/admin/includes/languages/english/categories.php:103) in /...../httpdocs/admin/includes/functions/general.php on line 22

 

As I looked at it and said "Hmmmm" I solved the problem. After the ?> at the end of the file I had an extra line. Something to look out for.

 

Cheers! Great work.

Move along.

Share this post


Link to post
Share on other sites
Hello Chris,

 

I've installed this mod yesterday which seemd to go without a hitch. I'm able to make new lists en new options but i'm still having two problems at the moment.

 

1. In de product -> options-list. This list is empty. No products show up.

 

2. When i click attach for one on lists i've made i get the following error.

Warning: Invalid argument supplied for foreach() in /home/zeebra-zeefdruk.nl/public_html/tinta/webwinkel/admin/global_attribute_update.php on line 287.

 

I'm new to this sort of thing. So please dont get to technical.

 

Thanks in advance.

 

Are you using standard osCommerce?

Either you are not or you have another contribution that uses the file 'global_attribute_update.php'

With proper integration ASP should work with just about any other contribution, but I'm afraid I can't help you because I have no idea what the file is or what it is doing and it would appear it is playing with attributes, which would appear to be conflicting with what ASP is trying to achieve.

 

regards

 

Chris.

Share this post


Link to post
Share on other sites
Are you using standard osCommerce?

Either you are not or you have another contribution that uses the file 'global_attribute_update.php'

With proper integration ASP should work with just about any other contribution, but I'm afraid I can't help you because I have no idea what the file is or what it is doing and it would appear it is playing with attributes, which would appear to be conflicting with what ASP is trying to achieve.

 

regards

 

Chris.

Hallo Chris,

 

Thanks for your swift responce. I've no idea if i'm using the startard version or not and if you dont know what the problem is i'm lost. Maybe in a couple of weeks i'll try again whan i've a little more experience with OSC.

Thanks anyway.

 

Best regards,

Joe

Share this post


Link to post
Share on other sites
Hallo Chris,

 

Thanks for your swift responce. I've no idea if i'm using the startard version or not and if you dont know what the problem is i'm lost. Maybe in a couple of weeks i'll try again whan i've a little more experience with OSC.

Thanks anyway.

 

Best regards,

Joe

 

On further investigation the file you have that is causing the problem is a part of the AttributesWizard contribution that would appear to directly conflict with this contribution. If you wish to use ASP I would suggest you remove that contribution.

 

regards

Chris.

Share this post


Link to post
Share on other sites

Hello,

 

just a little question; is anyone using this contrib together with QTPro?

 

This contrib seems to be exactly what I've been searching for, but I also need to set quantities for every products attributes.

 

I understood from previous posts in this forum that when the sets are created, oscommerce handles them the same as individually created attributes, so if that's correct there shouldn't be a problem I guess.

 

Thanks!

Share this post


Link to post
Share on other sites

First of all, thanks for sharing this script. I just have a little issue that i would like to ask, maybe some one has the same problem.

After I installed de script, it started to showing me products with attributes that have no stock.

?Does any one knows how to hide it from the final user?

Share this post


Link to post
Share on other sites

Hello again everyone!!

 

I am still having a problem with the sort order. I have been told by a few members that it could be a globals problem.

 

Someone told me that if I install the register globals patch that I would have a lot of difficulty since I have a bunch of contribs. installed. While others have told me that I could be open to security issues leaving the globals on, so I'm a little nervous changing it at all. If anyone has an opinion on this or knows what is right don't be afraid to PM me.

 

As for the SORT ORDER problem... if anyone has experienced this problem and solved it or found another way to control the order of the attributes on the output page product_info.php Please post it here or PM me or email, whatever! I'm desperate for this solution!

 

Thank you guys!!


James Tomasello

Share this post


Link to post
Share on other sites

I need to start out by saying I love this module, and thank you for developing it. I just installed it, and everythign 'works' fine (as far as how the module funcitons and is implemented), but I am having a problem.

 

Whenever I go to create a new item and I hit the finalizing "update" button. I get an error.

This error also occurs when ever I turn an items status from red to green and vice versa.

It seems as though any time the page is trying to 'redirect' back to the original page, this error comes up. It only happened after I installed this software. My entire site seems to still function, it is just when I get this error I have to press back to continue doing what I wanted to do (all the changes get made)

 

The error:

=========================

Warning: Cannot modify header information - headers already sent by (output started at /xxxxxx/shop/admin/includes/languages/english/categories.php:104) in /xxxxxx/shop/admin/includes/functions/general.php on line 22

=========================

 

My 'shop' directory is the same as the 'catalog' directory. Any help by anyone would be appreciated.

Share this post


Link to post
Share on other sites
Hello again everyone!!

 

I am still having a problem with the sort order. I have been told by a few members that it could be a globals problem.

 

Someone told me that if I install the register globals patch that I would have a lot of difficulty since I have a bunch of contribs. installed. While others have told me that I could be open to security issues leaving........

 

I found something strange. In the admin section I selected Attribute Sets and edited an existing set. If I re-order the options by the drop down menus and not the sort order, the order of options output on the product_info.php can be manipulated. I have been trying to adjust my code over and over to use the sort order as described in the initial install but it just won't change a thing. I'm not sure why this happened but it works time and time again. It would be much easier to change this through the Sort Order as some of my options add or subtract a dollar value. This must be changed manually right now. It's no big deal for now but if i need to offer more options per product it could get messy.

 

Thank you


James Tomasello

Share this post


Link to post
Share on other sites

One more thing.... How can I apply a set to, let's say 200 products at one time. If it's not possible now will it be possible in the near future? That would really help me as most of my products will have the same options and there are nearly 3,000 products and growing.


James Tomasello

Share this post


Link to post
Share on other sites
One more thing.... How can I apply a set to, let's say 200 products at one time. If it's not possible now will it be possible in the near future? That would really help me as most of my products will have the same options and there are nearly 3,000 products and growing.

 

With respect to the following lines:

$products_options_name_query = tep_db_query("

select distinct popt.products_options_id,

popt.products_options_name,

popt.products_options_type,

popt.products_options_length,

popt.products_options_comment

from " . TABLE_PRODUCTS_OPTIONS . " popt,

" . TABLE_PRODUCTS_ATTRIBUTES . " patrib

where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "'

and patrib.options_id = popt.products_options_id

and popt.language_id = '" . (int)$languages_id . "'

order by popt.products_options_id");

 

How do you want to sort you 'options'? I sort by product_options via id key, but you can sort any other way by indicating such in your PHP code. Or you could cheat, by going into the DB and changing the prod option ID...just make sure it is changed to the associated option values and attribute sets.

 

As to assigning to 200 products, I find making a "notepad" DB insert file for applying attrib sets to multiple products easier than one at a time. Simply make the file and then load into DB.

 

Just the way I do it...hope it helps.

Jim.

Share this post


Link to post
Share on other sites
As to assigning to 200 products, I find making a "notepad" DB insert file for applying attrib sets to multiple products easier than one at a time. Simply make the file and then load into DB.

 

Just the way I do it...hope it helps.

Jim.

 

 

Jim, could you give me an example of this db insert code?

Thanks

Share this post


Link to post
Share on other sites
Jim, could you give me an example of this db insert code?

Thanks

 

Hello Mattz0rr,

Here is an example of creating the product option all the way to the attribute set. From this example, you should be able to create your own INSERT statement for adding the attri set to the specific product(s).

J.

 

# First create the option

 

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 5, 1 , 'Personalize' , 1 , 15 , 'Enter Moms Maiden Name' );

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 5, 2 , '' , 1 , 15 , '' );

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 5, 3 , '' , 1 , 15 , '' );

 

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 6, 1 , 'Personalize' , 1 , 15 , 'Enter Child Name' );

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 6, 2 , '' , 1 , 15 , '' );

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 6, 3 , '' , 1 , 15 , '' );

 

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 7, 1 , 'Personalize' , 1 , 15 , 'Enter Child Birth Month' );

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 7, 2 , '' , 1 , 15 , '' );

INSERT into products_options (products_options_id , language_id , products_options_name , products_options_type , products_options_length , products_options_comment) VALUES( 7, 3 , '' , 1 , 15 , '' );

 

 

# Second - Create the option VALUES for the newly created option

# No values to enter as option is a text field

# INSERT INTO products_options_VALUES (products_options_VALUES_id , language_id , products_options_VALUES_name) VALUES ( 97 , 1 , 'A' );

 

 

# Third - Tie the option value to its respective product option

# Since no values to enter as option is a text field, there is no tying the two together

# INSERT INTO products_options_VALUES_to_products_options (products_options_VALUES_to_products_options_id, products_options_id, products_options_VALUES_id) VALUES ( 291 , 18 , 97 );

 

 

# Fourth - Create the Attribute Set

INSERT INTO products_attributes_sets ( products_attributes_sets_id , products_attributes_sets_name , products_options_id, attribute_set_sort ) VALUES ( 14 , 'Personalize Rocks' , 6 , 0 );

INSERT INTO products_attributes_sets ( products_attributes_sets_id , products_attributes_sets_name , products_options_id, attribute_set_sort ) VALUES ( 15 , 'Personalize Circa Birth Month' , 7 , 0 );

INSERT INTO products_attributes_sets ( products_attributes_sets_id , products_attributes_sets_name , products_options_id, attribute_set_sort ) VALUES ( 16 , 'Personalize Circa Birth Year' , 8 , 0 );

 

 

# Lastly - Tie the option VALUES (id) to the appropriate Attribute Set's Elements

INSERT INTO products_attributes_sets_elements (products_attributes_sets_elements_id, products_attributes_sets_id, options_VALUES_id, options_VALUES_price, price_prefix, sort_order) VALUES ( 27 , 14 , 22 , 0.0000 , '' , 1 );

INSERT INTO products_attributes_sets_elements (products_attributes_sets_elements_id, products_attributes_sets_id, options_VALUES_id, options_VALUES_price, price_prefix, sort_order) VALUES ( 28 , 15 , 22 , 0.0000 , '' , 1 );

INSERT INTO products_attributes_sets_elements (products_attributes_sets_elements_id, products_attributes_sets_id, options_VALUES_id, options_VALUES_price, price_prefix, sort_order) VALUES ( 29 , 16 , 22 , 0.0000 , '' , 1 );

 

 

# Import into your SQL DB and then use Admin Panel to tie Attribute Sets to specific Products

# or create additional INSERT Statements for tying AS to products.

# - Info Haven Productions, Inc. -

# Created: Feb 3, 2006

Share this post


Link to post
Share on other sites

First thanks for this contrib that save lots of my time,

 

I just want to report that the toasty package v1.01 works perfectly on my Install

 

on the other hand, I got some trouble with the last modif "Attribute Set - Increase Size" that bug when I try to link a product to a set with that error :

 

Attribute Sets Edit

1054 - Champ 'products_attributes_sets_value' inconnu dans field list

 

select products_attributes_sets_value FROM products_attributes_sets WHERE products_attributes_sets_id=3

 

[TEP STOP]

 

Anyway thanks a lot again for your great job

Share this post


Link to post
Share on other sites

I would like to put the options on the product info page in a certain order. This order is the order I added them in the attribute sets in admin. How would I do this?

 

Thanks

 

Jason

Share this post


Link to post
Share on other sites

Hi,

I tried to reproduce your problem but I was not able to.

 

on the other hand, I got some trouble with the last modif "Attribute Set - Increase Size" that bug when I try to link a product to a set with that error :

 

Attribute Sets Edit

1054 - Champ 'products_attributes_sets_value' inconnu dans field list

 

select products_attributes_sets_value FROM products_attributes_sets WHERE products_attributes_sets_id=3

 

[TEP STOP]

 

When I increase the size of an Attribute Set, then re-edit the Set and add the new attributes and afterwards try to add this modified Set to a product everything works fine on my system.

 

I would like to try and find out what exactly is causing this problem so I you would help me by giving me some more details on what exactly you did with the attribute set before you received this error your help would be highly appreciated.

Thanks.

Susan

Share this post


Link to post
Share on other sites
Hi,

I tried to reproduce your problem but I was not able to.

When I increase the size of an Attribute Set, then re-edit the Set and add the new attributes and afterwards try to add this modified Set to a product everything works fine on my system.

 

I would like to try and find out what exactly is causing this problem so I you would help me by giving me some more details on what exactly you did with the attribute set before you received this error your help would be highly appreciated.

Thanks.

Susan

 

Hi Sue,

Thank you for contributing the additional code - welcome aboard!

When I do the next full release I'll wrap it in - provided it works of course :-)

It won't be for a while yet as I'm away but I'm sure you've made some folk happy in the meantime.

all the best

Chris.

Share this post


Link to post
Share on other sites

is there any way to set up attribute set plus to work with the seprate price (SPPC) contribution?


What would you do if you knew you could not fail?

Share this post


Link to post
Share on other sites
I would like to put the options on the product info page in a certain order. This order is the order I added them in the attribute sets in admin. How would I do this?

 

Thanks

 

Jason

 

Hello Jason,

Look to the product_info.php file (forget what line number...different based on contrib anyways) and look to the the following lines to edit how you'll sort your options or option values:

 

$products_options_name_query = tep_db_query("

select distinct popt.products_options_id,

popt.products_options_name,

popt.products_options_type,

popt.products_options_length,

popt.products_options_comment

from " . TABLE_PRODUCTS_OPTIONS . " popt,

" . TABLE_PRODUCTS_ATTRIBUTES . " patrib

where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "'

and patrib.options_id = popt.products_options_id

and popt.language_id = '" . (int)$languages_id . "'

order by popt.products_options_id");

 

Hope this helps.

Jim.

Share this post


Link to post
Share on other sites
Hello Jason,

Look to the product_info.php file (forget what line number...different based on contrib anyways) and look to the the following lines to edit how you'll sort your options or option values:

 

$products_options_name_query = tep_db_query("

select distinct popt.products_options_id,

popt.products_options_name,

popt.products_options_type,

popt.products_options_length,

popt.products_options_comment

from " . TABLE_PRODUCTS_OPTIONS . " popt,

" . TABLE_PRODUCTS_ATTRIBUTES . " patrib

where patrib.products_id='" . (int)$HTTP_GET_VARS['products_id'] . "'

and patrib.options_id = popt.products_options_id

and popt.language_id = '" . (int)$languages_id . "'

order by popt.products_options_id");

 

Hope this helps.

Jim.

 

Thanks!

Share this post


Link to post
Share on other sites

I've just installed the Attribute Set Plus v1.01.

 

I added a number of attributes, such as colour, size, etc. After testing them on around a dousen of my products (without errors) I though I'd apply the attributes to the remainder of my products.

 

I now receive the following error:

1104 - The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay

SELECT pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix , pase.sort_order FROM products_attributes pa, products_attributes_sets_to_products pas2pa, products_attributes_sets pas, products_attributes_sets_elements pase, products_options_values pov WHERE pa.products_id = '222' AND pa.options_id = '1' AND pas2pa.products_id = pa.products_id AND pas.products_attributes_sets_id = pas2pa.products_attributes_sets_id AND pas.products_options_id = pa.options_id AND pase.products_attributes_sets_id = pas.products_attributes_sets_id AND pase.options_values_id = pa.options_values_id AND pov.products_options_values_id = pa.options_values_id AND pov.language_id = '1' ORDER BY pase.sort_order, pa.options_values_id

[TEP STOP]

 

Any ideas?


Jonathan Cole

=ASY=jof

Share this post


Link to post
Share on other sites

First off... thanks for a great contribution. Works great so far!

 

I manage to install with very little issues. Added options, attributes, etc. Everything seemed to work flawlessly until I noticed today that couldn't delete any products. New or old.

 

I've tried everything from creating a new product and deleting it, to editing and removing all data. Nothing I do will allow me to delete any of my products. When I click the delete buttom, i get the confirm delete. When I click that, the page simply refreshes and the deleted product is still there. I can delete categories with issues.

 

I've looked through the database and the products are there.

 

If I replace the modified categories.php file with my previous one, deleting products works fine.

 

Anyone have any ideas? Oh ya... by testing this, I manage to delete all the products in my db. Luckily i had a backup. Lets hope it works.

 

Any help would be greatly appreciated.

 

Shayne

Share this post


Link to post
Share on other sites
First off... thanks for a great contribution. Works great so far!

 

I manage to install with very little issues. Added options, attributes, etc. Everything seemed to work flawlessly until I noticed today that couldn't delete any products. New or old.

 

I've tried everything from creating a new product and deleting it, to editing and removing all data. Nothing I do will allow me to delete any of my products. When I click the delete buttom, i get the confirm delete. When I click that, the page simply refreshes and the deleted product is still there. I can delete categories with issues.

 

I've looked through the database and the products are there.

 

If I replace the modified categories.php file with my previous one, deleting products works fine.

 

Anyone have any ideas? Oh ya... by testing this, I manage to delete all the products in my db. Luckily i had a backup. Lets hope it works.

 

Any help would be greatly appreciated.

 

Shayne

 

Hi Shayne

My suggestion would be to go to backup and re-add your categories.php edits.

regards

Chris.

Edited by toasty

Share this post


Link to post
Share on other sites
I've just installed the Attribute Set Plus v1.01.

 

I added a number of attributes, such as colour, size, etc. After testing them on around a dousen of my products (without errors) I though I'd apply the attributes to the remainder of my products.

 

I now receive the following error:

1104 - The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET SQL_MAX_JOIN_SIZE=# if the SELECT is okay

SELECT pov.products_options_values_id, pov.products_options_values_name, pa.options_values_price, pa.price_prefix , pase.sort_order FROM products_attributes pa, products_attributes_sets_to_products pas2pa, products_attributes_sets pas, products_attributes_sets_elements pase, products_options_values pov WHERE pa.products_id = '222' AND pa.options_id = '1' AND pas2pa.products_id = pa.products_id AND pas.products_attributes_sets_id = pas2pa.products_attributes_sets_id AND pas.products_options_id = pa.options_id AND pase.products_attributes_sets_id = pas.products_attributes_sets_id AND pase.options_values_id = pa.options_values_id AND pov.products_options_values_id = pa.options_values_id AND pov.language_id = '1' ORDER BY pase.sort_order, pa.options_values_id

[TEP STOP]

 

Any ideas?

 

Ideas?...yeah: do what is says and SET_BIG_SELECTS=1

But seriously, I would need to look at the osC code to answer this (whihc I do not have time for just now). Another option is to increase the max join size or set big selects = 1 in your mysql config file.

Out of interest How many products/attributes do you have?

cheers

C.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×