Jump to content
Sign in to follow this  
enigma1

Active Countries

Recommended Posts

Sorry if this has been addressed, but I recently installed this module and it's great!

 

When a person is creating an account there was an error that line 462 had an extra } which I had to delete. Just wanted to see if anyone else had that problem.

 

 

What file did you have the error in and what version of sCommerce? Ms2.2 orMs2.2 RC1?

I was installing on MS2.2RC1 and needed to add a } in catalog\create_account.php after the block of code refered to in step 3-e of the latest install file.


Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites
now I got a problem login in my admin:

Fatal error: Cannot redeclare tep_validate_password() (previously declared in /home/content//html/catalog/admin/includes/functions/password_funcs.php:16) in /home/content/html/catalog/admin/includes/functions/password_funcs.php on line 16

 

now do I fix this problem?

 

When installing on MS2.2RC1 look in admin/login.php

find:

require('includes/functions/password_funcs.php');

and comment it out as it has been added to application top with the install of this contribution.

If using an earlier version of osCommerce check the admin/index.php, or do an admin folder search, for the same line.

Edited by Glcustoms

Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Share this post


Link to post
Share on other sites

This is a good contribution to install but if its not going to be working with the top wanted contributions such as sppc then its is quite hard to work with :(

 

Has anyone got this to work with sppc yet?

 

I been working on it but i am stuck at a point where it states "Parse error: syntax error, unexpected '}' in .......\catalog\admin\customers.php on line 2027"

 

Most of the problems occuring are in this file.

 

I think everything from catalog side for customer works fine. Just the admin side doesn't as soon as you click on customer from the left menu in admin

 

  } elseif( $action == 'ab_edit' && isset($HTTP_GET_VARS['cID']) && tep_not_null($HTTP_GET_VARS['cID']) ) {

 

I am a novice in php but am trying to find this extra parenthesis so i can delete it but i can't.

 

If i can get this to work i will share my customer.php file with you all with proper commenting as to where to change what. Have spent more then a day in doing this commenting.

 

Any chance anyone have any suggestions to this?

 

Below is the a bit of the surrounding code if this helps to find the extra parenthesis or give some insight as to how i find this extra parenthesis:

 

            <td class="main" colspan="2"><?php if ($cInfo->customers_tax_rate_exempt_settings == '1') {
	echo $customers_specific_taxes_exempt;
    } else {
	echo ENTRY_CUSTOMERS_TAX_RATES_DEFAULT;
    } 
    echo tep_draw_hidden_field('customers_specific_taxes_exempt'); ?></td>
  </tr>
<?php 
} // end else: $processed == true
?>
   </td>
  </tr>
 </table>
</td>
     </tr>
<!-- EOC - Separate Pricing Per Customer v4.20 -->

<!-- BOC - Active Countries v2.11 -->
         <tr>
           <td><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>
         </tr>

         <tr>
           <td class="formAreaTitle"><?php echo CATEGORY_OPTIONS; ?></td>
         </tr>
         <tr>
           <td class="formArea"><table border="0" cellspacing="2" cellpadding="2">
             <tr>
               <td class="main"><?php echo ENTRY_NEWSLETTER; ?></td>
               <td class="main">
<?php
   echo tep_draw_pull_down_menu('customers_newsletter', $newsletter_array, (($cInfo->customers_newsletter == '1') ? '1' : '0'));
?>
               </td>
             </tr>
             <tr>
               <td class="main"><?php echo ENTRY_ACCOUNT_NOTIFY; ?></td>
               <td class="main">
<?php
   echo tep_draw_checkbox_field('email_notify', '', true);
?>
               </td>
             </tr>
           </table></td>
         </tr>
         <tr>
           <td><?php echo tep_draw_separator('pixel_trans.gif', '1', '10'); ?></td>
         </tr>
         <tr>
<?php
   if( isset($HTTP_GET_VARS['cID']) && tep_not_null($HTTP_GET_VARS['cID']) ) {
?>
           <td align="right" class="main"><?php echo tep_image_submit('button_update.gif', IMAGE_UPDATE) . ' <a href="' . tep_href_link(FILENAME_CUSTOMERS, tep_get_all_get_params(array('action'))) .'">' . tep_image_button('button_cancel.gif', IMAGE_CANCEL) . '</a>'; ?></td>
<?php
   } else {
?>
           <td align="right" class="main"><?php echo tep_image_submit('button_insert.gif', IMAGE_INSERT) . ' <a href="' . tep_href_link(FILENAME_CUSTOMERS, tep_get_all_get_params(array('action'))) .'">' . tep_image_button('button_cancel.gif', IMAGE_CANCEL) . '</a>'; ?></td>
<?php
   }
?>
         </tr>
       </table></form></td>
     </tr>

<?php
 } elseif( $action == 'ab_edit' && isset($HTTP_GET_VARS['cID']) && tep_not_null($HTTP_GET_VARS['cID']) ) {
   $customers_query = tep_db_query("select CONCAT(customers_firstname, ' ', customers_lastname) as fullname, customers_default_address_id as default_address_id from " . TABLE_CUSTOMERS . " where customers_id = '" . (int)$HTTP_GET_VARS['cID'] . "'");
   $customers_array = tep_db_fetch_array($customers_query);
   $new_flag = false;
   if( isset($HTTP_GET_VARS['abID']) && tep_not_null($HTTP_GET_VARS['abID']) ) {
     $address_book_query_raw = "select * from " . TABLE_ADDRESS_BOOK . " where customers_id = '" . (int)$HTTP_GET_VARS['cID'] . "'";
     $address_book_split = new splitPageResults($page_index, 1, $address_book_query_raw, $address_book_query_numrows, 'address_book_id');
     $address_book_query = tep_db_query($address_book_query_raw);
     $address_book = tep_db_fetch_array($address_book_query);
   } elseif( isset($abInfo) && is_object($abInfo) ) {

 

Using latest oscommerce RC2

Share this post


Link to post
Share on other sites

hmmm .. i think i have gotten it working with sppc now.

 

There is only one problem now .. when you click on a customer to view customer details in admin everything works fine but now i see a new section called "Password (required for new accounts)" and in this box i am getting this error:

 

Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in ...\catalog\admin\includes\functions\database.php on line 99

 

I don't understand what this problem is. Anyone help?

Share this post


Link to post
Share on other sites

Hi! I have installed Active Countries version 2.11 and I receive an error: "Invalid country for shipping". It appears during checkout on the checkout_shipping_address.php for the customers who use Purchase Without Account. Any help is appreciated. I have 2.2 MS2. Thank you!

Share this post


Link to post
Share on other sites

Hey all

 

I installed this Contrib in 2.2 RC2a and at first I had the problem with the z.zone errors which I fixed.

 

However, even before the fix and still after the fix, I have the field names showing up all over. So instead of Catalog on the top menu I see HEADER_TITLE_CATALOG

 

It's like this everywhere.

 

Can anyone help?

 

Thanks,

Chris

Share this post


Link to post
Share on other sites

I've been using this contribution for a few years now..was easy to install and all (I'm not a programmer or know any programming), but the other week I was emailed by a customer who said that on their end the country on their order in their account history shows "array" instead of the name of the country. Anyone know a fix for this? I posted this on another thread and was told to redo my site with rc2a, but before I do that, I'd like to see if there's a quicker, less painful fix for it

 

ArrayError.jpg

Share this post


Link to post
Share on other sites

I just need the sort order for the countries, do I have to install the whole thing ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×