Jump to content
Sign in to follow this  
SteveOh

2checkout parameter error

Recommended Posts

Hello,

 

When I am using the pm2checkout module, the latest version in contribs section. When I confirm checkout and get sent to 2checkout page I get this error:

 

Parameter Error

 

 

Incorrect parameters were supplied, therefore this purchase cannot begin.

 

If you are attempting to purchase from a web site please contact the web site so that they can correct the error.

 

Here are the values that get past:

 

<form onKeyUp="highlight(event)" onClick="highlight(event)" onKeyUp="highlight(event)" onClick="highlight(event)"  name="checkout_confirmation" action="https://www2.2checkout.com/2co/buyer/purchase" method="post" onsubmit="return check_agree(this);">
<input type="hidden" name="c_prod_0" value="29,2">
<input type="hidden" name="sh_cost" value="15">
<input type="hidden" name="x_login" value="428603">
<input type="hidden" name="x_amount" value="7315.80">
<input type="hidden" name="x_invoice_num" value="20050928150047">
<input type="hidden" name="demo" value="Y">
<input type="hidden" name="fixed" value="Y">
<input type="hidden" name="id_type" value="2">
<input type="hidden" name="x_first_name" value="tester">
<input type="hidden" name="x_last_name" value="tester">
<input type="hidden" name="x_address" value="555 elm st">
<input type="hidden" name="x_city" value="555 Elm St">
<input type="hidden" name="x_state" value="Ontario">
<input type="hidden" name="x_zip" value="L5R 2T4">
<input type="hidden" name="x_country" value="Canada">
<input type="hidden" name="x_email" value="steve@overlee.com">
<input type="hidden" name="x_phone" value="555-555-5555">
<input type="hidden" name="x_ship_to_first_name" value="tester">
<input type="hidden" name="x_ship_to_last_name" value="tester">
<input type="hidden" name="x_ship_to_address" value="555 elm st">
<input type="hidden" name="x_ship_to_city" value="555 Elm St">
<input type="hidden" name="x_ship_to_state" value="Ontario">
<input type="hidden" name="x_ship_to_zip" value="L5R 2T4">
<input type="hidden" name="x_ship_to_country" value="Canada">
<input type="hidden" name="tco_currency" value="USD">
<input type="hidden" name="pay_method" value="CC">
<input type="hidden" name="x_email_merchant" value="TRUE">

 

I can't see what parameter is wrong? Can someone tell me what's wrong here, thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×