Jump to content
Sign in to follow this  
lalelunet

AttributesWizzard

Recommended Posts

Guest

Hi There,

 

I have a question that I need to have answered before I proceed wih the install of the attributewizzard.

 

The Setup document says

 

2 Copy following directories/files to shop/admin

- directory /images

- directory /price_lists

- file price_update.php

- file global_attribute_update.php

 

I have the images directory and the 2 files but I don't have the price_lists directory in the contribution that I downloaded. Can you advise as to why I don't have these in the contribution to download. Are there actually files in these directories that I need?

 

Any help would be appreciated.

 

Ian

Share this post


Link to post
Share on other sites
Guest

I installed attributesWizzard but it doesn't work...

 

got this message now,

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes values ('', '31', '3', '12', '', '+')

 

[TEP STOP]

 

did i do something wrong? or did i miss something?

 

Thanks,

 

Peter

Share this post


Link to post
Share on other sites
I'm stuck, I didn't see this anywhere else in this forum.

when I click on "Products options" I get this message.

"SQL inquiry is invalid. Unknown column 'alle' in 'field list'"

any thoughts on how I could fix this?

Thanks.

jon jackson

jon -a- crossoverts.com

 

This errormessage call that there is a missing table in your database. Check that you execute all database orders from the database.txt that you found in the download from aw


Greetings Thomas

Share this post


Link to post
Share on other sites
I've installed this and everything seems to be working ok, except for one thing. The sort order on the options seems to have no effect on how the options are sorted on the product listing. They just seem to be appearing in random order.

 

http://forums.oscommerce.com/index.php?s=&...st&p=763091

http://forums.oscommerce.com/index.php?s=&...st&p=764429


Greetings Thomas

Share this post


Link to post
Share on other sites
I have two questions please....... For the multi language, I need it to work with FRENCH, not English German or Spanish. What is the number needed ?

 

And also to the multi lang function; is there going to be a multi lang function any time soon...?

 

Check your database. Take a look at the table "languages". There you will find the language_id.


Greetings Thomas

Share this post


Link to post
Share on other sites
First of all, sorry for the frequent posts above. I just started from scratch, i.e. a clean OSC install, and everything's good.

 

I was wondering, however, if it's possible to assign an options list to specific choices in another option list. Here's an example:

 

Let's say I'm selling one style of pants. With waist size 32, the inseam choices are 33, 34, and 35. With waist size 34, the inseam choices are 35, 36, and 37. Is it possible when the customer chooses waist size 32, the inseam options show only 33, 34, 35, and not 35, 36, 37?

 

If not, is there another contribute that does this? Thanks in advance.

 

There is no fast solution for your problem with aw. You can do the following:

 

Create a list with all waist sizes inside. Then use the "copy-list" funktion for every size you offer and then just delete the lower sizes. There is no other solution I can offer you in the moment.


Greetings Thomas

Share this post


Link to post
Share on other sites
Hello all,

 

I need some help with this one. I have added a list and attached it to several products, BUT . . . It doesn't show up in my store. No attributes at all. Is there something obvious I'm missing here?

 

Thank you all,

~Mark

 

Check your language settings in the config file.


Greetings Thomas

Share this post


Link to post
Share on other sites
Hi Thomas,

 

I love this contribution and it has saved me literally hundreds of hours of work. Excellent Job! However I have one problem:

 

Everything works perfect EXCEPT when I add a new option value in the original Products Attributes panel. It stays, but only until I click save in AW then everything gets overwritten.

 

You had posted:

So I now understand what's going on. Before I just wondered where my attribute went!!! ;)

 

My problem is that I sell 1 item which allows the user to enter custom text which will appear on the item. I use the Option Type contribution to do this and it works fine for my needs.

 

Note: this is 1 option on 1 product and the only way I can see to do it is through the orginal Products Attributes panel.

 

Is there anyway to manually insert this into the database so your contrib won't erase it? or maybe someway to lock that one row after it's added so it doesn't get overwritten? There has to be someway around this, right? please? I only need 1 product to do this.

 

Thank you!

 

can you post the values from this option?


Greetings Thomas

Share this post


Link to post
Share on other sites
I am getting this error when I click on save

 

SQL Abfrage ist ung?ltig. Unknown column 'sort_order' in 'field list'

 

what does this mean? please let me know

thank you

 

 

This errormessage call that there is a missing table in your database. Check that you execute all database orders from the database.txt that you found in the download from aw


Greetings Thomas

Share this post


Link to post
Share on other sites
I am getting this error when I click on save

 

SQL Abfrage ist ung?ltig. Unknown column 'sort_order' in 'field list'

 

what does this mean? please let me know

thank you

 

 

This errormessage call that there is a missing table in your database. Check that you execute all database orders from the database.txt that you found in the download from aw


Greetings Thomas

Share this post


Link to post
Share on other sites
Hi There,

 

I have a question that I need to have answered before I proceed wih the install of the attributewizzard.

 

The Setup document says

 

2 Copy following directories/files to shop/admin

- directory /images

- directory /price_lists

- file price_update.php

- file global_attribute_update.php

 

I have the images directory and the 2 files but I don't have the price_lists directory in the contribution that I downloaded. Can you advise as to why I don't have these in the contribution to download. Are there actually files in these directories that I need?

 

Any help would be appreciated.

 

Ian

 

Just create the directory. It was used to store the price-lists in txt-format. There a no files inside at a new install.


Greetings Thomas

Share this post


Link to post
Share on other sites
I installed attributesWizzard but it doesn't work...

 

got this message now,

 

1136 - Column count doesn't match value count at row 1

 

insert into products_attributes values ('', '31', '3', '12', '', '+')

 

[TEP STOP]

 

did i do something wrong? or did i miss something?

 

Thanks,

 

Peter

 

At what point did this error occures?


Greetings Thomas

Share this post


Link to post
Share on other sites
can you post the values from this option?

 

What exactlty do you mean by values of this option?

 

I'll do my best to give a start on this:

 

from Products Description table:

3494	1	Create Your Own Product	Urinal Screen Deodorized and available in Blue or ...	 	8

 

from Products Attributes table:

68619	0	3494	49	203	0.0000	+	2

 

 

from Products Options:

49	1	Enter your custom text	0	1	32

 

There's a bit more but essentially the product # is 3494

 

and the options ID is 49

 

In short I want everything in your wonderful mod to work as normal, except I don't want this one product/options to be overwritten.

 

I could add this as the first product/attribute and have everything after that change... or I don't know.

 

 

 

 

I had thought of a workaround for this::::

 

Essentially it would create another column next to language_id, maybe 'trigger_id' or something. All products in the store would have a 'trigger_id' of '1' except for my custom product I don't want changed which would have a 'trigger_id' of '0'. Then perhaps edit the "global_attribute_update.php" file to only update those products with a 'trigger_id' of '1'??? Would that work? Or am I completely wrong.

Share this post


Link to post
Share on other sites
......

Would that work? Or am I completely wrong.

 

Maybe that works. I create a small (untested :-" ) hack for you. Give me your mail address that I can send you the files.


Greetings Thomas

Share this post


Link to post
Share on other sites
Maybe that works. I create a small (untested :-" ) hack for you. Give me your mail address that I can send you the files.

 

Thank you very much!

 

email address: ripthesystem@usa.net

 

I've been working on my own hack but I can't seem to figure it out. If you could send me something to work with it might be a much better start!! Thanks!

Share this post


Link to post
Share on other sites

Hi there,

Any working sites with this contribution, that I can see before I install it?

 

What I want to achive is a look like this site Click Here

 

thanks.

Kunal

Share this post


Link to post
Share on other sites

i'm getting the following error when trying to run the sql query as part of the installation:

 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ALTER TABLE `products_options_values` CHANGE `products_options_v

 

any idea what's up

Share this post


Link to post
Share on other sites
i'm getting the following error when trying to run the sql query as part of the installation:

 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ALTER TABLE `products_options_values` CHANGE `products_options_v

 

any idea what's up

 

In the database.txt file you find the notice:

 

# Some MySQL versions return error messages if you try to execute this file with f.e. phpMyAdmin

# in this case please insert the following instructions seperate ......

 

Just follow this notice.....


Greetings Thomas

Share this post


Link to post
Share on other sites

Hi!

 

I love this contrib! It's really great and saves me lots of time.

 

But I miss one thing. I have thousands of products so when to add products to the attributes. It's takes a good time of searching for the right ones. It would be perfect with a drop-down category list to display only thoose products in that given category. I think that is the thing missing for this contrib to be totally perfection :)

 

That shouldn't be to hard to fix, but my skills in PHP is not the best.

 

Any idea how to fix that?

 

Regards,

 

Gustav.

Share this post


Link to post
Share on other sites

So this is the problem Im facing...

 

The two options do show up on the side, Manage price lists & Product options.

But those two pages are empty.

 

When clicked on the Product Options page, it shows...

 

 

Preise aendern

 

Datenbankverbindung nicht möglich!

 

Where am I messing up??

Share this post


Link to post
Share on other sites
So this is the problem Im facing...

 

The two options do show up on the side, Manage price lists & Product options.

But those two pages are empty.

 

When clicked on the Product Options page, it shows...

Where am I messing up??

 

The translation according to AltaVista is "Data base connection not possible!". In main.inc.php, there are database variables that need to be filled in. I just replaced lines 108-111 with the following and it works fine for me so far:

 

  var $host                 = DB_SERVER;
 var $user                 = DB_SERVER_USERNAME;
 var $pass                 = DB_SERVER_PASSWORD;
 var $datenbank            = DB_DATABASE;

Share this post


Link to post
Share on other sites

8. chmod 777 to the catalog/admin/price_lists directory

 

 

--- where did you say to create this directory and what files go in it? :/

Share this post


Link to post
Share on other sites

I am making lists but there is nothing showing up on the product_info pages?

Share this post


Link to post
Share on other sites

This is an excellent contribution - well, I think it will be. I can't get the drop-downs (or any other way of selecting the attributes) on the product pages, either. Did you ever figure this out? The attributes/lists add into the admin interface just great.

 

Thanks for any help or advice you can give me!!

Stacey

Edited by staceyd

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×