Jump to content
Sign in to follow this  
toyicebear

Basic Design Pack Support

Recommended Posts

I'm not using the css buttons.

All of my buttons have disappeared now.

Even my click to enlarge button. All the code is there from pg. 99 in the document and the button is in includes/language/english/images/buttons

It appears with heavy modification osc becomes unstable, is this true?

 

It did a small test....

 

1. the wishlist in its current form can not be used with the css buttons. (The button for the wishlist showes but adds the product to the cart instead of to the wishlist.

 

2. if you do not use the css buttons version the wishlist button showes and works correctly.

 

 

The reason why it did not show at your site is probably this: In the Wishlist 3.5D download there is a mistake done in spelling for the languages folder.

 

In the download it is name language , ie. if you just upload the files and folders from Wishlist 3.5D the button and the wishlist language file will not be found by your shop....

 

To fix..upload the content inside the /language/ folder in Whishlist 3.5D to the /languages/ folder on your hosting/server.

Share this post


Link to post
Share on other sites

I've got a problem with the basic pack contribution combined with the saferpay contribution. Everything works quite well. But when I want to confirm the order on the "page" checkout_confirmation.php no window pops up. When I use the original html_output.php then it works.. but it wont show the informations about the shipping address and buyers address.

 

It'd be great if somebody could help me b/c at the moment nobody can pay with a credit card.

 

Thanks a lot!

 

Sammy

Share this post


Link to post
Share on other sites
I've got a problem with the basic pack contribution combined with the saferpay contribution. Everything works quite well. But when I want to confirm the order on the "page" checkout_confirmation.php no window pops up. When I use the original html_output.php then it works.. but it wont show the informations about the shipping address and buyers address.

 

It'd be great if somebody could help me b/c at the moment nobody can pay with a credit card.

 

Thanks a lot!

 

Sammy

 

Hi,

 

You can use the BDP together with your original html_output.php too aswell. Or it can be used with your choice of the included html_output.php files.

 

If the payment does not work correctly when you use the original html_output.php , the error is most likly in the used payment module and/or in the install of it at your site.

 

I have never tried saferpay so i can not give any indept info about that contribution, but try to look and see if someone have a fix in the saferpay contributions support tread....

Edited by toyicebear

Share this post


Link to post
Share on other sites

Thanks ToyIceBear

 

I have nothing found in the thread so far but I am using the html_output-nocss-buttons and it seems to work.

 

What I am not sure about is why the COD-Fee wasnt listed anymore. I reinstalled it but still nothing in the checkout. Could it be b/c of the Basic Pack ? (I dont know why it could be b/c of the BDP Contribution.. but you might know a similar problem)

 

Thanks a lot!

Edited by wsammy

Share this post


Link to post
Share on other sites

Hey toyicebear!

I need help debugging my button issue Pease.

I have no buttons whether I use CSS html-output or the original html-output. Only the text shows up.

Thanks in advanced for your help!

Share this post


Link to post
Share on other sites
Hey toyicebear!

I need help debugging my button issue Pease.

I have no buttons whether I use CSS html-output or the original html-output. Only the text shows up.

Thanks in advanced for your help!

 

 

Post your url and i will have a look.

Edited by toyicebear

Share this post


Link to post
Share on other sites

Hello Toyicebear,

 

THANK YOU!!! :D

for this excellent contrib. It's great.

 

However, one small item:

in the "notifications box" that comes with your download, the "corner_right_left.gif" is missing, which is why ppl have a "red x" in that box when using the last download.

 

Apart from that, I am happy with it - thanks again :-)

 

Mel

Share this post


Link to post
Share on other sites

 

Hi, there seems to be problems with accessing your button folder, it gives a 403 forbiden access message...

 

Check ut your folders permissions...

 

includes/languages/english/images/buttons/

 

Try this link to see the message.

 

http://www.brainbuildingtoys.com/includes/...button_back.gif

Share this post


Link to post
Share on other sites
Hello Toyicebear,

 

THANK YOU!!! :D

for this excellent contrib. It's great.

 

However, one small item:

in the "notifications box" that comes with your download, the "corner_right_left.gif" is missing, which is why ppl have a "red x" in that box when using the last download.

 

Apart from that, I am happy with it - thanks again :-)

 

Mel

 

Hi..thanks for the tip...i just checked the pack..and the image was in the correct folder but had for some reasons gotten the wrong name.

 

To fix it, eighter upload a new transparent corner named , corner_right_left.gif to images/ProductNotificationsBox/

 

or

 

Simply in images/ProductNotificationsBox/ rename the image called CORNER~3 to corner_right_left.gif

 

I will add the correctly named image there in the next version release of the pack.

Share this post


Link to post
Share on other sites
What should the permissions be? They are all set to 755.

 

Normally 755 would work out..i suggest you send the image button link and the error message to your web host and ask them what might be causing this.

 

Att a .htaccess file with access restrictions in that folder or further down in your folder tree might also be causing this.

Share this post


Link to post
Share on other sites
Normally 755 would work out..i suggest you send the image button link and the error message to your web host and ask them what might be causing this.

 

Att a .htaccess file with access restrictions in that folder or further down in your folder tree might also be causing this.

Thanks for everything toyicebear!

Share this post


Link to post
Share on other sites
Hello

The file basic_design_pack1mk7_1_2.zip in http://www.oscommerce.com/community/contributions,3570 is bad, Can upload again?

Thanks. the contribution is excellent!!

Antonio

 

 

Hi, i located the culprint, the added screenshop was to big and made the pack over 300 kb.

 

I have reduced the screenshop and pack size and upload a new version 1.7B , use that one.....

Edited by toyicebear

Share this post


Link to post
Share on other sites

THIS IS SUPER!!

 

I had no idea what OSCommerce was yesterday, now look at my site

 

www.graysonhobby.com/catalog/index.php

 

Does this template have the bestsellers module?

Edited by graysonhobby

Share this post


Link to post
Share on other sites

Guess you need to "purchase" before you have a bestseller..

 

Works Great!

 

how do I change the search..I seached on this but found many unrealted issues..

 

Anyway I would like the search button just to say SEARCH and moved to the top

Edited by graysonhobby

Share this post


Link to post
Share on other sites
Guess you need to "purchase" before you have a bestseller..

 

Works Great!

 

how do I change the search..I seached on this but found many unrealted issues..

 

Anyway I would like the search button just to say SEARCH and moved to the top

 

 

1. The tittle/text on the buttons can be edited in this file:

 

includes/languages/english.php

 

Or any other languages you use.

 

2. To move the button in the search box, you will eighter have to edit this file:

 

includes/boxes/search.php

 

or just upload your original search.php (You did make a backup right?) and overwrite the one from the BDP.

Share this post


Link to post
Share on other sites

GOT IT..I removed the <BR>..

 

Thanks for listening!

 

OK Heres another question..I would like to make the seachbutton read "GO" and be just as small?

Share this post


Link to post
Share on other sites

define('IMAGE_BUTTON_ADD_ADDRESS', 'Add Address');

define('IMAGE_BUTTON_ADDRESS_BOOK', 'Address Book');

define('IMAGE_BUTTON_BACK', 'Back');

define('IMAGE_BUTTON_BUY_NOW', 'Buy Now');

define('IMAGE_BUTTON_CHANGE_ADDRESS', 'Change Address');

define('IMAGE_BUTTON_CHECKOUT', 'Checkout');

define('IMAGE_BUTTON_CONFIRM_ORDER', 'Confirm Order');

define('IMAGE_BUTTON_CONTINUE', 'Continue');

define('IMAGE_BUTTON_CONTINUE_SHOPPING', 'Continue Shopping');

define('IMAGE_BUTTON_DELETE', 'Delete');

define('IMAGE_BUTTON_EDIT_ACCOUNT', 'Edit Account');

define('IMAGE_BUTTON_HISTORY', 'Order History');

define('IMAGE_BUTTON_LOGIN', 'Sign In');

define('IMAGE_BUTTON_IN_CART', 'Add to Cart');

define('IMAGE_BUTTON_NOTIFICATIONS', 'Notifications');

define('IMAGE_BUTTON_QUICK_FIND', 'GO');

define('IMAGE_BUTTON_REMOVE_NOTIFICATIONS', 'Remove Notifications');

define('IMAGE_BUTTON_REVIEWS', 'Reviews');

define('IMAGE_BUTTON_SEARCH', 'Search');

define('IMAGE_BUTTON_SHIPPING_OPTIONS', 'Shipping Options');

define('IMAGE_BUTTON_TELL_A_FRIEND', 'Tell a Friend');

define('IMAGE_BUTTON_UPDATE', 'Update');

define('IMAGE_BUTTON_UPDATE_CART', 'Update Cart');

define('IMAGE_BUTTON_WRITE_REVIEW', 'Write Review');

Share this post


Link to post
Share on other sites

for some reason, im not able to download the pack from the website, it only downloads it to 17k, that repeated on 3 computers, 2 on same connection, and 1 on a different service.

Share this post


Link to post
Share on other sites
define('IMAGE_BUTTON_ADD_ADDRESS', 'Add Address');

define('IMAGE_BUTTON_ADDRESS_BOOK', 'Address Book');

define('IMAGE_BUTTON_BACK', 'Back');

define('IMAGE_BUTTON_BUY_NOW', 'Buy Now');

define('IMAGE_BUTTON_CHANGE_ADDRESS', 'Change Address');

define('IMAGE_BUTTON_CHECKOUT', 'Checkout');

define('IMAGE_BUTTON_CONFIRM_ORDER', 'Confirm Order');

define('IMAGE_BUTTON_CONTINUE', 'Continue');

define('IMAGE_BUTTON_CONTINUE_SHOPPING', 'Continue Shopping');

define('IMAGE_BUTTON_DELETE', 'Delete');

define('IMAGE_BUTTON_EDIT_ACCOUNT', 'Edit Account');

define('IMAGE_BUTTON_HISTORY', 'Order History');

define('IMAGE_BUTTON_LOGIN', 'Sign In');

define('IMAGE_BUTTON_IN_CART', 'Add to Cart');

define('IMAGE_BUTTON_NOTIFICATIONS', 'Notifications');

define('IMAGE_BUTTON_QUICK_FIND', 'GO');

define('IMAGE_BUTTON_REMOVE_NOTIFICATIONS', 'Remove Notifications');

define('IMAGE_BUTTON_REVIEWS', 'Reviews');

define('IMAGE_BUTTON_SEARCH', 'Search');

define('IMAGE_BUTTON_SHIPPING_OPTIONS', 'Shipping Options');

define('IMAGE_BUTTON_TELL_A_FRIEND', 'Tell a Friend');

define('IMAGE_BUTTON_UPDATE', 'Update');

define('IMAGE_BUTTON_UPDATE_CART', 'Update Cart');

define('IMAGE_BUTTON_WRITE_REVIEW', 'Write Review');

 

Im sorry, but I cant seem to edit previous post..

 

Seems this is running the button AND header

// quick_find box text in includes/boxes/quick_find.php

define('BOX_HEADING_SEARCH', 'Search');

define('BOX_SEARCH_TEXT', 'blah blah');

define('BOX_SEARCH_ADVANCED_SEARCH', 'Advanced Search');

Share this post


Link to post
Share on other sites
GOT IT..I removed the <BR>..

 

Thanks for listening!

 

OK Heres another question..I would like to make the seachbutton read "GO" and be just as small?

 

includes/languages/english.php

 

change:

 

define('IMAGE_BUTTON_QUICK_FIND', 'Quick Find');

 

to:

 

define('IMAGE_BUTTON_QUICK_FIND', 'Go');

 

If you want that button to be smaller than the rest, i have described a metode of doing so earlie in this tread.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×