Jump to content
Sign in to follow this  
toyicebear

Basic Design Pack Support

Recommended Posts

as for the "what's new here" stuff, if you find it let me know, I think there is a contribution that changes it to the category name, but I see these things and think "must bookmark that" and promptly forget

 

Thank you....I will work on that counter thing first then....and you made me snort out loud (so lady like I know!) but sheesh....I do the exact same thing....I "think" I know where I saw that and now for the life of me I can't find it :rolleyes:

Share this post


Link to post
Share on other sites

replacing CSS button with graphic button

 

Ok I thoought i had followed the instructions but I can't seem to get it to work properly

 

this is for the search button on the search box, i can get it to appear, but it's not clickable the relevant code is below

 

'text' => tep_draw_input_field('keywords', '', 'size="10" maxlength="30" style="width: ' . (BOX_WIDTH-30) . 'px"') 
. ' ' . tep_hide_session_id() . '<br>' . 
tep_image('http://nigel.geek.nz/catalog/includes/languages/english/images/buttons/button_quick_find.gif', BOX_HEADING_SEARCH)
. '<br><a href="' . tep_href_link(FILENAME_ADVANCED_SEARCH) . '"><b>' . BOX_SEARCH_ADVANCED_SEARCH . '</b></a>');

 

Anyhelp would be appreciated, Cheers

Edited by nigelt74

Share this post


Link to post
Share on other sites
toyicebear, I'm still having trouble with a few of my orders. Someone in another forum here told me that my cookies are still set wrong, and I just had a big customer not be able to finish their order. Is there something I can use to check it without having to run a mysql (ain't messing with that!!!)

 

The cookie path and directory is set in this file includes/configure.php

 

When the setting is correct you will only see ?osCsid= attached to your urls on the 2-3 first clicks after arriving on your site and then it will diseapear.

Share this post


Link to post
Share on other sites
replacing CSS button with graphic button

 

Ok I thoought i had followed the instructions but I can't seem to get it to work properly

 

this is for the search button on the search box, i can get it to appear, but it's not clickable the relevant code is below

 

'text' => tep_draw_input_field('keywords', '', 'size="10" maxlength="30" style="width: ' . (BOX_WIDTH-30) . 'px"') 
. ' ' . tep_hide_session_id() . '<br>' . 
tep_image('http://nigel.geek.nz/catalog/includes/languages/english/images/buttons/button_quick_find.gif', BOX_HEADING_SEARCH)
. '<br><a href="' . tep_href_link(FILENAME_ADVANCED_SEARCH) . '"><b>' . BOX_SEARCH_ADVANCED_SEARCH . '</b></a>');

 

Anyhelp would be appreciated, Cheers

 

In this case the metode earlier described will not work (it was for buttons being called by tep_image_button), since its a form being submitted (called by the function tep_image_submit).

Share this post


Link to post
Share on other sites

okay, that file shows this

 

define('HTTP_COOKIE_DOMAIN', 'http://brugmansias.us');

define('HTTPS_COOKIE_DOMAIN', 'https://brugmansias.us');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

 

what am I doing wrong??

Share this post


Link to post
Share on other sites
In this case the metode earlier described will not work (it was for buttons being called by tep_image_button), since its a form being submitted (called by the function tep_image_submit).

 

Yeah i thought as much, nothing else i have tried has even got that far,

 

Any suggestions on how to tackle it?,

 

I thought of creating a new function but finding where these things are defined etc got me absolutlly lost

 

Thanks

Share this post


Link to post
Share on other sites
okay, that file shows this

 

define('HTTP_COOKIE_DOMAIN', 'http://brugmansias.us');

define('HTTPS_COOKIE_DOMAIN', 'https://brugmansias.us');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

 

what am I doing wrong??

 

Try this:

 

define('HTTP_COOKIE_DOMAIN', 'brugmansias.us');

define('HTTPS_COOKIE_DOMAIN', 'brugmansias.us');

define('HTTP_COOKIE_PATH', '/catalog/');

define('HTTPS_COOKIE_PATH', '/catalog/');

Share this post


Link to post
Share on other sites
Yeah i thought as much, nothing else i have tried has even got that far,

 

Any suggestions on how to tackle it?,

 

I thought of creating a new function but finding where these things are defined etc got me absolutlly lost

 

Thanks

 

 

that function is located in includes/functions/html_output.php

Share this post


Link to post
Share on other sites

No worries problem solved

 

added a condition to the function, fo that particular icon

 

included below for anyone else who might have a similar problem

 

/functions/html_output.php

function tep_image_submit($image, $value = '-AltValue-', $parameters = '') {
global $language;
if ($image == 'button_quick_find.gif') {
	$image_submit = '<input type="image" src="' . tep_output_string(DIR_WS_LANGUAGES . $language . '/images/buttons/' . $image) . '" border="0" alt="' . tep_output_string($alt) . '"';

	if (tep_not_null($alt)) $image_submit .= ' title=" ' . tep_output_string($alt) . ' "';

	if (tep_not_null($parameters)) $image_submit .= ' ' . $parameters;

	$image_submit .= '>';

	return $image_submit;
}
else
{
	$css_submit = '<input type="submit" class="cssButton" value="' . tep_output_string($value) . '" />';
	return $css_submit;
}
}

 

And of course removed my alterations on the search.php page

 

Thanks all

Share this post


Link to post
Share on other sites

Ok...HELP!!!

 

I did the BDP and everything went fine. As I had previously posted I had done the Define Main Page install and that went fine also. Now when I try to edit my page....everything disappears. I have put back the original and cannot even delete anything without the whole Define Main Page disappearing and then when I put back his original file everything is all canty wamped all over the place. If I edit out the link to that huge graphic I lose everything on the page but the left column of information...New Products for February and my cart too.

 

Even if I make one small change to the Header in the first announcement box....Where it says...We have just successfully installed Define Main Page....I had previously changed that to Welcome. If I just type that one little change it all disappears.

 

I don't know if any of that makes any sense or not.

 

Here is the link to my "dead" store

 

http://ascrappinfriendsy.com/store/catalog/

 

Any ideas? What is wrong? I am not getting any error messages...and I did edit some stuff in Define Main Page before I did the BDP...so is there a conflict there?

 

Thanks

 

Jo

Share this post


Link to post
Share on other sites

Where are the breadcrumbs located/defined? as i want to change the colour

 

Ok...HELP!!!

 

I did the BDP and everything went fine. As I had previously posted I had done the Define Main Page install and that went fine also. Now when I try to edit my page....everything disappears. I have put back the original and cannot even delete anything without the whole Define Main Page disappearing and then when I put back his original file everything is all canty wamped all over the place. If I edit out the link to that huge graphic I lose everything on the page but the left column of information...New Products for February and my cart too.

 

Even if I make one small change to the Header in the first announcement box....Where it says...We have just successfully installed Define Main Page....I had previously changed that to Welcome. If I just type that one little change it all disappears.

 

I don't know if any of that makes any sense or not.

 

Here is the link to my "dead" store

 

http://ascrappinfriendsy.com/store/catalog/

 

Any ideas? What is wrong? I am not getting any error messages...and I did edit some stuff in Define Main Page before I did the BDP...so is there a conflict there?

 

Thanks

 

Jo

 

 

What is it supposed to look like are the announcements and ratings supposed to be under the main body?

Edited by nigelt74

Share this post


Link to post
Share on other sites
Where are the breadcrumbs located/defined? as i want to change the colour

 

Ignore me, there needs to be a "delete post 20mins after posting" button as I spend ages trying to find a solution, then once i've posted and can't edit the post, The brain clicks into gear and the answer becomes obvious

Share this post


Link to post
Share on other sites
Ok...HELP!!!

 

I did the BDP and everything went fine. As I had previously posted I had done the Define Main Page install and that went fine also. Now when I try to edit my page....everything disappears. I have put back the original and cannot even delete anything without the whole Define Main Page disappearing and then when I put back his original file everything is all canty wamped all over the place. If I edit out the link to that huge graphic I lose everything on the page but the left column of information...New Products for February and my cart too.

 

Even if I make one small change to the Header in the first announcement box....Where it says...We have just successfully installed Define Main Page....I had previously changed that to Welcome. If I just type that one little change it all disappears.

 

I don't know if any of that makes any sense or not.

 

Here is the link to my "dead" store

 

http://ascrappinfriendsy.com/store/catalog/

 

Any ideas? What is wrong? I am not getting any error messages...and I did edit some stuff in Define Main Page before I did the BDP...so is there a conflict there?

 

Thanks

 

Jo

 

Had a look , seems to be working now...except that by using a banner with a widt of 600 px , you are stretching the layout....

 

The total width of the centered page is 778 px , when incerting graphics do take the width into consideration.

Share this post


Link to post
Share on other sites
Had a look , seems to be working now...except that by using a banner with a widt of 600 px , you are stretching the layout....

 

The total width of the centered page is 778 px , when incerting graphics do take the width into consideration.

 

That is the problem....if I change anything in the DMP file then it all just disappears. If I put the orginal back in it all shows back up, but is stretched all across the page. I just copy/pasted the original file back into the text box in administration and clicked saved....then it would show up stretched across the page (because of the graphic--I know that is why it is stretched) but I don't want the graphic there...in fact I would like to remove a lot of that--like the rating system, etc. But when I do any changes to the the define main page.php in administration the whole thing just disappears...and my permissions are set to 777.

 

I am off to check my define main page files that I altered to make sure all those changes are still there and correct....I don't think I altered any of them....but I may have without realizing it.

 

I made a change to the file (put Welcome in the first box--instead of you have successfully installed DMP).....and what you see now ....with just the left column is what I get.

 

http://ascrappinfriendsy.com/store/catalog/

 

Thanks for you help.....off to check out what I do know....which obviously is NOT much.

 

Jo

Share this post


Link to post
Share on other sites
That is the problem....if I change anything in the DMP file then it all just disappears. If I put the orginal back in it all shows back up, but is stretched all across the page. I just copy/pasted the original file back into the text box in administration and clicked saved....then it would show up stretched across the page (because of the graphic--I know that is why it is stretched) but I don't want the graphic there...in fact I would like to remove a lot of that--like the rating system, etc. But when I do any changes to the the define main page.php in administration the whole thing just disappears...and my permissions are set to 777.

 

I am off to check my define main page files that I altered to make sure all those changes are still there and correct....I don't think I altered any of them....but I may have without realizing it.

 

I made a change to the file (put Welcome in the first box--instead of you have successfully installed DMP).....and what you see now ....with just the left column is what I get.

 

http://ascrappinfriendsy.com/store/catalog/

 

Thanks for you help.....off to check out what I do know....which obviously is NOT much.

 

Jo

 

 

Make sure you are using this version of define mainpage:

 

Define MainPage 1.3.3 Lee Nielsen 21 Jul 2003

Share this post


Link to post
Share on other sites
Make sure you are using this version of define mainpage:

 

Define MainPage 1.3.3 Lee Nielsen 21 Jul 2003

 

 

I am...I think I have found my problem....somehow when I was FTP files I must have really screwed things up...files are not in the right spots. I am just going to uninstall what I have and start over....the good news....I actually know what I want now....have all the files that I have altered saved....just have to make sure I put them in the right spot this time...my problem was file names that were the same but different paths...then I deleted something and I think when I did that it deleted more than I intended.....so for sanity sake I think this is the best option.

 

Thanks

 

Jo

Share this post


Link to post
Share on other sites

Ok...question about Define Main Page.

 

I have everything back how it was except for this contribution. I am trying to decide if I do in fact want it. If I don't install this contribution then I just write what I would like for the main page on the index.php file and overwrite, correct? What makes Define Main Page so much easier? Am I missing something? (entirely possible)

 

Also...if I want the arrows a different color then I just need to make new graphics for them in PSE, right?

 

Oh...and what I have got right now is at this URL.

 

https://st27.startlogic.com/~ascrappi/asfstore/catalog/

Share this post


Link to post
Share on other sites
Ok...question about Define Main Page.

 

I have everything back how it was except for this contribution. I am trying to decide if I do in fact want it. If I don't install this contribution then I just write what I would like for the main page on the index.php file and overwrite, correct? What makes Define Main Page so much easier? Am I missing something? (entirely possible)

 

Also...if I want the arrows a different color then I just need to make new graphics for them in PSE, right?

 

Oh...and what I have got right now is at this URL.

 

https://st27.startlogic.com/~ascrappi/asfstore/catalog/

 

The define mainpage contribution lets you add and edit the front page text from your shops admin .....

 

But if you choose not to use it , then you can also easily just change this text manually too , it is located in this file includes/languages/english/index.php

Share this post


Link to post
Share on other sites
The define mainpage contribution lets you add and edit the front page text from your shops admin .....

 

But if you choose not to use it , then you can also easily just change this text manually too , it is located in this file includes/languages/english/index.php

 

 

right that was what I was thinking....it would be just as easy to change this in HTML kit or something like that rather than do the Contribution. You still have to know some HTML/PHP to write the page the way you want it anyways...which is what I was looking for....something that would make it easier for others to change...but that doesn't look like something they can handle...at least not at this stage of the game...thanks.

 

Jo

Share this post


Link to post
Share on other sites

I need help, my store is dying here. I have so many customers that CANNOT create an account. It has to be cookie related. When they try, they get sent back to the first page over and over. Yes, I can put a note 'if you have trouble, just email me your order' but then why would I even need a store??? I have a competitor that sells the exact same things I do and I am losing sales. Here's my URL but I'm putting in a * to keep Google from listing this as my urls first link. so take that out.

 

*brugmansias.us/catalog

Share this post


Link to post
Share on other sites

i hate the editting or lack of on this forum. anyway, I think it's related to AOL. Anyone else with aol problems and how could I fix it?

Share this post


Link to post
Share on other sites

Toyicebear, :)

 

I've installed your contribution and I really like it. I just wanted to tell you that. Here is My Webpage I am still working on the website, adding products, description, attributes, etc. If you have any suggestion, I would be happy to hear it!

Thank you!

 

Simona :)

 

P.S. Do you happen to know how I get rid of the pictures for the subcategories? I've been searching the forum for an answer but I couldn't find anything yet.

Share this post


Link to post
Share on other sites
Toyicebear, :)

 

I've installed your contribution and I really like it. I just wanted to tell you that. Here is My Webpage I am still working on the website, adding products, description, attributes, etc. If you have any suggestion, I would be happy to hear it!

Thank you!

 

Simona :)

 

P.S. Do you happen to know how I get rid of the pictures for the subcategories? I've been searching the forum for an answer but I couldn't find anything yet.

 

 

Nice color choice it seems to fit well with your product line.. ;-)

 

Sub-cat images can be removed in several ways....

 

1. go to your shops admin >> configuration >> images and set Image Required to "false" , then simply do not upload any images when you add/edit categories.

 

 

or

 

2. edit the index.php file to not show the images.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×