Jump to content
Sign in to follow this  
toyicebear

Basic Design Pack Support

Recommended Posts

some points to check

 

-Check that the folder permission for the imagecache folder is 777

 

-Check your settings under configuration >> images

Thanx for your prompt response!

settings is 777. config>>images is:

Small Image Width 100

Small Image Height 80

Heading Image Width 57

Heading Image Height 40

Subcategory Image Width 100

Subcategory Image Height 57

Calculate Image Size true

Image Required true

 

See anything fishy? Its default values.

Have this anything to do with the html_output files?

 

In my shop I have a category>>subcategory>>product

When I added the product in the "new product" area, I uploaded the image from my computer and the text IMG_4850.jpg is placed under the upload box. When I go to the preview area I receive a warning at the top: Warning: No file uploaded. The red warning line in admin area!

 

Maybe some simple beginner error?! :-"

Share this post


Link to post
Share on other sites

I see that the products that comes with oscommerce (default) is showing all right but they do not use the imagecache directory though.

Edited by megacooler

Share this post


Link to post
Share on other sites
yes it will save you some time, and yes you can just drop it over the install you already have.

 

As for productlisting in cloumns go through the older evrsions and you will find one version which have a module file called.

 

product_listing_col.php

 

using this you do not need to do any db changes , just upload the new file and change the call in index.php from product_listing.php to product_listing_col.php

Thanks for your reply, I found one Nov.03 by Randy P. I tried to open file but can't on my system?? the print shop borderbund "file is not supported" can' t open file, strange since I have print shop installed. any idea's

thanks again

Share this post


Link to post
Share on other sites
I see that the products that comes with oscommerce (default) is showing all right but they do not use the imagecache directory though.

 

 

The automatic thumbnailer does not resize pictures which is the same or smaller than the image setting and as standard do not resize gif's .

 

Uploading a jpg in larger size than the image setting dimentions for 1 product will show you if it works or not....

Share this post


Link to post
Share on other sites
Thanx for your prompt response!

settings is 777. config>>images is:

Small Image Width 100

Small Image Height 80

Heading Image Width 57

Heading Image Height 40

Subcategory Image Width 100

Subcategory Image Height 57

Calculate Image Size true

Image Required true

 

See anything fishy? Its default values.

Have this anything to do with the html_output files?

 

In my shop I have a category>>subcategory>>product

When I added the product in the "new product" area, I uploaded the image from my computer and the text IMG_4850.jpg is placed under the upload box. When I go to the preview area I receive a warning at the top: Warning: No file uploaded. The red warning line in admin area!

 

Maybe some simple beginner error?! :-"

 

If you can not upload images with products , then also check that your images folder has a permission of 777

Share this post


Link to post
Share on other sites
Thanks for your reply, I found one Nov.03 by Randy P. I tried to open file but can't on my system?? the print shop borderbund "file is not supported" can' t open file, strange since I have print shop installed. any idea's

thanks again

 

 

 

you can have a look at this one, Column Product Listing

Share this post


Link to post
Share on other sites
If you can not upload images with products , then also check that your images folder has a permission of 777

I can upload images with products and the image folder is set to 777.

The original picture is larger than the thumbnails. Everything looks good in the admin area (preview).

 

I can see the thumbnails to the right, at the right side of all the languages as thumbnail images so it seems to work. These thumbnails are comming from the catalog/images folder not the imagecache folder.

 

When I go to the shop, the pic-boxes is just empty?!

 

In the product preview page (admin) it says "Warning: No file uploaded." in ared line at the top. This warning text is also shown on the default images in the basic installation. Is this normal?

Share this post


Link to post
Share on other sites
I can upload images with products and the image folder is set to 777.

The original picture is larger than the thumbnails. Everything looks good in the admin area (preview).

 

I can see the thumbnails to the right, at the right side of all the languages as thumbnail images so it seems to work. These thumbnails are comming from the catalog/images folder not the imagecache folder.

 

When I go to the shop, the pic-boxes is just empty?!

 

In the product preview page (admin) it says "Warning: No file uploaded." in ared line at the top. This warning text is also shown on the default images in the basic installation. Is this normal?

 

no the warning should not show

Share this post


Link to post
Share on other sites

The standard automatic thumbnails from BDP does not work inf gdlip is not enabled and also it does not work on some gdlib versions.

 

If it does not work, you can try the the alternative html output file with on the fly thumbnails instead.

Share this post


Link to post
Share on other sites
thanks again, I tried and I get nothing.Zero. Is there another thread I can follow or do you have anymore insights into this?

thnx, mike

 

 

That one just requires upload of one file and change of 1 line in index.php so should be easy to use.

 

BUT, for further questions please open a new tread or find the support tread for the contribution you use/ want to use.

 

This tread is for BDP questions and tips.

Share this post


Link to post
Share on other sites
The standard automatic thumbnails from BDP does not work inf gdlip is not enabled and also it does not work on some gdlib versions.

 

If it does not work, you can try the the alternative html output file with on the fly thumbnails instead.

Yez, I tried that earlier today, and guess what... It worked!

Thanks for your support!

Teh only thing that is a little bit strange is the warning line that still is there "No picture uploaded". Maybe some conflict somehow!? i just will have to live with it I think ;)

Share this post


Link to post
Share on other sites

Hmm, another problem!

When I put a product "out of stock" with a date when I will have the product in stock again. It appear a table in the bottom of the shop saying that this product will be in stock again MM/DD/YY. That is fine, but when I click on the product link in this table I come to the product page but it says "no products" ? Howcome?

 

Also, if I put a product out of stock, without setting a date when it will be in stock again. Then the product is totally gone (erased) in the shop. Please advise!

Share this post


Link to post
Share on other sites

Good morning all,

 

Firstly thank you fot this great contribution, it really helped me out at the start...

 

I have been using the html_output-060817-on-the-fly-thumb.php' version with the CSS button code removed but noticed some talk on here of the imagecache version that I had completely missed! - I do not know why I am using 'on-the-fly' when I would have thought cacheing the images is alot more sensible (could anyone tell me why you'd want 'on-the-fly') except for memory issues? Is it that the quality is better as it is re-sampled? Does the code behind the imagecache way of doing it just re-size. If that is the case we could use the 'on-the-fly' but then cache those?

 

Am I correct in thinking that I need 'html_output-060817.php' to cache the images and I need to create the imagecache folder in /images? Does it keep the image aspect ratio?

 

Also, what exactly goes into the thumbnail name when it is saved, I just thought that you could end up with 10000 images in there and you would want unique names maybe including model number or something to help stop the site slowing down. (I read that unique names would be as good as an indexing system?)

 

Has there been any code created that would save the thumbnails in there respective folders?

 

Many Thanks

Becki

 

P.S A slightly off topic question but I presume the file size of the original is important and that the thumbnail code doesn't work like say the 'save for web feature' in photoshop where it doesn't matter what the quality is like to start with it just saves at the lower preset web quality. I.E a 1meg photo would thumbnail to a lot bigger file size compared to 100kb on the website. Whereas in photoshop 'save for web' they'd come out the same?

Share this post


Link to post
Share on other sites
Good morning all,

 

Firstly thank you fot this great contribution, it really helped me out at the start...

 

I have been using the html_output-060817-on-the-fly-thumb.php' version with the CSS button code removed but noticed some talk on here of the imagecache version that I had completely missed! - I do not know why I am using 'on-the-fly' when I would have thought cacheing the images is alot more sensible (could anyone tell me why you'd want 'on-the-fly') except for memory issues? Is it that the quality is better as it is re-sampled? Does the code behind the imagecache way of doing it just re-size. If that is the case we could use the 'on-the-fly' but then cache those?

 

Am I correct in thinking that I need 'html_output-060817.php' to cache the images and I need to create the imagecache folder in /images? Does it keep the image aspect ratio?

 

Also, what exactly goes into the thumbnail name when it is saved, I just thought that you could end up with 10000 images in there and you would want unique names maybe including model number or something to help stop the site slowing down. (I read that unique names would be as good as an indexing system?)

 

Has there been any code created that would save the thumbnails in there respective folders?

 

Many Thanks

Becki

 

P.S A slightly off topic question but I presume the file size of the original is important and that the thumbnail code doesn't work like say the 'save for web feature' in photoshop where it doesn't matter what the quality is like to start with it just saves at the lower preset web quality. I.E a 1meg photo would thumbnail to a lot bigger file size compared to 100kb on the website. Whereas in photoshop 'save for web' they'd come out the same?

 

 

The default html_output.php included in BDP , have automatic thumbnails . This caches a thumbnail of the image (withe the same name as the original image) in a new folder called imagecache , this folder and the thumbnails are created automatically.

 

The html_output.php with on the fly thumbnails is only included as an option for those who the other default bdp automatic thumbnails version does not work for.

Share this post


Link to post
Share on other sites
Hmm, another problem!

When I put a product "out of stock" with a date when I will have the product in stock again. It appear a table in the bottom of the shop saying that this product will be in stock again MM/DD/YY. That is fine, but when I click on the product link in this table I come to the product page but it says "no products" ? Howcome?

 

Also, if I put a product out of stock, without setting a date when it will be in stock again. Then the product is totally gone (erased) in the shop. Please advise!

 

 

Not BDP related, create a new separate tread for such questions.

Edited by toyicebear

Share this post


Link to post
Share on other sites
The default html_output.php included in BDP , have automatic thumbnails . This caches a thumbnail of the image (withe the same name as the original image) in a new folder called imagecache , this folder and the thumbnails are created automatically.

 

The html_output.php with on the fly thumbnails is only included as an option for those who the other default bdp automatic thumbnails version does not work for.

 

But am i right in thinking that the 'on-the-fly' resamples etc using the gdlib whereas the 'default' thumbnailer literally just scales down the image and thus is not as good quality? I'm confused as to why the 'default' thumnailer wouldn't work - i'd have thought the 'on the fly' thumbnailer wouldn't work as much due to the requirment for gdlib?

 

Thanks

Becki

Share this post


Link to post
Share on other sites
But am i right in thinking that the 'on-the-fly' resamples etc using the gdlib whereas the 'default' thumbnailer literally just scales down the image and thus is not as good quality? I'm confused as to why the 'default' thumnailer wouldn't work - i'd have thought the 'on the fly' thumbnailer wouldn't work as much due to the requirment for gdlib?

 

Thanks

Becki

 

 

default oscommerce have no thumbnailer system it just "resizes" the image shown by setting a different html dimesion. since this does not reduce the original images kb size it does tend to give slow load time.

 

 

The default BDP included thumbnailer used gdlib to create a new thumbnail upon first view which then is saved in a newly created folder. This created thumbnail is then used for further visitors.

 

The on the fly thumbnailer used gdlib functions to create reduced thumbnail on the fly upon each visit.

 

 

The 2 alternative from BDP uses different functions and as such on some set-ups one will work and not the other....

Share this post


Link to post
Share on other sites
default oscommerce have no thumbnailer system it just "resizes" the image shown by setting a different html dimesion. since this does not reduce the original images kb size it does tend to give slow load time.

The default BDP included thumbnailer used gdlib to create a new thumbnail upon first view which then is saved in a newly created folder. This created thumbnail is then used for further visitors.

 

The on the fly thumbnailer used gdlib functions to create reduced thumbnail on the fly upon each visit.

The 2 alternative from BDP uses different functions and as such on some set-ups one will work and not the other....

 

Thanks for info, I think i have just found out why i was using the 'on-the-fly'!

 

i used 'html_output-060817.php' and deleted GIF's from '$not_supported_formats = array ("GIF"); ' and now what it seems is that the transparent areas of the gif images are black?! But the 'on the fly' one worked, do you know why this is and also is there a fix? If it hasn't been done could the on-the-fly code be used to generate the thumb and then cache it.

 

If not in your expert opinion is it worth creating all my images as jpeg's (i haven't started uploading products yet) and make use of the cache (although this means changing all the stock gif images such as the transparents etc?) OR stick with on the fly! Do you know if there is another auto thumbnailer with cache that will work with my set-up?

 

thanks

Becki

Share this post


Link to post
Share on other sites

I am anxious to use this product. However, I do not understand the download process or application. Where to go etc., and save.

Can you be more explanatory for a "newbie" please?

Share this post


Link to post
Share on other sites
Thanks for info, I think i have just found out why i was using the 'on-the-fly'!

 

i used 'html_output-060817.php' and deleted GIF's from '$not_supported_formats = array ("GIF"); ' and now what it seems is that the transparent areas of the gif images are black?! But the 'on the fly' one worked, do you know why this is and also is there a fix? If it hasn't been done could the on-the-fly code be used to generate the thumb and then cache it.

 

If not in your expert opinion is it worth creating all my images as jpeg's (i haven't started uploading products yet) and make use of the cache (although this means changing all the stock gif images such as the transparents etc?) OR stick with on the fly! Do you know if there is another auto thumbnailer with cache that will work with my set-up?

 

thanks

Becki

 

'On the Fly' Auto Thumbnailer using GD Library

Share this post


Link to post
Share on other sites
I am anxious to use this product. However, I do not understand the download process or application. Where to go etc., and save.

Can you be more explanatory for a "newbie" please?

 

 

1. Click Me.......

 

2. On the new page shown click on the small folder with a green arrow , a pop-up window will show asking you to open or save file...choose save file and then choose where on your pc you want it saved press ok and the file is then downloaded to your local computer.

 

3. unzip the package

 

4. read the instructions inside the package

 

5. upload the files and folders inside the folder called "catalog" in the pack to your web hosting overwriting the smae files and folders there.

 

6. Go to view your site and press CTRL +F5

Share this post


Link to post
Share on other sites

Toyice, just testing this on a vanilla install of OSC, but the categories/products disappeared. Any idea why?

 

http://www.siteground153.com/~kosherac/

 

Thanks Toyice.


Jason

 

Simple 1-2-3 Intructions on how to get, install and configure SSL

 

The Google Sandbox explained

 

Simple to follow instructions on how to change the look of your OSC

 

How To Make A Horrible OSC Website

 

my toolbox: All things WordPress-related - All things Adobe-related - PHP Designer 2007 - Codecanyon Junkie - Crimson Editor - Winmerge - phpMyAdmin - WS_FTP

 

my installed contributions: Category Banners, File Upload feature-.77, Header Tags, Sort_Product_Attributes_1, XSellv2.3, Price Break 1.11.2, wishlist 3.5, rollover_category_images_v1.2, Short_Description_v2.1, UPSXML_v1_2_3, quickbooks qbi_v2_10, allprods v4.4, Mouseover-effect for image-buttons 1.0, Ultimate_SEO, AAP 1.41, Auto Select State Value, Fast Easy Checkout, Dynamic SiteMap v2.0, Image Magic, Links Manager 1.14, Featured Products, Customer Testimonials, Article Manager, FAQ System, and I'm sure more ...

Share this post


Link to post
Share on other sites
Toyice, just testing this on a vanilla install of OSC, but the categories/products disappeared. Any idea why?

 

 

..I have the same problem try renaming all of your images with a gif extension and all will return and work correctly.

 

The question though is how to use BDP with JPEG rather than GIF's. When I try JPEGS I just see the banner on my page too.

 

I am sure there is a simple answer to this?

 

Thanks,

 

Rob.

Share this post


Link to post
Share on other sites
Toyice, just testing this on a vanilla install of OSC, but the categories/products disappeared. Any idea why?

 

http://www.siteground153.com/~kosherac/

 

Thanks Toyice.

 

Hi,

 

have not seen that one before, but as usuall i recommend to try with one of the alternative includes/functions/html_output.php files included.

 

Also always check that all the files have been uploaded. (If for instance the file includes/classes/boxes.php has not been uploaded and replaced the old one such a fault as seen as your site would occure)

 

Try it out and please do give some feedback here in the support tread on the result.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×