Jump to content
Sign in to follow this  
toyicebear

Basic Design Pack Support

Recommended Posts

thanks for this contrib, i like the looks and the concept.

 

there is a contribution called dynamenu ((link to its forum) and link to its download page.

its very simple and uses css, a new box include, and a few of its own functions to generate flyout menues - either in tree like fashion vertical or horizontal...any ways.. y am i telling you this? because when i install it on a fresh install of oscommerce it works fantastic, but after i copy basic design pack over my fresh installation and then install that contribution(or in reverse order) the menues do not work.

the only files that are the same are footer and header in catalog/includes.

in the footer all i need to add is a one liner at the end of the file b4 the closing ?>

// Output the footer for Dynamenu for osCommerce
echo $GLOBALS['dmfooter'];

 

and in header i just output the menu like so

   <?php include(DIR_WS_BOXES . 'dm_categories.php'); ?>

 

or if you lookhere, on my header.php on line 62 is the complete header page

 

can any one help me figure out why is this menu not working after BDP is installed ?

even better, can any one help me get it to work ?

 

thanks,

zaxxon


currently using OSC2.2MS2 051113 with the following contributions:

 

AJAX Attributemanager 2.1 - All_products 4.4 - Banner manager 1.5b - banner hack picture in manager * description in product listing hack ms2 v2.4 * drop shadow boxes v.1.1 * Easy populater 2.76d-ms2 by surfalot * FCKEditor * header tag controller v2.5.9 * jcssmenu * LoginBox 5.6 * option type feature v1.71 * OSC-Cach-v1.1 * popup_imagecleaned_stilized_2 * Remove from cart button hack * scrolling bestsellers * Article manager1.4 * Links Manager v1.14. * proffessional invoice&packingslip 6.1 * Ultimate SEO URLs

Personaly i think all these features NEED to be in the main core as they are quite basic features that are missing. but then again what do i know?

Share this post


Link to post
Share on other sites

sorry double posted it - and it wont let me delete the second one...so i have to edit ,please excuse the lameness

Edited by zaxxon

currently using OSC2.2MS2 051113 with the following contributions:

 

AJAX Attributemanager 2.1 - All_products 4.4 - Banner manager 1.5b - banner hack picture in manager * description in product listing hack ms2 v2.4 * drop shadow boxes v.1.1 * Easy populater 2.76d-ms2 by surfalot * FCKEditor * header tag controller v2.5.9 * jcssmenu * LoginBox 5.6 * option type feature v1.71 * OSC-Cach-v1.1 * popup_imagecleaned_stilized_2 * Remove from cart button hack * scrolling bestsellers * Article manager1.4 * Links Manager v1.14. * proffessional invoice&packingslip 6.1 * Ultimate SEO URLs

Personaly i think all these features NEED to be in the main core as they are quite basic features that are missing. but then again what do i know?

Share this post


Link to post
Share on other sites
All the files in the /boxes/ folder has been changed......noone of the changes is security related......

 

The categories used in the pack are very different from the standard one..and yes its safe to use.

 

Well good to hear, but to me, adding (int) at the beginning of vars being used for SQL queries is a security measure.

 

Maybe it never was possible to inject anything in those, but you'll admin, the (int) is a restriction that prevent such injections ;)

 

Then, this package is just great :D

 

I love it, even though I would love to see smarty used here :D

 

Anyway oscomerce rocks, this community rocks, I am happy to have chosen this solution :D

 

++

Share this post


Link to post
Share on other sites

Hi

 

im just in the process of setting up a new template for my shop, i have a little gap at the right side of the main image? i cant seen to find how to remove it?

 

any suggestions

 

great contributon! saved me loads of time.

Share this post


Link to post
Share on other sites

I've applied the design package, BUT, I've only got 2 columns of product lists, in the jpeg supplied with there is 3 columns of products, basically, mine when applied is 800x600 and not 1024x768, and I have no information and quickfind on the left and no best sellers on the right, please can someone help me


No outside links in signature allowed. See forum rules please.

Share this post


Link to post
Share on other sites

Hey folks...

 

I am an uber newb when it comes to this stuff and attempted the install of the basic design pack. To my untrained eye, it appears to not have done anything.

 

If you have a look at my site it might help www.technologydirectcanada.com

 

The cartoony graphics are still there and those grey edges on all the boxes :(

 

I used an FTP program to copy the files over and it seemed to go OK.

 

Any help would be greatly appreciated.

 

Frank

Share this post


Link to post
Share on other sites

My server has just been upgrade and i have updated my site.

In doing so i have lost some things.

 

I have put the design pack in again however i can not get it to center and make it smaller it fit my heading graphic.

 

Can anybody help with this it was fine before the upgrade.

http://rbsorganics.com.au/shop/

 

thanks

Share this post


Link to post
Share on other sites
My server has just been upgrade and i have updated my site.

In doing so i have lost some things.

 

I have put the design pack in again however i can not get it to center and make it smaller it fit my heading graphic.

 

Can anybody help with this it was fine before the upgrade.

http://rbsorganics.com.au/shop/

 

thanks

 

had a look..it looks like you have not overwritten or modified the includes/header.php and includes/footer.php from the package.

Share this post


Link to post
Share on other sites
Hey folks...

 

I am an uber newb when it comes to this stuff and attempted the install of the basic design pack. To my untrained eye, it appears to not have done anything.

 

If you have a look at my site it might help www.technologydirectcanada.com

 

The cartoony graphics are still there and those grey edges on all the boxes :(

 

I used an FTP program to copy the files over and it seemed to go OK.

 

Any help would be greatly appreciated.

 

Frank

 

Had a look..it looks like you have changed to use a purchased template instead of the pack.

Share this post


Link to post
Share on other sites
I've applied the design package, BUT, I've only got 2 columns of product lists, in the jpeg supplied with there is 3 columns of products, basically, mine when applied is 800x600 and not 1024x768, and I have no information and quickfind on the left and no best sellers on the right, please can someone help me

 

an url would help to see what might be the mather...

 

But from what you describe it looks like you did not have an unmodified store to start with....

Share this post


Link to post
Share on other sites

Has anyone with this installed managed to get it running with PWA or Guest Account?

 

Ive tryed twice, and it sends the pages everywhere full screen again, having to get rid of it everytime.

Share this post


Link to post
Share on other sites

First of all this is a great contribution to osc then second how do i change the writing on the buttons.?

Some places in my shop it write the wrong text. for example when you add a product and go to your cart it says log off insted off continue just in danish insted of english. can anyone please help me here???

 

kind regards

Tonny

Share this post


Link to post
Share on other sites

Hi, first post here :)

 

Thanks for the great contrib. I am redoing my site at the moment and I just installed the contrib and it seems to work very well.

 

I have a couple of quick questions though, hopefully someone will be able to help.

 

Q1. I would like the site to have a different size depending on the screen resolution or client window size. I added the following code and it seems to work (kind of)

 

.fixcenter {

max-width : 955px;

width: expression(document.body.clientWidth > 955? "955px": "auto"); margin: 0 auto;

...

...

 

 

The problem I am having when I do this is that when I make the IE window smaller and then maximise the Category Items jump out of the box and are left on the far left hand side of the screen. As soon as I move over them, they jump back into the category box. Its really weird.

 

 

Q2. I notice that the width (when using a fixed width) seems to be different on firefox and IE 7 (RC1) is this usual? Is there anyway around it?

 

Cheers..

Share this post


Link to post
Share on other sites
Has anyone with this installed managed to get it running with PWA or Guest Account?

 

Ive tryed twice, and it sends the pages everywhere full screen again, having to get rid of it everytime.

 

 

You have to check if those and the BDP have some common files which has been modified..if so you need to merge the changes..

Share this post


Link to post
Share on other sites
First of all this is a great contribution to osc then second how do i change the writing on the buttons.?

Some places in my shop it write the wrong text. for example when you add a product and go to your cart it says log off insted off continue just in danish insted of english. can anyone please help me here???

 

kind regards

Tonny

 

 

The butoon texts can be found in the main text files

 

ie. for english

 

includes/languages/englis.php

 

for danish

 

includes/languages/danish.php

 

and so on...

Share this post


Link to post
Share on other sites
Hi, first post here :)

 

Thanks for the great contrib. I am redoing my site at the moment and I just installed the contrib and it seems to work very well.

 

I have a couple of quick questions though, hopefully someone will be able to help.

 

Q1. I would like the site to have a different size depending on the screen resolution or client window size. I added the following code and it seems to work (kind of)

 

.fixcenter {

max-width : 955px;

width: expression(document.body.clientWidth > 955? "955px": "auto"); margin: 0 auto;

...

...

The problem I am having when I do this is that when I make the IE window smaller and then maximise the Category Items jump out of the box and are left on the far left hand side of the screen. As soon as I move over them, they jump back into the category box. Its really weird.

Q2. I notice that the width (when using a fixed width) seems to be different on firefox and IE 7 (RC1) is this usual? Is there anyway around it?

 

Cheers..

 

Have not tried it this way:

 

.fixcenter {

max-width : 955px;

width: expression(document.body.clientWidth > 955? "955px": "auto"); margin: 0 auto;

 

But will give it a try when times permits...

 

On the other hand i have tried it togeter with Amandas BR&R and it works greate....

Share this post


Link to post
Share on other sites
Have not tried it this way:

But will give it a try when times permits...

 

On the other hand i have tried it togeter with Amandas BR&R and it works greate....

 

 

I will give that a go although looking at the code on how to install it; it does not seem as easy as doing it like the way I was trying.

 

Do you know why the width when using fixed width of 800 would be different on firefox and internet explorer? I would have thought if you set it to 800px then it should be 800px?

 

cheers

Share this post


Link to post
Share on other sites

hi......i was wondering if your contribution will work with the latest version of the oscommerce engine....it's my first time using this type of engine, so i'm a noob at it.....

Share this post


Link to post
Share on other sites
hi......i was wondering if your contribution will work with the latest version of the oscommerce engine....it's my first time using this type of engine, so i'm a noob at it.....

 

ignore that comment...i've tried the engine with your contrib and it works fine so far. I've the next question: is there a way to import a flash file into the starting page??....i'm using the spanish languaje and it says where to change it but when i try to put the banner it doesn't work....any ideas???....thx...

Share this post


Link to post
Share on other sites

Hi,

 

one small question:

 

i am using XAMPP to check my installation localy.

 

what i do not understand is this:

 

everytime i call a page from the catalog frontend, there is poping up some dos shell windows. it has to do with the on the fly thumbnailing feature, which i do like.

 

but it takes a lot more time to show the site, although i have a powerfull computer. if these pictures would be created the first time, i can understand that logically.

 

but this happens EVERY time i load the side. it happens even if i call the contact side where no picture at all is shown. (i excluded the columns right and left.) only on the backend it doesnt show up...

 

so im concerned if this happens to if i upload my shop in the net, and there i have only a shared server, loading page time will be very slow....

 

thanks for your help!

Share this post


Link to post
Share on other sites

Actually i have the same thing.

its totally lame. having the 20 or so pop up windows (dos shell)

 

why is this? how can i fix this so its not as.. well stupid in that reguard..

 

i am using Xampp to modify my page locally as well.

Share this post


Link to post
Share on other sites

Hi, great contrib. I just set up your version 1.8 and I am mostly happy with the results. HOWEVER, there seems to be glitch of sorts. Please have a look at my site here

 

The problem is the overhanging "new products".

 

Your advice would be very appreciated.

 

-j

Share this post


Link to post
Share on other sites

Hi,

I am trying to apply design pack 1.8. I have double checked/uploaded all the file to the right folder but yet no diffence can be seen. Can anyone please tell where i am wrong. Thanks

Share this post


Link to post
Share on other sites
Hi,

I am trying to apply design pack 1.8. I have double checked/uploaded all the file to the right folder but yet no diffence can be seen. Can anyone please tell where i am wrong. Thanks

 

Any idea?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×