Jump to content
Latest News: (loading..)
scottyb

Newsletter products, HTML email

Recommended Posts

Hi all,

 

Please help me as I failed to send html newletter and emails yet.

 

please advise me way to send HTML Newsletter and Html Email. What i did previously which failed, I created HTML Page for newsletter in dreamweaver and Copied code in NEWSLETTER manager in OSCommerce admin section. It showed me page in a way I created in preview.

When I locked it and sent it, in customer email it all comes up in a HTML code not as a proper Html newsletter.

 

there are several contribution with different comments on it which are making me confuse.

I will be very gratefull for any one give me right direction/advise or best working contribution link.

Following is my current setting which sends normal (default) emails without any problem.

 

 

E-Mail Transport Method smtp

E-Mail Linefeeds LF

Use MIME HTML When Sending Emails true

Verify E-Mail Addresses Through DNS false

Send E-Mails true

 

I prefer using Dreamweaver to create html newsletter, please advise me to enable sending html newsletter from my website.

Someone said that Email setting for html in "config-- Admin--" not always work, which code and which file I have to edit , please specify.

 

Thanks and regards.

 

zee

Edited by zeeshop

Share this post


Link to post
Share on other sites

Hi,

 

I have installed this contri and i don't get any errors, but i also don't get to see the products.

My preview is empty only the text is visable but no products.

What i'm missing.

 

I've installed it several times. I must say i have also installed "newsletters contri V050".

 

can someone please help me.

 

Sorry, for my bad english, i'm Dutch.

 

Thnx.

Share this post


Link to post
Share on other sites

Hi could some one help

 

I installed newsletter 2.0 posted on ( 22 May 2007) but having this problem

 

 

Unable to determine the page link!

 

Function used:

 

tep_href_link('', '', 'NONSSL')

 

 

could some one help.

 

Thanks

Ajay.

Share this post


Link to post
Share on other sites

I'm using the contrib "image manager"... and I'd like to view the product's image in small size, anyone tell me how?

 

Thank you!

Share this post


Link to post
Share on other sites

Hi patamu,

 

to change the size of your pictures in your newsletter , just change into the module/newsletter/newsletter_product.php

the osc function tep_image

 

tep_image(HTTP_CATALOG_SERVER . DIR_WS_CATALOG_IMAGES . $this->productsInfo[$i]['products_image'], $this->productsInfo[$i]['products_name'], $imgWidth, $imgHeight)

 

For Ajay,

You'll find the answer in this contribution support.

made a search at the bottom of a page, with the 'tep_href_link('', '', 'NONSSL')'

 

You'll find it out !

 

++

Share this post


Link to post
Share on other sites

Hi !

 

I've got a pb with this,

 

When I send or just preview my newsletter with newsletter_product module, I only got the pictures of the product I choose in my template.

 

But I didn't find out how to put the $content inside. Does it normaly works.

Maybe it's because I've got a error message when I edit my Nl after preview like :

Warning: reset() [function.reset]: Passed variable is not an array or object in root\admin\includes\classes\object_info.php on line 18

Warning: Variable passed to each() is not an array or object in root\admin\includes\classes\object_info.php on line 19

In this support tread, I found a post witch talk about it, but no answer and solution to resolve this !!!

 

Any Ideas?

 

Thanks!

Padaben

Share this post


Link to post
Share on other sites

I'm trying to install Newsletter products 2.0 and am having trouble when trying to create or edit a newsletter. The page displays everything down to the Contents box and then quits. When I view the last lines of the source for the pages I see the following:

 

<tr>

<td colspan="2" class="main" align="center">You need only select products and a template if you are using the newsletter_products module</td>

</tr>

<tr>

<td></td>

<td class="main">

 

I've traced the point of stoppage down to line 313 in the new newsletters.php which reads as follows:

 

<td class="main"><?php echo $products->choose_products(); ?></td>

 

 

Can anyone tell me why the $products->choose_products() would be causing PHP to suddenly quit? Just in case it matters I did use a search and replace to convert all instances of $HTTP_GET_VARS to $_GET and all instances of $HTTP_POST_VARS to $_POST in this contribution before I installed it so it would match the rest of our site and I changed the three comma joins in newsletter_products.php to the word join so that it would work with MYSQL5. Otherwise I haven't changed anything in the contribution source code so I am at a loss to explain why this contribution would work for other people but not for us.

Share this post


Link to post
Share on other sites
I'm trying to install Newsletter products 2.0 and am having trouble when trying to create or edit a newsletter. The page displays everything down to the Contents box and then quits. When I view the last lines of the source for the pages I see the following:

 

I found the problem. It had to do with the fact that our html_output.php had an old version of the function for drawing pull down menus.

Share this post


Link to post
Share on other sites

I just installed newsletter2.0 as well because my newsletters.php was cutting off right after the text box,

 

im now getting the following error: Unable to determine the page link!

 

Function used:

 

tep_href_link('', '', 'NONSSL')

Share this post


Link to post
Share on other sites

nevermind the above topic.

 

after having to go through and edit a ton of the code so this new 2.0 thing actually worked, I finally send my mail.

 

It didn't use the template. At all.

 

So now 100+ people have received an ugly email with no HTML pictures in it.

 

It seems like this 2.0 wasn't even tested at all.

 

how can i force it to use a template ?

Share this post


Link to post
Share on other sites
nevermind the above topic.

 

after having to go through and edit a ton of the code so this new 2.0 thing actually worked, I finally send my mail.

 

It didn't use the template. At all.

 

So now 100+ people have received an ugly email with no HTML pictures in it.

 

It seems like this 2.0 wasn't even tested at all.

 

how can i force it to use a template ?

 

 

answering my own question

 

 

around line 167 in admin/includes/modules/newsletters/newsletter_products.php :

		if(tep_not_null($this->template)){
		//HTML page from template
		$content = join('', file(DIR_WS_TEMPLATES . $this->template)); // this was originally commented out
		//$content = file_get_contents(DIR_WS_TEMPLATES . $this->template); // this wasn't commented out. switcharoo fixed the template not being used .
		//remove all line breaks and spaces in template to ensure no spaces resulting from email class
		$content = str_replace("\n", '', $content);

Share this post


Link to post
Share on other sites

Anyone have an idea of how to integrate this contribution with Simple Visitor Newsletter. I have both of these great contributions installed and working seperately.

Share this post


Link to post
Share on other sites

in preview i have this error:

 

1054 - Unknown column 'p.products_image2' in 'field list'

 

i have multiple images hack. anyone have demo templates for this contrib?

 

Thanks a lot.

 

AlexOsp

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites
in preview i have this error:

 

1054 - Unknown column 'p.products_image2' in 'field list'

 

i have multiple images hack. anyone have demo templates for this contrib?

 

Thanks a lot.

 

AlexOsp

 

Hi, it's because in your dsatabase, p.products_image2 don't exists.

change in your files to p.products_image .

 

Bye

Edited by Jan Zonjee

Share this post


Link to post
Share on other sites
Hi, it's because in your dsatabase, p.products_image2 don't exists.

change in your files to p.products_image .

 

Bye

 

Thanks, now works fine.

 

Any template demo?

Share this post


Link to post
Share on other sites
Thanks, now works fine.

 

Any template demo?

Hi !

 

good for you.

 

For any template, find it out on oscommerce commnity, or on google, you'll find some.

There's any on french oscommerce community ;)

 

Bye

Share this post


Link to post
Share on other sites

Hi !

 

I've got a problem :

The "content" in the newsletter doesn't show when I use the newsletter_products module

It's shows just fine when using newsletter module so it's not an empty fieldin the database...

 

To me it seems like $html_content doesn't collect the value from the field "content" in table "newsletters"...

 

What could be wrong?

 

 

BTW Great Contribution !!

Share this post


Link to post
Share on other sites
v1.0 was developed using only one language. A couple of people have contacted me about multiple products showing up when more than one language is being used.

 

Although I had included the $language_id variable in the sql, it's apparent that it doesn't work.

 

Until I have time to fix the language issue for v1.1, a fix for multiple languages can be simply changing $language_id to the actual number used for the desired language (i.e. '1' for english etc.).

Two occurances of the variable are around lines 31, and 45 of includes/modules/newsletter/newsletter_products.php.

 

Thanks to Teun for pointing this out.

 

 

Can you tell me how i send HTML base Newsletter and how to make html template(I mean how i create html base newsletter)?

Share this post


Link to post
Share on other sites

Hi all,

 

I'm trying to install Newsletter products 2.0 and am having some trouble. I try to create a new Newsletter but the buttons Save, Exit don't appear in the page.

 

Thanx, on behalf.

Share this post


Link to post
Share on other sites

Hi,

 

I have install this contribution, but i have 2 problems.

1. after the preview, what is how i wanted, i get a error :

 

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ') and pd.language_id=4' at line 1

 

select p.products_id, pd.products_name, p.products_image, p.products_price, p.products_tax_class_id, if(s.status, s.specials_new_products_price, NULL) as specials_price from products p, products_description pd left join specials s on p.products_id = s.products_id where pd.products_id = p.products_id and p.products_id in() and pd.language_id=4

 

p.products in() = empty

 

When i filled p.products in() with a productnummer in newsletter_to_products.php, emails where send.

 

2. When i look at the recieved email, i don't get the template to see, only products.

 

What could be wrong?

Share this post


Link to post
Share on other sites
Anyone have an idea of how to integrate this contribution with Simple Visitor Newsletter. I have both of these great contributions installed and working seperately.

 

I have the same wish. Anyone have an idea?

 

Thx!

Share this post


Link to post
Share on other sites
Hi !

 

I've got a problem :

The "content" in the newsletter doesn't show when I use the newsletter_products module

It's shows just fine when using newsletter module so it's not an empty fieldin the database...

 

To me it seems like $html_content doesn't collect the value from the field "content" in table "newsletters"...

 

What could be wrong?

BTW Great Contribution !!

 

I've got the same issue. It's driving me crazy--does anyone else know why this field data is not carried over to the $html_content variable?

 

Thanks!

Share this post


Link to post
Share on other sites

I have a question regarding the newsletter products email. I dont know if I messed up the code myself but I need to have a message above the products, any Idea how to get this there?

 

I mean when your in the admin pages / newsletter page you type a subject and below this you have the message form. I want this message above the products.

 

All help is appreciated

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×