Jump to content
Latest News: (loading..)

Archived

This topic is now archived and is closed to further replies.

mergesort

Unable to connect to database server

Recommended Posts

After the installation, when i try to go to the homepage, it always gives me "unable to connect to database server". Everything seemed to be successful during the installation and I checked the control panel of my web hosting and can see that the database does have all those tables. The address is http://www.hellopotato.com

 

thanks

Share this post


Link to post
Share on other sites

figured it out...

 

After the installation, when i try to go to the homepage, it always gives me "unable to connect to database server". Everything seemed to be successful during the installation and I checked the control panel of my web hosting and can see that the database does have all those tables. The address is http://www.hellopotato.com

 

thanks

Share this post


Link to post
Share on other sites

I am having the same problem, how do I fix? Installation all good, but when I go to admin panel the error message "Unable to connect to database server!" shows. Please help

Share this post


Link to post
Share on other sites

I had my development on the local machine, when i finished everythg, i decide to upload to the server. It went well and when i checked the url; it navigates as expected but when i tried to access the admin page it says: Unable to connect to database server! I will appreciate every support i can get. I checked the config.php file it seems to be ok with ther database parameter.

Share this post


Link to post
Share on other sites

I had my development on the local machine, when i finished everythg, i decide to upload to the server. It went well and when i checked the url; it navigates as expected but when i tried to access the admin page it says: Unable to connect to database server! I will appreciate every support i can get. I checked the config.php file it seems to be ok with ther database parameter.

 

have you done both configure.php files?

Share this post


Link to post
Share on other sites

Ok, I am getting the same message on both the site and admin part of the site. I haven't checked the config files yet, but if I hadn't made any changes to those, how would they be any different? We just had to renew the domain name, and it worked for 1 day afterwards. Then last night we get this message.

 

What should I be looking for in the config file? Could it be something dealing with the domain renewal?

Share this post


Link to post
Share on other sites

in the configure files

 

  define('DB_SERVER', 'localhost');
 define('DB_SERVER_USERNAME', xxxx');
 define('DB_SERVER_PASSWORD', 'xxxx');
 define('DB_DATABASE', 'xxxx');
 define('USE_PCONNECT', 'false');

 

You should just need to edit the fields above with xxxx in them, get the login info from your cpanel sql module, remember the user must have full permissions otherwise you could get the same error

 

 

Domain renewal should have no bearing, especially if your host is not your registrar, if it did it would be their fault.


Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Share this post


Link to post
Share on other sites

Hi, I get the same thing.

............................/catalog/admin/filegroup_db_setup.php

 

Unable to connect to database server

 

........................../admin/

 

Goes straight to admin logon.

 

I have used winmerg to check both configuration.php. files. (in the ............/admin/ & ............./Catalog/admin/

Both are identical.

This code is not in either of them

[/size][/font]
[font=arial,helvetica,sans-serif][size=3]  define('DB_SERVER', 'localhost');
 define('DB_SERVER_USERNAME', xxxx');
 define('DB_SERVER_PASSWORD', 'xxxx');
 define('DB_DATABASE', 'xxxx');
 define('USE_PCONNECT', 'false');

 

Is there a table flow chart that shows which files run from login.php on the .........../admin/login.php (what is the next file to run?) This works.

And the same with .........../catalog/admin/filegroup_db_setup.php (what is the next file to run?) This does not work. 'Unable to connect to database server'

 

Any help would be great. I have deleted the db, recreated, uninstalled OSC and reinstalled. followed Super Download Store for osCommerce 2.3.x, Installation Instructions 3 times now. And get the same result each time.

 

Cheers Andy. Pulling hair out...........

Share this post


Link to post
Share on other sites

Can anyone help with this error?

 

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'xxxxxxxxxx'@'xxxxxxxxx' (using password: YES) in/home/content/30/9677030/html/onlinestore/catalog/includes/functions/database.php on line 19

Unable to connect to database server!

 

Things I've verified...

Both config files have the correct username and password

I can login through MyPHPAdmin and run queries

I can login to the Admin of the onlinestore

But if I click on catalogs or try to visit the store I get the above error.

 

What am I missing?

 

I never had a problem until I changed my password in the MyPHPAdmin. Again, I can login fine..

If I try to grant permission to the user is gives me access denied as well...

Share this post


Link to post
Share on other sites

Lora,

 

Just because you can login into your MyPHPAdmin doesn't mean diddly, sorry Lora. You said you never had a problem until after you changed your password in MyPHPAdmin...So, you changed your password in your sites MyPHPAdmin to a new password but that wasn't for the database that was for your MyPHPAdmin.

 

Once you did that, did you insure that the original database user had all permissions for the database, and make sure that you used the correct user/password/ combination for your database in both your includes/configure.php and the admin/includes/configure.php files, because your error message is telling you the user doesn't have the correct password information or permissions for this database.

 

I would go back to your MyPHPAdmin and check it very carefully, because this is where your problem lays, with your username and password for the applicable database... Even better, instead of messing around sign into your MyPHPAdmin and make up a new user for the database you want to use, make sure to give that new username full permissions for the database and save it. Then go and change both files above to the new user/password combination. Hope this helps...

 

Cheers,

DougB

Share this post


Link to post
Share on other sites

×