Jump to content
Sign in to follow this  
nana

fast easy checkout

Recommended Posts

I have installed FEC along with STS and all seems to be working normally ...... until i also installed an individual postage contribution ( http://www.oscommerce.com/community/contributions,367 ) and now I have a problem carrying the postage through to the checkout.

 

Obviously the contribution didnt know I had FEC installed and I need to add code to the FEC pages ( no what or idea which ) to carry the postage field ( which was the db weight field ) from the product listing pages through to the checkout.

 

Has anyone installed this contrib with FEC or does anyone know how I should do it ?

 

regards

Graham

Share this post


Link to post
Share on other sites

I am using Fast Easy Checkout. As you can see here https://dreamstars.com/catalog/create_account2.php the City box is missing from the Shipping Information so it will not allow people to progress any further in creating an account.

 

Also the Check to use Billing Information checkbox does not enter the information from the Billing side

 

I have spent hours searching for the answer within this forum. Can someone please direct me to the solution?

Share this post


Link to post
Share on other sites

Hello, I just installed FEC and I am having a couple of problems...

1. If a customer who is already logs in goes to checkout then none of the shipping modules work and will not allow the customer to proceed. (new customers it works for unless they hit the back button after picking theri shipping and cc info.) this can be tested using

email: seeinstars89@cox.net

password:password

 

2. In admin/orders page I am getting this error:

 

Parse error: parse error, unexpected T_CASE in /home/grunionf/public_html/admin/orders.php on line 71

 

I had previously installed the Purchase Without Account contribution and maybe this is what caused my problems. either way I dont know. Any help would be so great.

 

http://grunionfabrication.com

Share this post


Link to post
Share on other sites
Hello, I just installed FEC and I am having a couple of problems...

1. If a customer who is already logs in goes to checkout then none of the shipping modules work and will not allow the customer to proceed. (new customers it works for unless they hit the back button after picking theri shipping and cc info.) this can be tested using

email: seeinstars89@cox.net

password:password

 

2. In admin/orders page I am getting this error:

 

Parse error: parse error, unexpected T_CASE in /home/grunionf/public_html/admin/orders.php on line 71

 

I had previously installed the Purchase Without Account contribution and maybe this is what caused my problems. either way I dont know. Any help would be so great.

 

http://grunionfabrication.com

 

Ok, I got this fixed somehow..... Maybe I just installed it wrong...

Share this post


Link to post
Share on other sites
Ok, I got this fixed somehow..... Maybe I just installed it wrong...

 

Hi

 

Just installed FEC and apart from a few minor changes in the layout it seems to be working. The prob that I am having is with the Contact us page.

 

I have the contact us installed and when I am logged in I can't type in the name and email address boxes but I can in the big enquiry box but I can type in all boxes when I am logged out. I have uploaded the default OSC contact us page and it still happens so I know it isn't the contact us page.

 

Thanks

 

Ian

Share this post


Link to post
Share on other sites
Hi

 

Just installed FEC and apart from a few minor changes in the layout it seems to be working. The prob that I am having is with the Contact us page.

 

I have the contact us installed and when I am logged in I can't type in the name and email address boxes but I can in the big enquiry box but I can type in all boxes when I am logged out. I have uploaded the default OSC contact us page and it still happens so I know it isn't the contact us page.

 

Thanks

 

Ian

 

Hi again

 

Doing some more testing and it seems the original contact us works :blush: I have viewed the source of the page and the entry boxes are set to readonly. If the customer is logged in it should prefill the name and email boxes and set them to readonly. That bit is right it just isn't displaying the name and email. If I uninstall the FEC contrib then it all works. The code in the contact us choice contrib is

 

			  <tr>
			<td class="main"><?php 
		  // prefill first+last name and email address if customer is logged in
		  if (tep_session_is_registered('customer_id')) {
		  $customer_query_raw = "select customers_firstname, customers_lastname, customers_email_address from " . TABLE_CUSTOMERS . " where customers_id='" . $customer_id . "'";
		  $customer_query = tep_db_query($customer_query_raw);
		  $customer_array = tep_db_fetch_array($customer_query);
		  echo tep_draw_input_field('name', $customer_array['customers_firstname'] . " " . $customer_array['customers_lastname'],'readonly');
		  echo "</td></tr><tr><td class=\"main\">" . ENTRY_EMAIL . "</td></tr><tr><td class=\"main\">";
		  echo tep_draw_input_field('email', $customer_array['customers_email_address'],'readonly');
			} else {
		  echo tep_draw_input_field('name');
		  echo "</td></tr><tr><td class=\"main\">" . ENTRY_EMAIL . "</td></tr><tr><td class=\"main\">";
			echo tep_draw_input_field('email');
			} ?></td>
		  </tr>

 

Hope someone can help

 

Ian

Share this post


Link to post
Share on other sites

hi there, i just installed the fec, i have selected to use create_account2.php for check out. after customer fills in info on create_account2.php, i click next, it gave me an error:

 

0 -

 

insert into customers_info (customers_info_id, customers_info_number_of_logons, customers_info_date_account_created) values ('0', '0', now())

 

which the query is from:

tep_db_perform(TABLE_CUSTOMERS, $sql_data_array);

$customer_id = tep_db_insert_id();

 

tep_db_query("insert into " . TABLE_CUSTOMERS_INFO . " (customers_info_id, customers_info_number_of_logons, customers_info_date_account_created) values ('" . (int)$customer_id . "', '0', now())");

 

 

is the $customer_id supposed to be 0? i have checked the "tep_db_perform(TABLE_CUSTOMERS, $sql_data_array); " does insert the record for the customer, but "$customer_id = tep_db_insert_id();" didn't get the customer_id out.

 

do i miss anything anywhere? or anything i didn't set up? please help. thanks.

Share this post


Link to post
Share on other sites

OK OK

How the heck do you get the CCGV module to appear and WORK on checkout_shipping.php

 

cannot get it to work at all............

and im pulling my hair out !!!!!!

Share this post


Link to post
Share on other sites
OK OK

How the heck do you get the CCGV module to appear and WORK on checkout_shipping.php

 

cannot get it to work at all............

and im pulling my hair out !!!!!!

 

I feel your pain. If you uncomment the line:

 

// echo $order_total_modules->credit_selection();//rmh M-S_ccgv

 

the coupon box shows up as expected, and works in firefox, but in IE you get the javascript error:

 

Error: 'document.checkout_payment.payment.0' is null or not an object

 

I've been looking at this for 3+ days now and haven't got anywhere!

 

Anybody else want to chime in?

 

-Matt

Share this post


Link to post
Share on other sites
Hi again

 

Doing some more testing and it seems the original contact us works :blush: I have viewed the source of the page and the entry boxes are set to readonly. If the customer is logged in it should prefill the name and email boxes and set them to readonly. That bit is right it just isn't displaying the name and email. If I uninstall the FEC contrib then it all works. The code in the contact us choice contrib is

 

<tr>
			<td class="main"><?php 
		  // prefill first+last name and email address if customer is logged in
		  if (tep_session_is_registered('customer_id')) {
		  $customer_query_raw = "select customers_firstname, customers_lastname, customers_email_address from " . TABLE_CUSTOMERS . " where customers_id='" . $customer_id . "'";
		  $customer_query = tep_db_query($customer_query_raw);
		  $customer_array = tep_db_fetch_array($customer_query);
		  echo tep_draw_input_field('name', $customer_array['customers_firstname'] . " " . $customer_array['customers_lastname'],'readonly');
		  echo "</td></tr><tr><td class=\"main\">" . ENTRY_EMAIL . "</td></tr><tr><td class=\"main\">";
		  echo tep_draw_input_field('email', $customer_array['customers_email_address'],'readonly');
			} else {
		  echo tep_draw_input_field('name');
		  echo "</td></tr><tr><td class=\"main\">" . ENTRY_EMAIL . "</td></tr><tr><td class=\"main\">";
			echo tep_draw_input_field('email');
			} ?></td>
		  </tr>

 

Hope someone can help

 

Ian

 

Hi again

 

just thought I'd let everyone know that I have solved it. I had the same prob (boxes not filled in) on the edit account page so I created a test account on the OSC demo page just to check and the boxes were filled in.

 

Anyway, after a bit of digging I overwrote my html_output.php file with the default and all is OK.

 

Thanks

 

Ian

Share this post


Link to post
Share on other sites
I feel your pain. If you uncomment the line:

 

// echo $order_total_modules->credit_selection();//rmh M-S_ccgv

 

the coupon box shows up as expected, and works in firefox, but in IE you get the javascript error:

 

Error: 'document.checkout_payment.payment.0' is null or not an object

 

I've been looking at this for 3+ days now and haven't got anywhere!

 

Anybody else want to chime in?

 

-Matt

 

hi matt

i have done this.... but now when i try to gey past that stage all that shows is this

 

You did not enter a redeem code. ... and i cannot get any further. even when a code is redeemed, it takes it off but still wont go further

Share this post


Link to post
Share on other sites
hi matt

i have done this.... but now when i try to gey past that stage all that shows is this

 

You did not enter a redeem code. ... and i cannot get any further. even when a code is redeemed, it takes it off but still wont go further

 

 

ahhha

going back to a post mAde in 2005 (!)

 

in checkout_confirmation.php

 

you need to change the code to this

 

//fast easy checkout start

foreach ($_SESSION as $key => $val) {

//print $key.' => '.$val.' - ';print_r($val);echo "<br>";

$HTTP_POST_VARS[$key] = $val;

 

}

// first two lines are for ccgv

tep_session_unregister('gv_redeem_code');

tep_session_unregister('credit_covers');

 

// following 2 lines added by Ed to sort CCGV problem

tep_session_unregister('submit_redeem_x');

tep_session_unregister('submit_redeem_y');

 

tep_session_unregister('cc_number');

tep_session_unregister('cc_expires_month');

tep_session_unregister('cc_expires_year');

tep_session_unregister('cc_owner');

tep_session_unregister('authorizenet_cc_number');

tep_session_unregister('authorizenet_cc_expires_month');

tep_session_unregister('authorizenet_cc_expires_year');

tep_session_unregister('authorizenet_cc_owner');

//fast easy checkout end

Share this post


Link to post
Share on other sites

Can anyone tell me how to add text to the purchase confirmation email sent out by checkout process.php ?

 

I would like to add appropriate text in several places but mainly following this line

 

//fec start

// lets start with the email confirmation

$email_order = STORE_NAME . "\n" .

 

can I just enter html into the file ( hasn't worked when I tried it :) ) or do I need to do something in a language file and then link to it ?

 

There must be some way of tidying up this email

 

regards

Graham

Share this post


Link to post
Share on other sites

Do you actually have this working now with both fec and ccgv? If so, can you send me your checkout_shipping.php file, and your checkout_payment.php file?

 

email to mattm.ebay at verizon.net

 

Thanks,

-Matt

 

ahhha

going back to a post mAde in 2005 (!)

 

in checkout_confirmation.php

 

you need to change the code to this

 

//fast easy checkout start

foreach ($_SESSION as $key => $val) {

//print $key.' => '.$val.' - ';print_r($val);echo "<br>";

$HTTP_POST_VARS[$key] = $val;

 

}

// first two lines are for ccgv

tep_session_unregister('gv_redeem_code');

tep_session_unregister('credit_covers');

 

// following 2 lines added by Ed to sort CCGV problem

tep_session_unregister('submit_redeem_x');

tep_session_unregister('submit_redeem_y');

 

tep_session_unregister('cc_number');

tep_session_unregister('cc_expires_month');

tep_session_unregister('cc_expires_year');

tep_session_unregister('cc_owner');

tep_session_unregister('authorizenet_cc_number');

tep_session_unregister('authorizenet_cc_expires_month');

tep_session_unregister('authorizenet_cc_expires_year');

tep_session_unregister('authorizenet_cc_owner');

//fast easy checkout end

Share this post


Link to post
Share on other sites

Very interesting post. Great work on the contrib.

 

I just downloaded fec 3.2 in the lang files there is no fast account.php file. so i went down to the update and got it from there. Now what happens is the site works fine untill I go to checkout then get page can not be displayed. Does anyone have any ideas on this? I just spent the better half of 3 hours looking and reading this post to no avail.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I just relized I am missing the fec folder in the includes part to. It wasnt with the download from the contrib section. Can someone direct me to the complete download?

 

Thank you

Share this post


Link to post
Share on other sites

OK, I have figured out the fec on the download page ot the top updated 27, feb, 2007 is very incomplete. Downloaded nebbs ubdates and all works fine. The only issue I can find is after completing the order I go to the success page and then click continue and get page can not be diplayed.

 

Any thoughts?

Share this post


Link to post
Share on other sites

I searched the forum and didn't see an answer to this one and I am hoping this is a quick fix. I am using create_account3.php so customers do not need to create an account when purchasing. I recently noticed that when a customer adds an item to the cart and once they complete the information on create_account3.php they are redirected to an empty cart and have to put their items back into the cart in order to proceed to checkout. It almost appears that they are starting another session or lost their session. Does anyone have a fix for this one?

 

Thanks!

Share this post


Link to post
Share on other sites

Just installed OSC 2.2 MS 2, FEC 3.2, caught the lack of quotes on a Javascript call, did all the debugging I can think of, but I can't make this one go away. On create_account2.php, the 'Check this box to use billing information' checkbox generates a object expected JavaScript error at line 323, even with all the fields filled in properly on the billing side.

 

On the client side of the house, line 323 of create_account2.php is this:

 

(Check to use Billing Information: <input type="checkbox" name="copy" OnClick="java script:ShipToBillPerson(this.form);" value="checkbox"> )

 

Any ideas why this is freaking out?

Edited by amayernx

Share this post


Link to post
Share on other sites
Just installed OSC 2.2 MS 2, FEC 3.2, caught the lack of quotes on a Javascript call, did all the debugging I can think of, but I can't make this one go away. On create_account2.php, the 'Check this box to use billing information' checkbox generates a object expected JavaScript error at line 323, even with all the fields filled in properly on the billing side.

 

On the client side of the house, line 323 of create_account2.php is this:

 

(Check to use Billing Information: <input type="checkbox" name="copy" OnClick="java script:ShipToBillPerson(this.form);" value="checkbox"> )

 

Any ideas why this is freaking out?

 

Okay, fixed the error. I had to use the "Use this if you're having problems with the no password" optional script, which seems to me that it's not so "optional". I also had to comment out the lines related to suburbs on the form_check.js.php page. I don't recall exact line numbers, but in the area of 166, 170, and 186 on form_check.js.php, there's some commentary on suburbs. If you've got that field disabled, it freaks out. In addition, there's a bug in the code for create_account2.php.

 

I'll be compiling my fixes (and I'll try to tackle that "Get New Total" button) and putting it out there for your amusement this evening. I'll try to make it more complete so that people don't have to hunt down all of those "change this to this" sections, as that's kind of daunting for something that's supposed to be plug and play.

Share this post


Link to post
Share on other sites

And I'll talk to myself some more.

 

But, if you're listening, I have a surprise.

 

I have fixed the 'Get New Total' AJAX button on 'checkout_shipping.php'.

 

On line 265 in 'includes/fec/ajax_shipping.php', change it to:

 

document.write('<input type=button class="button" value="Get New Total" onclick="ajaxLoader(\'checkout_2confirmation.php?tip=\'+ zprice+\'&zship=\'+zhipper+\'&osCsid=\'+Csid,\'contentLYR\')" name="CLEARBUTTON">');

 

I just made this change on the site I'm putting together, and the button works now.

 

Hope this helps :lol:

Share this post


Link to post
Share on other sites

Hi

 

Just install fast easy checkout on top of Ultimate SEO URLs with SSL on and every time I try and checkout the site kicks me back to the logon page.

 

If I true SSL off all works fine.

Same if I turn SEO of all works fine.

 

Has any one else had this problem, if so how was it fixed.

 

Thanks if you can help.

Share this post


Link to post
Share on other sites

Hi - this contribution is excellent. My site runs for UK only - is there a way to remove the country selection process from the checkout page?

thanks

Share this post


Link to post
Share on other sites
I searched the forum and didn't see an answer to this one and I am hoping this is a quick fix. I am using create_account3.php so customers do not need to create an account when purchasing. I recently noticed that when a customer adds an item to the cart and once they complete the information on create_account3.php they are redirected to an empty cart and have to put their items back into the cart in order to proceed to checkout. It almost appears that they are starting another session or lost their session. Does anyone have a fix for this one?

 

Thanks!

It looks like I had a cookie issue, unrelated to FEC - fix is in this thread

Share this post


Link to post
Share on other sites

I installed the FEC. Thanks for the fantastic contribution!

 

I only have one payment method, and no billing adress, only the shipping adress. Therefore I would like to skip the checkout_shipping.php and let the user directly goes to the Checkout_confirmation.php.

 

However, there are lots of status session checking in the Checkout_confirmation.php, so it keeping through me back to the checkout_shipping.php anyway even I from the shop_cart.php directly go to the Checkout_confirmation.php.

 

How shall I do? I would like to skip the checkout_shipping.php and let the user directly from shopping_cart.php goes to the Checkout_confirmation.php.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×