Jump to content
Sign in to follow this  
nana

fast easy checkout

Recommended Posts

I'm looking at older versions than 3.2 and I see that there was database changes and some header changes. Doesn't need any of this the newest 3.2 version ? And the files in /include directory are not needed for shipping+payment in 1 method ? (installation file doesn't mention it).

Share this post


Link to post
Share on other sites

Problem solved... I forgot to remove the column_left.php wich I don't use (I print the category in the header) and that was declaring 2 times tep_show_category().

 

Now I've a doubt... I have a tax applied to cash on delivery method but the "calculate total" button of this contribution doesn't check if payment method is cod, transfer,etc or doesn't apply correctly the tax if is needed. How could I add the tax of COD method to the "total box" printed in this contribution ?

Edited by krampak

Share this post


Link to post
Share on other sites

Am I wrong or this contrib is ont designed for checkout without creating account? When i try the demo it asks me for providing password, why is that if not for creating account ?

Share this post


Link to post
Share on other sites

And it seems your test site does not work well:

 

http://seelily.com/fec/account_password_new.php?thx=1

 

 

Warning: main(includes/languages/english/create_account1.php): failed to open stream: No such file or directory in /home/franksee/public_html/fec/account_password_new.php on line 15

 

Warning: main(includes/languages/english/create_account1.php): failed to open stream: No such file or directory in /home/franksee/public_html/fec/account_password_new.php on line 15

 

Fatal error: main(): Failed opening required 'includes/languages/english/create_account1.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/franksee/public_html/fec/account_password_new.php on line 15

Share this post


Link to post
Share on other sites
I want to install this contribution and Discount Coupon Codes. Should I install one before the other? Has anyone tried using Discount Coupon Codes with fast easy checkout?

 

Yes, it works fine for me.

 

However, I have another problem with the fast easy checkout:

 

A customer who does not create an account receives a link by email with which he can create an account (he only needs to choose a password). When he does, he receives the following error-message:

 

Your Current confirmation key did not match the key in our records. Please try again.

 

Does somebody know what's wrong?

 

Thanks a lot

 

Sandra

Edited by kitchenniche

HIM - Dark Light - Out on 26/09/05

Share this post


Link to post
Share on other sites

Any help in this matter is greatly appreciated. I am running into two issues with the fast easy checkout, but I am not sure excatly which version was applied as we recently took over this website. Basically, when a customer puts in Order Comments on the checkout_payment page, those comments are not being recorded or updated anywhere. The operating system used is Linux web2.websitesource.net 2.4.21-32.0.1 and the webserver is Apache/1.3.34 (Unix) mod_ssl/2.8.25 OpenSSL/0.9.7a FrontPage/5.0.2.2635. We are using PHP version 4.4.1.

 

Another issue I am noticing deals with the Discount Coupons contribution. With the install of version 1.3 Discount Coupons when a customer keys in the Coupon code on checkout_payment, then clicks continue to checkout_confirmation the discount is correctly applied. However, if customer goes back to checkout_payment and changes to another coupon code or even to take out the existing one, upon clicking continue and being taken to checkout_confirmation, the old discount still is visible. There appears to be no way to change or take out the coupon code that was initially keyed. Sent a note to the developer on the Discount Coupons module and here are there comments related to code pasted from our catalog/checkout_confirmation.php which seem to relate the issue to this fast easy checkout process:

 

So at the top you have the Fast Easy checkout code:

 

CODE//fast easy checkout start

foreach ($_SESSION as $key => $val) {

// print $key.' => '.$val.' - ';print_r($val);echo "<br>";

$HTTP_POST_VARS[$key] = $val;

 

}

 

What this code is doing is overwriting the POSTed variables with the existing session variables. So, first time through, you enter a coupon code and it is set to the session. Second time through, you enter a new coupon code, but it gets replaced by the 'existing' session variable value. The second coupon code is not written to the session until later in the code, after it can be validated. So at this exact point in the code, the coupon session variable is not the same as the POSTed coupon variable from the form.

 

I haven't the faintest idea why on earth fast easy checkout is doing this. I would also suspect from looking at the code that you would have this same problem with the comments box as well. What happens when you go back and change the comments? Does that change hold?

 

I'd suggest getting in touch with the developer of that contribution. He/she seems active and I think you might get a better answer. My first guess would be to prevent this code from happening to the coupon POST variable like so:

 

CODE//fast easy checkout start

foreach ($_SESSION as $key => $val) {

// print $key.' => '.$val.' - ';print_r($val);echo "<br>";

//kgt - discount coupons

//prevent the session value from overwriting the POST value

if( $key != 'coupon' ) {

$HTTP_POST_VARS[$key] = $val;

}

//$HTTP_POST_VARS[$key] = $val;

//end kgt - discount coupons

}

 

But I don't know if that change would be appropriate due to the changes fast easy checkout makes to the checkout.

 

The other thing I notice is line 309-312:

 

CODEif (MODULE_ORDER_TOTAL_INSTALLED) {

// $order_total_modules->process();

echo $order_total_modules->output();

}

 

There's no comment I can see as to why the process() line has been commented out. As far as I know, this line is required to get the proper output(). I'm guessing there's some contribution you have that handles this differently, since you haven't complained that none of your order total lines show up! This was the only other thing I saw that differed significantly from stock OSC with discount coupon codes applied. Other changes appeared to be largely cosmetic in nature

Share this post


Link to post
Share on other sites

Nana,

 

This is really just an enquiry, you mentioned on your post when you added FEC 3.2 that you would be updating it soon with any fixes etc, I'm just wondering when this will be before I try and go through this forum looking for the fixes etc? If it's not going to be for a month or two please let me know and i'll get cracking with 3.2 and the fixes.

 

Many thanks.

 

Becki

 

P.S - Has anyone got a set of new files with all the fixes etc they want to share :) ?

Edited by Becki

Share this post


Link to post
Share on other sites

Issues with session variables and comments with fast easy checkout applied.

 

Any help in this matter is greatly appreciated. I am running into two issues with the fast easy checkout, but I am not sure excatly which version was applied as we recently took over this website. Basically, when a customer puts in Order Comments on the checkout_payment page, those comments are not being recorded or updated anywhere. The operating system used is Linux web2.websitesource.net 2.4.21-32.0.1 and the webserver is Apache/1.3.34 (Unix) mod_ssl/2.8.25 OpenSSL/0.9.7a FrontPage/5.0.2.2635. We are using PHP version 4.4.1.

 

Another issue I am noticing deals with the Discount Coupons contribution. With the install of version 1.3 Discount Coupons when a customer keys in the Coupon code on checkout_payment, then clicks continue to checkout_confirmation the discount is correctly applied. However, if customer goes back to checkout_payment and changes to another coupon code or even to take out the existing one, upon clicking continue and being taken to checkout_confirmation, the old discount still is visible. There appears to be no way to change or take out the coupon code that was initially keyed. Sent a note to the developer on the Discount Coupons module and here are there comments related to code pasted from our catalog/checkout_confirmation.php which seem to relate the issue to this fast easy checkout process:

 

So at the top you have the Fast Easy checkout code:

 

CODE//fast easy checkout start

foreach ($_SESSION as $key => $val) {

// print $key.' => '.$val.' - ';print_r($val);echo "<br>";

$HTTP_POST_VARS[$key] = $val;

 

}

 

What this code is doing is overwriting the POSTed variables with the existing session variables. So, first time through, you enter a coupon code and it is set to the session. Second time through, you enter a new coupon code, but it gets replaced by the 'existing' session variable value. The second coupon code is not written to the session until later in the code, after it can be validated. So at this exact point in the code, the coupon session variable is not the same as the POSTed coupon variable from the form.

 

I haven't the faintest idea why on earth fast easy checkout is doing this. I would also suspect from looking at the code that you would have this same problem with the comments box as well. What happens when you go back and change the comments? Does that change hold?

 

I'd suggest getting in touch with the developer of that contribution. He/she seems active and I think you might get a better answer. My first guess would be to prevent this code from happening to the coupon POST variable like so:

 

CODE//fast easy checkout start

foreach ($_SESSION as $key => $val) {

// print $key.' => '.$val.' - ';print_r($val);echo "<br>";

//kgt - discount coupons

//prevent the session value from overwriting the POST value

if( $key != 'coupon' ) {

$HTTP_POST_VARS[$key] = $val;

}

//$HTTP_POST_VARS[$key] = $val;

//end kgt - discount coupons

}

 

But I don't know if that change would be appropriate due to the changes fast easy checkout makes to the checkout.

 

The other thing I notice is line 309-312:

 

CODEif (MODULE_ORDER_TOTAL_INSTALLED) {

// $order_total_modules->process();

echo $order_total_modules->output();

}

 

There's no comment I can see as to why the process() line has been commented out. As far as I know, this line is required to get the proper output(). I'm guessing there's some contribution you have that handles this differently, since you haven't complained that none of your order total lines show up! This was the only other thing I saw that differed significantly from stock OSC with discount coupon codes applied. Other changes appeared to be largely cosmetic in nature

Share this post


Link to post
Share on other sites

I just got this installed and Im having a little problem. Even though the Create Account box isnt checked its still asking for a password. How can I fix that?

 

Also how can I change/add/remove the info that it is asking for in the checkout page?

 

Thanks

Share this post


Link to post
Share on other sites

Being a newbie I need help with the following.

 

I installed FEC on a clean OSC install. Before the FEC installation I made an order to check that OSC was working OK in it's original version. It did.

 

After installing FEC I wanted to do the same, of course. Hence I tried to delete the "old" customer + order in Admin. But I made this in the wrong order I guess, deleting the customer before the order. When I clicked "Order" to delete it I got the following error message:

 

Parse error: syntax error, unexpected T_VARIABLE in /usr/home/web25961/domains/somed.se/public_html/butik/iadmin/orders.php on line 39

 

Line 39 in orders.php is:

 

$check_status = tep_db_fetch_array($check_status_query);

 

I don't know if the orders.php file is wrong or if I messed up the db. What do you guys think? How can I fix this? If I can delete the order in the db using phpMyAdmin, how do I do that? (Please explain it in detail. I'm a total rookie when it comes to db management using phpMyAdmin.)

 

Thanks in advance / Tomas

Share this post


Link to post
Share on other sites

can someone please give me the password solution. When I do not want an account I am still getting "Your Password must contain a minimum of 5 characters." I have searched this forum with no luck finding the answer. I have the latest version installed.

Share this post


Link to post
Share on other sites

BTW, I am using create_account2.php & I have these variables set:

 

$show_account_box = 2;
//0 no create account box
//1 javascript create account box
//2 normal create account box
$create_password =1;// set to 1 to create an account with random password
$show_login=2;
//0 no create login box
//1 javascript login account box
//2 normal create login box

Edited by spencermjax

Share this post


Link to post
Share on other sites

Any solution to the Authorize.net AIM problems???

If I don't get it working in a day or two, I hate to say it but I will have to uninstall fec. I really don't want to do that. I love what this contribution offers.

By the way, I am not using Simple Template System or CCGV and PWA account mods

I'd really like to get this baby working. It looks nice , but I have some worries I'm trying to work through.

 

I am working with this FEC contribution in a testing area,

and I keep getting the below error after entering the test credit card numbers in my authorize.net test account.

I'm using Authorize.net AIM.

also : just to note:

I have Simple Template System and CCGV and PWA account mods already in the code.

Here is the error message I keep getting after submitting a payment.

(note the card numbers and the authorize AIM module are working fine in another testing area without this contribution.)

 

Here is the error message: (I get after submitting payment)

---

The first four digits of the number entered are: <br>If that number is correct, we do not accept that type of credit card.<br>If it is wrong, please try again.

 

---

 

I saw one or two other posts regarding this error , but did not see any real fixes posted.

Anyone have any ideas on fixing this?

Or know where to point me.

I don't think its related to just the Authorize.net AIM payment module either.

 

--

Many thanks in advance for any tips.

Edited by spencermjax

Share this post


Link to post
Share on other sites

OK, I thought I would try the built-in authorize.net payment type just to see if I could get it to work. Now I hver a problem with that. When I click the "confirm order" button I am redirected to the OSC login.php page with this in the address bar: https://certification.authorize.net/gateway/transact.dll

 

No transaction is taking place.

 

Any thoughts on this??

Share this post


Link to post
Share on other sites

Hi, I just installed this contribution and it seems to be working great. I have one question though about changing the color of the font in the "Create an Account?" box at the bottom of the checkout. It seems to be the same color as the border and i'm not sure how or where to change that.....any help would be appreciated.

 

The address of my site is Oodles of Jewels

 

Thank you in advance for any help. :thumbsup:

Share this post


Link to post
Share on other sites

Proud,

I just took a look at your site to see if you were using authnet payment and your fec does not seem to be working correctly. It asked me for a passwork when I choose not to create an account and it also said that all of the information was needed (name,address,etc.). I did check the box for shipping info the same as billing, that was the problem. when I filled out the shipping info also, it worked. I know there is a post somewhere inthis post to fix the password problem, I just can't remember where it is and as for the other problem...I have no clue. Just thought I'd let you know.

Share this post


Link to post
Share on other sites

Check this out---->here(http://forums.oscommerce.com/index.php?s=&showtopic=199381&view=findpost&p=889232)....It worked for us.....

 

Any solution to the Authorize.net AIM problems???

If I don't get it working in a day or two, I hate to say it but I will have to uninstall fec. I really don't want to do that. I love what this contribution offers.

By the way, I am not using Simple Template System or CCGV and PWA account mods

Edited by golfman2006

Share this post


Link to post
Share on other sites
A customer who does not create an account receives a link by email with which he can create an account (he only needs to choose a password). When he does, he receives the following error-message:

 

Your Current confirmation key did not match the key in our records. Please try again.

the key that's showing up for account_password_new.php (i think that's the filename) is either not in the database or it's incorrect (such as split / broken.. possibly by the mail provider's message window) dodgeit is known to break long url's (i use it for testing)

 

have you double-checked to ensure the link you clicked was full? (not missing a single digit!)

Share this post


Link to post
Share on other sites

Need a little help for all of us trying to run this FEC module with the new Authorize.net AIM contribution(http://www.oscommerce.com/community/contributions,4091). Seeing two issues:

 

1. While researching for a fix, I found an answer to the error issue "The first four digits of the number entered are: If that number is correct, we do not accept that type of credit card. If it is wrong, please try again." I'm entering the basic 4111111111111111 test acount code. Here is the fix I tried which was changed everywhere in the file, where it says "$_POST", replace it with "$HTTP_POST_VARS".

POST to HTTP $ POST: (http://forums.oscommerce.com/index.php?showtopic=199381&st=200&p=885888entry885888).

 

This resolved the error issue when trying to submit the payment. No longer is the error generated, now all seems to be working properly, with transaction going all the way through admin and receiving approval emails from A.net. However, the developer from the Authorize.net module, wrote this tidbit about the above fix we applied as he first thought the original issue with the error above to be related to our PHP version. Keep in mind, It only stops working when I install the combined checkout_shipping/payment page with FEC.

 

"PHP 4.4.1 is fine, so either your hosts are imposing some kind of restriction on Super Globals (highly unlikely), or else Fast Easy Checkout cannot work with a module which uses Super Globals (much more likely).

 

If you wish to rewrite Fast Easy Checkout to work with Authorize Net AIM then please do so - but please don't rewrite Authorize Net AIM to work with FEC and post it as an update as this will probably lead to the whole module breaking down for anyone not using FEC."

 

I checked with our host and they indicated there are no restrictions on Super Globals from their end. Due to many of us using FEC and wanting a version of Autorize.net with AIM, would there be any hance you could issue a fix so FEC works with A.net AIM?

 

If I update the "$_POST", and replace it with "$HTTP_POST_VARS", then the error is gone.

 

2. The only other outstanding thing I see so far is that the CVV is not being valided on checkout_shipping rather checkout_payment. This is because the developer for A.net AIM does not use FEC and thus built their contribution around checkout_payment. Would it be possible for the CCV field which is on checkout_shipping to validate on both the combined cchout shipping/payment page from FEC?

 

I have no problem running some tests on any code changes you can make to get this to function with A.net AIM..Any guidance you can give to a fill in web developer/dad is much appreciated....Thanks!

Edited by golfman2006

Share this post


Link to post
Share on other sites

Would it be possible to install FEC without using the combo checkout_shipping/payment page?

The instrunctions for installation leads me to believe that it is possible. I don't know all of the code inside & out so I don't know if that would create additional errors.

 

So in essence, have the first page (create_account1.php,create_account2.php or create_account3.php) then the rest of the checkout procedure be the standard pages?

I ask this because I like the a.net AIM mod and I like having the "create account" option that FEC offers. I got the AIM mod to work (quite easily) with the standard checkout procedures.

Edited by spencermjax

Share this post


Link to post
Share on other sites

how do you fix the problem (on create_account2.php) that when you click on "Use same Billing Info as Shipping", it doesnt work. It makes you retype everything which is very untasteful. And the same thing with the password create account at the bottom.. If I unkchek that box, it still asks me for a password... This is a fantastic contribution... and makes osCommerce look and run much better, from the customer standpoint.

 

Some else mentioned that there was a fix for this somewhere in this thread, and I have spent over 4 hours now looking for it and I cant find it. Please some help here. Thanks!

Share this post


Link to post
Share on other sites

In checkout_shipping.php make sure have one of these uncommented(located at top of which ever you use):

//  tep_redirect(tep_href_link('create_account1.php', '', 'SSL'));
//  tep_redirect(tep_href_link('create_account2.php', '', 'SSL'));
//  tep_redirect(tep_href_link('create_account3.php', '', 'SSL'));

 

and make sure the following is set in which ever create_account file you use (located at top).

 

$create_password =1;// set to 1 to create an account with random password

 

That should take care of the password problem. The other ahipping address issue...I don't know.

Edited by spencermjax

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×