Jump to content
Latest News: (loading..)
Sign in to follow this  
nana

fast easy checkout

Recommended Posts

Ah, just noticed- when a customer elects to proceed without creating an account, the "Log Off | My Account" still shows in the header. Here is my applicable header code:

<tr>
								<td align="right" bgcolor="#cccccc"><?php if (tep_session_is_registered('customer_id')) { ?><a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?></a>  |  <a href="<?php if (!tep_session_is_registered('createaccount')) {echo tep_href_link(FILENAME_ACCOUNT, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; } else {echo tep_href_link('account_password_new.php', '', 'SSL'); ?>" class="headerNavigation">  <?php echo 'Create Account'; }  ?></a>  <?php } else { ?><a href="<?php echo tep_href_link(FILENAME_LOGIN, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGIN;
?></a>    <?php } ?><a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CART_CONTENTS; ?><?php echo $currencies->format($cart->show_total());?></a>    <a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CHECKOUT; ?></a>   </td>
							</tr>


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites

if you do not want to have the logoff use this

<tr>
<td align="right" bgcolor="#cccccc"><?php if (tep_session_is_registered('customer_id')) { if (!tep_session_is_registered('createaccount')) {?><a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?></a>  |  <a href="<?php }if (!tep_session_is_registered('createaccount')) {echo tep_href_link(FILENAME_ACCOUNT, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; } else {echo tep_href_link('account_password_new.php', '', 'SSL'); ?>" class="headerNavigation">  <?php echo 'Create Account'; } ?></a> <?php } else { ?><a href="<?php echo tep_href_link(FILENAME_LOGIN, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGIN;
?></a>    <?php } ?><a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CART_CONTENTS; ?><?php echo $currencies->format($cart->show_total());?></a>    <a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CHECKOUT; ?></a>   </td>
</tr>

Share this post


Link to post
Share on other sites

I tried that-it's still showing both Log Off and My account...


Quidquid latine dictum sit, profundum viditur.

Share this post


Link to post
Share on other sites

can you try this

if not post your original if possible i am not on my computer and don't have my files

<tr>
<td align="right" bgcolor="#cccccc">
<?php if (!tep_session_is_registered('createaccount')) { ?>
<?php if (tep_session_is_registered('customer_id')) { ?>
<a href="<?php echo tep_href_link(FILENAME_LOGOFF, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGOFF; ?></a>
  |  <a href="<?php echo tep_href_link(FILENAME_ACCOUNT, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?></a>     <?php } else { ?>
<a href="<?php echo tep_href_link(FILENAME_LOGIN, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGIN;?></a>    <?php } ?>
<?php } else { ?>
<?php if (tep_session_is_registered('customer_id')) { ?>
<a href="<?php echo tep_href_link('account_password_new.php', '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_MY_ACCOUNT; ?></a>     <?php } else { ?>
<a href="<?php echo tep_href_link(FILENAME_LOGIN, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_LOGIN;?></a>    <?php } } ?>

<a href="<?php echo tep_href_link(FILENAME_SHOPPING_CART); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CART_CONTENTS; ?><?php echo $currencies->format($cart->show_total());?></a>    <a href="<?php echo tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'); ?>" class="headerNavigation"><?php echo HEADER_TITLE_CHECKOUT; ?></a>   </td>
</tr>

Share this post


Link to post
Share on other sites

put this code

 

 

if ($createaccount != 'Y') tep_session_register('createaccount');

 

 

 

in your create_account2.php right before

 

 

 

 

if ($createaccount == 'Y') {

if ($cart->count_contents() > 0) {

tep_redirect(tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'));

} else {

tep_redirect(tep_href_link(FILENAME_CREATE_ACCOUNT_SUCCESS, '', 'SSL'));

} }

else {

tep_redirect(tep_href_link(FILENAME_CHECKOUT_SHIPPING, '', 'SSL'));

}

}

}

 

 

if not pm me the link

Share this post


Link to post
Share on other sites

nana

i put the newest version of shipping & payment combined on a test site.

 

 

is there a way to display the grand total by default? i see the option in the source, but there is nowhere to turn it on?

 

when i delete if ($show_total ==1) from:

<?php
$show_total = tep_db_prepare_input($HTTP_GET_VARS['show_total']);	
 if ($show_total ==1)		  require('includes/fec/total_box.php');?>

it shows the total & subtotal... but the shipping cost is not calculated in it, so it's inaccurate.

 

when i click "update total", the page reloads and a red bar appears at the top stating "Please select a payment method"

 

but now the total & subtotal show accurately.

Share this post


Link to post
Share on other sites
nana

i put the newest version of shipping & payment combined on a test site.

is there a way to display the grand total by default? i see the option in the source, but there is nowhere to turn it on?

 

when i delete if ($show_total ==1) from:

<?php
$show_total = tep_db_prepare_input($HTTP_GET_VARS['show_total']);	
 if ($show_total ==1)		  require('includes/fec/total_box.php');?>

it shows the total & subtotal... but the shipping cost is not calculated in it, so it's inaccurate.

 

when i click "update total", the page reloads and a red bar appears at the top stating "Please select a payment method"

 

but now the total & subtotal show accurately.

that is the only way you can get this to work once the customer chooses his shipping method he can clicks get total button before adding his payment info

you might want to use javascript but its not a very good idea

Share this post


Link to post
Share on other sites

okay now i understand :)

did you have a chance to test out the conf. bug in the other edits? :)

Share this post


Link to post
Share on other sites

no i will do it tommorrow are you sure it does not work as is and are you sure you have a redirect.php that is not modified

Share this post


Link to post
Share on other sites

i have the security fixes for redirect.php, that's it.

 

 

i just moved some stuff around on the checkout page, and when i changed shipping preferences and tried to update my total, the page refreshed and told me to pick a payment option.

 

when i pick a payment option, i am taken to checkout_confirmation.php

 

not sure what i did?

Share this post


Link to post
Share on other sites

If I only have one shipping option/method, is it possible to hide that section in checkout_shipping.php?

 

thanks,

Fredrik

Share this post


Link to post
Share on other sites
the new version takes you to checkout_confirmation when you pick the payment as usuall

 

 

i'm a bit confused:

BEFORE i even select a payment type...

i have 2 methods of shipping

Ground

Air

 

both are different prices.

 

once the customer makes a selection and wants to see their new total, it is supposed to redirect them to checkout_confirmation instead of reloading the page and offering an updated price?

 

if i do not have a payment type selected, it takes them to checkout_payment and requests a payment selection. this is what doesn't make any sense to me. why do they have to select a payment method in order to view their total?

 

wouldn't it be easier to just supply a link to checkout_confirmation.php instead of the button? ;)

 

 

 

 

 

now once i am on checkout_confrmation and i click the back button on my browser, i am taken back to checkout_shipping. i can see a fresh subtotal, shipping, tax, etc. charges. how does that happen?

Share this post


Link to post
Share on other sites

eww change all occurances of FILENAME_CHECKOUT_PAYMENT to FILENAME_CHECKOUT_SHIPPING in checkout confirmation.php

it is supposed to take you back and show you the total i do not remember if i had this in the install instructions

 

redrum i never tested that , just comment the line of code that calls the shipping box and see what happnds

and let us know it might work

Edited by nana

Share this post


Link to post
Share on other sites

Hi Frank & others,

 

I have been installing this contribution and whilst it has been quite a struggle I think I now have a working shop.

 

However I was checking the customer database and the new field confirmation_key seems to store the customer's password UNENCRYPTED!! Surely this is a major security issue as many people use the same password for many things and oscommerce recognises this by encrypting the standard password field. The shop owner should not be able to see their customer's passwords.

 

What exactly is the confirmation_key field used for and can I disable it?

 

Ed

Share this post


Link to post
Share on other sites

as far as i remember i think once these customers create account this change they password and this becomes useless

if this is not true then i have to find a work around

Share this post


Link to post
Share on other sites

ed thank you for bringing this to my attention

there should have been a line in both create accoubr files right after

if ($error == false) {

if ($createaccount == 'Y') {$confirmation='completeaccount';}

this seems to be lost in the files sometime when i was editing the files

i will upload anew version tonight

Share this post


Link to post
Share on other sites

Hi Frank,

 

ed thank you for bringing this to my attention

there should have been a line in both create accoubr files right after

if ($error == false) {

if ($createaccount == 'Y') {$confirmation='completeaccount';}

this seems to be lost in the files sometime when i was editing the files

i will upload anew version tonight

 

Thanks for the fast response - that seems to do the trick.

 

Ed

Share this post


Link to post
Share on other sites
redrum i never tested that , just comment the line of code that calls the shipping box and see what happnds

and let us know it might work

 

Thanks for your reply. But after looking into it I decided to leave it be, since the customers might want to know how much the shipping cost are, before they reach checkout_confirmation.php.

 

Here's a little tip for those who want to display thier country in the country drop down selector in create_accountX.php

<?php echo tep_get_country_list('country', STORE_COUNTRY) . '?' . (tep_not_null(ENTRY_COUNTRY_TEXT) ? '<span class="inputRequirement">' . ENTRY_COUNTRY_TEXT . '</span>': ''); ?>

 

How heavily is this contribution tested? Is it ready for a live shop? Has it been any issues when several customers check out whitout creating an account at the same time?

 

// Fredrik

Share this post


Link to post
Share on other sites

I thought I had got this contribution working but I have still been having problems with CCGV which is now on the checkout_shipping page.

 

After clicking on the REDEEM button for a coupon the appropriate message appears however then clicking confirm on checkout_shipping to move on to the checkout_confirmation page usually gives a warning message 'you did not enter a redeem code' and stays on the checkout_shipping page, i.e. it appeared that the confirm button was reapplying whatever was entered in the coupon box.

 

After much investigation I have finally found that the following seems to cure the problem. Simply add 2 lines to the section of code in checkout_confirmation.php as shown below:

 

//fast easy checkout start
foreach ($_SESSION as $key => $val) {
			  //print $key.' => '.$val.' - ';print_r($val);echo "<br>";
			  $HTTP_POST_VARS[$key] = $val;

			  }
// first two lines are for ccgv
tep_session_unregister('gv_redeem_code');
tep_session_unregister('credit_covers');

// following 2 lines added by Ed to sort CCGV problem
tep_session_unregister('submit_redeem_x');
tep_session_unregister('submit_redeem_y');

tep_session_unregister('cc_number');
tep_session_unregister('cc_expires_month');
tep_session_unregister('cc_expires_year');
tep_session_unregister('cc_owner');
tep_session_unregister('authorizenet_cc_number');
tep_session_unregister('authorizenet_cc_expires_month');
tep_session_unregister('authorizenet_cc_expires_year');
tep_session_unregister('authorizenet_cc_owner');
//fast easy checkout end

 

 

Can anyone else confirm if they have had this problem and whether this fixes it?

 

Ed

Share this post


Link to post
Share on other sites

I've looked through this whole thread a few times, can't find the answer.

I installed FEC about 3 or 4 times now on different servers before I do it on my live store.

The main problem I'm running into is:

 

After user goes through everything, and checks out. Then they decide to enter a password to create an account, I'm redirected to the empty Shopping cart. I REALLY need to be redirected to a completely different section of my website. IE:

 

I'm coming from http://thedomain.com/catalog/account_password_new.php

once someone enters the password, I want to redirect them to:

http://members.thedomain.com/welcome.php

 

How can I do that?

any thoughts?

thanks.

that jon jackson

jon@crossoverts.com

Share this post


Link to post
Share on other sites

sorry people i had an error and i did not notice it the site is back and running

 

Ed Douglas adding this line allows your entery for ccgv to be changed so if was not changing it should solve your problem

 

redrum an account with a random password is actually created although it should be invisible to the customer . actually very little is changed so i do not know why there should be any problem

 

john

in account_password_new.php change

 

 

if (tep_session_is_registered('customer_id')){

if (sizeof($navigation->snapshot) > 0) {

$origin_href = tep_href_link($navigation->snapshot['page'], tep_array_to_string($navigation->snapshot['get'], array(tep_session_name())), $navigation->snapshot['mode']);

$navigation->clear_snapshot();

tep_redirect($origin_href);

} else {

tep_redirect(tep_href_link(FILENAME_DEFAULT));

}

 

 

to

tep_redirect(tep_href_link('welcome.php', '', 'SSL'));

 

this should do it

Share this post


Link to post
Share on other sites

Hi, I am only doing the first step, combine checkout_shipping.php and checkout_payment.php

 

but after first step everytime when click on check out, it gives me empty page and just stay there doing nothing.

 

anyone any idea?

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×