Jump to content
equilla

Support Thread for Supertracker Contribution

Recommended Posts

LOL, holy crap! My client had set up each of his keywords urls wrong.

 

He just has them set up to be "http://www.mysite.com/index.php" or "www.mysite.com/product_info.php?cPath=XX&products_id=XXX".

 

So I guess I have to tell him that he needs to change the urls to include ?ref=googlead&keyw=wiggits. (heh, heh and he hired an SEO firm to help him with this... :blink:)

 

Thanks Robert! :thumbsup:

 

Chris B.

 

Well .. you may want the campaign item to point to "products_id=" so the click moves to a specific product, but you still need ref=xxx&keyw=xxx for supertracker to record it

 

you would probably add it as "&ref=xxx&keyw=xxx" but I'm sure Mark will reply with a recommended solution when he has the time.

Edited by thunderace

Share this post


Link to post
Share on other sites

now i have another question...

 

i've had it going for a few hours now and it seems collecting SOME data

 

but i get 1065 empty query on most of the links in the tracker.

 

Top ref. 1065

top sales gen ref 1065

visitor countries stats -OK!

search keyword - nothing shown

 

top exit pages 1065

top exit (cart) 1065

av time 1065

supertracker seems ok (prod.cov.rep.)

10 visitors OK!

 

it looks to me that quite a bit of data is not being stored?

 

in the database almost all referrers are internal. that coming from wityhin the site.

 

Lars

Share this post


Link to post
Share on other sites
LOL, holy crap! My client had set up each of his keywords urls wrong.

 

He just has them set up to be "http://www.mysite.com/index.php" or "www.mysite.com/product_info.php?cPath=XX&products_id=XXX".

 

So I guess I have to tell him that he needs to change the urls to include ?ref=googlead&keyw=wiggits. (heh, heh and he hired an SEO firm to help him with this... :blink:)

 

Thanks Robert! :thumbsup:

 

Chris B.

 

Hmm, ok, I was just looking at my client's AdWord stuff. They have only 1 campaign named after their company. Within the one campaign are 20 AdGroups. Within each AdGroup are approx. between 1-25 keywords. So just to clarify, my url would now read:

 

http://www.mysite.com/product_info.php?cPa...ad&keyw=AdGroup

 

Then within supertracker.php, after "array(" I would put in my list of keywords:

 

AdGroupName:keyword,keyword,keyword,AdGroupName:keyword,keyword,keyword

 

Hope I'm on the right track...

 

Thanks!

Chris B.

Share this post


Link to post
Share on other sites
now i have another question...

 

i've had it going for a few hours now and it seems collecting SOME data

 

but i get 1065 empty query on most of the links in the tracker.

 

Top ref. 1065

top sales gen ref 1065

visitor countries stats -OK!

search keyword - nothing shown

 

top exit pages 1065

top exit (cart) 1065

av time 1065

supertracker seems ok (prod.cov.rep.)

10 visitors OK!

 

it looks to me that quite a bit of data is not being stored?

 

in the database almost all referrers are internal. that coming from wityhin the site.

 

Lars

 

 

Did you run the DB query to update your database?

Share this post


Link to post
Share on other sites
Well .. you may want the campaign item to point to "products_id=" so the click moves to a specific product, but you still need ref=xxx&keyw=xxx for supertracker to record it

 

you would probably add it as "&ref=xxx&keyw=xxx" but I'm sure Mark will reply with a recommended solution when he has the time.

Well .. you may want the campaign item to point to "products_id=" so the click moves to a specific product, but you still need ref=xxx&keyw=xxx for supertracker to record it

 

you would probably add it as "&ref=xxx&keyw=xxx" but I'm sure Mark will reply with a recommended solution when he has the time.

 

Wow, it got busy in here whilst I was gone (away working on some improvements to this contrib as it happens).

 

Thunderace has hit the nail on the head again - that's exactly how to do it :)

 

 

Mark

(Having some problems accessing these forums at the moment - either a dodgy connection or the server is struggling......)

Share this post


Link to post
Share on other sites
Hmm, ok, I was just looking at my client's AdWord stuff. They have only 1 campaign named after their company. Within the one campaign are 20 AdGroups. Within each AdGroup are approx. between 1-25 keywords. So just to clarify, my url would now read:

 

http://www.mysite.com/product_info.php?cPa...ad&keyw=AdGroup

 

Then within supertracker.php, after "array(" I would put in my list of keywords:

 

AdGroupName:keyword,keyword,keyword,AdGroupName:keyword,keyword,keyword

 

Hope I'm on the right track...

 

Thanks!

Chris B.

 

you seem to have added keyword twice .. e.g.

 

AdGroupName:keyword,keyword

 

My understanding is the following is correct ...

 

AdGroupName:keyword,AdGroupName:keyword,AdGroupName:keyword,AdGroupName:keyword

Share this post


Link to post
Share on other sites

Hmmm, this is a big campaign - google probably stand to make a ton of cash here!

 

Anyways, although not specifically considered in the Supertracker design, there's probably a way to cover tracking to the Ad Group level. Let's illustrate by example...

 

Suppose I have 2 Ad Groups.

 

AdGroup 1 is triggered for the keywords sugar, spice and honey

 

AdGroup 2 is triggered for the keywords salt, pepper and ketchup

 

If we set up AdGroup1 one so that there are specific URLs for each of the keywords as follows:

http://www.mysite.com/product_info.php?pro...glead1&keyw=sug

http://www.mysite.com/product_info.php?pro...glead1&keyw=spi

http://www.mysite.com/product_info.php?pro...glead1&keyw=hon

 

and Adgroup2 as follows:

 

http://www.mysite.com/product_info.php?pro...glead2&keyw=sal

http://www.mysite.com/product_info.php?pro...glead2&keyw=pep

http://www.mysite.com/product_info.php?pro...glead2&keyw=ket

 

(If you're wondering why we even need to use short codes such as sal, pep, and ket, BTW it's because sometimes you can run ad campaigns with key phrases such as "spicy ketchup", which has spaces in and obviously we aren't allowed spaces in URLs).

 

Then we should setup the config of supertracker as follows:

 

$ppc = array ('googlead1' => array ('title' => 'Google Adwords Ad Group 1', 'keywords' => 'sug:sugar,spi:spice,hon:honey'),'googlead2' => array('title' => 'Google Adwords Ad Group 2', 'keywords' => 'sal:salt,pep:pepper;ket:ketchup'));

 

At least, I think I managed to write that out without making any errors.....Then you should get separate reporting for each of the Adgroups and each of the keywords in each Ad Group.

 

Unfortunately, there's was no simple way to design this, so it's perhaps a little counter-intuitive!

 

Regards,

 

 

Mark

Share this post


Link to post
Share on other sites

Is it just me or does supertracker considerably slow down the server?

Most of the visitors to my site have been spiders and search engine indexers. Any way to eliminate them from being recorded in the stats?

Share this post


Link to post
Share on other sites
Did you run the DB query to update your database?

 

nope,

 

i had to run the sql manually. the supertracker_update_db.php (think it was called) did not work since i had already made some changes so pages did not load. ;)

 

so i might check the structure of the supertracker table?

 

i have it and there is plenty of data in it...

 

Lars

Share this post


Link to post
Share on other sites
nope,

 

i had to run the sql manually. the supertracker_update_db.php (think it was called) did not work since i had already made some changes so pages did not load. ;)

 

so i might check the structure of the supertracker table?

 

i have it and there is plenty of data in it...

 

Lars

 

Hi Lars,

 

sorry it took a while to get the opportunity to look directly at your problem. It was very interesting actually as it revealed a bug which has been in Supertracker since the very beginning and nobody found it before...!

 

This is the line in /catalog/admin/supertracker which was causing the problem:

 

$report_type=$HTTP_GET_VARS['report'];

 

The thing is, it is $report and not $report_type which is used throughout the script to determine which type of report to show.

 

Changing the line to :

 

$report=$HTTP_GET_VARS['report'];

 

fixed the problem.

 

I can only imagine that it is because the rest of us all have register_globals set to on, that this problem wasn't found before.

 

Obviously, this will be fixed in the next release.

 

Regards,

 

 

 

 

Mark

P.S. The outstanding question regarding Supertracker's effect on server performance requires a slightly longer answer, so I will respond to this one in due course.

Share this post


Link to post
Share on other sites

BIG Typo in Directions For New Installs Found

 

Step 5.

Download the latest binary version of GeoIP.dat from

and upload it to your /catalog/admin/includes folder

 

 

SHOULD BE

 

Step 5.

Download the latest binary version of GeoIP.dat from

and upload it to your /catalog/includes folder

Share this post


Link to post
Share on other sites

Oops! That is a bit of a problem - thanks for pointing that out.

 

A new version will be posted later today that corrects this issue, along with the other issues that have reported in this thread over the last couple of days. There will also be a couple of minor enhancements due to the stuff I have been working at the same time (upgraders simply have to replace the one file in admin).

 

Thanks again,

 

 

 

 

Mark

Share this post


Link to post
Share on other sites
Oops! That is a bit of a problem - thanks for pointing that out.

 

A new version will be posted later today that corrects this issue, along with the other issues that have reported in this thread over the last couple of days. There will also be a couple of minor enhancements due to the stuff I have been working at the same time (upgraders simply have to replace the one file in admin).

 

Thanks again,

Mark

 

Not a problem! This is a wonderfully usefull contribution!

 

-Im wondering what the before and after install - parse times for pages are. It doesnt seem like it takes too long for pages to load however.

Share this post


Link to post
Share on other sites
Not a problem! This is a wonderfully usefull contribution!

 

-Im wondering what the before and after install - parse times for pages are. It doesnt seem like it takes too long for pages to load however.

Yes, I'm wondering about that too. Anecdotally, things slow down noticably when the database table grows to the order of 10 thousand lines, but I plan to do some more scientific benchmark testing soon (unless someone beats me to it).

 

I'm sure there is some scope for improvement in the queries used to locate a given session too, which I will work on as part of that exercise.

 

Regards,

 

 

 

Mark

Share this post


Link to post
Share on other sites

Hi All,

 

an update as advertised earlier today (or perhaps yesterday, depending on what timezone you are in...) has now been posted.

 

Details repeated here for info:

 

This release corrects the bugs reported in the support thread since the release of version 2.1 and also incorporates webschiff's work on language files and the stylesheet.

 

Merging the ongoing work with the efforts made by others has been challenging, so apologies in advance for any quirks that arise from this release.

 

Note, upgraders won't notice too many changes other than a slightly improved report selection function in admin (dropdown selector instead of hyperlinks) and the odd new feature here and there in the existing reports.

 

Notwithstanding any disastrous errors that may have crept into the release, I don't plan to make any further releases until significant progress has been made on new reports.

 

 

Hopefully, this will be a baseline we can all use for a while as writing the installation instructions just gets more complicated with lots of releases in quick succession and provides scope for mistakes (as you all know this isn't my strong suit!)

 

Cheers,

 

 

 

Mark

Share this post


Link to post
Share on other sites

hi thre i got some tips and a question :

 

TIPS 1 :

in the installation :

 

step 1 :

Upload the new files to your webspace. These are:

/admin/images/geo_flags/....various

 

in the contribution zip the flags.zip should be included in a geo_flags directory not

in admin\images\

 

TIPS 2 :

Download the latest binary version of GeoIP.dat from here: http://www.maxmind.com/app/geoip_country

and upload it to your /catalog/includes folder

 

idea is includethe latest geoip dat file in the contrib and advice people to update it if the contribution archives is not too big for downlaod contribution size limit

 

QUESTION or TIPS 3 :

 

locally , for ip adress 127.0.0.1 it was lokking for pixel_trans.gif in the wrong directory , i was looking in the flag directory while it was in catalog /includes/images root !?

 

QUESTION :

 

on a local installation , i don't see the flag in " VISITORS COUNTRIES STAT" is it normal because it s locally ?


MS2

Share this post


Link to post
Share on other sites
hi thre i got some tips and a question :

 

TIPS 1 :

in the installation :

 

 

 

in the contribution zip the flags.zip should be included in a geo_flags directory not

in admin\images\

 

TIPS 2 :

 

 

idea is includethe latest geoip dat file in the contrib and advice people to update it if the contribution archives is not too big for downlaod contribution size limit

 

QUESTION or TIPS 3 :

 

locally , for ip adress 127.0.0.1 it was lokking for pixel_trans.gif in the wrong directory , i was looking in the flag directory while it was in catalog /includes/images root !?

 

QUESTION :

 

on a local installation , i don't see the flag in " VISITORS COUNTRIES STAT" is it normal because it s locally ?

 

Hi,

 

thanks for your input. Regarding the geoip.dat file. There are a couple of reasons for not including it: 1. There are licence issues with doing so and 2. The zip filesize would overstep the size at which I can simply upload it in the contributions area.

 

Regarding pixel_trans.gif - hmmm, yes I really should have checked this new code that I cut and pasted in more thoroughly :blush: :

 

if($country_code==''){

$country_code='pixel_trans';

}

 

This is only going to work as long as there is a pixel_trans.gif in the /admin/images/geo_flags/ folder.

 

The Visitors Countries Stats page doesn't currently make use of the flags, but it would be really easy to do this. One for a future release I think :D

 

Thanks again,

 

 

 

 

Mark

Share this post


Link to post
Share on other sites
Hmmm, this is a big campaign - google probably stand to make a ton of cash here!

 

Anyways, although not specifically considered in the Supertracker design, there's probably a way to cover tracking to the Ad Group level. Let's illustrate by example...

 

Suppose I have 2 Ad Groups.

 

AdGroup 1 is triggered for the keywords sugar, spice and honey

 

AdGroup 2 is triggered for the keywords salt, pepper and ketchup

 

If we set up AdGroup1 one so that there are specific URLs for each of the keywords as follows:

http://www.mysite.com/product_info.php?pro...glead1&keyw=sug

http://www.mysite.com/product_info.php?pro...glead1&keyw=spi

http://www.mysite.com/product_info.php?pro...glead1&keyw=hon

 

and Adgroup2 as follows:

 

http://www.mysite.com/product_info.php?pro...glead2&keyw=sal

http://www.mysite.com/product_info.php?pro...glead2&keyw=pep

http://www.mysite.com/product_info.php?pro...glead2&keyw=ket

 

(If you're wondering why we even need to use short codes such as sal, pep, and ket, BTW it's because sometimes you can run ad campaigns with key phrases such as "spicy ketchup", which has spaces in and obviously we aren't allowed spaces in URLs).

 

Then we should setup the config of supertracker as follows:

 

$ppc = array ('googlead1' => array ('title' => 'Google Adwords Ad Group 1', 'keywords' => 'sug:sugar,spi:spice,hon:honey'),'googlead2' => array('title' => 'Google Adwords Ad Group 2', 'keywords' => 'sal:salt,pep:pepper;ket:ketchup'));

 

At least, I think I managed to write that out without making any errors.....Then you should get separate reporting for each of the Adgroups and each of the keywords in each Ad Group.

 

Unfortunately, there's was no simple way to design this, so it's perhaps a little counter-intuitive!

 

Regards,

Mark

 

Thanks, Mark, that explains that beautifully. I have much work to do to get this implemented, so off I go. Again, thanks for all the help!

 

Chris B.

Share this post


Link to post
Share on other sites

is it possible to disable the country checking? since i installed this mod, the page load slowed from 127.94 seconds on 28.8k to 135.44 seconds and nearly a full second on T1

 

i don't need the geo checking, as i have it in my awstats :)

Share this post


Link to post
Share on other sites
is it possible to disable the country checking? since i installed this mod, the page load slowed from 127.94 seconds on 28.8k to 135.44 seconds and nearly a full second on T1

 

i don't need the geo checking, as i have it in my awstats :)

 

Hi,

 

Note that country information is only recorded once when each visitor first arrives, so I'm surprised that this is having a noticeable effect.

 

However, you should be able to do disable it by removing this section of code in /catalog/includes/supertracker.php around line 170 (note that this is off the top of my head and so is untested):

 

include(DIR_WS_INCLUDES . "geoip.inc");

$gi = geoip_open(DIR_WS_INCLUDES . "GeoIP.dat",GEOIP_STANDARD);

$country_name = geoip_country_name_by_addr($gi, $ip);

$country_code = strtolower(geoip_country_code_by_addr($gi, $ip));

geoip_close($gi);

 

and change the insert query a few lines down from :

 

$query = "INSERT INTO `supertracker` (`ip_address`, `browser_string`, `country_code`, `country_name`, `referrer`,`referrer_query_string`,`landing_page`,`exit_page`,`time_arrived`,`last_click`) VALUES ('" . $ip . "','" . $browser_string . "','" . $country_code . "', '" . $country_name . "', '" . $referrer . "', '" . $query_string . "','" . $landing_page . "','" . $current_page . "','" . $time_arrived . "','" . $time_arrived . "')";

 

to :

 

$query = "INSERT INTO `supertracker` (`ip_address`, `browser_string`,`referrer`,`referrer_query_string`,`landing_page`,`exit_page`,`time_arrived`,`last_click`) VALUES ('" . $ip . "','" . $browser_string . "','" . $referrer . "', '" . $query_string . "','" . $landing_page . "','" . $current_page . "','" . $time_arrived . "','" . $time_arrived . "')";

 

country_code and country_name have been removed.

 

Regards,

 

 

 

Mark

Share this post


Link to post
Share on other sites

what do i do with the insert query? i have already installed it, so would it be feasible to simply delete the unneeded table through phpmyadmin?

 

also,

 

would you happen to know how i could disable the "Products Viewed" that comes with the stock osc? i prefer to use the products viewed that your conribution has instead. i don't see a point in logging it twice if i only use one :)

Share this post


Link to post
Share on other sites

Hello

 

I'm facing some problem with the top referrer list.

 

I have a lot of top referrer with no url indicated in it :

 

 

Let's take an exa

Share this post


Link to post
Share on other sites

Hello

 

I'm facing some problem with the top referrer list.

 

I have a lot of top referrer with no url indicated in it :

Rank------------------- Referring URL---------------------------------------------- Number of hits

1-----------------------------------------------------------------------------------------------3

2----http://www.clubfitting.net/tech_meas_length.php---------------------------------- 1

there is only a few in the example, as I just droped the table to run the upadte query again manually (making sure the supertracker table has the correct structure)

 

Let's take an example of this empty referring URL....

From my adwords admin page, I click on a link taking me to my website:

 

Then when I'm on my site, I click on :

And I close the explorer

 

Result in top referrer :

The following page doesn't appear.

After checking the contents of the table, I can see that the landing page is recorded

but the referrer is empty

 

 

On top of that, the Exit page is not indicated as being

but it stands for being product_reviews.php (it's wrong, I've never been on this page during the test carried out).

 

Is something wrong with my website (SEO URL contrib incompatibility) or bug in the supertracker contrib ?

 

Thanks for your comments

Patrice

www.clubfitting.net

Edited by patator

Share this post


Link to post
Share on other sites
Hello

 

I'm facing some problem with the top referrer list.

 

I have a lot of top referrer with no url indicated in it :

Let's take an example of this empty referring URL....

From my adwords admin page, I click on a link taking me to my website:

Then when I'm on my site, I click on :

 

And I close the explorer

 

Result in top referrer :

The following page doesn't appear.

 

After checking the contents of the table, I can see that the landing page is recorded

 

but the referrer is empty

On top of that, the Exit page is not indicated as being

 

but it stands for being product_reviews.php (it's wrong, I've never been on this page during the test carried out).

 

Is something wrong with my website (SEO URL contrib incompatibility) or bug in the supertracker contrib ?

 

Thanks for your comments

Patrice

www.clubfitting.net

 

 

I have exactly the same.

Share this post


Link to post
Share on other sites
I have exactly the same.

Great, I hope that Mark might have a look at our issue....

 

 

Does anybody have the same problem ?

 

Patrice

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×