Jump to content
Latest News: (loading..)
equilla

Support Thread for Supertracker Contribution

Recommended Posts

I have the next ten button working on 3 different sites, so I'm not sure why it doesn't for others - possibly it requires something installed on your server? it is an easy fix though - just revert the button code to the old code and you'll be fine:

 

in catalog/admin/supertracker.php

 

Find this:

 

<br><strong><a href="supertracker.php?special=last_ten&offset=<?php echo $offset + 10;?>&filter=<?php echo $filter;?>&refer_match=<?php echo $refer_match;?>"><input type="submit" value="<?php echo TABLE_TEXT_NEXT_TEN_RESULTS; ?>"></a></strong>

 

Replace with this:

 

<br><strong><a href="supertracker.php?special=last_ten&offset=<?php echo $offset + 10;?>&filter=<?php echo $filter;?>&refer_match=<?php echo $refer_match;?>"><?php echo TABLE_TEXT_NEXT_TEN_RESULTS; ?></a></strong>

 

Scott

Edited by olsonsp4c

Share this post


Link to post
Share on other sites

I have went through all of the post on this forum and a few others, and I still have not been able to solve my problem.

I am still getting a black index.php page when i add:

 

// Supertracker

require(DIR_WS_CLASSES . 'supertracker.php');

$tracker = new supertracker;

$tracker->update();

 

to the application_top.php. I have even added the agent field and that did not do anything either.

 

If anyone has any other suggestions they would be much appreciated!

 

Thanks!

 

sacunnin

Share this post


Link to post
Share on other sites
I have went through all of the post on this forum and a few others, and I still have not been able to solve my problem.

I am still getting a black index.php page when i add:

 

// Supertracker

require(DIR_WS_CLASSES . 'supertracker.php');

$tracker = new supertracker;

$tracker->update();

 

to the application_top.php. I have even added the agent field and that did not do anything either.

 

If anyone has any other suggestions they would be much appreciated!

 

Thanks!

 

sacunnin

 

The only suggestion I have is to verify that you actually uploaded the files to the correct directories because it sounds like it is trying to find a file that isn't there...

 

Scott

Share this post


Link to post
Share on other sites
The only suggestion I have is to verify that you actually uploaded the files to the correct directories because it sounds like it is trying to find a file that isn't there...

 

Scott

 

 

That's the same thing I thought when I first found the problem. I double checked which directories I uploaded the files to and everything is correct.

 

I'm puzzled.

 

Steven

Share this post


Link to post
Share on other sites
That's the same thing I thought when I first found the problem. I double checked which directories I uploaded the files to and everything is correct.

 

I'm puzzled.

 

Steven

 

Have you tried re-uploading your fileset - one of them may have been corrupted during upload...

 

Scott

Share this post


Link to post
Share on other sites
I have the next ten button working on 3 different sites, so I'm not sure why it doesn't for others - possibly it requires something installed on your server? it is an easy fix though - just revert the button code to the old code and you'll be fine:

 

in catalog/admin/supertracker.php

 

Find this:

 

<br><strong><a href="supertracker.php?special=last_ten&offset=<?php echo $offset + 10;?>&filter=<?php echo $filter;?>&refer_match=<?php echo $refer_match;?>"><input type="submit" value="<?php echo TABLE_TEXT_NEXT_TEN_RESULTS; ?>"></a></strong>

 

Replace with this:

 

<br><strong><a href="supertracker.php?special=last_ten&offset=<?php echo $offset + 10;?>&filter=<?php echo $filter;?>&refer_match=<?php echo $refer_match;?>"><?php echo TABLE_TEXT_NEXT_TEN_RESULTS; ?></a></strong>

 

Scott

 

 

Thanks Scott. This fixed the "Next Ten Results" button.

 

Cheers,

Chuck

Share this post


Link to post
Share on other sites
you are welcome.

 

Scott

Thanks Scott

I will test it shortly.

 

I have noticed that the file

admin/supertracker.php

has

<script language="javascript" src="includes/menu.js"></script>

I do not have that js file and it causes minor file not found errors. Not enough to stop it working, just generating errors.

 

The call for the menu.js file has been in the contribution in prior versions to yours as well.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Thanks Scott

I will test it shortly.

 

I have noticed that the file

admin/supertracker.php

has

<script language="javascript" src="includes/menu.js"></script>

I do not have that js file and it causes minor file not found errors. Not enough to stop it working, just generating errors.

 

The call for the menu.js file has been in the contribution in prior versions to yours as well.

Thanks Scott

 

The changes worked and it is much better.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Have you tried re-uploading your fileset - one of them may have been corrupted during upload...

 

Scott

 

 

I re-uploaded the entire fileset and drop the supertracker table and re-created the table.

 

Still no luck.

 

my guess is that something must not be compatible.

 

Steven

Share this post


Link to post
Share on other sites
I re-uploaded the entire fileset and drop the supertracker table and re-created the table.

 

Still no luck.

 

my guess is that something must not be compatible.

 

Steven

 

Steven, my last guess is that there is some sort of server software requirement that your server has not installed... you might look into that and inquire with your hosting support team... often they can install packages for you for free...

 

Scott

Share this post


Link to post
Share on other sites

I am installing Supertracker 3.3 into a MS2 (060817) installation:

 

Step 6 of instructions says in /admin/includes/boxes/reports.php:

Find, "'<a href="' . tep_href_link(FILENAME_STATS_CUSTOMERS, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_ORDERS_TOTAL . '</a><br>'

 

and Insert this BEFORE: '<a href="' . tep_href_link(FILENAME_SUPERTRACKER, '', 'NONSSL') . '" class="menuBoxContentLink">' . BOX_REPORTS_SUPERTRACKER . '</a><br>' .

 

 

 

There is no such line in my reports.php file.

Should I just forget installing this contrib, or do you have a solution??

Share this post


Link to post
Share on other sites

Look in the file - there are many lines that will look almost just like it in the array. Just make sure that is is NOT the last line in the array and you'll be fine.

 

Scott

Share this post


Link to post
Share on other sites
Look in the file - there are many lines that will look almost just like it in the array. Just make sure that is is NOT the last line in the array and you'll be fine.

 

Scott

 

 

 

Thanks Scott. Now that I look again, it's pretty obvious. The reason my search didn't find that line is because I copied the search string from the install instructions. The instruction has the <br> in that line, but in reality, the last line doesn't have a <br> in it. For dummies like me, I suggest editing the install instruction.

 

Anyway, it works and looks like it will be a great contrib. Thanks again.

Roger.

Share this post


Link to post
Share on other sites

hi. your doing great in modifiing this contrib, but why was the agent tracking removed? newer versions since 3.1 do no longer track the agents (?rep=xxx), thats just one step back instead oh ahead. a really appreciated what your doing here but it would be less trouble updating when the last official version is used instead of your own files. 3.1 has agent tracking then several updates and 3.3 does not have this anymore. just made me downgrade last night because i missed my stats.

Share this post


Link to post
Share on other sites
hi. your doing great in modifiing this contrib, but why was the agent tracking removed? newer versions since 3.1 do no longer track the agents (?rep=xxx), thats just one step back instead oh ahead. a really appreciated what your doing here but it would be less trouble updating when the last official version is used instead of your own files. 3.1 has agent tracking then several updates and 3.3 does not have this anymore. just made me downgrade last night because i missed my stats.

 

maybe at some point it can be re-integrated - don't know why it was not included in other packages before mine - I'm sure there were reasons - that is the nature of Open Source. I'm glad that 3.1 works fine for you.

 

Scott

Share this post


Link to post
Share on other sites

hi

Thaks for contribution i have 2 question

1) i have test this and i think i have a problem with "Search Keywords" i have search a keyword in web page but in super tracker i don't see any word

2) if i install this i can delete the other voice of report??? example:

Products Viewed

Products Purchased

Customer Orders-Total

 

Thanks

Share this post


Link to post
Share on other sites

Thanks for the nice contribution. Looks to be working fine for me. I have a couple questions about the way it works.

 

I posted a link today to my oscommerce website on an unrelated forum. In Supertracker, I expected to see that other website as a 'Referred by' url in 'Last Ten Site Visitors'. Instead, those show up as 'direct access / bookmark' in Last Ten Site Visitors. Is this strange?

 

Also I see alot of "http://mysite.com/?" next to 'Referred by:' in Last Ten Site Visitors, and am wondering if that is because my web root is redirecting folks to my store, which is in a subdirectory. Is that what is happening here?

 

Just trying to understand a bit more about how this works and the info it provides.

Edited by revenson

Share this post


Link to post
Share on other sites

Like the pay per click tracking option.

 

How can I add a second ppc site?

 

I tried duplicating the first one, but then the second one was the only one that 'took'. The first gets ignored. Is there a syntax that allow more than one to be active at the same time?

Share this post


Link to post
Share on other sites
Like the pay per click tracking option.

 

How can I add a second ppc site?

 

I tried duplicating the first one, but then the second one was the only one that 'took'. The first gets ignored. Is there a syntax that allow more than one to be active at the same time?

 

 

In case others run into this issue, here's the syntax that worked for me in /admin/supertracker.php. In this example, there are two referring ppc sites and keywords are not included, only the 2 referring ppc sites (?ref=ppc site):

 

$ppc = array

(

"barnstormers" => array ('title' => 'Barnstormers Ad'),

"vaf" => array ('title' => 'VansAirForce')

);

Share this post


Link to post
Share on other sites

Hi there,

 

Just a quick question regarding 'Last Ten Visitors > Bailed Carts'

 

Is it possible to add a filter to the bailed cart page to only show users that have signed up to our site?

 

Thanks for any help given!

Edited by eighty6

Share this post


Link to post
Share on other sites

Noticed I get a 404 error report when I view the last 10 visitors and a visitor used a satellite uplink.

 

It is looking for images/geo_flags/a2.gif

 

which of course there isn't, hence the error.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×