Jump to content
equilla

Support Thread for Supertracker Contribution

Recommended Posts

Hi,

 

we used supertracker and it worked like a dream. However, yesterday we moved to a more powerful server. Now our supertracker reports only deliver blank results (I checked the database and supertracker is still collecting information, but it is not displayed anymore if I e.g. select last 10 visitors).

I thought it was a problem with permissions and set pretty much all supertracker files to full access.

 

Do you have any suggestions?

 

Thank you,

 

Carsten

 

Please let me know if you have any idea why supertracker would not work (reports don't produce any results) anymore after move to another server,

 

Thank you,

 

Carsten

Share this post


Link to post
Share on other sites
Hi

 

Thanks for the great contribution.

 

I seem to be having trouble using the search strings to filter the referers. I am trying to filter all the search engine bots and crawlers. I have tried typing in googlebot and "googlebot" and (googlebot) it just makes everything disappear from the last 10 customers page I just want to get rid of the search engines so that I can see what is being looked at clearly.

 

Any help would be appreciated.

 

Thanks

 

Karl

 

I am also facing the problem of bots taking up db space. Has anyone figured out how to filter them out of the results?

Thanks in advance.


Debora

Breaking code.... one website at a time.

Vibrators: like cute little puppies without the puppy breath. Who can't like a vibrator?

Life Tip: Taking yourself too seriously? Put on a penis hat and look in the mirror every 5 minutes. That should fix it.

"Finally found the ball gag for those damn voices. Now to pull out the whip...." - Me

Member of the CODE BREAKERS CLUB - WE RULE!

Share this post


Link to post
Share on other sites

I've installed this contribution with no problem - it's a fantastic resource.

 

My one issue is I cannot figure out how to add an Agent - I've read the Agent guide and tried using the myshop.com\?rep=xx landing page and even done a demo purchase but I still have no Agent - can anyone tell me how to get an agent.

Share this post


Link to post
Share on other sites
I've installed this contribution with no problem - it's a fantastic resource.

 

My one issue is I cannot figure out how to add an Agent - I've read the Agent guide and tried using the myshop.com\?rep=xx landing page and even done a demo purchase but I still have no Agent - can anyone tell me how to get an agent.

 

Anyone?

Share this post


Link to post
Share on other sites
I've installed this contribution with no problem - it's a fantastic resource.

 

My one issue is I cannot figure out how to add an Agent - I've read the Agent guide and tried using the myshop.com\?rep=xx landing page and even done a demo purchase but I still have no Agent - can anyone tell me how to get an agent.

How did you conduct the test?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
How did you conduct the test?

 

I followed the instructions in the agent readme - but possibly I have misunderstood.

 

I arrived at my site at the URL: www.mydomain.co.uk/catalog/rep?=Fred

 

I thought this would add Fred to the database in the new agent field - perhaps I am not doing the test right - I just have agent number 1.

 

Thanks

 

Lotti

Share this post


Link to post
Share on other sites
I followed the instructions in the agent readme - but possibly I have misunderstood.

 

I arrived at my site at the URL: www.mydomain.co.uk/catalog/rep?=Fred

 

I thought this would add Fred to the database in the new agent field - perhaps I am not doing the test right - I just have agent number 1.

 

Thanks

 

Lotti

Did you do the agent_update.rtf changes?


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Did you do the agent_update.rtf changes?

 

Sorry a true case of a blond moment - did upload the changed files - now working fantastically - thanks for bearing with me.

 

Fantastic contribution!

Share this post


Link to post
Share on other sites
Sorry a true case of a blond moment - did upload the changed files - now working fantastically - thanks for bearing with me.

 

Fantastic contribution!

Easy to miss things, but I agree, it is a great contribution.


The Coopco Underwear Shop

 

If you live to be 100 years of age, that means you have lived for 36,525 days. Don't waste another, there aren't many left.

Share this post


Link to post
Share on other sites
Yup it's not looking for /includes/geoip.inc

 

It's looking for includes/GeoIP.dat

I'm getting the same error. Where do I change the code so it's looking for the right file?


Debora

Breaking code.... one website at a time.

Vibrators: like cute little puppies without the puppy breath. Who can't like a vibrator?

Life Tip: Taking yourself too seriously? Put on a penis hat and look in the mirror every 5 minutes. That should fix it.

"Finally found the ball gag for those damn voices. Now to pull out the whip...." - Me

Member of the CODE BREAKERS CLUB - WE RULE!

Share this post


Link to post
Share on other sites

Hopfully someone can help me with this problem.

 

I just installed Supertracker v3.2b It looks like it will work, If I go to the admin area, I can see on the reports section the supertracker and the types of report I can run, however on my site once when I type my index URL I just get a blank page?? I noticed that if I remove the following code:

//Do the superstats business

require(DIR_WS_CLASSES . 'supertracker.php');

$tracker = new supertracker;

$tracker->update();

 

from /catalog/includes/application_top.php then my site works again?

 

Any idea why this may be happening?

 

Any advice is greatly appreciated.

 

Pair.

Share this post


Link to post
Share on other sites

Hi

 

Thank for kode but i have a problem > enter my www then i get This

 

1054 - Unknown column 'agent' in 'field list'

 

INSERT INTO `supertracker` (`ip_address`, `browser_string`, `country_code`, `country_name`, `referrer`,`referrer_query_string`,`landing_page`,`exit_page`,`time_arrived`,`last_click`, `agent`) VALUES ('80.62.177.189','Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; InfoPath.1)','dk', 'Denmark', '', '','/','/index.php','2008-06-25 23:26:30','2008-06-25 23:26:30','')

 

[TEP STOP]

Share this post


Link to post
Share on other sites

Hello You just missing this agent in You sql - put it in via. phpmysql and then it works :-)

 

ALTER TABLE `supertracker` ADD `agent` VARCHAR(255) NULL;

 

It works for me

Edited by Steen Smidt

Share this post


Link to post
Share on other sites

I think I botched the install. Looks all ok but I get zero reports on supertracker.php. The only part of the install I don't quite understand is this:

 

"You will also need to add this new box in Administrator -> File Access from the admin menu."

 

Where is this?

Share this post


Link to post
Share on other sites

Hello everyone, <_<

This is my second post about my problem, hopefully someone can help me this time as I have a live site and I really need the stats of where my customers are coming from? Your answer I'm sure will help not only me but others as well.

 

Here is my problem.

If I add the following code to my catalog/includes/application_top.php

//Do the superstats business

require(DIR_WS_CLASSES . 'supertracker.php');

$tracker = new supertracker;

$tracker->update();

When I type on a browser my website URL I get a blank page, if I remove the code I can see my website again.

 

Please helpppppppppppp.

Share this post


Link to post
Share on other sites

DELETE from supertracker ORDER by tracking_id ASC LIMIT

 

Seems as if this issue hasn't been solved yet. I too am experiencing this issue, and as indicated it has to do with the version of mysql that is being used. From the mysql documentation:

ORDER BY can be used with DELETE beginning with MySQL 4.0.0.

 

I'm using mysql ver 3.23.x so the delete code in Supertracker:

DELETE from supertracker ORDER by tracking_id ASC LIMIT " . $rows_to_delete;

won't work.

 

SOLUTION:

We could figure out what the lowest tracker_id numbers are and start to delete based on those. However, if you use this code instead:

DELETE from supertracker limit ".$rows_to_delete;

This works for me, as it did delete the lowest numbered row (when I had $rows_to_delete = 1).

 

QUESTION:

Since tracker_id is the primary key in the table, if you don't give the query an ORDER BY, won't it default to ordering by the primary key in the ASC order? If this is true, then the above suggested code should work just fine. Question remains... will the table ever be ordered by some other column?

Share this post


Link to post
Share on other sites

@Cool >> Did you paste:

 

//Do the superstats business

require(DIR_WS_CLASSES . 'supertracker.php');

$tracker = new supertracker;

$tracker->update();

 

just before the last ?> in application_top.php ?

Edited by stephano6

Share this post


Link to post
Share on other sites

hello

 

in admin/supertracker.php for Last ten Visitors,

 

to: Customers Cart : (value=6.00) :

 

QUESTION:

 

the price is wrong because it is home to 6.30,

even if I change to 6.10 / 6.50 / 6.90 / it remains to 6.00 (prices in euro)

 

how to debug?

 

Thank you

 

Greetings

Share this post


Link to post
Share on other sites
@Cool >> Did you paste:

 

//Do the superstats business

require(DIR_WS_CLASSES . 'supertracker.php');

$tracker = new supertracker;

$tracker->update();

 

just before the last ?> in application_top.php ?

Hi Williams,

Thanks for replying.

My problem is that if I add the code you mentioned above, when I type my URL, the index page shows blank. When I remove the code I can see my site as normal?

On the admin side it appears like everything will function properly once this puzzle gets solve as I can’t see any errors, at least for now. It shows the following but I’m assuming is because is not tracking anything yet.

Database Info: the Supertracker database currently holds 0 rows (oldest record : )

 

Do you have any idea what other file may be causing the problem that once I add the code on catalog/application_top.php the index page display blank?

 

Any advice from you or anyone will be greatly appreciated.

 

Cool :huh:

Share this post


Link to post
Share on other sites

Cool.

 

Try to narrow it down. In application_top.php just add the first line

require(DIR_WS_CLASSES . 'supertracker.php');

then save the file and see if you are having the same problem with a blank index page (if the index page is blank, what about an interior page like /contact_us.php ???).

Share this post


Link to post
Share on other sites

Was anyone able to figure out why the catalog is blank when you install supertracker. I'm having the same problem and can't figure it out. Seems like when I take the code from application top everything looks fine.

Share this post


Link to post
Share on other sites

Hi, I wonder if anybody experienced this or similar scenario:

Our site is unavailable completely, when I try to see any page, I'm receiving SQL error:

145 - Table './mysite04/supertracker' is marked as crashed and should be repaired

 

when I view the database structure in phpMyAdmin, I see that the table supertracker table is "in use". I am however unable to browse it:

Error

 

SQL query: Edit

 

SHOW INDEX FROM `supertracker` ;

 

MySQL said: Documentation

#145 - Table './mysite04/supertracker' is marked as crashed and should be repaired

 

When I try to repair the table, I receive this message:

mysite04.supertracker repair Error Table './mysite04/supertracker' is marked as cra...

mysite04.supertracker repair Error Table 'supertracker' is marked as crashed and shou...

mysite04.supertracker repair status Table is already up to date

 

Does anybody know:

 

a/how to repair/fix the table as I'm unable to fix it via phpMyAdmin

b/ how to avoid this from happening in the future?

Edited by mr_absinthe

Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

It's not uncommon for heavily accessed tables to become corrupted. It happens fairly often to the sessions table. If you can't repair it using phpmyadmin, then it would have to be replaced. There may be tools on the web to fix such a table but the cost and time needed for that wouldn't be worth it in my opinion since you are losing important data by replacing it. If you are concerned about losing that though, you can see if your host has a backup, or maybe you have one, that you can copy that table from. Then you wouldn't lose all of it.

 

Jack

Share this post


Link to post
Share on other sites

Thank you Jack, it is exactly what I did in the end - I spoke to support and we decided to replace the table from backup - so if anybody will have similar problem, this might be a solution for you.


Absinthe Original Liquor Store

Share this post


Link to post
Share on other sites

Hey there,

 

I've got a problem when install this contr.

 

 

1054 - Unknown column 'agent' in 'field list'

 

INSERT INTO `supertracker` (`ip_address`, `browser_string`, `country_code`, `country_name`,

 

`referrer`,`referrer_query_string`,`landing_page`,`exit_page`,`time_arrived`,`last_click`, `agent`)

 

VALUES ('75.206.139.134','Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3)

 

Gecko/2008092417 Firefox/3.0.3','us', 'United States', 'http://brand-n-

 

style.com/admin/supertracker.php', 'report=success_refer','/','/index.php','2008-10-07

 

20:09:09','2008-10-07 20:09:09','')

 

[TEP STOP]

 

 

anyone can help me pls. I've been looking for kind of this tracking system long time

 

Thanks in advance

Niki

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×