Jump to content

Archived

This topic is now archived and is closed to further replies.

raddygast

Tiny SSL issue: after checkout_success, non-SSL

Recommended Posts

I was in the same boat also. I have made the changes includes/configure.php

 

from this:

 

  define('HTTP_SERVER', 'https://brs-giftshop.com'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
 define('HTTPS_SERVER', 'https://brs-giftshop.com'); // eg, [url="https://localhost"]https://localhost[/url] - should not be empty for productive servers
 define('ENABLE_SSL', true); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', 'brs-giftshop.com');
 define('HTTPS_COOKIE_DOMAIN', '');

 

to this:

 

define('HTTP_SERVER', 'http://www.brs-giftshop.com'); // eg, [url="http://localhost"]http://localhost[/url] - should not be empty for productive servers
define('HTTPS_SERVER', 'https://brs-giftshop.com'); // eg, [url="https://localhost"]https://localhost[/url] - should not be empty for productive servers
define('ENABLE_SSL', true); // secure webserver for checkout procedure?
define('HTTP_COOKIE_DOMAIN', 'www.brs-giftshop.com');
define('HTTPS_COOKIE_DOMAIN', 'brs-giftshop.com');

 

After cleaning the cache and then reentering my website http://www.brs-giftshop.com/ the site will open. The index page is still secured. The only other pages that are secured are the checkout like they should be.

 

After doing this a few times of typing the URL, looks like it is being redirected to https:// www.etc.

 

Checked out catalog/redirect/php. It looks fine. So could this problem be on the server where site is hosted?

 

Thanks.

Share this post


Link to post
Share on other sites

I've got a somewhat similar problem. Once you get to the checkout process on my site, every single link begins with https://, so it doesn't switch back to http://. Please read my post here:

 

279013

 

Thanks,

Matt

Share this post


Link to post
Share on other sites

×