Jump to content
Sign in to follow this  
Vger

Thumbnail PDF Catalogue

Recommended Posts

I don't know which version you are using, so can't answer your question. My original version uses thumbnails which have to be generated once by viewing all of the images on the site, but once generated are permanent images. The later contribution uses an 'on-the-fly' thumbnailer which generates thumbnails each time they are needed.

 

Vger

Share this post


Link to post
Share on other sites
I don't know which version you are using, so can't answer your question. My original version uses thumbnails which have to be generated once by viewing all of the images on the site, but once generated are permanent images. The later contribution uses an 'on-the-fly' thumbnailer which generates thumbnails each time they are needed.

 

Vger

 

I am using the Thumbnail PDF Catalogue v2.0,

 

Did I need to edit the info you did in the OTF thumbnailer with GD library.txt file to get the pdf catalog to work?

 

Just noticed also that the link properties for generating the pdf file from my admin panel shows it is looking for this: www.mysite.com/admin/FILENAME_PDF_CATALOGUE is that correct or have I made a boo boo with copying in the links ?! :-"

Share this post


Link to post
Share on other sites

The "OTF thumbnailer with GD library" is not my original contribution. You'll have to get Scott to advise you about how his version operates.

 

Vger

Share this post


Link to post
Share on other sites
The "OTF thumbnailer with GD library" is not my original contribution. You'll have to get Scott to advise you about how his version operates.

 

Vger

 

Ah ok - I will scrap this install and come back in a few minutes to feedback my result.

 

Diaz

Share this post


Link to post
Share on other sites

Once installed I will need to go to each of the products I know. But will I need to go in to each item to get the larger view of the items or just to the catagories sections to get them?

 

 

TIA

 

Diaz

Edited by Diaz

Share this post


Link to post
Share on other sites

Well the thumbnails are being generated and cached in the imagecache folder, so the problem does not lay there - provided you have viewed each of them at least once. However, you obviously have not completed the install of the Thumbnail PDF Catalogue, because (at the very least) some images are missing from the contribution e.g. adobe_pdf.gif and getacro.gif.

 

Please report what error you are getting when you try to generate the Catalogue in osC admin.

 

Vger

Share this post


Link to post
Share on other sites

Hmmm.. I see what you mean but I can not see these pics in the download I did either.

Edited by Diaz

Share this post


Link to post
Share on other sites

When I click on "Generate Catalog(s)" it just takes me to the main catalog page that the customers see. I suspect the rediect has come from the server not finding what ever it was looking for.

 

 

Diaz

Share this post


Link to post
Share on other sites

Well, with that redirect in place you're never going to find out what's happening.

 

Vger

Share this post


Link to post
Share on other sites
Well, with that redirect in place you're never going to find out what's happening.

 

Vger

I have taken the error rediect off but its still the same. Where was the adobe_pdf.gif file supposed to have been in the downloaded file? I can not seem to find it.

Share this post


Link to post
Share on other sites

Okay, so now you've taken out the redirect, what errors are being reported?

 

Vger

Share this post


Link to post
Share on other sites

That error is telling you that you have not installed the contribution properly. Please follow the install instructions - every part of them.

 

Vger

Share this post


Link to post
Share on other sites
That error is telling you that you have not installed the contribution properly. Please follow the install instructions - every part of them.

 

Vger

 

Still can not get this to work, must be a small copy paste error somewhere. Anyone else had this problem that can offer any help?

 

:blink:

Share this post


Link to post
Share on other sites

It's not a copy and paste error - you've missed out at least one file or one instruction. As this is a large install it's a fairly safe bet that there's more than one thing missed.

 

Vger

Share this post


Link to post
Share on other sites

I installed OTF Catalog 2.0.

 

When generating the PDF I get the following error:

 

Fatal error: Cannot access empty property in C:\apachepub\shop.xxxx.be\admin\pdf_catalogue.php on line 618

 

617		 //recherche le nom de la categorie pere
618			$this->$parent_category_name='';
619			$this->ParentsName($current_category_level,$i,$categorieslevelsarray, $categoriesnamearray);

 

What can be wrong?

Adding text (just to test) on line 618 between the '' (eg. 'xxx') generates an identical error.

 

I have this error with both Catalog 1.59 and Catalog 2.0

 

Thanks for your help.

Share this post


Link to post
Share on other sites

When i click save in the admin panel i get this error

 

1054 - Unknown column 'p.products_id' in 'on clause'

 

select p.products_id, pd.products_name, pd.products_description, p.products_image, p.products_model, p.products_price, p.products_tax_class_id, IF(s.status, s.specials_new_products_price, NULL) as specials_new_products_price, p.products_date_added, m.manufacturers_name from products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_description pd left join specials s on p.products_id = s.products_id, categories c, products_to_categories p2c where products_status = '1' and p.products_id = pd.products_id and pd.language_id = '1' and p.products_id = p2c.products_id and p2c.categories_id = c.categories_id and p2c.categories_id='1' order by pd.products_name, p.products_date_added DESC

 

[TEP STOP]

 

Please someone help me

 

I drive the new OSC

Share this post


Link to post
Share on other sites

Michael - this is the Thumbnail PDF Catalogue contribution thread, but your post has nothing to do with that.

 

Vger

Share this post


Link to post
Share on other sites
Michael - this is the Thumbnail PDF Catalogue contribution thread, but your post has nothing to do with that.

 

Vger

 

But is come when i will save the pdf catalog from the admin panel

Share this post


Link to post
Share on other sites

That error has nothing to do with Thumbnail PDF Catalogue - unless you have installed it incorrectly and corrupted some of the website's other coding.

 

I would advise you to restore the files altered using the backup you took before installing the contribution, then start over again.

 

If you didn't take a backup - well, the contribution tells you to do that.

 

Vger

Share this post


Link to post
Share on other sites
That error has nothing to do with Thumbnail PDF Catalogue - unless you have installed it incorrectly and corrupted some of the website's other coding.

 

I would advise you to restore the files altered using the backup you took before installing the contribution, then start over again.

 

If you didn't take a backup - well, the contribution tells you to do that.

 

Vger

 

I have try that, but it come with the error, but only when i try to make the pdf catalog from the admin panel

Share this post


Link to post
Share on other sites

How many times can I say this - that error has absolutely nothing to do with Thumbnail PDF Catalogue (as written by myself - Vger). If you are using either of the other two contributions - PDF Catalog or PDF Catalogue with OTF Thumbnailer - then you need to go to their support threads.

 

Vger

Share this post


Link to post
Share on other sites
How many times can I say this - that error has absolutely nothing to do with Thumbnail PDF Catalogue (as written by myself - Vger). If you are using either of the other two contributions - PDF Catalog or PDF Catalogue with OTF Thumbnailer - then you need to go to their support threads.

 

Vger

 

I have only install this modul "Thumbnail PDF Catalogue v2.0" and it only this modul there come with the error. You can get my login and password to my admin site, and try it self.

Edited by TheExterminator

Share this post


Link to post
Share on other sites
1054 - Unknown column 'p.products_id' in 'on clause'

 

That error means that you don't have a field in your 'products' table (in your database) for 'products_id' - and that has absolutely nothing to do with this contribution.

 

Those are my final words on the subject.

 

Vger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×