Jump to content
Sign in to follow this  
jhudson08

Easy Populate Errors

Recommended Posts

Hello,

 

I was hoping someone might be able to help with these errors I am recieving when I try to upload an EP file using Easy Populate:

 

Here are the errors

 

Filename: test898_tabdelimited.txt

 

Warning: file(/kunden/homepages/16/d100301682/htdocs/catalog//catalog/temp/test898_tabdelimited.txt): failed to open stream: No such file or directory in /homepages/16/d100301682/htdocs/catalog/admin/easypopulate.php on line 684

 

Warning: Invalid argument supplied for foreach() in /homepages/16/d100301682/htdocs/catalog/admin/easypopulate.php on line 689

 

I'm sure it's a very simple fix but I'm a novice at OSCommerce...

 

Thanks in advance.

Share this post


Link to post
Share on other sites

You have a double slash here: /catalog//catalog/ I'm sure there should only be one catalog also :P

 

Look at your easypopulate file and set the correct path :D

 

Matti


Matti Ressler

 

We were all once expert at...... nothing

_____

Share this post


Link to post
Share on other sites
You have a double slash here:  /catalog//catalog/  I'm sure there should only be one catalog also  :P

 

Look at your easypopulate file and set the correct path  :D

 

Matti

 

 

Hi Johnson,

 

I guess that directory reference is what I'm having trouble with. Where in the code would I replace that error?

 

Best I can figure is lines 21 and 22:

 

$tempdir = "/catalog/temp/";

$tempdir2 = "/catalog/temp/";

 

However, those directories look like they're listed correctly. It must be somewhere else in the code but I'm not sure where.

 

BTW- I'm looking in easypopulate.php...

 

Thanks

Share this post


Link to post
Share on other sites

most likely your document root setting in the admin/includes/configure.php file needs to be changed to $DOCUMENT_ROOT and that should solve it


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
most likely your document root setting in the admin/includes/configure.php file needs to be changed to $DOCUMENT_ROOT and that should solve it

 

Hi Mibble,

 

On line 20 the code reads as:

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)

 

The other thing I was thinking is that i'm on a shared server through GoDaddy. Do I need to change the path to something like:

 

/kunden/homepages/16/d100301682/htdocs/catalog/

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Just got done dealing with this problem. Don't put $DOCUMENT_ROOT in there. It just changes the error. You can't use localhost either. I had to put /home/globeche/public_html before the /catalog to make it work. Now in your case, just like you said, you're right, it would be /kunden/homepages/16/d100301682/htdocs/catalog. It's the full server route to get to that catalog folder. That'll fix it.

 

Hi Mibble,

 

On line 20 the code reads as:

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)

 

The other thing I was thinking is that i'm on a shared server through GoDaddy. Do I need to change the path to something like:

 

/kunden/homepages/16/d100301682/htdocs/catalog/

 

Thanks for your help.

Share this post


Link to post
Share on other sites
Just got done dealing with this problem.  Don't put $DOCUMENT_ROOT in there.  It just changes the error.  You can't use localhost either.  I had to put /home/globeche/public_html before the /catalog to make it work.  Now in your case, just like you said, you're right, it would be /kunden/homepages/16/d100301682/htdocs/catalog.  It's the full server route to get to that catalog folder.  That'll fix it.

 

 

OY- I know that has to be the right solution, but I just played around with that suggestion trying to get it implemeted correctly and got the following error.

 

Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /homepages/16/d100301682/htdocs/catalog/admin/includes/functions/database.php on line 19

Unable to connect to database server!

 

I have no idea what I did. I put everything back to the original and I'm still getting this error. I think I'm going to have to go back and start over.

 

Ugh.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×