Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Hi All!

Do you know of other way of creating new products attributes? I've tryed EP's model/attributes, but that doesn't solve the problem, because I have 6 languages, and need to create 480 different colors for a product. That means I had to figure out 480x6=2880 different codes to put in the first row......

Any help would be apreciated.

C?lia

Share this post


Link to post
Share on other sites
Dear mibble,

Can you please guide me as to how to download by category - Please?

 

Kunal

 

Can some one please tell me what code am I looking for in EP to download a specific category.

 

Please help!!

Kunal

Share this post


Link to post
Share on other sites

Hi,

 

I believe this is a very interesting and may be important topic to some of us. So... start this new thread. I have been searching a solution to get them working. Any comments, experience, tips & tricks are greatly appreciated from us.

 

So guys.....lets start.... :thumbsup:

Share this post


Link to post
Share on other sites

explained in the very first post of this thread. the first person to use it states he had no problem following how it works with the explanation, i have others who have had no problem following the explanation on how to use products attributes and options, i even have customers who use it who dont know much about excel and they have no problem.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
explained in the very first post of this thread.  the first person to use it states he had no problem following how it works with the explanation, i have others who have had no problem following the explanation on how to use products attributes and options, i even have customers who use it who dont know much about excel and they have no problem.

 

Mibble,

 

I do not understand. You are contradicting yourself. When you PM me telling me the solution is at the end of this thread and now you are indicating there is no problem with this contribution from the first person who use it. I am very sure you are not familiar with Product attributes - option type feature contribution.

 

Easy populate has no problem with product attributes. But it has problem with the contribution when you use product attributes - option type feature. When you use easypopulate to upload products with attributes such as text input boxes, radio button, text area box for comments, all data is gone. The attributes using text input boxes, radio button with data did not upload back to the database correctly and the product info page is not showing such attributes at all.

 

If you think there is a solution, show it to me as I have search through this thread with no result.

Share this post


Link to post
Share on other sites

in the pm i stated the solution is at the front of the thread

the very first post

please read the beginning of the thread

i have no problem with the various options boxes and others in the thread here have said the same thing.

if you can not get it to work, not much i can do, the instructions are there.

Edited by Mibble

John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
in the pm i stated the solution is at the front of the thread

the very first post

please read the beginning of the thread

i have no problem with the various options boxes and others in the thread here have said the same thing.

if you can not get it to work, not much i can do, the instructions are there.

 

Mibble,

Below is the pm message from you. You have a bad memory, so let me refresh your memory.....

 

Yesterday Message....from Mibble

"it is at the end of the easypopulate support thread not a separate thread per other moderator input"

 

If you are not interested to support... fine.. Nobody ask you for help. You are the one started all this.....

If you do not know, let me and others voice their opinions.

Edited by akkinmore

Share this post


Link to post
Share on other sites

One more go!!!

 

Can anyone please guide me as to how to download by category

 

I am sure if it simple some one can show the rest of us how it is done.

It is hard enough for people who are frustrated enough and on top of that finding things become harder.

 

So if you can help please post it on here again and help others.

 

Thanks!

Kunal

Share this post


Link to post
Share on other sites
Hi,

I have searched the thread for an answer to this but cannot find one. I am using Excel spreadsheet to produce SQL queries for attributes, and to produce easypopulate file for the products. Everything works fine except some products do not show images. The paths are correct, if I swap names around of the images they show up in the correct places with the new image. The admin panel shows 'image does not exist' for these products. If I add them manually then it works. I did upload the easy populate file before the images and I suspect this has caused the problem. However after deleting the products and starting again I still get the same problem. Can anyone help?

 

I didn't see a solution for this, but I'm having this problem now.

 

Some of my images are showing, while others are not. I extracted the image names from an EP download, and all images showed originally (manually entered).

Share this post


Link to post
Share on other sites

Hi,

I need some help. I have added some fieds to my product_description table. I need to be able to add them to easy populate. If you could help me that would be great.

 

Thanks,

Philip

Share this post


Link to post
Share on other sites

Hello.

 

I have installed the contribution and tested to download first.

This is working fine.

 

Then I try to upload the same file and I have the following message :

File uploaded.

Temporary filename: /tmp/phppx0LV6

User filename: EP2005jui18-2311.txt

Size: 160270

 

So it seems to work.

Then I remove one ligne and duplicate the last one changing the model number.

When I upload it again, it says the same message but nothing happens.

 

If I have a look at the database, no new line appears.

 

Could you help me ?

Share this post


Link to post
Share on other sites
Hello.

 

I have installed the contribution and tested to download first.

This is working fine.

 

Then I try to upload the same file and I have the following message :

File uploaded.

Temporary filename: /tmp/phppx0LV6

User filename: EP2005jui18-2311.txt

Size: 160270

 

So it seems to work.

Then I remove one ligne and duplicate the last one changing the model number.

When I upload it again, it says the same message but nothing happens.

 

If I have a look at the database, no new line appears.

 

Could you help me ?

 

I have checked the temp dir as well and everything is OK. EP is writing the file in it.

However, the upload still doesn't work...

 

:'(

Share this post


Link to post
Share on other sites
Please... is there anybody to have a look to my problem ?...  :blush:

 

There could be one of 3 problems

 

1. Check your settings in EP. Which directory is it looking for i.e. what is the name of the "temp" directory

 

2. Check the config.php settings to make sure the program knows where the temp directory is

 

3. USe CHMOD to see the directory attributes to make sure you can write to the directory.

 

It's usually the combination of 1 & 2 above so that EP goes looking in the wrong place


Citizen of US Minor Outlying Islands

Share this post


Link to post
Share on other sites
There could be one of 3 problems

 

1. Check your settings in EP. Which directory is it looking for i.e. what is the name of the "temp" directory

 

2. Check the config.php settings to make sure the program knows where the temp directory is

 

3. USe CHMOD to see the directory attributes to make sure you can write to the directory.

 

It's usually the combination of 1 & 2 above so that EP goes looking in the wrong place

 

 

I have check everything and EP writes the file I want to upload in the temp directory (so the CHMOD is OK and the settings are OK)

Share this post


Link to post
Share on other sites

Hello,

 

I would appreciate some help making a (hopefully) minor modification to my easyPopulate contrib currently installed on my store (it is either v2.3 or v2.4 - I can't remember off the top of my head).

 

I would like to be able to upload items to my database, and instead of the value in the v_products_quantity field being stored in the database, I would like it to be added to the value already stored in the database - i.e. something to this effect:

 

SET products_quantity = (products_quantity + v_products_quantity)

 

I'm afraid my PHP skills at this moment are a little lacking, and I'm not even really sure where I would make this change in the file.

 

I would appreciate any help and/or advice in this matter, as I make anywhere between 1 and 4 updates a week to my database, and this would certainly save quite a bit of time.


Mike Greenleaf

CCG Realm

 

The trust of the innocent is the liar's most useful tool. - Stephen King

Share this post


Link to post
Share on other sites

try the data one line at at time. comma's all need to be preceded with a \ in front of them, even in the descriptions.

 

Is there anybody to help me here ? It's two days I'm trying to understand why it doesn't work fine for me...

 

:'(


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
try the data one line at at time.  comma's all need to be preceded with a \ in front of them, even in the descriptions.

 

I have tested to try with only one insertion but it's doesn't work better...

I have put a \ before all the commas as well...

Share this post


Link to post
Share on other sites

This has possibly been answered before. I have searched extensively but can't find a thread, although there are some that are close to this.

 

I've done the temp dirs and chmod'd 777, i've tried changing the directory settings in easypopulate.php ....... no difference.

 

The errors I get are:

 

Warning: move_uploaded_file(/temp/tabbedreadyforimport.txt): failed to open stream: No such file or directory in /homepages/26/d67453580/htdocs/shop/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phptbWyrY' to '/temp/tabbedreadyforimport.txt' in /homepages/26/d67453580/htdocs/shop/admin/easypopulate_functions.php on line 32

 

Warning: fopen(/temp/tabbedreadyforimport.txt): failed to open stream: No such file or directory in /homepages/26/d67453580/htdocs/shop/admin/easypopulate.php on line 728

 

Warning: fgets(): supplied argument is not a valid stream resource in /homepages/23456/43543453580/htdocs/shop/admin/easypopulate.php on line 731

Creating file EP_Split1.txt ...

Warning: fopen(/temp/EP_Split1.txt): failed to open stream: No such file or directory in /homepages/2346/d6345437453580/htdocs/shop/admin/easypopulate.php on line 737

 

Warning: fwrite(): supplied argument is not a valid stream resource in /homepages/2344446/345345344/htdocs/shop/admin/easypopulate.php on line 738

 

Warning: fgets(): supplied argument is not a valid stream resource in /homepages/3426/345345435/htdocs/shop/admin/easypopulate.php on line 741

Added 0 records and closing file...

 

 

Warning: fclose(): supplied argument is not a valid stream resource in /homepages/26/345344553455/htdocs/shop/admin/easypopulate.php on line 767

 

Warning: fclose(): supplied argument is not a valid stream resource in /homepages/26/435345435/htdocs/shop/admin/easypopulate.php on line 768

You can download your split files in the Tools/Files under /catalog/temp/

 

Any offers?

Share this post


Link to post
Share on other sites

Heyo,

 

I am curoius if anyone added a special prices field to their easypopulate that could be used in place of retail price. If not, does anyone know how to add an extra field (v_specials_new_products_price) to easypopulate so that it is recognized and stored in database when uploaded from a spreadsheet?!

 

Thank you. :thumbsup:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×