Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Incidentally, I also just attempted to split a file and it didn't do anything either. I attempted both the unedited original output file (28 lines long) and an output file I edited to be 568 lines long, in case the first was due to the shortness of the original file. I say this in case it'll help people in figuring out what's wrong.


Always BACK UP your files and your database before making any changes. Before asking questions, check out the Knowledge Base. Check out the contributions to see if your problem's solved there. Search the forums.

 

Useful threads: Store Speed Optimization How to make a horrible shop Basics for design change How to search the forums

 

Useful contributions: Easypopulate Fast, Easy Checkout Header Tag Controller

Share this post


Link to post
Share on other sites

It worked! I fixed it!

 

Apparently I needed to define $tempdir as /temp/ rather than /catalog/temp/. I'm not sure whether to be happy with myself for having finally gotten it to work, or irritated for taking so long.


Always BACK UP your files and your database before making any changes. Before asking questions, check out the Knowledge Base. Check out the contributions to see if your problem's solved there. Search the forums.

 

Useful threads: Store Speed Optimization How to make a horrible shop Basics for design change How to search the forums

 

Useful contributions: Easypopulate Fast, Easy Checkout Header Tag Controller

Share this post


Link to post
Share on other sites

reason you had to define as temp instead of catalog/temp (if your path is /catalog/admin) is your document root setting is wrong in your admin/includes/configure.php file and will continue to cause you problems in the future unless you change it now . ..


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

I am about to install the EP feature (THANK YOU BTW). I saw on your last post that if you don't have a "catalog/" path, you will continue to have errors. I do not have a "catalog/" path or folder. The osCommerce is installed in my "Public HTML" folder and has "DOCS", "admin", "download", "extras", "images", "includes" and "pub", as well as the main PHP files.

 

Am I ok with this? No "catalog" folder? Thought I would just ask before I try to tackle this tonight!

 

:thumbsup:

 

Rob

Share this post


Link to post
Share on other sites
reason you had to define as temp instead of catalog/temp (if your path is /catalog/admin) is your document root setting is wrong in your admin/includes/configure.php file and will continue to cause you problems in the future unless you change it now . ..

 

I see. I just went into my configure file and realized that I had /catalog at the end of my document root. I fixed it, fixed my easypopulate back to catalog/temp and it still works perfectly. Thank you.


Always BACK UP your files and your database before making any changes. Before asking questions, check out the Knowledge Base. Check out the contributions to see if your problem's solved there. Search the forums.

 

Useful threads: Store Speed Optimization How to make a horrible shop Basics for design change How to search the forums

 

Useful contributions: Easypopulate Fast, Easy Checkout Header Tag Controller

Share this post


Link to post
Share on other sites

OK...managed to install the EP. Working great so far. Still need to do some work on it, but I am running into a small bump :huh:

 

Where are the images coming from? I have the images located in this path:

/images/magazines/41569.jpg

 

So, would I enter images/magazines/41569.jpg in the excel file where the image name is?

 

Any ideas?

 

Thanks,

 

Rob

Edited by MagazineMonkey

Share this post


Link to post
Share on other sites

I've searched the forum too many times now, and the search function on here appears to be too vague... or no one else has had the problem i am running into with EP.

 

anyway, this is the problem:

 

Installed EP, Created an Excel .txt (tab delimited), Uploaded. Everything appeared to have worked, so I was very happy about that.

 

However, I noticed that the tax was registering as "none". I need to charge tax to NY residents, so I have all of that configured in "Taxable Goods", there are no problems with that. Tax is added to NY residents upon checkout.

 

I have a column for "v_tax_class_id", but when I place "Taxable Goods" (both are without the quotation marks), it still shows --none-- as the tax in the product editor within osC.

 

Am I not using the right column title for this? I used the manual to guide me through setting up the Excel sheet.

 

I do not think it is relevant, but my EP.php shows:

 

//**** Price includes tax? ****
// Set the v_price_with_tax to
// 0 if you want the price without the tax included
// 1 if you want the price to be defined for import & export including tax.
global $price_with_tax;
$price_with_tax =true;

 

 

Thanks in advance for any help, I just can't wait to start using this contrib. and getting my products added to the catalog a lot faster.

Share this post


Link to post
Share on other sites

I have a general question concerning easyPopulate:

 

Is there a way to make it so that, when I upload items using easyPopulate, the value in the v_products_quantity is added to the current total stored in my database, as opposed to overwriting it, as it does now.

 

For example, I run a trading cards store, and I routinely add singles to the store. If I were to upload the following example:

 

v_products_model

123-456-78

 

v_products_price

$1.00

 

v_products_quantity

5

 

EOREOR

EOREOR

 

I would like the new quantity value (in this ex., 5) to be added to the stored value in my database (for the example's sake, we'll say there are 12 singles in stock already). So, instead of entering 17 (and having to check for each item to see how many are currently in stock), I would like to add the 5 to the current 12 (I hope this makes sense....if not, I apologize).

 

I'm hoping that there is a patch I can add or modify to the current easyPopulate file to make this happen (I did read through the modifications at the beginning of the file, but found nothing to answer this question).

 

Thanks in advance!


Mike Greenleaf

CCG Realm

 

The trust of the innocent is the liar's most useful tool. - Stephen King

Share this post


Link to post
Share on other sites
It looks like a valid path. What do yu think is wrong with it?

 

Jack

 

 

it says "catalog//catalog" instead only once /catalog --> its producing a second slash with catalog --> so the whole thing doesn`t work

Share this post


Link to post
Share on other sites

Oh, sorry. I didn't notice that. Most likely the problem is in your configure file. You probably have catalog appended to the url. You can post that here, minue the sensitive parts, for someone to look at. If you don't want to do that, yu can edit the admin/easypopulate.php file. The path in it is /catalog/temp/. Change it to /temp/. However, if your config is as I suspect, you will have other problems down the road with other parts of your shop so that should be fixed.

 

Jack

Share this post


Link to post
Share on other sites
OK...managed to install the EP. Working great so far. Still need to do some work on it, but I am running into a small bump  :huh:

 

Where are the images coming from? I have the images located in this path:

/images/magazines/41569.jpg

 

So, would I enter images/magazines/41569.jpg in the excel file where the image name is?

 

Any ideas?

 

Thanks,

 

Rob

 

 

open the sample file included with the easypopulate documentation, shows the correct way of ding paths

 

Do you mean the 'sample_output_file'? I'm reading through it, but there is so much code there. Just want to make sure I'm at the right place.

 

:D

 

Rob

Share this post


Link to post
Share on other sites
Oh, sorry. I didn't notice that. Most likely the problem is in your configure file. You probably have catalog appended to the url. You can post that here, minue the sensitive parts, for someone to look at. If you don't want to do that, yu can edit the admin/easypopulate.php file. The path in it is /catalog/temp/. Change it to /temp/. However, if your config is as I suspect, you will have other problems down the road with other parts of your shop so that should be fixed.

 

Jack

 

 

yes - that was it - no more error messages. thank you.

Share this post


Link to post
Share on other sites
yes - that was it - no more error messages. thank you.

 

 

But no changes in database are beeing made - as soon as I change anything in the textfile (i.e. some numbers from the products) - and load the whole thing up - I do not get any erros - but the changes end up in elaminating up to hundred products -

no Idea what this could be.

 

even though I get this beautiful message here.

 

File uploaded.

Temporary filename: /tmp/phpneAVrh

User filename: EP2005Jul09-1503.txt

Size: 29581

 

any Ideas?

Share this post


Link to post
Share on other sites

Ok people...I'm starting to think I'm really out of my league here...or dumb :rolleyes:

 

I'm having trouble uploading images via EP. If the image I'm trying to upload is located at mydomain.com/magazine/images/magazines/1234.jpg, what is the path I use for the EP .txt file?

 

Thank you all very much :thumbsup:

 

Rob

Share this post


Link to post
Share on other sites
anyone know what the tax problem i ran into is from? thanks!

 

i solved this problem, by changing "id" to "title" in the excel tag.

 

the products are now registered as taxable goods in the catalog, HOWEVER:

 

rather than adding the tax to the net price, the tax amount is subtracted from the net price, so that the gross price (price w/ tax) displays as what the net price should be.

 

example:

 

product price is $289

 

net price is showing as 267.28

 

gross price is showing at 289

Share this post


Link to post
Share on other sites
Ok people...I'm starting to think I'm really out of my league here...or dumb  :rolleyes:

 

I'm having trouble uploading images via EP. If the image I'm trying to upload is located at mydomain.com/magazine/images/magazines/1234.jpg, what is the path I use for the EP .txt file?

 

Thank you all very much  :thumbsup:

 

Rob

 

So..anyone know this one?

 

B)

Share this post


Link to post
Share on other sites
the separate price contribution was programmed by someone, thus if using that, you need to makee sure your database tables match what they have programmed into easypopulate.

 

This is the way the Separate Price part of easypopulate.php (at the end of the file) looks for each price group:

 

if ($v_customer_price_1 != ''){

$result = tep_db_query('

INSERT INTO

'.TABLE_PRODUCTS_GROUPS.'

VALUES

(

' . $v_customer_group_id_1 . ',

' . $v_customer_price_1 . ',

' . $v_products_id . ',

' . $v_products_price . '

)'

 

This is the way that it should look:

 

if ($v_customer_price_1 != ''){

$result = tep_db_query('

INSERT INTO

'.TABLE_PRODUCTS_GROUPS.'

VALUES

(

' . $v_customer_group_id_1 . ',

' . $v_customer_price_1 . ',

' . $v_products_id . '

)'

 

There are only three fields in the customer_group table. Easypopulate is trying to add 4 fields to it. If the $v_products_price field is removed for each set of customer_group_id's that is being uploaded, then easypopulate correctly updates the customer_group table.

Share this post


Link to post
Share on other sites

in the sample database txt file, the image is listed in the format of image.jpg, thus if you have it lower than that, then you list directory_name/image.jpg


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

hello have easypopulate installed ( by a friend) but have a bit of trouble getting this one.

 

i am setting up a computer store, does anybody have a small file(product file) that i could view( small piece) just to have a better understanding of what to try and do. i have viewed the test file but ( &^$$ bugger me , hard to get my head around that straight away.) does the file have to be txt or can it be xls or csv.

 

 

Also i have only installed the contributions

:back button in buy now page

:osCommerce MS2 HTML WYSIWYG Editor, Product Desc, Email +_files

 

i have manually installed some products and categories but this takes to long (2000+ products and categories) so wish to try EP.

 

Also do you need to remove all former products and categories before using this , and is it advisable to have pictures in specific folders when uploading .

 

thanxs for the help but obviously not a techie, but find it easier to learn by getting it going with help then breaking it down. i have viewed the test file but ( &^$$ bugger me , hard to get my head around that straight away.

 

thanxs

titch

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×