Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

its a file which is being sent to me... and i dont fancy entering 13000 '.jpg's

 

thanks anyway :D looks like i'll use a macro.

Share this post


Link to post
Share on other sites
its a file which is being sent to me... and i dont fancy entering 13000 '.jpg's

 

thanks anyway :D looks like i'll use a macro.

 

You don't actually need a Macro to do this. Look at the CONCATENATE function and you'll see how to do what you want.

 

Then take the result of the CONCATENATE and Copy and Paste Special (Value) to get the result (picture.jpg) into the cells you'll be uploading.

 

Make sense?

 

Mike


Mike in Key West

Share this post


Link to post
Share on other sites

Please help!

 

I cannot get EasyPopulate working this time around. I uploaded the files to the proper place. I made sure the permissions are set. I have a different catalog directory name so I made the appropriate changes to easypopulate.php to set $tempdir to /catalog7/temp/.

 

I downloaded a sample file from the data in the db using EasyPopulate. I changed the prices only and uploaded it back up. I got the usual EasyPopulate screen with the following text at the top:

 

File uploaded.

Temporary filename: /tmp/phpH2dnzV

User filename: test.txt

Size: 510

 

Yet when I check the products, none of the prices changed. Nothing happened. Why would I not have any activity when I have the files uploaded properly and the temp directory has the correct permissions and is properly identified in the ep file.

Share this post


Link to post
Share on other sites

if u downloaded version 2.75, it is probably because it is set to a semicolon and not a tab delimited, you need to change your ep file for that


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
if u downloaded version 2.75, it is probably because it is set to a semicolon and not a tab delimited, you need to change your ep file for that

 

I changed the ep file to tab delimited. I found the problem. The readme file says if your catalog is in a nonstandard place you have to change $tempdir. This is not so. I could only get it to work when I set $tempdir simply to "temp/". It's simply a matter of the readme file being either incorret or unclear. Either way this is a matter of poor documentation.

 

I now have a fully functional install of EasyPopulate.

Share this post


Link to post
Share on other sites

it is not poor documentation, that is probably because you have the document root problem in your admin/includes/configure.php file, what do you have listed in it for document_root?

 

if it is incorrect you will have other problems also.

Edited by Mibble

John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
who ever uploaded the version you downloaded, changed the tab delimited, thus you need to change ep back to tab delimited or you need to change your data to being seperated by the semicolon.

also what do you have for a temp dir location in your ep file?

what does document_root say in your admin/includes/configure.php

 

 

Hi John,

How do I change the ep back to tab delimited.

 

The version I have is the 2.76.

 

I have my temp dir location as /temp/

 

My document_root in your admin/includes/configure.php is the right path

Share this post


Link to post
Share on other sites

as long as your document root does not end with a / and does not include catalog, etc you are ok.

search the easypopulate.php file, youwill find where you change to tab.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
as long as your document root does not end with a / and does not include catalog, etc you are ok.

search the easypopulate.php file, youwill find where you change to tab.

 

 

I checked the root dir

in the ep.php

I found this

 

global $separator;

//$separator = "\t"; // tab is default

//$separator = ","; // comma

$separator = ";"; // semi-colon

//$separator = "~"; // tilde

//$separator = "-"; // dash

//$separator = "*"; // splat

 

 

but when I change to this

global $separator\t;

//$separator = "\t"; // tab is default

//$separator = ","; // comma

$separator = ";"; // semi-colon

//$separator = "~"; // tilde

//$separator = "-"; // dash

//$separator = "*"; // splat

 

 

it does not work

Share this post


Link to post
Share on other sites

global $separator;

$separator = "\t"; // tab is default

//$separator = ","; // comma

//$separator = ";"; // semi-colon

//$separator = "~"; // tilde

//$separator = "-"; // dash

//$separator = "*"; // splat

 

what the global is doing is naming a variable $separator

 

then the tab is assigned to separator

Edited by Mibble

John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Thanks John,

worked well but after updating the file, only the new categories show but no new products show in the catalog

Share this post


Link to post
Share on other sites

I cannot download a file from the admin page. I've tried both solutions, the download Complete Tab delimited .txt file to edit and to download to the temp directory.

 

Nothing works. I also use the Firefox browser..... <_<

 

I guess I should get a question where to save the file in the first download and the second should just download to catalog/temp ???

 

// Storeman:-

 

:'(

Share this post


Link to post
Share on other sites

if the download isnt asking you where to save, even tho it only goes to one spot, there is something else wrong.

what do you have for your document_root setting in admin/includes/configure.php


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
that is on your data entry end, you could write a macro in excel to merge your image field with a .jpg

Hi Mibble and thank you for your support !!!!

 

Here is my line in configure.php:

define('DIR_FS_DOCUMENT_ROOT', '/usr/home/xxxxxxxxxxx/xxxxxx.de/public_html/catalog/');

 

Seems correct to me. I've reinstalled with a couple of earlier releases but nothing seems so work. I will soon give up this though I would really need it. I also tried to make a file of my own from the attached sample-file in the contrib but it won't read that either from the temp file or from my computer.........

 

Help !!

 

:blink:

Share this post


Link to post
Share on other sites

define('DIR_FS_DOCUMENT_ROOT', '/usr/home/xxxxxxxxxxx/xxxxxx.de/public_html');

 

you can verify this by going to your store admin, tools, server info and searching for document_root (will be down near the bottom)


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Dear oscommerce users. Sinds yesterday I use easy populate. It works very fine. But the main problem is that when i download a compleet list of the shop he only gets de dutch categories. The englisch categories I've made in my admin don't come with it. Everything works except this problem. Can someone help me?

 

Sorrie for my bad english.

 

Greetings from Holland

Share this post


Link to post
Share on other sites

I know something more i cahnged the default language into englisch. Now easypopulate takes the englisch categories but not the dutch ones. Can someone help me?

Share this post


Link to post
Share on other sites

I've still been working to get a file to upload through Easy Populate. I'm on a Mac computer and using Excel and textEdit. Finally, I tried saving the data file as a csv (windows) file instead of a tab-delimited file, and changed the separator in the easypopulate.php file to comma "," instead of tab "/t".... and it worked this time... I actually had products added to my catalog, it just didn't work quite right.

 

My problem now is that my product descriptions have commas in the text, so in the upload it breaks the data into a new field at each comma (including the commas in the description) throwing some of the info into the wrong fields.

 

My question is there some character I should be placing in front of the commas that are part of the punctuation in the product description to prevent the csv file from being split at the wrong spots?

 

I hope someone has a simple solution to this problem...

 

sharon


Sharon

Share this post


Link to post
Share on other sites

no, as you have it set to comma's instead of a tab, ep will see every comma in the spreadsheet, (which is now a text file) as a separator.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×