Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

that is where you need to start.  download a sheet from your store.  use that for your template.  fill in one line.

once you get one line to import, then the rest should be a piece of cake.

(by one line i mean one product,)

That is exactely what I have done. I even tried to upload the sample file - same thing happened.

 

Do you have any idea where I go wrong ?

Share this post


Link to post
Share on other sites
what do you have for document root in your configure.php file?

where is your temp dir located?

- I dont know whats document root in easypopulate.php - how do I find out ?

- My temp dir is in www,new-lifestyle.dk/catalog/temp/

Share this post


Link to post
Share on other sites

go to your store admin, tools, server info and search for document_root

then open your admin/includes/configure.php and look for document root there.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Hello All

 

I have EP working and I have to say it is a lifesaver. I have now decided to offer download files etc but I am having difficulties bringing my download Files, Expiry dates and Maximum download count into the EP file. It is bringing in the attributes eg size value etc fine, but not the filename etc needed for the download.

 

I have read page after page in this thread, however I have yet to find out what I must be doing wrong.

 

Any help pointing me in the right direction would be greatly appreciated.

 

Kind Regards

Trap

Share this post


Link to post
Share on other sites
go to your store admin, tools, server info and search for document_root

then open your admin/includes/configure.php and look for document root there.

In Server info my document root is:

 

"/hsphere/local/home/tzinck/new-lifestyle.dk"

 

 

In configure.php is says like this (sorry - I dont know much about programming. I can see that the server root is wrong - but I don't know how to fix it)

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)

define('DIR_WS_ADMIN', '/admin/');

define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);

define('DIR_WS_CATALOG', '/catalog/');

define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

Edited by tzinck

Share this post


Link to post
Share on other sites

you need to fill in your configure.php file and also create a password for mysql:

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright ? 2002 osCommerce

 

Released under the GNU General Public License

*/

 

// define our webserver variables

// FS = Filesystem (physical)

// WS = Webserver (virtual)

define('HTTP_SERVER', 'http://new-lifestyle.dk');

define('HTTP_CATALOG_SERVER', 'http://new-lifestyle.dk');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false');

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT);

define('DIR_WS_ADMIN', '/admin/');

define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);

define('DIR_WS_CATALOG', '/catalog/');

define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

define('DB_SERVER', 'localhost');

define('DB_SERVER_USERNAME', 'xxxxx');

define('DB_SERVER_PASSWORD', '');

define('DB_DATABASE', 'xxxxxxxx');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');

?>

 

 

In Server info my document root is:

 

"/hsphere/local/home/tzinck/new-lifestyle.dk"?

In configure.php is says like this (sorry - I dont know much about programming. I can see that the server root is wrong - but I don't know how to fix it)

 

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)

? define('DIR_WS_ADMIN', '/admin/');

? define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);

? define('DIR_WS_CATALOG', '/catalog/');

? define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

Edited by Mibble

John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
you need to fill in your configure.php file and also create a password for mysql:

 

<?php

/*

  osCommerce, Open Source E-Commerce Solutions

  http://www.oscommerce.com

 

  Copyright ? 2002 osCommerce

 

  Released under the GNU General Public License

*/

 

// define our webserver variables

// FS = Filesystem (physical)

// WS = Webserver (virtual)

  define('HTTP_SERVER', 'http://new-lifestyle.dk');

  define('HTTP_CATALOG_SERVER', 'http://new-lifestyle.dk');

  define('HTTPS_CATALOG_SERVER', '');

  define('ENABLE_SSL_CATALOG', 'false');

  define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT);

  define('DIR_WS_ADMIN', '/admin/');

  define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);

  define('DIR_WS_CATALOG', '/catalog/');

  define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

  define('DIR_WS_IMAGES', 'images/');

  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

  define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

  define('DIR_WS_INCLUDES', 'includes/');

  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

  define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

  define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

  define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

  define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

  define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

// define our database connection

  define('DB_SERVER', 'localhost');

  define('DB_SERVER_USERNAME', 'xxxxx');

  define('DB_SERVER_PASSWORD', '');

  define('DB_DATABASE', 'xxxxxxxx');

  define('USE_PCONNECT', 'false');

  define('STORE_SESSIONS', 'mysql');

?>

Thanks a lot. Where can I find this (and other iportant) information - I would like to know what I'm doing so I can do it myself another time ?

Share this post


Link to post
Share on other sites
Thanks a lot.? Where can I find this (and other important) information - I would like to know what I'm doing so I can do it myself another time ?

 

By the way.  How do I passwordprotect MySql

Edited by tzinck

Share this post


Link to post
Share on other sites
I had to reinstall Easy Populate - so thats fine now... But Unfortunately it still doesn't work.  I have changed some things in config.php and easy_populate.php.

 

I still get all the categories, but no goods.

 

HELP ME - what is wrong ?

Share this post


Link to post
Share on other sites

EP keeps timing out for me. I have over 3000 products and many have attributes. I have seen it referenced to turn attributes off - but can not find the instructions to do this. (I am assuming at this point that it is the attributes making ep time out)

 

Can anyone point me in the right direction please?

Share this post


Link to post
Share on other sites

well, u wouldnt believe how many overlook even reading the file. there is tons in there. i havent updated the contribution as too many would get lost again.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

I started everything from the beginning again now

 

Can anyone explain to me (just short) what Froogle is all about ?

 

MUST I configure Froogle in easypopulate.php - or can I leave it as it is ?

Share this post


Link to post
Share on other sites

I got easy populate populating attributes perfectly. When the setting is off in Easy Populate.php there is no problem, but I need them on.

 

The problem I am facing is Easy populate is ignoring the SORT order of the attributes when we upload, whatever the sort order of a attribute is easypopulate is resetting it to '0'. I am still looking for a way on how to stop this sort order destruction :)

 

I am working with like 350 products on a test site and I am manually updating sort order for attributes every time I upload or change them :(

very painful though ;)

 

help is appreciated.

Share this post


Link to post
Share on other sites
you can leave it as it is if, not necessary to configure

Thanks a lot Mibble - I really appreciate your active help.

 

Maybe you can help me on this also:

 

Warning: move_uploaded_file(/hsphere/local/home/tzinck/new-lifestyle.dk/catalog//catalog/temp/EP2005Apr19-test1.txt): failed to open stream: No such file or directory in /hsphere/local/home/tzinck/new-lifestyle.dk/catalog/admin/easypopulate_functions.php on line 32

 

I have looked in "easypopulate_functions.php on line 32", but I dont know mush about programming, so I dont see where the mistake can be.

 

I guess something about "...catalog//catalog..." - but how can I fix it ? :rolleyes:

Share this post


Link to post
Share on other sites

Help!

 

I found that the easypopulate.php script is not getting the download and dltype attribute from the http request into $download and $dltype variables.

 

As a result, my $download and $dltype is always empty.

 

Do u have the problem? Which part of the code is suppose to read the http attributes and put it into $download and $dltype?

 

Surf'n Beauty - Your Online Dr. Hauschka Store

Edited by BlueNoteMKVI

Share this post


Link to post
Share on other sites

I have installed EP wich operates fine. My only problems are:-

1) I need to link to my suppliers web site.

2) I need to link to my suppliers image.

All of this needs to be done through EP.

 

I am not too sure how to go about this.

Good instructions are needed to help me sort this one - no quick one liners!

Your help would be most appreciated.

Regards

Darren

Share this post


Link to post
Share on other sites

you have to get your info from your vendors first, prior to being able to do anything with ep. how are they going to provide the data?

will it be in db or csv?


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

VJ, great work w/ ep and added features attributes... thank you it works great!...

 

just wondering if anyone was successfull in using css inline or internal (external not an option) for their description.. i had to revert back to old html w/o the " " and had to turn on (escape character conversion) .. if i hadnt, problems uploading to the db would result in nothing happening at all or sumn displayed w/ showing [TEP STOP] etc...... but all in all.. this contribution is top notch

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×