Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

VJ

Easy Populate & Products Attributes

Recommended Posts

Guest

whatever value in the column for your attribute will work. i use quattro pro as it goes out over 18000 columns

i keep my manufacturers in different sheets, makes it easier for me, as i tie them to categories and options and then just download the particular option and i get what i need downloaded. course i usually dont download, just upload. i see no need to download the data at all.

Share this post


Link to post
Share on other sites

Can anyone help ??

 

Im looking for advice on how to use Easypopulate with affiliate datafeeds. I know it can be done and have seen it done, but not sure on a couple of things.

 

1. How to get the image linked from the affiliate ? Nearly all affiliate feeds include links to the products image and thumbnail

 

2. How to get the BUY NOW button to link straight to the affiliate site ? Not sure about this one ? Ive seen sites that add the affiliate products to the cart and then when you goto checkout it takes you to the Affiliate Program site ( ive seen this with Linkshare ).

 

I would prefer to have a BUY NOW button ( instead of addto cart ) that when clicked will take you to Affiliate Program site.

 

Anyone got any ideas ? Any help would be appeciated.

 

Bennett

Share this post


Link to post
Share on other sites
Can anyone help ??

 

Im looking for advice on how to use Easypopulate with affiliate datafeeds. I know it can be done and have seen it done, but not sure on a couple of things.

 

1. How to get the image linked from the affiliate ? Nearly all affiliate feeds include links to the products image and thumbnail

 

2. How to get the BUY NOW button to link straight to the affiliate site ? Not sure about this one ? Ive seen sites that add the affiliate products to the cart and then when you goto checkout it takes you to the Affiliate Program site ( ive seen this with Linkshare ).

 

I would prefer to have a BUY NOW button ( instead of addto cart ) that when clicked will take you to Affiliate Program site.

 

Anyone got any ideas ? Any help would be appeciated.

 

Bennett

 

These are not really easy populate questions.

First you must figure out how to do it manually. EP can automate the "bulk load" of the product/category/attribute information.

You'll have some roadblocks and decisions to make. For instance, since you want to hotlink images have you consider what will happen on the ssl pages?

 

Just my 2 cents,

Robert

Edited by Rob123

Share this post


Link to post
Share on other sites
Guest

Hi, I have been using Easy Populate with great success for a couple of years now on a particular site. However I have recently copied the entire site to a new host on a new domain. The reason was to create a new site selling similar products etc but without having to add all the contris etc.

 

The problem I now have is that Easy Pop won't work on the new install. I think it is something fairly simple but I can't track it down. I can download the tab file no problem but when trying to upload and Insert into DB I just get a 500 Server error?

 

I think I have permissions etc correct but even having searched these forums I can't find the solution.

 

Could someone please suggest where I might stat looking? I have tried to resolve with my host but no luck I'm afraid.

Share this post


Link to post
Share on other sites
Guest

what is your document root path? what is your temp file path?

Share this post


Link to post
Share on other sites
Guest

This is part of my ADMIN config.php

 

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.mydomain.com');

define('HTTPS_SERVER', 'http://www.mydomain.com');

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('DIR_WS_CATALOG', '/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');

define('DIR_FS_DOCUMENT_ROOT', '/usr/home/somthing/public_html/');

define('DIR_FS_CATALOG', '/usr/home/somthing/public_html/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

 

If you can point me in the right direction I would very grateful.

Share this post


Link to post
Share on other sites

I need help. I used easypopulate to upload my products and everything worked fine. I even created the froogle file. Now it doesn't do anything (no downloads)

 

PLEASE HELP

 

Ian Falu

 

Thanks

Share this post


Link to post
Share on other sites

OK I am maybe I am desesperate.

 

I can start here. Where do I change the easypopulate.php file in order to download one category, maybe that help me to know If my host is slow!!

 

Thanks

Share this post


Link to post
Share on other sites
Guest

if u read thru the file you will see where, do it by option not category. if u need it by category needs some custom work.

Share this post


Link to post
Share on other sites
Guest

this:

define('DIR_FS_DOCUMENT_ROOT', '/usr/home/somthing/public_html/');

needs to be:

define('DIR_FS_DOCUMENT_ROOT', '/usr/home/somthing/public_html');

 

you probably got two // in the path

 

also set your temp properly with 777 permissions

 

 

This is part of my ADMIN config.php

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

  define('HTTP_SERVER', 'http://www.mydomain.com');

  define('HTTPS_SERVER', 'http://www.mydomain.com');

  define('ENABLE_SSL', true); // secure webserver for checkout procedure?

  define('DIR_WS_CATALOG', '/'); // absolute path required

  define('DIR_WS_IMAGES', 'images/');

  define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

  define('DIR_WS_INCLUDES', 'includes/');

  define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

  define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

  define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

  define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

  define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

  define('DIR_WS_DOWNLOAD_PUBLIC', DIR_WS_CATALOG . 'pub/');

  define('DIR_FS_DOCUMENT_ROOT', '/usr/home/somthing/public_html/');

  define('DIR_FS_CATALOG', '/usr/home/somthing/public_html/');

  define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

  define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

If you can point me in the right direction I would very grateful.

Share this post


Link to post
Share on other sites
Guest

Thanks for the advice, however sadly it doesn't work.

 

I still have the same 500 server Error when trying to do the import. Removing the extra / also causes the following error on the site,

 

Warning: The downloadable products directory does not exist: /usr/home/something/public_htmldownload/. Downloadable products will not work until this directory is valid

 

Any more suggestions?

 

 

this:

define('DIR_FS_DOCUMENT_ROOT', '/usr/home/somthing/public_html/');

needs to be:

define('DIR_FS_DOCUMENT_ROOT', '/usr/home/somthing/public_html');

 

you probably got two // in the path

 

also set your temp properly with 777 permissions

Share this post


Link to post
Share on other sites
Guest

put the / in front of download in your configure.php

Share this post


Link to post
Share on other sites
Guest

500 error is something generic, if you like, i can look at it, however would require store admin access

Share this post


Link to post
Share on other sites

Hi,

 

The only way I could download all my products is if I do it without attrbutes. So far that's what I need. I'll try the options at a later stage.

 

Thanks

 

For yur help

Share this post


Link to post
Share on other sites

Hello all, My question is as basic as it gets:

 

I am new and have been reading deep to get up to speed. My site has only a few items and has not had any changes to the folder structure.

 

I want to use easypopulate which I found on "top downloads" of the contributions page. I have read the manual and easypopulate.php indepth.

 

I have searched long for a thread for basic set up, I must be missing something major here, I have read the included instructions many times and I am not getting anywhere, I can't even see EP form my Admin panel after copy pasting the line to admin/includes/boxes/catalog.php

 

The only files I downloaded were "27 Nov 2004 - EP 2.74 Author: Mibble " from the contribution forum.

 

Following the instructions I:

1- Coped files easypopulate.php and easypopulate_functions into admin/.

-- I found 2 admin folders, which one do I paste to? The one with-in the Catalog folder or the one parallel to catalog folder?

2- Changed two lines in easypopulate.php to point at my HTTP- Is this enough or did I miss something here?

3- Added temp/catalog folder

4- Added text for adding link to the Admin, edit file admin/includes/boxes/catalog.php by adding

this line:

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '"

class="menuBoxContentLink">Easy Populate</a><br>'.

--Again, which admin folder does this refer to? The one with in Catalog or the one parallel to catalog folder? Is this supposed to contain '  before it just as the other lines do?

 

I don't see any new links to EP on the admin after this. I also do not have any .xls files with what I downloaded, should I?

 

Do I have to install Excel import 1.51 for EP to work?

 

Can some on please either clear up the basics for me or point me to a thread that already has?

 

I really like OSC and these forums to thank you in advance for your advice.

 

-Mark

Share this post


Link to post
Share on other sites
Guest

there is no parallel folder to catalog, it goes /catalog/admin and the files go in admin. have no idea why you have a parallel admin, could be for something else your host installed.

match the install with what you have in the /catalog/admin/includes/boxes/catalog.php file for the menu to show up.

Share this post


Link to post
Share on other sites

I can easaly download from EP but when i use the same file i've downloaded to upload it goes wrong. EP takes only 1 product and the rest wont word. I have tested something else but every time he only picks the first product. What goes wrong.

 

Can anybody tell me?

 

Klick here to try it yourself

Share this post


Link to post
Share on other sites
Guest

you need to fix all your errors first, your system is in 'safe mode'. ask your host to remove safe mode from the server.

also what did you set the temp directory path to in your ep file? and the properties?

Share this post


Link to post
Share on other sites

To use EP, do I first have to install "Excel import 1.51" or any other files? Or just the items described in the EP manual?

 

Thanks for your help people!

 

Hello all, My question is as basic as it gets:

 

 

The only files I downloaded were "27 Nov 2004 - EP 2.74 Author: Mibble "  from the contribution forum.

 

Following the instructions I:

1- Coped files easypopulate.php and easypopulate_functions into admin/.

    -- I found 2 admin folders, which one do I paste to? The one with-in the Catalog folder or the one parallel to catalog folder?

2- Changed two lines in easypopulate.php to point at my HTTP- Is this enough or did I miss something here?

3- Added temp/catalog folder

4- Added text for adding link to the Admin, edit file admin/includes/boxes/catalog.php by adding

this line:

'<a href="' . tep_href_link('easypopulate.php', '', 'NONSSL') . '"

class="menuBoxContentLink">Easy Populate</a><br>'.

    --Again, which admin folder does this refer to? The one with in Catalog or the one parallel to catalog folder? Is this supposed to contain '  before it just as the other lines do?

 

I don't see any new links to EP on the admin after this. I also do not have any .xls files with what I downloaded, should I?

 

Do I have to install Excel import 1.51 for EP to work?

 

 

Share this post


Link to post
Share on other sites
Guest

there is no mention anywhere in the documentation of excel import.

Share this post


Link to post
Share on other sites
there is no mention anywhere in the documentation of excel import.

 

Thank you John, I was up to late last night.......... I started from scratch with the directory advice you provided and WALA! It's there.

 

The help from this forum is greatly appreciated!!!!!!!! :thumbsup:

Share this post


Link to post
Share on other sites

That's strange. a year ago i used EP also and the the server wasn't in save mode also?

 

M temp directorie in easypopulate is liket this:

 

$tempdir = "/temp/";

$tempdir2 = "/temp/";

Share this post


Link to post
Share on other sites

continuing form thread http://forums.oscommerce.com/index.php?sho...42entry555842

 

After reading this thead (http://forums.oscommerce.com/index.php?showtopic=64945&st=1460), Mibble says that the admin folder should be in the catalog folder. My admin folder is parallel to the catalog folder and there is no admin folder elsewhere. The online store is cuurently running ok, with 100' of products in it. So I'm wondering what's the problem here or if there even is a problem? I still haven't found the file, database_tables.php that the easypopulate.php seems to be calling for.

 

Any help is appreciated.

Share this post


Link to post
Share on other sites
Guest

without knowing your directory structure, not many going to be able to help you

Share this post


Link to post
Share on other sites

Hi John,

Is this what you were looking for?

 

drwxr-x---    7 32101    99          4096 Feb 17 13:51 .

drwx--x--x  11 32101    woodwork    4096 Feb 22 04:17 ..

-rw-r--r--    1 32101    woodwork        0 Apr 18  2004 .htaccess

drwxr-xr-x    5 32101    woodwork    4096 Feb 22 10:18 admin

drwxr-xr-x    7 32101    woodwork    4096 Feb 22 10:10 catalogue

drwxr-xr-x    2 32101    woodwork    4096 Apr 17  2004 cgi-bin

drwxr-xr-x  10 32101    woodwork    4096 Jan  3 08:47 discussion

drwxr-xr-x    2 32101    woodwork    4096 Apr 20  2004 images

-rw-r--r--    1 32101    woodwork    8847 Sep 29 18:06 index-orig.html

-rw-r--r--    1 32101    woodwork    9732 Oct 28 07:51 index-temp.html

-rw-r--r--    1 32101    woodwork    10590 Feb 17 13:51 index.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×