Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

Could anyone please help me, for some reason I see that all my posts are overlooked. I make sure to have the proper folder (I can upload into the database). I have the right permissions, Also the data file seems to be OK, If I split it manually I can upload.

 

But there is no way I can make EP to split.

 

Please any thoughts!!!

Share this post


Link to post
Share on other sites

your posts are not ignored, you just need to read thru your own ep file thouroughly.

look at this part:

 

//**** File Splitting Configuration ****

// we attempt to set the timeout limit longer for this script to avoid having to split the files

// NOTE: If your server is running in safe mode, this setting cannot override the timeout set in php.ini

// uncomment this if you are not on a safe mode server and you are getting timeouts

// set_time_limit(330);

 

you have the time limit commented out


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

sussed out the problem with the extra comma's and now have my products on the site in the correct category's

only problem i have no is that EVERY product has the value as ZERO :)

 

my v_products_price column is all correct, prices such as 22.99, 1.99 etc.. no ? & $ anywhere,

what'd cause this to be zero?

Share this post


Link to post
Share on other sites
could you post two lines or so of your text file?

 

 

bear in mind that these are "adult" items :)

 

chocp 4561.jpg Chocolate Body Paint 5.95 3 100 Aphrodisiacs EOREOR

Delay 325.jpg Delay Spray 9.95 3 100 Aphrodisiacs EOREOR

 

 

let me know if this is enough

Share this post


Link to post
Share on other sites
so the rest of your file is empty in the fields?  what is your field layout? (top line)

 

i've formatted the line to make it a bit clearer

 

 

v_products_model - vb6682-c

v_products_image - vb6682-c.jpg

v_products_name_1 - Tantus Techno

v_products_description_1 - The Techno is a toy etccccc

v_products_url_1 -

v_products_price - 19.99

v_products_weight -

v_date_avail -

v_date_added -

v_products_quantity - 100

v_manufacturers_name -

v_categories_name_1 - Toys

 

all the other cat's (upto #30) are blank and everything above without a value is blank

 

 

v_tax_class_title

v_status

 

EOREOR (at the end of every line)

Edited by kronik76

Share this post


Link to post
Share on other sites

forgot to mention that i can see the correct prices within the admin section of OSC

just the zero value on the site which has me puzzled

Share this post


Link to post
Share on other sites

Sorry for my desesperation but I was uncommenting other pieces of codes I coouldn't find that one in particular.

 

Thanks for your great job

Share this post


Link to post
Share on other sites
means the path is still incorrect or the permissions are not correct.  what do you have in your easypopulate.php file for the temp file path.

 

 

Hi,

I have:

$tempdir = "/magazin/temp/";

$tempdir2 = "/magazin/temp/";

 

The permissions are set to 777.

Share this post


Link to post
Share on other sites

Hi,

 

I am working with Milestone Version and installed Easypopulate.

It worked great and did a good job.

 

However I stopped working with the shop some months ago. As I tryed to run Easypopulta again it just stopped working.

 

I have following problem:

 

File uploaded. 
Temporary filename: /tmp/php2hjdDQ
User filename: EP2004Dez13-1010.txt
Size: 1370
| 1000154 | 1000154 | FSC PR RX2 | FSC PR RX2 | | 2714.66 | 0.00 | | 0000-00-00 | 0 | Fujitsu Si | Systeme | PC | Server | MWSt | Inactive Updated
| 233;10001 | 100347;ht | 10039;100 | 123456;ha | 123456;ha 
|

 

As you can see Easypopulate only imports the first row. But it seems to get "confused" with further lines (2 and more). It seems that Easypopulate is not able to find the seperator which I tried first with tabs and in this example with semicolons. The first line is imported correctly. Additional lines make problems.

 

As I installed a new and clean testshop and just uploaded the newest Easypopulate Script it gets the same problem.

 

Has someone a solution? We updated the Server some weeks ago with PHP5. I changed the upload.php as it is described in the bug report.

 

It seems that there is a conflict with something. I hope you can help me.

 

Thanks

Macus

Share this post


Link to post
Share on other sites

Warning: file(/home/store/public_html/magazin/tempEP2004Nov05-14021.txt):

 

if you take a look at your path from your previous post, you will see that you are somehow missing the / at the end of temp, (look at the sentence above)

 

once you can get that portion fixed, then it will work


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
this on the server?  one thing you can do, is setup a system locally running 4.3.9, and then create a database there.  then upload the products from the database to the live server.

then use easypopulate to create more of the products locally, then restore just the tables for the products to your server.l

 

:huh: Do you mean this?

 

:'( This isn't a good solution for me :'(

Share this post


Link to post
Share on other sites

(w00t) :thumbsup:

 

Find

array_walk($readed, 'walk');

 

replace by this

 

//array_walk($readed, 'walk'); 
foreach ($readed as $readed_record) { 
  walk($readed_record); 
}

 

 

 

 

Thanks a lot

Edited by Macus

Share this post


Link to post
Share on other sites

Hello,

 

Before posting usually a read all forum, but 64 pages is to much.

I having a problem with ep with the contribution separated prices per customer.

 

Wend I download the list price/model/quantity the regular price is fine (ex:150) but the group price shows like 140.0000.

 

Any idea what is need to group prices appear without .000 ?

 

Thanks,

 

S?rgio

Share this post


Link to post
Share on other sites

Can anyone upload v_products_tax_class_id and get it to work?

 

Changing the number from 0 to 1 still makes the products not taxed and 1 should be "Taxable Goods" The records for the newly uploaded products are fine except this field.

 

Am I missing something?

 

Thanks, Ken

Edited by Top_Speed

define('PROJECTS', 'Something that goes on forever!');

Share this post


Link to post
Share on other sites

Hi All!!!

 

I really need some help! I have been using EP for quite some time and i think it a great contribution! But in the last couple of days it just stoped working... when i try to import a file from the temp directory i just get one line of text:

 

Filename: new.txt

 

When i try and upload one i get:

File uploaded. 
Temporary filename: /tmp/phpLK6t1F
User filename: new.txt
Size: 379864

 

I have checked the temp path directory and it is correct in fact if i change it i get errors... I have checked the permissions and the are all 777 for the files and the folder... i have tried the php 5 fix just in case no luck... i spoke to my web host and asked if they changed something and they said no.

 

I'm really out of ideas as to what could be causing this... ANY help would really be appreciated!!!!

 

Cheers,

 

Edwin.

Share this post


Link to post
Share on other sites
if ($v_date_avail == '') {

//  $v_date_avail = "CURRENT_TIMESTAMP";

  $v_date_avail = "NULL";

 

	if (ltrim(rtrim($v_products_quantity)) == '') {
 $v_products_quantity = 1;
}
if ($v_date_avail == '') {
//  $v_date_avail = "CURRENT_TIMESTAMP";
 $v_date_avail = "NULL";
} else {
 // we put the quotes around it here because we can't put them into the query, because sometimes
 //   we will use the "current_timestamp", which can't have quotes around it.
 $v_date_avail = '"' . $v_date_avail . '"';
}

if ($v_date_added == '') {
//  $v_date_added = "CURRENT_TIMESTAMP";
 $v_date_added = "NULL";
} else {
 // we put the quotes around it here because we can't put them into the query, because sometimes
 //   we will use the "current_timestamp", which can't have quotes around it.
 $v_date_added = '"' . $v_date_added . '"';
}

 

Is this right mibble?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×