Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

any of them have apostrophes in them?

 

No, none of them do. As far as I can see, all the ones that are acting up have ampersands in them, but there are plenty of other categories with ampersands that are behaving properly.

 

I'm baffled.

Share this post


Link to post
Share on other sites

A quick Q, if I may: I'm running on Fedora Core 3 with OpenOffice.org 1.1.2. Unfortunately, when I try to open an EasyPopulate file, OpenOffice.org insists on opening it in the Word-clone. I guess it doesn't see or appreciate the tabs :-).

 

Anyone know how to force an open in Calc?

 

Thanks.

Share this post


Link to post
Share on other sites
you should be able to specify that it is a tab delimited text file.  or open the spreadsheet app first, then the txt file

 

Can't specify that in the open dialogue, i actually renamed it to .xls, and i'm opening it in the spreadsheet app first. Worst case, I'll have to send this to a windows machine, open it there, save it differently, then send it back, but I was hoping to avoid that :-(.

Share this post


Link to post
Share on other sites
open as xls and save as tab delimited text, you dont dont need to send back and forth

 

OOo on Linux doesn't seem to be forceable. But for future reference, I managed to get it to work by opening the file in gEdit and copying/pasting into Calc. It recognized the tabs just fine.

 

Whew.

Share this post


Link to post
Share on other sites
how about posting a few lines of your txt file

 

Certainly. Here's one that works OK:

 

CV725  Blooming Lovely Broccoli Soup  14.72 0  0 KNOBBLY CARROT SOUPS & SAUCES (CHILLED)        1 EOREOR

CV723  Cosmic Courgette & Lemon Soup  14.72 0  0 KNOBBLY CARROT SOUPS & SAUCES (CHILLED)        1 EOREOR

 

These two lines, as you'd expect, create a category called SOUPS & SAUCES (CHILLED) and insert two products into it.

 

This bit, however

 

CV534  Actisun  8.97 0  0 SOJASUN SOYA YOGURTS & DESSERTS (CHILLED)        1 EOREOR

CV281  Apricot/Guava soya dessert OG  2.48 0  0 SOJASUN CV281  Apricot/Guava soya dessert OG  2.48 0  0 SOJASUN SOYA YOGURTS & DESSERTS (CHILLED)        1 EOREOR

 

creates two separate categories, both called SOYA YOGURTS & DESSERTS (CHILLED) , one of which contains Actisun and one of which contains Apricot/Guava soya dessert.

 

It's something to do with the category names. I found a work-round by reducing category names that were causing problems, such as SOYA YOGURTS to just one word. They then imported correctedly and I renamed the category from the Admin tool.

 

But I can't see why the two strings SOUPS & SAUCES (CHILLED) and SOYA YOGURTS & DESSERTS (CHILLED) should behave differently, since they both contain ampersands and parentheses.

Share this post


Link to post
Share on other sites

Ooops. I copied the misbehaving lines wrongly. They are, in fact

 

CV534  Actisun  8.97 0  0 SOJASUN SOYA YOGURTS & DESSERTS (CHILLED)        1 EOREOR

CV281  Apricot/Guava soya dessert OG  2.48 0  0 SOJASUN SOYA YOGURTS & DESSERTS (CHILLED)        1 EOREOR

 

Steve

Share this post


Link to post
Share on other sites

I'm trying to upload a product list but a lot of the products and descriptions have quote characters in them. It seems to throw things off. Are there any recommendations?

Share this post


Link to post
Share on other sites

Hey Guys,

 

I just downloaded Easy Populate 2.74-MS2. Everything is working great. Only problem is I'm also using UltraPics to have more pictures in the Product Description.

 

Is there a way to have the extra pictures uploaded along with all the attributes?

 

Thanks

Gary Osterholt

Share this post


Link to post
Share on other sites

Mibble, is there a way to have easy populate to auto insert products from a text file?

 

I'd like to run a cron job to do it. I've developed a program (with some other help) that I can use MS Word to mail merge products to a template, then take that code, transfer it into html code, then place that code into the description field of a excel temp file, also it copies over a model number into the model number field and product pic field. From there it allow you to edit it in excel to modify any catagories that need to be changed, then exports it all into a tab delimited file. I've tested this today and it works brilliantly. Even autouploads it to an ftp server. :o)

I'm willing to share it with others if I can get a cron job to automate the imports instead of having to go into the admin tool.

 

ttyl

Edited by djgizmo

Share this post


Link to post
Share on other sites

Quick question

 

Can I use EP just to download everything except the product descriptions and upload it without it deleting the existing descriptions?


Go New England Patriots!!!!

Share this post


Link to post
Share on other sites

Hey John,

 

Great contribution.

I'm using Easy Populate 2.74 MS2. Works great. I can upload and download.

 

The only problem is I'm also using UltraPics. To get more pictures in the products pages. When i download a text file, I only have an option for one photo.

 

I've downloaded an Easy Populate Ultra Add On, but it won't download or upload the attributes for the products.

 

Any ideas???

 

Thanks

Gary Osterholt

Share this post


Link to post
Share on other sites

guys, i want to download easy populate, but which file do i download from the contributions section?

 

whats the file, that has all i need to setup and install?

 

Steve

Share this post


Link to post
Share on other sites

John,

 

Thanks alot for the help. Ended up opening both the EP-Ultrapics and the 2.74 version. Added the images stuff throughout the 2.74. Works great.

 

Thanks again.

 

Gary Osterholt

Share this post


Link to post
Share on other sites

Hi, I wonder if anyone can help me...my problem doesn't appear to have been mentioned in any previous discussion of easypopulate.

 

I've just installed it, the Aug12 version 2.74 and the page opens fine. Downloading EP files works OK too and I've now ironed out (I think) the initial problems I had with the temp dir (I don't have a catalog folder).

 

However, I can't upload anything. Clicking the insert into db button, either to upload, split or from the temp dir just takes me to a 406 error page

 

"The resource cannot be displayed

The resource you are looking for cannot be opened by your browser.

--------------------------------------------------------------------------------

Please try the following:

Click the Back button to try another link.

Click Search to look for information on the Internet.

HTTP Error 406 - Not acceptable

Internet Explorer"

 

So I'm stumped. Any pointers would be appreciated.

Cheers

Edited by starkie

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×