Jump to content
VJ

Easy Populate & Products Attributes

Recommended Posts

they have to be added, in the 12 august download you can use the other version of easy populate and merge it with yours, i believe it has that pricing in there.  or you can look at the fields in the current easypoplulate.php file, think they need uncommenting and verify the names.

 

This is probably a silly question but will ask anyway.

 

When using EasyPopulate in conjunction with Total B2B, when you download a complete tab-delimited file should it include pricing levels?

 

I have uncommented the following in the easypopulate.php file:

 

// uncomment the customer_price and customer_group to support multi-price per product contrib
 $filelayout = array(
	 'v_products_model'  => $iii++,
	 'v_products_price'  => $iii++,
	 'v_products_quantity'  => $iii++,
	 'v_customer_price_1'  => $iii++,
	 'v_customer_group_id_1'  => $iii++,
	 'v_customer_price_2'  => $iii++,
	 'v_customer_group_id_2'  => $iii++,
	 'v_customer_price_3'  => $iii++,
	 'v_customer_group_id_3'  => $iii++,
	 'v_customer_price_4'  => $iii++,
	 'v_customer_group_id_4'  => $iii++,

 

Is that what I was supposed to do and should that allow for the dowload of pricing? Sorry for the stupid questions.

 

Regards

Robyn

Share this post


Link to post
Share on other sites

somewhere in your admin configure.php file you are missing a trailing slash (/) where your document root is. what gives this away is:

(/home/store/public_html/magazin/tempEP2004Nov05-14021.txt

and it should be:

(/home/store/public_html/magazin/temp/EP2004Nov05-14021.txt

 

you can either try to find the error or post your admin/includes/configure.php file without the db info

 

File uploaded.

Temporary filename: /tmp/phpc6WdRt

User filename: EP2004Nov05-14021.txt

Size: 41308

 

Warning: file(/home/store/public_html/magazin/tempEP2004Nov05-14021.txt): failed to open stream: No such file or directory in /home/store/public_html/magazin/admin/easypopulate.php on line 657

 

Warning: Invalid argument supplied for foreach() in /home/store/public_html/magazin/admin/easypopulate.php on line 680

I can not get out of this error. I have a /magazin/temp/ folder, with 777 permissions.

I have only 170 products in database.

Please help me because I don't now what more I can do.

With many thanks!!


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

i have not checked the differences in the different contributions, thus you will need to make sure that the field names match the ones you have from your particular contribution. once the names are right then it should work.

 

This is probably a silly question but will ask anyway.

 

When using EasyPopulate in conjunction with Total B2B, when you download a complete tab-delimited file should it include pricing levels?

 

I have uncommented the following in the easypopulate.php file:

 

// uncomment the customer_price and customer_group to support multi-price per product contrib
?$filelayout = array(
?	'v_products_model' ?=> $iii++,
?	'v_products_price' ?=> $iii++,
?	'v_products_quantity' ?=> $iii++,
?	'v_customer_price_1' ?=> $iii++,
?	'v_customer_group_id_1' ?=> $iii++,
?	'v_customer_price_2' ?=> $iii++,
?	'v_customer_group_id_2' ?=> $iii++,
?	'v_customer_price_3' ?=> $iii++,
?	'v_customer_group_id_3' ?=> $iii++,
?	'v_customer_price_4' ?=> $iii++,
?	'v_customer_group_id_4' ?=> $iii++,

 

Is that what I was supposed to do and should that allow for the dowload of pricing? Sorry for the stupid questions.

 

Regards

Robyn


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

<?php

/*

$Id: configure.php,v 1.14 2003/02/21 16:55:24 dgw_ Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright ? 2002 osCommerce

 

Released under the GNU General Public License

*/

 

// define our webserver variables

// FS = Filesystem (physical)

// WS = Webserver (virtual)

define('HTTP_SERVER', 'http://store.ro');

define('HTTP_CATALOG_SERVER', '');

define('HTTPS_CATALOG_SERVER', '');

define('ENABLE_SSL_CATALOG', 'false'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', $DOCUMENT_ROOT); // where your pages are located on the server. if $DOCUMENT_ROOT doesnt suit you, replace with your local path. (eg, /usr/local/apache/htdocs)

define('DIR_WS_ADMIN', '/magazin/admin/');

define('DIR_FS_ADMIN', DIR_FS_DOCUMENT_ROOT . DIR_WS_ADMIN);

define('DIR_WS_CATALOG', '/magazin/');

define('DIR_FS_CATALOG', DIR_FS_DOCUMENT_ROOT . DIR_WS_CATALOG);

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_CATALOG_IMAGES', DIR_WS_CATALOG . 'images/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

define('DIR_WS_CATALOG_LANGUAGES', DIR_WS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_LANGUAGES', DIR_FS_CATALOG . 'includes/languages/');

define('DIR_FS_CATALOG_IMAGES', DIR_FS_CATALOG . 'images/');

define('DIR_FS_CATALOG_MODULES', DIR_FS_CATALOG . 'includes/modules/');

define('DIR_FS_BACKUP', DIR_FS_ADMIN . 'backups/');

 

 

you can either try to find the error or post your admin/includes/configure.php file without the db info

 

 

 

 

This is my admin/includes/configure.php page.

I could not find the mistake.

Thanks a lot for your help.

Edited by sty1129

Share this post


Link to post
Share on other sites
somewhere in your admin configure.php file you are missing a trailing slash (/) where your document root is. what gives this away is:

 

I solve it

The slash was missing after the temp, in easypopulate.php file.

Now i have the corect path: /magazin/temp/

Thanks a lot again!

Share this post


Link to post
Share on other sites

When I go to easypopulate.php, I get the following errors:

 

Warning: main(easypopulate_functions.php): failed to open stream: No such file or directory in /home/audiox/public_html/shop/admin/easypopulate.php on line 164

 

Warning: main(): Failed opening 'easypopulate_functions.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/audiox/public_html/shop/admin/easypopulate.php on line 164

 

What do I need to do to fix this?

Share this post


Link to post
Share on other sites

the original easypopulate contribution dated 12 august has the file easypopulate_functions.php included, the ones after are for diferent things and should not have been posted without the rest of the contribution. if you are not using master products, then use the 12 aug version.


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites
the original easypopulate contribution dated 12 august has the file easypopulate_functions.php included, the ones after are for diferent things and should not have been posted without the rest of the contribution.  if you are not using master products, then use the 12 aug version.

 

I cannot find the 12 aug version in the contribution page. Can you possibly link it to me?

Share this post


Link to post
Share on other sites

I finally figured out how to get easypopulate .. I was just being stupid and overlooking the aug 12 update. I have it installed, and its working except for the splitting part of it. When I try to split, I get the following errors:

 

 

Warning: move_uploaded_file(/home/audiox/public_htmltemp/EP2004Nov10-1402.txt.xls): failed to open stream: No such file or directory in /home/audiox/public_html/shop/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpBsEmtz' to '/home/audiox/public_htmltemp/EP2004Nov10-1402.txt.xls' in /home/audiox/public_html/shop/admin/easypopulate_functions.php on line 32

 

Warning: fopen(/home/audiox/public_htmltemp/EP2004Nov10-1402.txt.xls): failed to open stream: No such file or directory in /home/audiox/public_html/shop/admin/easypopulate.php on line 719

 

Warning: fgets(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 722

Creating file EP_Split1.txt ...

Warning: fopen(/home/audiox/public_htmltemp/EP_Split1.txt): failed to open stream: No such file or directory in /home/audiox/public_html/shop/admin/easypopulate.php on line 728

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 729

 

Warning: fgets(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 732

Added 0 records and closing file...

 

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 758

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 759

You can download your split files in the Tools/Files under /shop/temp/

 

What can I do to fix this?

Share this post


Link to post
Share on other sites

if you look at this:

 

/home/audiox/public_htmltemp/EP2004Nov10-

 

should read like this:

 

/home/audiox/public_html/temp/EP2004Nov10-

 

 

somewhere in your configure.php for the admin is missing a /


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

I found that but i still get the following errors: (its the same, but now the / is there)

 

Warning: move_uploaded_file(/home/audiox/public_html/temp/EP2004Nov10-1402.txt): failed to open stream: No such file or directory in /home/audiox/public_html/shop/admin/easypopulate_functions.php on line 32

 

Warning: move_uploaded_file(): Unable to move '/tmp/phpIDpzRi' to '/home/audiox/public_html/temp/EP2004Nov10-1402.txt' in /home/audiox/public_html/shop/admin/easypopulate_functions.php on line 32

 

Warning: fopen(/home/audiox/public_html/temp/EP2004Nov10-1402.txt): failed to open stream: No such file or directory in /home/audiox/public_html/shop/admin/easypopulate.php on line 719

 

Warning: fgets(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 722

Creating file EP_Split1.txt ...

Warning: fopen(/home/audiox/public_html/temp/EP_Split1.txt): failed to open stream: No such file or directory in /home/audiox/public_html/shop/admin/easypopulate.php on line 728

 

Warning: fwrite(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 729

 

Warning: fgets(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 732

Added 0 records and closing file...

 

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 758

 

Warning: fclose(): supplied argument is not a valid stream resource in /home/audiox/public_html/shop/admin/easypopulate.php on line 759

You can download your split files in the Tools/Files under /shop/temp/

Share this post


Link to post
Share on other sites

did u set the properties to 777 for the temp directory?

what is the path you used for your temp directory?

 

your very last line here: /shop/temp/

 

is nowhere in your path above


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

So what do I need to do in order to get easy populate to work? I can't get anything to work. I cant upload the tab delimited text files, I can't split files, I cant do anything..

Share this post


Link to post
Share on other sites
Hi Vijay,

 

I had a strange problem with Easypopulate only loading the first line of the file.

I understood from another member that this is due to me using PhP 5.0.

Are there any plans to fix this (soon :-" )?

 

Thanks

Francis

Hi,

 

I'm having this problem too.

From what I've found:

 

"Migrating from PHP 4 to PHP 5

(...)

Backward Incompatible Changes

Although most existing PHP 4 code should work without changes, you should pay attention to the following backward incompatible changes:

(...)

array_merge() was changed to accept only arrays. If a non-array variable is passed, a E_WARNING will be thrown for every such parameter. Be careful because your code may start emitting E_WARNING out of the blue."

 

http://www.php.net/manual/en/migration5.incompatible.php

 

The easypopulate.php file uses this function a lot. Could it be the problem?

I don't know any PHP at all, so I can't help. :-"

 

But hey, we should all get to use PHP5 within months right? Can't anyone try to figure this out? :thumbsup:

Share this post


Link to post
Share on other sites

Hi All...

 

Is it possible to enter the location of the downloadable file for downloadable products in easy populate? I'm using v2.74.

 

My aim is to create an image store, with bith downloadable images and prints available. I have got easy populate to upload products in bulk but i have to enter the downloadable file info manually via the admin panel... any suggesstions? I'm brand new to php and osc, apologies if I've done something stupid..

 

This is a great mod, many thanks indeed to all involved.

Share this post


Link to post
Share on other sites

can you post your admin/includes/configure.php file here without the database info, password .. .

 

So what do I need to do in order to get easy populate to work?  I can't get anything to work.  I cant upload the tab delimited text files, I can't split files, I cant do anything..


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

that is possible, i have not looked to see what is being passed, to figure out what function to replace it with.

 

Hi,

 

I'm having this problem too.

From what I've found:

 

"Migrating from PHP 4 to PHP 5

(...)

Backward Incompatible Changes

Although most existing PHP 4 code should work without changes, you should pay attention to the following backward incompatible changes:

(...)

array_merge() was changed to accept only arrays. If a non-array variable is passed, a E_WARNING will be thrown for every such parameter. Be careful because your code may start emitting E_WARNING out of the blue."

 

http://www.php.net/manual/en/migration5.incompatible.php

 

The easypopulate.php file uses this function a lot. Could it be the problem?

I don't know any PHP at all, so I can't help.  :-"

 

But hey, we should all get to use PHP5 within months right? Can't anyone try to figure this out?  :thumbsup:


John Oligario

 

Knowledge Base Contributions

Share this post


Link to post
Share on other sites

Greetings all.

 

If someone has this working with More Pics, could you please private-message me with the end goal of e-mailing me your easypop.php files?

 

I have tried nearly everything, including copying loads of code from the generous souls on this board, without any success. I'm getting desperate. I have hundreds of items and we're growing daily. I can't keep up with the tedious uploading via the admin tool.

 

Thanks to any and all.


He who joyfully marches in rank and file has already earned my contempt. He has been given a large brain by mistake, since for him the spinal cord would suffice.

- Albert Einstein

Share this post


Link to post
Share on other sites

Hello All , Im a newbie to the OSC .. I would appreciate your insights in this

 

 

I want help with Easy Populate Module .. I used the most earliest version

20 Nov 2002 - Easy Populate v1.0 just to install and check whether it really works ..

 

I followed all the instructions in the document .. that is

added the easypopulate.php file admin/

edited the categories table to add the column categories_root column

edited the catalog.php file admin/includes/boxes/

 

 

After that when i went to the Catalog menu and clicked on Easy Populate

I got the message saying

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

 

Please contact the server administrator, admin@planetguide.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

 

I checked the log files of the webserver ... and it gave me this piece of information

Premature end of script headers: php-script, referer: http://www.neworleanswebsitedesign.com/osc...ted_box=catalog

 

"easypopulate.php" File is uploaded as is .. so it is not a upload problem ..

... Please help .. I need to test this soon .. .

 

Thanks in advance :( :( :(

Share this post


Link to post
Share on other sites

I've got easypopulate working but I'm getting very puzzing results in that it 's sometimes -- for no reason I can understand -- listing each occurance of a category as a separate category.

 

For example, in my product list (which lives in MS Access) I've got 6 different products described as 'SOUPS & SAUCES (CHILLED)' As you'd expect, on running easypopulate I've ended up with a new category called 'SOUPS & SAUCES (CHILLED)' with 6 products in it.

 

However, there are 13 products on the list described as 'SOYA YOGHURTS & DESSERTS (CHILLED)' and I discover I've unexpectly got 13 categories called 'SOYA YOGHURTS & DESSERTS (CHILLED)', each containing one product, when obviously I expect one category containing thirteen products.

 

Can anyone explain why? There are several examples of this, and initially I wondered if I should escape non-alphanumeric characters but this example suggests that's not the problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×